Gönderen Konu: [Çözüldü] .Net Sdk kurulum hatası  (Okunma sayısı 69 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı kodkabagi

  • Çok Yeni Penguen
  • *
  • İleti: 8
    • Blog Sitem
  • Dağıtım: Linux Mint
  • Masaüstü: Cinnamon 19.1 Tessa
  • Grafik Kartı: GTX 940
  • İşlemci: i5
  • RAM: 12 Gb
[Çözüldü] .Net Sdk kurulum hatası
« : 11 Mart 2019, 00:16:57 »
.Net Sdk kurmayı denediğimde bir hata aldım. Yüklemeye çalıştığım hiçbir şeyde başarılı olamadım. Acaba ekstra kurmam gereken ya da açmam gereken ayarlar mı var?

Aldığım hata ;

root@ali-X556UQK:/home/ali# apt-get install dotnet-sdk-2.1.4
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Bazı paketler kurulamadı. Bu durum, olanaksız bir durum istemiş
olduğunuzu ya da kararsız (unstable) dağıtımı kullandığınızı ve
bazı paketlerin henüz oluşturulamamış  ya da oluşturulmakta
olduğunu gösterir.
Aşağıdaki bilgiler durumu çözmenize yardımcı olabilir:

Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
 dotnet-sdk-2.1.4 : Bağımlılıklar: dotnet-runtime-2.0.5 ama kurulmayacak
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.
« Son Düzenleme: 11 Mart 2019, 02:15:46 Gönderen: kodkabagi »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16466
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: .Net Sdk kurulum hatası
« Yanıtla #1 : 11 Mart 2019, 00:43:01 »
@kodkabagi , Linux Mint 19.x serisi, Ubuntu 18.04 tabanını kullanır. Linux Mint 19.x serisine bir uygulama kuracağınız zaman, Ubuntu 18.04.x için olan anlatımlardan yararlanabilirsiniz.



MS'in resmi sayfasında Ubuntu 18.04 serisi için dotnet-sdk-2.2 kurulumu vardı. Bunu Linux Mint 19.x seirisine özel olarak aşağıdaki şekilde kurabilirsiniz. MS'in sitesinde Universe deposunun etkinleştirilmesi ile ilgili kısıma Linux Mint'te gerek yok, hali hazırda etkin geliyor.

Aşağıdaki komutlarla gerekli depoyu ve GPG doğrulama anahtarını içeren paketi indirip kurunuz.

Kod: [Seç]
wget -q --no-check-certificate https://packages.microsoft.com/config/ubuntu/18.04/packages-microsoft-prod.deb
Kod: [Seç]
sudo dpkg -i packages-microsoft-prod.deb
Ardından aşağıdaki komutlar depo bilgilerini güncelleyip gerekli paketlerle birlikte dotnet-sdk-2.2 paketini kurabilirsiniz.

Kod: [Seç]
sudo apt-get install apt-transport-https
Kod: [Seç]
sudo apt-get update
Kod: [Seç]
sudo apt-get install dotnet-sdk-2.2
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı kodkabagi

  • Çok Yeni Penguen
  • *
  • İleti: 8
    • Blog Sitem
  • Dağıtım: Linux Mint
  • Masaüstü: Cinnamon 19.1 Tessa
  • Grafik Kartı: GTX 940
  • İşlemci: i5
  • RAM: 12 Gb
Ynt: .Net Sdk kurulum hatası
« Yanıtla #2 : 11 Mart 2019, 00:59:09 »
Kod: [Seç]
root[member=471]ali[/member]-X556UQK:/home/ali# sudo apt-get install dotnet-sdk-2.2
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti      
Bazı paketler kurulamadı. Bu durum, olanaksız bir durum istemiş
olduğunuzu ya da kararsız (unstable) dağıtımı kullandığınızı ve
bazı paketlerin henüz oluşturulamamış  ya da oluşturulmakta
olduğunu gösterir.
Aşağıdaki bilgiler durumu çözmenize yardımcı olabilir:

Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
 dotnet-sdk-2.2 : Bağımlılıklar: aspnetcore-runtime-2.2 (>= 2.2.2) ama kurulmayacak
                  Bağımlılıklar: dotnet-runtime-2.2 (>= 2.2.2) ama kurulmayacak
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16466
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: .Net Sdk kurulum hatası
« Yanıtla #3 : 11 Mart 2019, 01:12:15 »
@kodkabagi , lütfen geri dönüşlerde sadece son kısmın çıktılarını paylaşmayınız. Hatanın nedeni önceki aşamalarla ilgili olabilir. Lütfen tüm işlemleri tekrarlayıp tüm çıktıları paylaşınız.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı kodkabagi

  • Çok Yeni Penguen
  • *
  • İleti: 8
    • Blog Sitem
  • Dağıtım: Linux Mint
  • Masaüstü: Cinnamon 19.1 Tessa
  • Grafik Kartı: GTX 940
  • İşlemci: i5
  • RAM: 12 Gb
Ynt: .Net Sdk kurulum hatası
« Yanıtla #4 : 11 Mart 2019, 01:26:57 »
@Butterfly , Tekrarladım hocam;

Kod: [Seç]
root[member=471]ali[/member]-X556UQK:/home/ali# wget -q --no-check-certificate https://packages.microsoft.com/config/ubuntu/18.04/packages-microsoft-prod.deb

Kod: [Seç]
root[member=471]ali[/member]-X556UQK:/home/ali# sudo dpkg -i packages-microsoft-prod.deb
(Veritabanı okunuyor ... 256540 dosya veya dizin kurulu durumda.)
Paket açılacak: packages-microsoft-prod.deb ...
Paket açılıyor: packages-microsoft-prod (1.0-ubuntu18.04.2) üzerine (1.0-ubuntu18.04.2) ...
Ayarlanıyor: packages-microsoft-prod (1.0-ubuntu18.04.2) ...

Kod: [Seç]
root[member=471]ali[/member]-X556UQK:/home/ali# sudo apt-get install apt-transport-https
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor      
Durum bilgisi okunuyor... Bitti     
apt-transport-https zaten en yeni sürümde (1.6.8).
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 245 paket yükseltilmeyecek.
Kod: [Seç]
root[member=471]ali[/member]-X556UQK:/home/ali# sudo apt-get update
Aynı:  1 http://archive.canonical.com/ubuntu bionic InRelease
Aynı:  2 http://archive.ubuntu.com/ubuntu bionic InRelease                    
İndir: 3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]  
İndir: 4 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Yoksay:5 http://packages.linuxmint.com tessa InRelease                        
Aynı:  6 https://packages.microsoft.com/repos/microsoft-ubuntu-xenial-prod xenial InRelease
Aynı:  7 https://packages.microsoft.com/ubuntu/18.04/prod bionic InRelease    
Aynı:  8 http://archive.ubuntu.com/ubuntu bionic-backports InRelease          
Aynı:  9 http://packages.linuxmint.com tessa Release                          
Aynı:  10 https://packages.microsoft.com/repos/vscode stable InRelease        
1 sn.'de 177 kB alındı (157 kB/s)                                             
Paket listeleri okunuyor... Bitti

Kod: [Seç]
root[member=471]ali[/member]-X556UQK:/home/ali# sudo apt-get install dotnet-sdk-2.2
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti      
Bazı paketler kurulamadı. Bu durum, olanaksız bir durum istemiş
olduğunuzu ya da kararsız (unstable) dağıtımı kullandığınızı ve
bazı paketlerin henüz oluşturulamamış  ya da oluşturulmakta
olduğunu gösterir.
Aşağıdaki bilgiler durumu çözmenize yardımcı olabilir:

Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
 dotnet-sdk-2.2 : Bağımlılıklar: aspnetcore-runtime-2.2 (>= 2.2.2) ama kurulmayacak
                  Bağımlılıklar: dotnet-runtime-2.2 (>= 2.2.2) ama kurulmayacak
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.


Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16466
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: .Net Sdk kurulum hatası
« Yanıtla #5 : 11 Mart 2019, 01:30:10 »
Aşağıdaki komutun çıktısını bakalım.

Kod: [Seç]
inxi -Sr
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı kodkabagi

  • Çok Yeni Penguen
  • *
  • İleti: 8
    • Blog Sitem
  • Dağıtım: Linux Mint
  • Masaüstü: Cinnamon 19.1 Tessa
  • Grafik Kartı: GTX 940
  • İşlemci: i5
  • RAM: 12 Gb
Ynt: .Net Sdk kurulum hatası
« Yanıtla #6 : 11 Mart 2019, 01:33:52 »
@Butterfly , buyrun hocam;

Kod: [Seç]
System:
  Host: ali-X556UQK Kernel: 4.15.0-20-generic x86_64 bits: 64
  Desktop: Cinnamon 4.0.8 Distro: Linux Mint 19.1 Tessa
Repos:
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/dotnetdev.list
  1: deb [arch=amd64] https://packages.microsoft.com/repos/microsoft-ubuntu-xenial-prod xenial main
  Active apt repos in: /etc/apt/sources.list.d/microsoft-prod.list
  1: deb [arch=amd64] https://packages.microsoft.com/ubuntu/18.04/prod bionic main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
  1: deb http://packages.linuxmint.com tessa main upstream import backport
  2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
  Active apt repos in: /etc/apt/sources.list.d/official-source-repositories.list
  1: deb-src http://packages.linuxmint.com tessa main upstream import backport
  2: deb-src http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
  3: deb-src http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
  4: deb-src http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
  5: deb-src http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb-src http://archive.canonical.com/ubuntu/ bionic partner
  Active apt repos in: /etc/apt/sources.list.d/vscode.list
  1: deb [arch=amd64] https://packages.microsoft.com/repos/vscode stable main

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16466
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: .Net Sdk kurulum hatası
« Yanıtla #7 : 11 Mart 2019, 01:43:24 »
Aşağıdaki komutla /etc/apt/sources.list.d/dotnetdev.list  dosyasını ve içerdiği depoyu silip,

Kod: [Seç]
sudo rm -f /etc/apt/sources.list.d/dotnetdev.list
aşağıdaki komutlarla yeniden kurulum deneyiniz.

Kod: [Seç]
sudo apt-get update
Kod: [Seç]
sudo apt-get install dotnet-sdk-2.2
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı kodkabagi

  • Çok Yeni Penguen
  • *
  • İleti: 8
    • Blog Sitem
  • Dağıtım: Linux Mint
  • Masaüstü: Cinnamon 19.1 Tessa
  • Grafik Kartı: GTX 940
  • İşlemci: i5
  • RAM: 12 Gb
Ynt: .Net Sdk kurulum hatası
« Yanıtla #8 : 11 Mart 2019, 02:13:19 »
Hocam Allah razı olsun, çok teşekkür ederim. Sorunum çözüldü.

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16466
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: [Çözüldü] .Net Sdk kurulum hatası
« Yanıtla #9 : 11 Mart 2019, 02:34:28 »
Rica ederiz.

Dış kaynaklı yazılım kurarken, ilk mesajdaki önerilerimi dikkate alınız. Bu konudaki sorun aynı paket için birden fazla depo kurulması idi. Yani aynı ipte iki cambaz oynayamadığı için sorun yaşıyordunuz.

Sorun çözüldüğü için konu kilitlenmiştir.
« Son Düzenleme: 11 Mart 2019, 02:39:10 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...