Gönderen Konu: [Çözüldü] KDE Connect Çalışıyor ama Indicator Çalışmıyor  (Okunma sayısı 103 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı okanakinci

  • Penguen
  • ***
  • İleti: 356
  • Dağıtım: Linux Mint 19.1
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia GT820M + Intel Haswell-ULT
  • İşlemci: Intel Core i5-4210U @ 1.70GHz x 2
Linux Mint 19.1 Cinnamon üzerinde KDE Connect yazılımını kullanıyorum. Yazılım arka planda harika bir şekilde çalışıyor. Telefonumla bağlantılı işlemleri sorunsuz yapabiliyorum. Fakat paneldeki simgesini çalıştıramıyorum. KDE Connect Indicator'u başlangıç uygulamalarına ekledim ama olmadı. Menüden tıklayıp açıyorum ama o da olmadı. Uçbirimden komutla çalıştırmaya çalıştığımda ise nihayet çalıştı ama aşağıdaki çıktıyı aldım:

Kod: [Seç]
okanakinci[member=234]okan[/member]-mint-3542:~$ kdeconnect-indicator
qt5ct: using qt5ct plugin
qt5ct: D-Bus system tray: no
QSystemTrayIcon::setVisible: No Icon set


Hiçbir depo eklemedim.

Kod: [Seç]
sudo apt install kdeconnect komutuyla kurdum. Belki de PPA ekleyerek kurmam lazım diye düşündüm ve yaptım ama o tarafta da aynı sorun söz konusu.

Mesajlar Birleştirildi.
Ekleme: Yukarıdaki çıktıyı sadece bir kereye mahsus aldım. Birgisayarı bir daha başlattım ve bundan sonra şu çıktı gelmeye başladı:

Kod: [Seç]
okanakinci[member=234]okan[/member]-mint-3542:~$ kdeconnect-indicator
qt5ct: using qt5ct plugin
okanakinci[member=234]okan[/member]-mint-3542:~$
« Son Düzenleme: 05 Mart 2019, 18:46:49 Gönderen: okanakinci »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16466
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: KDE Connect Çalışıyor ama Indicator Çalışmıyor
« Yanıtla #1 : 05 Mart 2019, 11:43:59 »
Hata çıktısı değişmiş, yeniden başlattıktan sonra sistem çekmesi simge sorunu çözülmedi mi?
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı okanakinci

  • Penguen
  • ***
  • İleti: 356
  • Dağıtım: Linux Mint 19.1
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia GT820M + Intel Haswell-ULT
  • İşlemci: Intel Core i5-4210U @ 1.70GHz x 2
Ynt: KDE Connect Çalışıyor ama Indicator Çalışmıyor
« Yanıtla #2 : 05 Mart 2019, 11:46:04 »
Hayır, çözülmedi. En son verdiğim çıktı aynen devam ediyor. qt5ct nedir diye baktım, Cinnamon Menüsündeki QT Ayarlarıymış. Biraz kurcaladım ama bir sonuca ulaşamadım.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16466
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: KDE Connect Çalışıyor ama Indicator Çalışmıyor
« Yanıtla #3 : 05 Mart 2019, 11:49:41 »
Depodan oxygen-icon-theme paketini yükleyip, qt5ct simge teması sekmesinden bunu seçmeyi deneyebilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı okanakinci

  • Penguen
  • ***
  • İleti: 356
  • Dağıtım: Linux Mint 19.1
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia GT820M + Intel Haswell-ULT
  • İşlemci: Intel Core i5-4210U @ 1.70GHz x 2
Ynt: KDE Connect Çalışıyor ama Indicator Çalışmıyor
« Yanıtla #4 : 05 Mart 2019, 11:54:01 »
Şimdi yaptım ama işe yaramadı. Sorun hâlâ aynı.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16466
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: KDE Connect Çalışıyor ama Indicator Çalışmıyor
« Yanıtla #5 : 05 Mart 2019, 13:17:46 »
Kurup ben de denedim, depodaki sürüm ile sistem çekmesinde herhangi bir sorun yaşamadım. Hatta aynı uçbirim çıktılarını alıyorum ama sistem çekmesi göstergesinin başlatılmasında bir sorun yaşamıyorum. İlk defa kurdum bu uygulamayı gerçekten güzelmiş, sunum ve ortam çalıcısı kontrollerini beğendim.

Belki sorun kullandığınız simge teması ile ilgilidir, değiştirmeyi denediniz mi?

Ayrıca aşağıdaki komutların çıktısına da bakalım.

Kod: [Seç]
dpkg -l | grep kdeconnect
apt policy kdeconnect
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı okanakinci

  • Penguen
  • ***
  • İleti: 356
  • Dağıtım: Linux Mint 19.1
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia GT820M + Intel Haswell-ULT
  • İşlemci: Intel Core i5-4210U @ 1.70GHz x 2
Ynt: KDE Connect Çalışıyor ama Indicator Çalışmıyor
« Yanıtla #6 : 05 Mart 2019, 15:03:20 »
İşte çıktılar:

Kod: [Seç]
okanakinci[member=234]okan[/member]-mint-3542:~$ dpkg -l | grep kdeconnect
ii  kdeconnect                                 1.3.3-0ubuntu0.18.04.1                      amd64        connect smartphones to your KDE Plasma Workspace
ii  kdeconnect-plasma                          1.3.3-0ubuntu0.18.04.1                      all          Transitional package (kdeconnect-plasma -> kdeconnect)
okanakinci[member=234]okan[/member]-mint-3542:~$ apt policy kdeconnect
kdeconnect:
  Installed: 1.3.3-0ubuntu0.18.04.1
  Candidate: 1.3.3-0ubuntu0.18.04.1
  Version table:
 *** 1.3.3-0ubuntu0.18.04.1 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     1.3.0-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
okanakinci[member=234]okan[/member]-mint-3542:~$

Ben de ilk defasında sorun yaşamıyorum. Sorun bilgisayarı başlattıktan sonra başlıyor. Bu arada sorun KDE Connect sorunu da değil. Uygulama mükemmel çalışıyor. Sadece sistem tepsisinde simgesini göremiyorum.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16466
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: KDE Connect Çalışıyor ama Indicator Çalışmıyor
« Yanıtla #7 : 05 Mart 2019, 17:18:53 »
Aşağıdaki komutla kdeconnect-plasma paketini kaldırmayı deneyebilirsiniz.

Kod: [Seç]
apt purge kdeconnect-plasma
Eğer sorun bu şekilde çözülmezse indicator-kdeconnect paketini kurmayı ve bununla gelen göstergeyi kullanmayı deneyebilirsiniz.

Kod: [Seç]
sudo add-apt-repository ppa:webupd8team/indicator-kdeconnect
sudo apt update
sudo apt install indicator-kdeconnect
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı okanakinci

  • Penguen
  • ***
  • İleti: 356
  • Dağıtım: Linux Mint 19.1
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia GT820M + Intel Haswell-ULT
  • İşlemci: Intel Core i5-4210U @ 1.70GHz x 2
Ynt: KDE Connect Çalışıyor ama Indicator Çalışmıyor
« Yanıtla #8 : 05 Mart 2019, 18:46:39 »
@Butterfly teşekkür ederim. Sorun çözüldü. kdeconnect-plasma paketini kaldırmak işe yaramadı ama PPA ile indicator-kdeconnect paketini kurmak işe yaradı.

Fakat dikkat etmek gereken birkaç şey var. Yoksa çözüm işe yaramıyor. O yüzden ben nasıl yaptığımı anlatayım.

1) Bu adım gerekli mi bilmiyorum ama KDE Connect'i PPA olmadan kurduysanız onu kaldırın. Şu komutla kaldırabilirsiniz.

Kod: [Seç]
sudo apt autoremove kdeconnect
2) Şu üç komutu sırayla girerek PPA'dan kurulum yapın.

Kod: [Seç]
sudo add-apt-repository ppa:webupd8team/indicator-kdeconnect
sudo apt update
sudo apt install indicator-kdeconnect

3) Eğer güvenlik duvarından KDE Connect yazılımına izin vermediyseniz verin. Forumdaki bu mesajda nasıl olduğu anlatılmış.

4) Cinnamon Menüsünden KDE Connect Settings yazılımına girin ve telefonunuzdaki KDE Connect uygulaması ile bağlantı kurun.

5) Başlangıç Uygulamalarına gidin ve KDE Connect Indicator yazılımını ekleyin. İşte burası kritik. Sisteminizde iki tane KDE Connect Indicator var. Bunlardan birisi kdeconnect-indicator paketi, diğeri ise indicator-kdeconnect paketi. Siz, indicator-kdeconnect olanını (muhtemelen alttaki) başlangıca eklemelisiniz. Diğeri çalışmıyor.

6) Bilgisayarınızı yeniden başlatın. Sorun çözülmüştür. Eğer hâlâ Indicator simgesini görmüyorsanız bunun tek nedeni telefonunuzun o an bağlı olmamasıdır. Telefonunuzun ekran kilidine şöyle bir dokunun, hemen bilgisayarınızla bağlantı kuracaktır. İşte o an Cinnamon sistem tepsisinde simge görünecektir.

PPA ile kurulan KDE Connect'te sorun çözülmüş. Ayrıca bir avantajı daha var: Bilgisayardan SMS göndermek mümkün. PPA'sız kurulanında bu özellik eksikti.

Mesajlar Birleştirildi.
İlk defa kurdum bu uygulamayı gerçekten güzelmiş, sunum ve ortam çalıcısı kontrollerini beğendim.

Bu arada evet. Muhteşem kolaylık. Bilgisayar odanın öbür ucundayken ve bilgisayarda film izlerken, müzik dinlerken yerimden kalkmadan dondurabiliyorum, ileri geri sarabiliyorum, bir sonraki ya da bir öncekine atlayabiliyorum. Ayrıca telefonu touchpad ve klavye olarak da kullanabiliyorum. Hatta bazı özel komutlar göndermek de mümkün. Resmen bilgisayarın bir uzaktan kumandası oldu.
« Son Düzenleme: 05 Mart 2019, 19:05:28 Gönderen: okanakinci »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16466
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
kdeconnect-indicator ile ilgili sorunun çözümünü buldum, ben senaryoyu uygulayıp başlangıç uygulamalarına eklemediğim için her seferin gösterge sorunsuz açılmıştı. Daha sonra başlangıç uygulamalarına ekleyince bende de gösterge ne otomatik başladı ne de uçbirimden başladı. Süreci öldürüp yeniden deneyince gösterge çalışıyordu.

Bunun etrafından dolaşmak için, başlangıç uygulmalarına eklediğiniz komuta gecikme eklemeniz gerekiyor. Girdiyi açıp, "Başlangıç gecikmesi" kısmını artırmalsınız. Bu şekilde oturum açıldığında gösterge kendiliğincen başlıyor.

« Son Düzenleme: 05 Mart 2019, 19:32:57 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı okanakinci

  • Penguen
  • ***
  • İleti: 356
  • Dağıtım: Linux Mint 19.1
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia GT820M + Intel Haswell-ULT
  • İşlemci: Intel Core i5-4210U @ 1.70GHz x 2
PPA sürümünde gecikme eklemek gerekmiyor. PPA sürümü her bakımdan daha fazla özelliğe ve daha az soruna sahip. Yine de sonuç olarak elimizde iki farklı çözüm olmuş bulundu.