Gönderen Konu: [Çözüldü] Lutris açılmama sorunu  (Okunma sayısı 237 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı Okkhan

  • Çok Yeni Penguen
  • *
  • İleti: 5
[Çözüldü] Lutris açılmama sorunu
« : 15 Ocak 2019, 12:36:18 »
bildiğimiz üzere bütün platormlardaki oyunları oyanayabilmemiz için lutris adında bir proğram var. ancak bu proğramı yüklediği halde  oyun emilatörlerini indiremiyorum. resimdeki gibi bir uyarı veriyor hezaman. bu yüzden steam üzerinde satın almış olduğum microsott destekli oyunları kuramıyorum.


bu işim çözümü nedir ne yapmam gerikiyor acaba. çözemiyorum...
« Son Düzenleme: 17 Ocak 2019, 19:47:03 Gönderen: Okkhan »

Çevrimdışı Leopard

  • Forum Sorumlusu
  • *****
  • İleti: 996
  • Dağıtım: Linux Mint 19.1 64-bit
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia Geforce GTX 1050
  • İşlemci: Intel Core i7 7700HQ
Ynt: Lutris açılmama sorunu
« Yanıtla #1 : 15 Ocak 2019, 15:01:08 »
Lutris'de Türkiye'ye has bir ağ sorunu mevcut ama sizde verdiği hata farklı birşeye benziyor.


https://github.com/lutris/lutris/issues/1140

Ubuntu 18.10 tabanındaki SSL paketi 18.04 tabanına da gelecek, ki sorunu çözmekte.

Eğer Steam'den Windows uyumlu oyunları oynamak niyetindeyseniz forumumuzun Oyun bölümündeki SteamPlay/Proton sabit konusuna bakabilirsiniz.
The only people who should kill are those prepared themselves to die!



Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16272
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Lutris açılmama sorunu
« Yanıtla #2 : 15 Ocak 2019, 15:33:55 »
LC_ALL=C değişkeni ile bu sorunların etrafından dolaşılabiliyor. Aşağıdaki komutlarla sürümünüze uygun menü düzenleyiciyi açın.

Cinnamon için

Kod: [Seç]
cinnamon-menu-editor
MATE için

Kod: [Seç]
mozo
Xfce için

Kod: [Seç]
menulibre
Açılan düzenleyicide Oyunlar bölümünün altında Lutris uygulamasının başlatıcısnı bulun. Aşağıdaki komut kısımını,

Kod: [Seç]
lutris %U
aşağıdaki şekilde değiştirip uygulayın/kaydedin.

Kod: [Seç]
env LC_ALL=C lutris %U
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Okkhan

  • Çok Yeni Penguen
  • *
  • İleti: 5
Ynt: Lutris açılmama sorunu
« Yanıtla #3 : 15 Ocak 2019, 21:06:02 »
Belirtilen işlemleri yaptım ancak sorunuma çözüm olmadı.

Lakin Nvidia ekran kartım için nvidia-390.87 paketini kullanıyordum. Bunu kaldırdıp  nvidia-410.78 paketini kurdum sorunum çözüldü.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16272
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Lutris açılmama sorunu
« Yanıtla #4 : 15 Ocak 2019, 21:25:41 »
Bahsettiğiniz Nvidia sürücüsü kurulumunun ilk mesajda bahsettiğiniz sorunu çözeceğini sanmıyorum. Nvidia sürücüsü güncellemesi ile Lutris yardımıyla bir uygulama kurulamaması sorunu arasında bir bağlantı olma olasılığı, yok denilecek kadar düşük. Ekran görüntüsünde bahsettiğiniz sorun başlatıcı dosyasındaki düzenleme ile çözülüyor.

Aradaki farkı Lutris uygulamasını aşağıdaki komutlarla başlatarak teyit edebilirsiniz. İlk komutla aynı hatayı alırsınız, ikinci komut ise sorunu etrafından dolaşarak çözecektir.

Kod: [Seç]
lutris
Kod: [Seç]
LC_ALL=C lutris
Başlığı etiketlerseniz konuyu kilitleyebiliriz.

« Son Düzenleme: 15 Ocak 2019, 22:08:59 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16272
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Lutris açılmama sorunu
« Yanıtla #5 : 16 Ocak 2019, 03:29:16 »
@Leopard , buradaki düzeltme yaptığım paketi dener misin? Web modülü ve Wine sürümlerinin yönetimi ile ilgili kısımları düzelttiğimi düşünüyorum. Uygulamayı uçbrimden başlatırken de SSL sertifikası ile ilgili uyarı yapmıyor. Sadece web.py, resouces.py ve runtime.py dosyalarına ufak bir ekleme yaptım.

sha256 doğrulama kodu

Kod: [Seç]
9cd146e102830eba178df7b7f8ca697cead48fef91b8191a126e07b3dbed4714  lutris_0.4.23-fixed_amd64.deb
Düzeltme: sha256 doğrulama kodu ekledim ve pakette ufak bir düzeltme yaptım.
« Son Düzenleme: 16 Ocak 2019, 04:14:34 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16272
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Lutris açılmama sorunu
« Yanıtla #6 : 16 Ocak 2019, 17:02:46 »
@Leopard 'ın Github sayfasında bahsettiği gibi sorun Openssl sürümü ile alakalıymış. Sürümü güncelleyince sorun çözüldü. Openssl'in 1.1.1 sürümü, aşağıdaki komutlarla PPA depoları eklenerek kurulabilir. Bu durumda düzeltilmiş paketi kullanmanıza gerek yok, PPA deposundan güncelleme yapmak istemeyenler düzeltilmiş paketi kullanabilir.

Linux Mint 19.x serisi (ve Ubuntu 18.04 tabanı) için

Kod: [Seç]
sudo add-apt-repository ppa:mgrocock/openssl
Linux Mint 18.x serisi (ve Ubuntu 16.04 tabanı) için

Kod: [Seç]
sudo add-apt-repository ppa:carsten-uppenbrink-net/openssl
Ardından Güncelleme Yönetisini yenileyip Openssl ile ilgili güncellemeleri kurabilirsiniz.


Düzenleme: Linux Mint 185.x için Openssl PPA deposu değişti.
« Son Düzenleme: 14 Şubat 2019, 23:38:34 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Leopard

  • Forum Sorumlusu
  • *****
  • İleti: 996
  • Dağıtım: Linux Mint 19.1 64-bit
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia Geforce GTX 1050
  • İşlemci: Intel Core i7 7700HQ
Ynt: Lutris açılmama sorunu
« Yanıtla #7 : 17 Ocak 2019, 13:50:52 »
@Butterfly

Hocam denedim verdiğiniz paketi , 16.04 tabanında çalışıyor.

Bu ssl sorunu illa ki düzelecek ama sadece bizde çıkması baya garip doğrusu.
The only people who should kill are those prepared themselves to die!



Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16272
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Lutris açılmama sorunu
« Yanıtla #8 : 17 Ocak 2019, 19:40:53 »
Sorun ascii kodlamasından kaynaklı olabilir, kodlamayı utf destekli yaparlarsa sorun büyük ihtimalle çözülecektir. Zaten LC_ALL=C değişkeni ile sorun yaşanmaması da buna işaret ediyor gibi. Openssl'in son sürümünde bundan kaynaklı bir Python uyumluluk sorununu düzeltmiş olabilirler.

Emin olmamakla birlikte, güncel Opensll sürümünde düzelmenin kaynağı şu düzeltme olabilir.

Changes between 1.0.2h and 1.1.0  [25 Aug 2016]

  *) Windows command-line tool supports UTF-8 opt-in option for arguments
     and console input. Setting OPENSSL_WIN32_UTF8 environment variable
     (to any value) allows Windows user to access PKCS#12 file generated
     with Windows CryptoAPI and protected with non-ASCII password, as well
     as files generated under UTF-8 locale on Linux also protected with
     non-ASCII password.
     [Andy Polyakov]
« Son Düzenleme: 17 Ocak 2019, 19:48:12 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...