Gönderen Konu: Linux Mint 19.1 - KDE kurulum hatası  (Okunma sayısı 241 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı egetun

  • Çok Yeni Penguen
  • *
  • İleti: 8
    • egetun
    • EGETUN.com
  • Dağıtım: Linux Mint
  • Masaüstü: Xfce
  • Grafik Kartı: Nvidia GeForce GT 740M
  • İşlemci: Intel i5
Linux Mint 19.1 - KDE kurulum hatası
« : 11 Ocak 2019, 16:39:24 »
merhabalar.

bildiğimiz gibi linux mint 19 ve 19.1'de kde iso'ları yer almadı. ancak sonrasından kde kurabilmek teknik olarak mümkün.
 
internet aramalarından yola çıkarak uyguladığım yöntemlerde ise çözemediğim bir sıkıntıyla karşılaştım.

yöntemleri özetleyecek olursak;
 
Kod: [Seç]
sudo add-apt-repository ppa:kubuntu-ppa/ppa
sudo apt update
sudo apt install kubuntu-desktop

komutlarını uygulamamız yeterli oluyor.

ancak sorun bundan sonra başlıyor. esasen yeni bir depo eklemesek dahi kubuntu paketleri zaten yazılım yöneticisi'nde görünüyor. ancak her iki koşulda da (yani yeni depoyu eklemeden öncesinde ve sonrasında) kurmak istediğim zaman aşağıdaki durum ile karşılaşıyorum.

Kod: [Seç]
Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
  kubuntu-desktop : Bağımlılıklar: software-properties-kde ama kurulmayacak
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.

çıktının tamamı türkçe [https://ghostbin.com/paste/s9z8a] ve ingiliizce [https://ghostbin.com/paste/qrtdd] olarak ayrı ayrı mevcut.

bir diğer sorun, software-properties-kde'i ayrıca kurmak istediğimde karşıma karşılanmamış başka bir bağımlılık daha çıkarıyor. her defasında "<x paket>: bağımlılıklar: <y paket> ama kurulmayacak" şeklinde birbirlerini kovalıyorlar.

işin ilginç tarafı, synaptic paket yöneticisi'nde herhangi bir bozuk paket yörünmemekte. mint19.1 64bit xfce sürümünü kullanıyorum. sonrasında hatayı tekrarlayabilmek için virtualbox'ta mint19.1-32bit xfce sürümünü kurdum ve hem harici kubuntu deposunu eklemeden öncesinde ve sonrasında, aynı şekilde kde paketlerini kurmak istediğimde de aynı hatayı aldım. bu hatayı denen almış olabileceğimi düşünerek interneti kurcaladım, ama bir sonuca varamadım.

işin komut tarafı, youtube'da bu işlemi yaparken sorunsuzca gerçekleşen kurulum video'ları mevcut. tek fark ise onların mint19'da bunu yapıyor olmaları, 19.1'de değil.

aramalarıma karşın benzer bir başlığa denk gelmediğim için ve çözümsüz kaldığım için bu başlığı açmış bulunuyorum. aynı içeriğe sahip başka bir başlık açılmış ise şimdiden özür dilerim.
Deniz Ege Tunçay

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16608
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Linux Mint 19.1 - KDE kurulum hatası
« Yanıtla #1 : 11 Ocak 2019, 16:57:40 »
Aşağıdaki komutların çıktılarına bakalım.

Kod: [Seç]
apt install software-properties-kde
apt policy python3-software-properties
« Son Düzenleme: 11 Ocak 2019, 16:59:57 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı egetun

  • Çok Yeni Penguen
  • *
  • İleti: 8
    • egetun
    • EGETUN.com
  • Dağıtım: Linux Mint
  • Masaüstü: Xfce
  • Grafik Kartı: Nvidia GeForce GT 740M
  • İşlemci: Intel i5
Ynt: Linux Mint 19.1 - KDE kurulum hatası
« Yanıtla #2 : 12 Ocak 2019, 00:10:05 »
Kod: [Seç]
apt install software-properties-kde
[sudo] password for egetun: 
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Bazı paketler kurulamadı. Bu durum, olanaksız bir durum istemiş
olduğunuzu ya da kararsız (unstable) dağıtımı kullandığınızı ve
bazı paketlerin henüz oluşturulamamış  ya da oluşturulmakta
olduğunu gösterir.
Aşağıdaki bilgiler durumu çözmenize yardımcı olabilir:

Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
 software-properties-kde : Bağımlılıklar: python3-software-properties (= 0.96.24.32.7) ama 1.8.4 kurulacak
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.



Kod: [Seç]
apt policy python3-software-properties
python3-software-properties:
  Kurulu: 1.8.4
  Aday:   1.8.4
  Sürüm çizelgesi:
 *** 1.8.4 700
        700 http://mint.ipacct.com/packages tessa/upstream amd64 Packages
        700 http://mint.ipacct.com/packages tessa/upstream i386 Packages
        100 /var/lib/dpkg/status
     0.96.24.32.7 500
        500 http://ubuntu.saglayici.com/ubuntu bionic-updates/main amd64 Packages
        500 http://ubuntu.saglayici.com/ubuntu bionic-updates/main i386 Packages
     0.96.24.32.1 500
        500 http://ubuntu.saglayici.com/ubuntu bionic/main amd64 Packages
        500 http://ubuntu.saglayici.com/ubuntu bionic/main i386 Packages

Deniz Ege Tunçay

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16608
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Linux Mint 19.1 - KDE kurulum hatası
« Yanıtla #3 : 12 Ocak 2019, 00:17:39 »
Alıntı
*** 1.8.4 700
        700 http://mint.ipacct.com/packages tessa/upstream amd64 Packages
        700 http://mint.ipacct.com/packages tessa/upstream i386 Packages
        100 /var/lib/dpkg/status
     0.96.24.32.7 500
        500 http://ubuntu.saglayici.com/ubuntu bionic-updates/main amd64 Packages
        500 http://ubuntu.saglayici.com/ubuntu bionic-updates/main i386 Packages
     0.96.24.32.1 500
        500 http://ubuntu.saglayici.com/ubuntu bionic/main amd64 Packages
        500 http://ubuntu.saglayici.com/ubuntu bionic/main i386 Packages

Linux Mint deposundaki python3-software-properties paketi, Ubuntu deposundaki paketi ezdiği için sorun oluyor sanırım. Aşağıdaki komutla önce bu sorunu çözüp, ardından kurulum deneyebilirsiniz.

Kod: [Seç]
sudo apt install python3-software-properties/bionic
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı egetun

  • Çok Yeni Penguen
  • *
  • İleti: 8
    • egetun
    • EGETUN.com
  • Dağıtım: Linux Mint
  • Masaüstü: Xfce
  • Grafik Kartı: Nvidia GeForce GT 740M
  • İşlemci: Intel i5
Ynt: Linux Mint 19.1 - KDE kurulum hatası
« Yanıtla #4 : 12 Ocak 2019, 01:05:33 »
Kod: [Seç]
sudo apt install python3-software-properties/bionic

sisteme kde kurmak istiyorum, ancak xfce'i kaldırmayacağım. dahası, masaüstü ortamları arasında geçiş yapabilirim, diye umuyorum. bu komutun ardından xfce arayüzünde bir hatayla karşılaşmamak için önce virtualbox'taki sistemde deneyeyim.

Mesajlar Birleştirildi.
Kod: [Seç]
sudo apt install python3-software-properties/bionic

bu komutu girdim.

Kod: [Seç]
$ sudo apt install python3-software-properties/bionic
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Selected version '0.96.24.32.7' (Ubuntu:18.04/bionic-updates [all]) for 'python3-software-properties'
Recommended packages:
  unattended-upgrades
The following packages will be DOWNGRADED:
  python3-software-properties
0 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 136 not upgraded.
Need to get 22,0 kB of archives.
After this operation, 120 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 python3-software-properties all 0.96.24.32.7 [22,0 kB]
Fetched 22,0 kB in 0s (56,7 kB/s)               
dpkg: warning: downgrading python3-software-properties from 1.8.4 to 0.96.24.32.7
(Reading database ... 251276 files and directories currently installed.)
Preparing to unpack .../python3-software-properties_0.96.24.32.7_all.deb ...
Unpacking python3-software-properties (0.96.24.32.7) over (1.8.4) ...
Setting up python3-software-properties (0.96.24.32.7) ...

bu komutun ardından...

Kod: [Seç]
$ sudo apt install software-properties-kde
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:

(...)

Unpacking software-properties-kde (0.96.24.32.7) ...
dpkg: error processing archive /tmp/apt-dpkg-install-JYdxMn/111-software-properties-kde_0.96.24.32.7_all.deb (--unpack):
 trying to overwrite '/usr/share/man/man1/software-properties-kde.1.gz', which is also in package mintsources 1.8.4
Errors were encountered while processing:
 /tmp/apt-dpkg-install-JYdxMn/111-software-properties-kde_0.96.24.32.7_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


... şeklinde bir hata aldım. hata çıktısının tamamı ise burada.
« Son Düzenleme: 12 Ocak 2019, 02:43:39 Gönderen: egetun »
Deniz Ege Tunçay

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16608
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Linux Mint 19.1 - KDE kurulum hatası
« Yanıtla #5 : 12 Ocak 2019, 03:48:16 »
Aşağıdaki komutla software-properties-kde paketini kaldırıp,

Kod: [Seç]
sudo apt purge software-properties-kde
aşağıdaki komutla kde-full paketi ile kurulum yapmayı deneyebilirsiniz. Bu paketin software-properties-kde bağımlılığı olmadığı için sorun olmadan kurulum yapabilirsiniz. Bu şekilde SDDM gibi ikinci bir görüntü yöneticisi de kurulmayacaktır. Böylece LightDM ile yola devam edebilirsiniz.

Kod: [Seç]
apt install kde-full systemsettings
Aşağıdaki komutla Türkçe dil paketlerini de kurabilirsiniz.

Kod: [Seç]
apt install language-pack-kde-tr kde-l10n-tr
« Son Düzenleme: 12 Ocak 2019, 04:02:42 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...