Gönderen Konu: Lamp Server Kurulumu Sonrasında .htaccess Çalışmaması  (Okunma sayısı 164 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı BlockCode

  • Çok Yeni Penguen
  • *
  • İleti: 1
  • Dağıtım: Mint
  • Masaüstü: Cinnamon
  • RAM: 12
Merhaba hocalar,
Sorunun çözümü  ile  alakalı  yaptığım araştırmada apache/conf/httpd.conf dosyasından yapılması gereken ayarlar olduğunu öğrendim evvela bende böyle bir dosya yok apache2/apache.conf adında bir config dosyam var.

Ardından  "#LoadModule rewrite_module modules/mod_rewrite.so" bu ayarı bulup yorum satırı halinden çıkarmam gerek ama benim config dosyamda  bu yazıda yok.
   
"Allowverride None" yazan yeride "Allowoverride All"  olarak değiştirmem gerekiyor tamamdır bu mevcut aşağıdaki gibi değiştirdim. Fakat bu seferde İnterval Server 500 Hatası alıyorum. bu hatanın kaynağı da "mod_rewrite" aktif  olmamasından dolayıymış fakat  "sudo a2enmod rewrite" bu komutu terminale girdiğimde "Module rewrite already enabled" Diyor işin  içinden  çıkamadım. Aşağıya conf  dosyamın linkini de bırakıyorum.

<Directory /var/www/>
   Options Indexes FollowSymLinks
   AllowOverride All
   Require all granted
</Directory>


etc/apache2/apache2.conf dosyamın içeriği  : https://paste.ubuntu.com/p/3GjRwdQ3Bp/



Yardımlarınız için şimdiden çok teşekkürler..


 

Çevrimiçi Danny

  • Proje Sorumlusu
  • *****
  • İleti: 1998
  • Nihilist
  • Dağıtım: Linux Mint
  • Masaüstü: Cinnamon
  • Grafik Kartı: Intel HD 620
  • İşlemci: Intel i7 - 7500U
  • RAM: 8 GB
Ynt: Lamp Server Kurulumu Sonrasında .htaccess Çalışmaması
« Yanıtla #1 : 11 Ocak 2019, 09:58:21 »
Kurumu hangi kaynaktan yararlanarak gerçekleştirdiniz ?
Gelip sağ yanağımdan öptü. Dindar değildim ama sol yanağımı da çevirmek istedim o an...