Gönderen Konu: [Çözüldü] Cinnamon Uygulamacık, Tema, Eklenti Önbelleği Yüklenemiyor [SSL: CERTIFICATE_VERIFY_FAILED  (Okunma sayısı 461 defa)

dnnkys ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı nongliadin

  • Yeni Penguen
  • *
  • İleti: 48
  • Dağıtım: Mint
  • Masaüstü: Cinnamon
  • İşlemci: Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz
Merhaba. Uygulamacıklar'ı açıp indir sekmesine geldiğimde bu hatayı alıyorum.


« Son Düzenleme: 08 Ocak 2019, 22:05:23 Gönderen: nongliadin »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16229
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Alıntı
Kurulum Öncesi ve Sonrası

Kurulum aşamasında ve sonrasında yaşadığınız sorunlara ait yardım alabileceğiniz forum alanı. Lütfen bu bölüme kurulum ile ilgisi olmayan hususlarda konu açmayınız.

@nongliadin , lütfen konuları uygun bölümlere açmaya özen gösteriniz, konu açıklamaları konuları hangi bölümlerde çabileceğiniz hususunda yardımcı olacaktır. Konu Cinnamon masaüstü bölümüne taşınmıştır.

Alıntı
[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:847)

Benzer sorunları yaşayanların forum içi arama yaptıklarında bulabilmeleri amacıyla, hata çıktılarını foruma aktarmaya dikkat edelim.



Aynı sorun bende de mevcut. Sanırım "Cinnamon Spices" sitesinde SSL sertifikası ile ilgili geçici genel bir sorun yaşanıyor (bununla birlikte web tarayıcısı ile sertifika geçerli görünüyor). Bu sorunun etrafından aşağıdaki şekilde dolaşabilirsiniz.

Önce aşağıdaki komutla Spices.py dosyasını yedekleyiniz.

Kod: [Seç]
sudo cp /usr/share/cinnamon/cinnamon-settings/bin/Spices.py /usr/share/cinnamon/cinnamon-settings/bin/Spices.py.YEDEK
Ardından aşağıdaki komutla Spices.py dosyasını açınız.

Kod: [Seç]
sudo xed /usr/share/cinnamon/cinnamon-settings/bin/Spices.py
Açılan dosyada aşağıdaki satırı bulup,

Kod: [Seç]
    import datetime
bir altına aşağıdaki satırı ekleyiniz, girintilerin aynı olmasına dikkat ediniz.

Kod: [Seç]
    import ssl
Ardından dosyanın en altına aşağıdaki satırı ekleyip dosyayı kaydediniz.

Kod: [Seç]
ssl._create_default_https_context = ssl._create_unverified_context
Bu işlemler geçici olarak SSL sertifikasının sorgulanmamasını sağlayacaktır. Sorun çözüldüğünde yedeklediğiniz dosyayı geri almayı ya da eklediğiniz satırları silmeyi deneyebilirsiniz.
« Son Düzenleme: 08 Ocak 2019, 20:03:10 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı nongliadin

  • Yeni Penguen
  • *
  • İleti: 48
  • Dağıtım: Mint
  • Masaüstü: Cinnamon
  • İşlemci: Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz
@nongliadin , lütfen konuları uygun bölümlere açmaya özen gösteriniz, konu açıklamaları konuları hangi bölümlerde çabileceğiniz hususunda yardımcı olacaktır. Konu Cinnamon masaüstü bölümüne taşınmıştır.

Benzer sorunları yaşayanların forum içi arama yaptıklarında bulabilmeleri amacıyla, hata çıktılarını foruma aktarmaya dikkat edelim.



Aynı sorun bende de mevcut. Sanırım "Cinnamon Spices" sitesinde SSL sertifikası ile ilgili geçici genel bir sorun yaşanıyor (bununla birlikte web tarayıcısı ile sertifika geçerli görünüyor). Bu sorunun etrafından aşağıdaki şekilde dolaşabilirsiniz.

Önce aşağıdaki komutla Spices.py dosyasını yedekleyiniz.

Kod: [Seç]
sudo cp /usr/share/cinnamon/cinnamon-settings/bin/Spices.py /usr/share/cinnamon/cinnamon-settings/bin/Spices.py.YEDEK
Ardından aşağıdaki komutla Spices.py dosyasını açınız.

Kod: [Seç]
sudo xed /usr/share/cinnamon/cinnamon-settings/bin/Spices.py
Açılan dosyada aşağıdaki satırı bulup,

Kod: [Seç]
    import datetime
bir altına aşağıdaki satırı ekleyiniz, girintilerin aynı olmasına dikkat ediniz.

Kod: [Seç]
    import ssl
Ardından dosyanın en altına aşağıdaki satırı ekleyip dosyayı kaydediniz.

Kod: [Seç]
ssl._create_default_https_context = ssl._create_unverified_context
Bu işlemler geçici olarak SSL sertifikasının sorgulanmamasını sağlayacaktır. Sorun çözüldüğünde yedeklediğiniz dosyayı geri almayı ya da eklediğiniz satırları silmeyi deneyebilirsiniz.
Üstadım belki inanmayacaksın ama konuları açmadan önce yarım saat düşünüyorum acaba nereye açsam diye. Kurulum öncesi ve sonrasına açmamın sebebide 6 ay önce kullandığımda böyle bir sorun yokdu. Şimdi tekrar Linux'a geçtim acaba kurulum da bir hata mı yaptım diye düşünüp buraya açtım... Bu arada çözüm için de teşşekkürler.

Çevrimdışı tolstoy

  • Yeni Penguen
  • *
  • İleti: 38
  • Dağıtım: Linux Mint 17.2 Rafaela
  • Masaüstü: Kde
  • Grafik Kartı: Nvidia GEFORCE GT 240M CUDA 1GB
  • İşlemci: İntel Core 2 Due Processor T9600
İyi günler,

Sistem ayarlarındaki uygulamacıklar sekmesinde oluşan hatayı gideremedim.
Form sayfanızda   https://forum.linuxmint.net.tr/index.php?topic=9827  belirtmiş olduğunuz gibi  komutları girip düzeltme imkanı bulamadım.

Kod: [Seç]
import os
    import sys
    import zipfile
    import shutil
    import cgi
    import subprocess
    import threading
    import time
    import dbus
    from PIL import Image
    import datetime
    import ssl
except Exception as detail:
    print(detail)
    sys.exit(1)

ve  sayfa sonuna eki;

Kod: [Seç]
  return Gtk.Image.new_from_icon_name('image-missing', 2)
            ssl._create_default_https_context = ssl._create_unverified_context

Uç birimdeki çıkan veri,

Kod: [Seç]
sudo xed /usr/share/cinnamon/cinnamon-settings/bin/Spices.py     

(xed:3404): Gdk-CRITICAL **: 17:48:03.693: gdk_window_get_window_type: assertion 'GDK_IS_WINDOW (window)' failed

(xed:3404): Gtk-CRITICAL **: 17:48:36.244: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:48:36.245: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:48:36.245: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:48:36.245: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:48:36.246: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:48:36.247: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:49:32.364: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:49:32.365: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:49:32.365: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:49:32.365: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:49:32.367: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:49:32.367: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:51:04.933: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:51:04.933: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:51:04.934: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:51:04.934: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:51:04.935: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

(xed:3404): Gtk-CRITICAL **: 17:51:04.935: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

** (xed:3404): WARNING **: 17:51:45.473: Set document metadata failed: Öznitelik metadata::xed-position ataması desteklenmiyor


Sertifika sorunundaki desteğinizi ve yardımlarınızı rica ederim. 



Saygılar


Düzenleme: Kod Etiketi
« Son Düzenleme: 09 Ocak 2019, 18:46:00 Gönderen: Butterfly »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16229
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
En sona eklediğiniz satırın başında girinti olmayacak, girintiyi sıfırlamayı deneyiniz. Aşağıdaki gibi görünecek.

Kod: [Seç]
        except Exception as e:
            print("There was an error processing one of the images. Try refreshing the cache.")
            return Gtk.Image.new_from_icon_name('image-missing', 2)
ssl._create_default_https_context = ssl._create_unverified_context
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı tolstoy

  • Yeni Penguen
  • *
  • İleti: 38
  • Dağıtım: Linux Mint 17.2 Rafaela
  • Masaüstü: Kde
  • Grafik Kartı: Nvidia GEFORCE GT 240M CUDA 1GB
  • İşlemci: İntel Core 2 Due Processor T9600

Yardımınıza teşekkür ederim.Tamamdır.

Saygılar.

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16229
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Sorunun doğrudan çözümü için bir düzeltme gönderdim. Düzeltmeyi içeren dosyayı aşağıdaki komutlarla sisteminize indirebilirsiniz.

Kod: [Seç]
wget --no-check-certificate https://raw.githubusercontent.com/linuxmint/Cinnamon/584cbed6b908090531467fe00adb4909245a12f3/files/usr/share/cinnamon/cinnamon-settings/bin/Spices.py
Kod: [Seç]
sudo cp -rf ./Spices.py /usr/share/cinnamon/cinnamon-settings/bin/
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı talhax33

  • Yeni Penguen
  • *
  • İleti: 45
Cinnamon Tema Hatası
« Yanıtla #7 : 15 Ocak 2019, 21:38:05 »
Merhaba sayın hocalarım.Linux mint cinnamon kullanmaktayım bugün tema değiştireyim dedim fakat tema önbelleğinin güncellenmesi esnasında "sunucuya erişim sağlama sırasında bir hata oluştu " şeklinde bir hata alıyorum ön bellek güncellenemediği için güzeilim temaları indirip deneyemiyorum da yardımlarınız için teşekkürler şimdiden.Hata resmi şu şekilde ;



Çevrimdışı Depresif

  • Yeni Penguen
  • *
  • İleti: 77
  • Dağıtım: Linux Mint 19.1
  • Masaüstü: Cinnamon
  • İşlemci: Pentium 2.70GHz × 2
  • RAM: 3.8 Gb
Panel ve Masaüstü Uygulamacıkları Sorunu
« Yanıtla #8 : 17 Ocak 2019, 20:15:39 »
Panele ve masaüstüne yeni uygulamacık indirmeye çalıştığımda şu hatayı alıyorum. Bu hatayı 19.1 sürümünü temiz kurulum yaptıktan sonra almaya başladım.




Çevrimdışı metin_mehmet

  • Çok Yeni Penguen
  • *
  • İleti: 1
Arkadaşlar,
sistem ayarları - temalar - ekle/kardır tıkladığımda önbellek güncellensin mi diye soruyor.
Evet dediğimde
sunucuya erişim sağlama denenirken bir sorun yaşandı. Lütfen bi süre sonra tekrar deneyin .

detaylar (SSL:SERTIFICATE_VERIFY_FAİLED)  ...........(_ssl.c:847 )

bu konuda yardımcı olabilecek var mı

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16229
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Lütfen uygun konulara mesaj gönderelim, öncesinde forum içi arama yapmayı ihmal etmeyelim.

Mesajınız bölünerek çözüm içeren konuyla birleştirildi.
Elimizden geldiğince dilimizin döndüğünce...