Gönderen Konu: [Çözüldü] Linux Mint 19.1 Kurulumda ve Kurulum Sonrasında Donma  (Okunma sayısı 99 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı rtaha

  • Çok Yeni Penguen
  • *
  • İleti: 5
  • Dağıtım: Linux Mint
Merhaba iyi forumlar. Öncelikle sorunumla ilgili kısa bir özet geçmek istiyorum. Sorunum dağıtımdan bağımsız bir sorun sanırım. Fakat yeterli bilgim olmadığı için tam olarak neyden kaynaklı bilemiyorum. Şöyleki Linux Mint'de dahil olmak üzere herhangi bir dağıtımda kurulum yapmak istediğimde ve kurulum sonrasında çeşitli kernel parametreleri kullanmak zorunda kalıyorum. Örneğin pcie=nomsi veya noaer Fakat tam olarak sorunumun neyden kaynaklandığını bilmediğim için bu parametrelerde kesin bir çözüm olmuyor gibi. Şimdi Linux Mint 19.1 ile temiz kurulum yapmak istediğim için kurulum öncesi bu problemi sizinle paylaşmak istedim.

Bariz Belirtiler.
1) Açılış ve kapanış esnasında çeşitli yazılar çıkması. (Açılış ve kapanış esnasında olduğu için maalesef detaylı bir çıktı veremiyorum)

2) Parametre eklemeden kurulum yapılamaması
3) Parametre eklemeden kullanmak istenildiğinde arkaplanda muhtemelen açılırken veya kapanırken bastırılan mesajlar bastırılmaya devam ettiği için ciddi bir performans kaybı yaşanması.

Linux Mint 19.1 Beta kurulumu yapmıştım. Ve bu kurulum ve sonrasında pcie=noaer parametresini kullanmak zorunda kalmıştım.

Kod: [Seç]
System:    Host: asus Kernel: 4.19.0-1-amd64 x86_64 bits: 64 compiler: gcc v: 6.3.0
           Desktop: Xfce 4.12.3 tk: Gtk 2.24.31 wm: xfwm4 dm: LightDM
           Distro: MX-18_x64 Continuum March 14  2018 base: Debian GNU/Linux 9 (stretch)
Machine:   Type: Laptop System: ASUSTeK product: X541UV v: 1.0 serial: <filter>
           Mobo: ASUSTeK model: X541UV v: 1.0 serial: <filter> UEFI: American Megatrends
           v: X541UV.304 date: 07/17/2017
Battery:   ID-1: BAT0 charge: 34.8 Wh condition: 34.8/34.6 Wh (101%) volts: 10.8/10.8
           model: ASUSTeK ASUS Battery serial: <filter> status: Not charging
CPU:       Topology: Dual Core model: Intel Core i5-6198DU bits: 64 type: MT MCP arch: Skylake
           rev: 3 L2 cache: 3072 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19200
           Speed: 2700 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 2700 2: 2700 3: 2700
           4: 2700
Graphics:  Device-1: Intel HD Graphics 510 vendor: ASUSTeK driver: i915 v: kernel
           bus ID: 00:02.0 chip ID: 8086:1906
           Device-2: NVIDIA GM108M [GeForce 920MX] driver: N/A bus ID: 01:00.0
           chip ID: 10de:134f
           Display: x11 server: X.Org 1.19.2 driver: modesetting unloaded: fbdev,vesa
           resolution: 1366x768~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 510 (Skylake GT1) v: 4.5 Mesa 18.2.6
           compat-v: 3.0 direct render: Yes
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel
           v: kernel bus ID: 00:1f.3 chip ID: 8086:9d70
           Sound Server: ALSA v: k4.19.0-1-amd64
Network:   Device-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet vendor: ASUSTeK
           driver: r8169 v: kernel port: d000 bus ID: 02:00.2 chip ID: 10ec:8136
           IF: eth0 state: down mac: <filter>
           Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lite-On
           driver: rtl8723be v: kernel port: c000 bus ID: 03:00.0 chip ID: 10ec:b723
           IF: wlan0 state: up mac: <filter>
Drives:    Local Storage: total: 223.57 GiB used: 68.57 GiB (30.7%)
           ID-1: /dev/sda vendor: SanDisk model: Ultra II 240GB size: 223.57 GiB speed: 6.0 Gb/s
           serial: <filter>
Partition: ID-1: / size: 216.81 GiB used: 68.57 GiB (31.6%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 2.00 GiB used: 2.2 MiB (0.1%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 53.0 C mobo: N/A
           Fan Speeds (RPM): cpu: 2700
Info:      Processes: 195 Uptime: 2m Memory: 3.72 GiB used: 880.3 MiB (23.1%) Init: SysVinit
           v: 2.88 runlevel: 5 default: 5 Compilers: gcc: 6.3.0 alt: 6 Shell: bash v: 4.4.12
           running in: xfce4-terminal inxi: 3.0.29
« Son Düzenleme: 04 Ocak 2019, 18:40:47 Gönderen: rtaha »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16061
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Linux Mint 19.1 Kurulumda ve Kurulum Sonrasında Donma
« Yanıtla #1 : 27 Aralık 2018, 21:29:48 »
pcie=nomsi yerine pci=nomsi değişkeni olacak sanırım. pcie=noaer değişkenini açılışta sorun çözmeye hiç bir faydası yok. Sadece PCIE ile ilgili hata raporlamayı engelliyor. pci=nomsi  değişkeni işe yarayabilir, burada kullanım amacından bahsetmiştik.

Bir de yardımcı olunmasını zorlaştırmamak için, hataları resim olarak paylaşmak yerine, bir miktar zahmetle hata çıktılarını metin olarak foruma aktarmanız daha olumlu olacaktır. Ya da ilgili hatayı masaüstüne ulaştığınızda dmesh komutunun çıktısından süzebilirsiniz.

Hata mesajındaki aygtın hangisi olduğunu aşağıdaki komutun çıktısı ile anlayabilirsiniz. Komutun çıktısından PCI aygıtların PID ve VID değerlerine ulaşılabilir. Bu şekilde hangi aygıt ile sorun yaşandığı bilgisini paylaşabilirsiniz.

Kod: [Seç]
lspci -nn
Kurulum sonrasında Bumbelbe kurarsanız, donma ile ilgili sorunun çözüleceğini düşünüyorum.


Eğer sorun bu şekilde çözülmezse, aşağıdaki komutlarla pci=nomsi değişkenini kalıcı hale getirebilirsiniz.

Kod: [Seç]
echo 'GRUB_CMDLINE_LINUX="$GRUB_CMDLINE_LINUX pci=nomsi"' | sudo tee  /etc/default/grub.d/nomsi.cfg
Kod: [Seç]
sudo update-grub
Eğer pcie=noaer değişkenini de eklemek isterseniz aşağıdaki komutları kullanınız.

Kod: [Seç]
echo 'GRUB_CMDLINE_LINUX="$GRUB_CMDLINE_LINUX pci=nomsi pcie=noaer"' | sudo tee  /etc/default/grub.d/nomsi.cfg
Kod: [Seç]
sudo update-grub
Çekirdek değişkenlerinin ne işe yaradıkları burada ve buradaki kaynaklarda ayrıntılı olarak açıklanıyor.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı rtaha

  • Çok Yeni Penguen
  • *
  • İleti: 5
  • Dağıtım: Linux Mint
Ynt: Linux Mint 19.1 Kurulumda ve Kurulum Sonrasında Donma
« Yanıtla #2 : 04 Ocak 2019, 18:40:19 »
pcie=nomsi yerine pci=nomsi değişkeni olacak sanırım. pcie=noaer değişkenini açılışta sorun çözmeye hiç bir faydası yok. Sadece PCIE ile ilgili hata raporlamayı engelliyor. pci=nomsi  değişkeni işe yarayabilir, burada kullanım amacından bahsetmiştik.

Bir de yardımcı olunmasını zorlaştırmamak için, hataları resim olarak paylaşmak yerine, bir miktar zahmetle hata çıktılarını metin olarak foruma aktarmanız daha olumlu olacaktır. Ya da ilgili hatayı masaüstüne ulaştığınızda dmesh komutunun çıktısından süzebilirsiniz.

Hata mesajındaki aygtın hangisi olduğunu aşağıdaki komutun çıktısı ile anlayabilirsiniz. Komutun çıktısından PCI aygıtların PID ve VID değerlerine ulaşılabilir. Bu şekilde hangi aygıt ile sorun yaşandığı bilgisini paylaşabilirsiniz.

Kod: [Seç]
lspci -nn
Kurulum sonrasında Bumbelbe kurarsanız, donma ile ilgili sorunun çözüleceğini düşünüyorum.


Eğer sorun bu şekilde çözülmezse, aşağıdaki komutlarla pci=nomsi değişkenini kalıcı hale getirebilirsiniz.

Kod: [Seç]
echo 'GRUB_CMDLINE_LINUX="$GRUB_CMDLINE_LINUX pci=nomsi"' | sudo tee  /etc/default/grub.d/nomsi.cfg
Kod: [Seç]
sudo update-grub
Eğer pcie=noaer değişkenini de eklemek isterseniz aşağıdaki komutları kullanınız.

Kod: [Seç]
echo 'GRUB_CMDLINE_LINUX="$GRUB_CMDLINE_LINUX pci=nomsi pcie=noaer"' | sudo tee  /etc/default/grub.d/nomsi.cfg
Kod: [Seç]
sudo update-grub
Çekirdek değişkenlerinin ne işe yaradıkları burada ve buradaki kaynaklarda ayrıntılı olarak açıklanıyor.

Forumda bulunamadım uzun süre kusura bakmayın cevap için teşekkürler ediyorum.