Gönderen Konu: samba paketi sorunu  (Okunma sayısı 280 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı alierol

  • Yeni Penguen
  • *
  • İleti: 65
samba paketi sorunu
« : 11 Aralık 2018, 16:56:03 »
Güncellemelerde samba paketi kurulmadı ve sürekli hata veriyor.
"E: samba: installed samba package post-installation script subprocess returned error exit status 1"
çözümü bilen var mı?
Linux dışında işletim sistemi kullanmam.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16809
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı alierol

  • Yeni Penguen
  • *
  • İleti: 65
Ynt: samba paketi sorunu
« Yanıtla #2 : 18 Aralık 2018, 14:59:09 »
Kod: [Seç]
sudo apt-get install -f

Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  libuser1 linux-headers-4.15.0-33 linux-headers-4.15.0-33-generic linux-headers-4.15.0-34
  linux-headers-4.15.0-34-generic linux-headers-4.15.0-36 linux-headers-4.15.0-36-generic linux-headers-4.15.0-38
  linux-headers-4.15.0-38-generic linux-image-4.15.0-33-generic linux-image-4.15.0-34-generic
  linux-image-4.15.0-36-generic linux-image-4.15.0-38-generic linux-modules-4.15.0-33-generic
  linux-modules-4.15.0-34-generic linux-modules-4.15.0-36-generic linux-modules-4.15.0-38-generic
  linux-modules-extra-4.15.0-33-generic linux-modules-extra-4.15.0-34-generic linux-modules-extra-4.15.0-36-generic
  linux-modules-extra-4.15.0-38-generic python-libuser
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
1 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 0 B ek disk alanı kullanılacak.
Ayarlanıyor: samba (2:4.7.6+dfsg~ubuntu-0ubuntu2.5) ...
Samba is not being run as an AD Domain Controller.
Please ignore the following error about deb-systemd-helper not finding samba-ad-dc.service.

Job for nmbd.service failed because a timeout was exceeded.
See "systemctl status nmbd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript nmbd, action "restart" failed.
● nmbd.service - Samba NMB Daemon
   Loaded: loaded (/lib/systemd/system/nmbd.service; enabled; vendor preset: enabled)
   Active: failed (Result: timeout) since Tue 2018-12-18 14:57:21 +03; 7ms ago
     Docs: man:nmbd(8)
           man:samba(7)
           man:smb.conf(5)
  Process: 25956 ExecStart=/usr/sbin/nmbd --foreground --no-process-group $NMBDOPTIONS (code=killed, signal=TERM)
 Main PID: 25956 (code=killed, signal=TERM)
   Status: "nmbd: No local IPv4 non-loopback interfaces available, waiting for interface ..."

Ara 18 14:55:51 ali-merkez nmbd[25956]:   Ignoring unknown parameter "password level"
Ara 18 14:55:51 ali-merkez nmbd[25956]: [2018/12/18 14:55:51.394464,  0] ../lib/param/loadparm.c:784(lpcfg_map_parameter)
Ara 18 14:55:51 ali-merkez nmbd[25956]:   Unknown parameter encountered: "update encrypted"
Ara 18 14:55:51 ali-merkez nmbd[25956]: [2018/12/18 14:55:51.394476,  0] ../lib/param/loadparm.c:1811(lpcfg_do_global_parameter)
Ara 18 14:55:51 ali-merkez nmbd[25956]:   Ignoring unknown parameter "update encrypted"
Ara 18 14:55:51 ali-merkez nmbd[25956]: [2018/12/18 14:55:51.395609,  0] ../lib/util/become_daemon.c:135(daemon_status)
Ara 18 14:55:51 ali-merkez nmbd[25956]:   STATUS=daemon 'nmbd' : No local IPv4 non-loopback interfaces available, waiting for interface ...NOTE: NetBIOS name resolution is not supported for Internet Protocol Version 6 (IPv6).
Ara 18 14:57:21 ali-merkez systemd[1]: nmbd.service: Start operation timed out. Terminating.
Ara 18 14:57:21 ali-merkez systemd[1]: nmbd.service: Failed with result 'timeout'.
Ara 18 14:57:21 ali-merkez systemd[1]: Failed to start Samba NMB Daemon.
dpkg: samba paketi işlenirken sorun yaşandı (--configure):
 installed samba package post-installation script subprocess returned error exit status 1
Tetikleyiciler işleniyor: libc-bin (2.27-3ubuntu1) ...
İşleme sırasında hatalarla karşılaşıldı:
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)


Linux dışında işletim sistemi kullanmam.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16809
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: samba paketi sorunu
« Yanıtla #3 : 18 Aralık 2018, 16:25:48 »
Aşağıdaki komutların çıktılarına bakalım.

Kod: [Seç]
systemctl status NetworkManager-wait-online.service
journalctl --no-pager -b -p3
systemctl --no-pager --state=failed
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı alierol

  • Yeni Penguen
  • *
  • İleti: 65
Ynt: samba paketi sorunu
« Yanıtla #4 : 22 Aralık 2018, 01:02:11 »
Kod: [Seç]
[code]systemctl status NetworkManager-wait-online.service
● NetworkManager-wait-online.service - Network Manager Wait Online
   Loaded: loaded (/lib/systemd/system/NetworkManager-wait-online.service; enabl
   Active: active (exited) since Sat 2018-12-22 00:45:11 +03; 10min ago
     Docs: man:nm-online(1)
  Process: 937 ExecStart=/usr/bin/nm-online -s -q --timeout=30 (code=exited, sta
 Main PID: 937 (code=exited, status=0/SUCCESS)

Ara 22 00:45:07 ali-merkez systemd[1]: Starting Network Manager Wait Online...
Ara 22 00:45:11 ali-merkez systemd[1]: Started Network Manager Wait Online.
lines 1-9/9 (END)[code]
-------------------------------
[code]journalctl --no-pager -b -p3
-- Logs begin at Mon 2018-08-27 19:15:46 +03, end at Sat 2018-12-22 00:57:24 +03. --
Ara 22 00:45:02 ali-merkez kernel: CX24123: cx24123_i2c_readreg: reg=0x0 (error=-121)
Ara 22 00:45:02 ali-merkez kernel: CX24123: wrong demod revision: 87
Ara 22 00:45:12 ali-merkez nmbd[1004]: [2018/12/22 00:45:12.667779,  0] ../lib/param/loadparm.c:784(lpcfg_map_parameter)
Ara 22 00:45:12 ali-merkez nmbd[1004]:   Unknown parameter encountered: "password level"
Ara 22 00:45:12 ali-merkez nmbd[1004]: [2018/12/22 00:45:12.709940,  0] ../lib/param/loadparm.c:1811(lpcfg_do_global_parameter)
Ara 22 00:45:12 ali-merkez nmbd[1004]:   Ignoring unknown parameter "password level"
Ara 22 00:45:12 ali-merkez nmbd[1004]: [2018/12/22 00:45:12.710046,  0] ../lib/param/loadparm.c:784(lpcfg_map_parameter)
Ara 22 00:45:12 ali-merkez nmbd[1004]:   Unknown parameter encountered: "update encrypted"
Ara 22 00:45:12 ali-merkez nmbd[1004]: [2018/12/22 00:45:12.710055,  0] ../lib/param/loadparm.c:1811(lpcfg_do_global_parameter)
Ara 22 00:45:12 ali-merkez nmbd[1004]:   Ignoring unknown parameter "update encrypted"
Ara 22 00:45:12 ali-merkez nmbd[1004]: [2018/12/22 00:45:12.711204,  0] ../lib/util/become_daemon.c:135(daemon_status)
Ara 22 00:45:12 ali-merkez nmbd[1004]:   STATUS=daemon 'nmbd' : No local IPv4 non-loopback interfaces available, waiting for interface ...NOTE: NetBIOS name resolution is not supported for Internet Protocol Version 6 (IPv6).
Ara 22 00:45:19 ali-merkez pulseaudio[1488]: [pulseaudio] pid.c: Daemon already running.
Ara 22 00:45:48 ali-merkez pulseaudio[1391]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Ara 22 00:46:45 ali-merkez systemd[1]: Failed to start Samba NMB Daemon.
Ara 22 00:46:45 ali-merkez smbd[1771]: [2018/12/22 00:46:45.840695,  0] ../lib/param/loadparm.c:784(lpcfg_map_parameter)
Ara 22 00:46:45 ali-merkez smbd[1771]:   Unknown parameter encountered: "password level"
Ara 22 00:46:45 ali-merkez smbd[1771]: [2018/12/22 00:46:45.840731,  0] ../lib/param/loadparm.c:1811(lpcfg_do_global_parameter)
Ara 22 00:46:45 ali-merkez smbd[1771]:   Ignoring unknown parameter "password level"
Ara 22 00:46:45 ali-merkez smbd[1771]: [2018/12/22 00:46:45.840832,  0] ../lib/param/loadparm.c:784(lpcfg_map_parameter)
Ara 22 00:46:45 ali-merkez smbd[1771]:   Unknown parameter encountered: "update encrypted"
Ara 22 00:46:45 ali-merkez smbd[1771]: [2018/12/22 00:46:45.840841,  0] ../lib/param/loadparm.c:1811(lpcfg_do_global_parameter)
Ara 22 00:46:45 ali-merkez smbd[1771]:   Ignoring unknown parameter "update encrypted"
Ara 22 00:46:45 ali-merkez smbd[1771]: [2018/12/22 00:46:45.960737,  0] ../lib/util/become_daemon.c:124(daemon_ready)
Ara 22 00:46:45 ali-merkez smbd[1771]:   STATUS=daemon 'smbd' finished starting up and ready to serve connections

-----------------------------------------------
[code]systemctl --no-pager --state=failed
  UNIT         LOAD   ACTIVE SUB    DESCRIPTION                               
● nmbd.service loaded failed failed Samba NMB Daemon                           

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.

1 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.

Linux dışında işletim sistemi kullanmam.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16809
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: samba paketi sorunu
« Yanıtla #5 : 22 Aralık 2018, 01:20:36 »
Aşağıdaki komutla samba paketini kaldırıp sistemi yeniden başlatınız.

Kod: [Seç]
sudo apt purge samba
Sistemi yeniden başlattıktan sonra paketi tekrar kurmayı deneyiniz.

Kod: [Seç]
sudo apt install samba
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı alierol

  • Yeni Penguen
  • *
  • İleti: 65
Ynt: samba paketi sorunu
« Yanıtla #6 : 22 Aralık 2018, 02:03:52 »
yine hata verdi

 
Kod: [Seç]
[code]sudo apt purge samba
[sudo] password for ans:
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  libuser1 linux-headers-4.15.0-33 linux-headers-4.15.0-33-generic
  linux-headers-4.15.0-34 linux-headers-4.15.0-34-generic
  linux-headers-4.15.0-36 linux-headers-4.15.0-36-generic
  linux-headers-4.15.0-38 linux-headers-4.15.0-38-generic
  linux-image-4.15.0-33-generic linux-image-4.15.0-34-generic
  linux-image-4.15.0-36-generic linux-image-4.15.0-38-generic
  linux-modules-4.15.0-33-generic linux-modules-4.15.0-34-generic
  linux-modules-4.15.0-36-generic linux-modules-4.15.0-38-generic
  linux-modules-extra-4.15.0-33-generic linux-modules-extra-4.15.0-34-generic
  linux-modules-extra-4.15.0-36-generic linux-modules-extra-4.15.0-38-generic
  python-dnspython python-libuser tdb-tools
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Aşağıdaki paketler KALDIRILACAK:
  gadmin-samba* samba*
0 paket yükseltilecek, 0 yeni paket kurulacak, 2 paket kaldırılacak ve 4 paket yükseltilmeyecek.
1 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 11,6 MB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] E
(Veritabanı okunuyor ... 462189 dosya veya dizin kurulu durumda.)
Kaldırılıyor: gadmin-samba (0.3.2-0ubuntu2) ...
Kaldırılıyor: samba (2:4.7.6+dfsg~ubuntu-0ubuntu2.5) ...
Tetikleyiciler işleniyor: mime-support (3.60ubuntu1) ...
Tetikleyiciler işleniyor: desktop-file-utils (0.23+linuxmint4) ...
Tetikleyiciler işleniyor: menu (2.1.47ubuntu2.1) ...
Tetikleyiciler işleniyor: libc-bin (2.27-3ubuntu1) ...
Tetikleyiciler işleniyor: man-db (2.8.3-2ubuntu0.1) ...
Tetikleyiciler işleniyor: gnome-menus (3.13.3-11ubuntu1.1) ...
(Veritabanı okunuyor ... 461980 dosya veya dizin kurulu durumda.)
Yapılandırma dosyaları kaldırılıyor: gadmin-samba (0.3.2-0ubuntu2) ...
dpkg: uyarı: gadmin-samba kaldırılırken '/var/lib/samba/profiles' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: gadmin-samba kaldırılırken '/etc/gadmin-samba' dizini boş olmadığı için kaldırılmadı
Yapılandırma dosyaları kaldırılıyor: samba (2:4.7.6+dfsg~ubuntu-0ubuntu2.5) ...
Tetikleyiciler işleniyor: ufw (0.35-5) ...
Tetikleyiciler işleniyor: ureadahead (0.100.0-20) ...
ureadahead will be reprofiled on next reboot
Tetikleyiciler işleniyor: menu (2.1.47ubuntu2.1) ...
Tetikleyiciler işleniyor: systemd (237-3ubuntu10.9) ...

-------------------------------------------------------------------
[code] sudo apt install samba
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  libuser1 linux-headers-4.15.0-33 linux-headers-4.15.0-33-generic
  linux-headers-4.15.0-34 linux-headers-4.15.0-34-generic
  linux-headers-4.15.0-36 linux-headers-4.15.0-36-generic
  linux-headers-4.15.0-38 linux-headers-4.15.0-38-generic
  linux-image-4.15.0-33-generic linux-image-4.15.0-34-generic
  linux-image-4.15.0-36-generic linux-image-4.15.0-38-generic
  linux-modules-4.15.0-33-generic linux-modules-4.15.0-34-generic
  linux-modules-4.15.0-36-generic linux-modules-4.15.0-38-generic
  linux-modules-extra-4.15.0-33-generic linux-modules-extra-4.15.0-34-generic
  linux-modules-extra-4.15.0-36-generic linux-modules-extra-4.15.0-38-generic
  python-libuser
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Önerilen paketler:
  bind9 bind9utils ctdb ldb-tools ntp | chrony smbldap-tools winbind
Tavsiye edilen paketler:
  samba-dsdb-modules samba-vfs-modules
Aşağıdaki YENİ paketler kurulacak:
  samba
0 paket yükseltilecek, 1 yeni paket kurulacak, 0 paket kaldırılacak ve 4 paket yükseltilmeyecek.
0 B/854 kB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 11,2 MB ek disk alanı kullanılacak.
Daha önce seçili olmayan samba paketi seçiliyor.
(Veritabanı okunuyor ... 461973 dosya veya dizin kurulu durumda.)
Paket açılacak: .../samba_2%3a4.7.6+dfsg~ubuntu-0ubuntu2.5_amd64.deb ...
Paket açılıyor: samba (2:4.7.6+dfsg~ubuntu-0ubuntu2.5) ...
Tetikleyiciler işleniyor: ufw (0.35-5) ...
Tetikleyiciler işleniyor: ureadahead (0.100.0-20) ...
Tetikleyiciler işleniyor: libc-bin (2.27-3ubuntu1) ...
Tetikleyiciler işleniyor: systemd (237-3ubuntu10.9) ...
Tetikleyiciler işleniyor: man-db (2.8.3-2ubuntu0.1) ...
Ayarlanıyor: samba (2:4.7.6+dfsg~ubuntu-0ubuntu2.5) ...
Samba is not being run as an AD Domain Controller, masking samba-ad-dc.service.
Please ignore the following error about deb-systemd-helper not finding samba-ad-dc.service.
Job for nmbd.service failed because a timeout was exceeded.
See "systemctl status nmbd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript nmbd, action "start" failed.
● nmbd.service - Samba NMB Daemon
   Loaded: loaded (/lib/systemd/system/nmbd.service; disabled; vendor preset: enabled)
   Active: failed (Result: timeout) since Sat 2018-12-22 01:55:28 +03; 4ms ago
     Docs: man:nmbd(8)
           man:samba(7)
           man:smb.conf(5)
  Process: 7938 ExecStart=/usr/sbin/nmbd --foreground --no-process-group $NMBDOPTIONS (code=killed, signal=TERM)
 Main PID: 7938 (code=killed, signal=TERM)
   Status: "nmbd: No local IPv4 non-loopback interfaces available, waiting for interface ..."

Ara 22 01:53:58 ali-merkez nmbd[7938]: [2018/12/22 01:53:58.288058,  0] ../lib/param/loadparm.c:784(lpcfg_map_parameter)
Ara 22 01:53:58 ali-merkez nmbd[7938]:   Unknown parameter encountered: "password level"
Ara 22 01:53:58 ali-merkez nmbd[7938]: [2018/12/22 01:53:58.288097,  0] ../lib/param/loadparm.c:1811(lpcfg_do_global_parameter)
Ara 22 01:53:58 ali-merkez nmbd[7938]:   Ignoring unknown parameter "password level"
Ara 22 01:53:58 ali-merkez nmbd[7938]: [2018/12/22 01:53:58.288220,  0] ../lib/param/loadparm.c:784(lpcfg_map_parameter)
Ara 22 01:53:58 ali-merkez nmbd[7938]:   Unknown parameter encountered: "update encrypted"
Ara 22 01:53:58 ali-merkez nmbd[7938]: [2018/12/22 01:53:58.288230,  0] ../lib/param/loadparm.c:1811(lpcfg_do_global_parameter)
Ara 22 01:53:58 ali-merkez nmbd[7938]:   Ignoring unknown parameter "update encrypted"
Ara 22 01:53:58 ali-merkez nmbd[7938]: [2018/12/22 01:53:58.289376,  0] ../lib/util/become_daemon.c:135(daemon_status)
Ara 22 01:53:58 ali-merkez nmbd[7938]:   STATUS=daemon 'nmbd' : No local IPv4 non-loopback interfaces available, waiting for interface ...NOTE: NetBIOS name resolution is not supported for Internet Protocol Version 6 (IPv6).
dpkg: samba paketi işlenirken sorun yaşandı (--configure):
 installed samba package post-installation script subprocess returned error exit status 1
Tetikleyiciler işleniyor: libc-bin (2.27-3ubuntu1) ...
Tetikleyiciler işleniyor: systemd (237-3ubuntu10.9) ...
Tetikleyiciler işleniyor: ureadahead (0.100.0-20) ...
Tetikleyiciler işleniyor: ufw (0.35-5) ...
İşleme sırasında hatalarla karşılaşıldı:
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)


Mesajlar Birleştirildi.
bu hatayı sürekli veriyor
Kod: [Seç]
Samba is not being run as an AD Domain Controller, masking samba-ad-dc.service.
Please ignore the following error about deb-systemd-helper not finding samba-ad-dc.service.

« Son Düzenleme: 22 Aralık 2018, 02:09:35 Gönderen: alierol »
Linux dışında işletim sistemi kullanmam.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16809
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: samba paketi sorunu
« Yanıtla #7 : 22 Aralık 2018, 03:43:16 »
Aşağıdaki komutu uçbirimde çalıştırın.

Kod: [Seç]
sudo xed /var/lib/dpkg/info/samba.postrm
Açılan dosya içeriğini silin ve şağıdaki satırları dosyaya ekleyip kaydedin.

Kod: [Seç]
#! /bin/sh -e

set -e

if [ "$1" = purge ]; then

if [ -e /usr/share/debconf/confmodule ]; then
. /usr/share/debconf/confmodule
db_purge
fi
fi

# Automatically added by dh_installinit/11.1.6ubuntu1
if [ "$1" = "purge" ] ; then
update-rc.d samba-ad-dc remove >/dev/null
fi


# In case this system is running systemd, we make systemd reload the unit files
# to pick up changes.
if [ -d /run/systemd/system ] ; then
systemctl --system daemon-reload >/dev/null || true
fi
# End automatically added section
# Automatically added by dh_installinit/11.1.6ubuntu1
if [ "$1" = "purge" ] ; then
update-rc.d nmbd remove >/dev/null
fi


# In case this system is running systemd, we make systemd reload the unit files
# to pick up changes.
if [ -d /run/systemd/system ] ; then
systemctl --system daemon-reload >/dev/null || true
fi
# End automatically added section
# Automatically added by dh_installinit/11.1.6ubuntu1
if [ "$1" = "purge" ] ; then
update-rc.d smbd remove >/dev/null
fi


# In case this system is running systemd, we make systemd reload the unit files
# to pick up changes.
if [ -d /run/systemd/system ] ; then
systemctl --system daemon-reload >/dev/null || true
fi
# End automatically added section
# Automatically added by dh_installdeb/11.1.6ubuntu1
dpkg-maintscript-helper rm_conffile /etc/init/nmbd.conf 2:4.6.5\+dfsg-5\~ -- "$@"
dpkg-maintscript-helper rm_conffile /etc/init/reload-smbd.conf 2:4.6.5\+dfsg-5\~ -- "$@"
dpkg-maintscript-helper rm_conffile /etc/init/samba-ad-dc.conf 2:4.6.5\+dfsg-5\~ -- "$@"
dpkg-maintscript-helper rm_conffile /etc/init/smbd.conf 2:4.6.5\+dfsg-5\~ -- "$@"
dpkg-maintscript-helper rm_conffile /etc/init.d/samba 2:4.6.5\+dfsg-5\~ -- "$@"
# End automatically added section
# Automatically added by dh_installsystemd/11.1.6ubuntu1
if [ "$1" = "remove" ]; then
if [ -x "/usr/bin/deb-systemd-helper" ]; then
deb-systemd-helper mask 'nmbd.service' 'smbd.service' >/dev/null || true
fi
fi

if [ "$1" = "purge" ]; then
if [ -x "/usr/bin/deb-systemd-helper" ]; then
deb-systemd-helper purge 'nmbd.service' 'smbd.service' >/dev/null || true
deb-systemd-helper unmask 'nmbd.service' 'smbd.service' >/dev/null || true
fi
fi
# End automatically added section

Ardından aşağıdaki komutu yeniden çalıştırarak samba paketini silmeyi deneyin.

Kod: [Seç]
sudo apt purge samba
Elimizden geldiğince dilimizin döndüğünce...