Gönderen Konu: [Çözüldü] Eski bir Ubuntu sürümüne program yükleme  (Okunma sayısı 230 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı marcos3

  • Yeni Penguen
  • *
  • İleti: 55
  • Dağıtım: Zorin OS 12.4 Lite
  • Masaüstü: Xfce
  • Grafik Kartı: Intel + Nvidia Optimus
  • İşlemci: i3 işlemci 2300 mhz 2.30 Ghz x2
Ubuntunun eski bir sürümünü kurmayı düşünüyorum.

Bu sürümde program kurmak için depoları nasıl ekleyebilirim ?

Yani eski bir sürümü kullanacağım ama program kurarken sorun yaşamak istemiyorum. Bunun için ne yapmalıyız ?
« Son Düzenleme: 18 Kasım 2018, 00:12:45 Gönderen: marcos3 »

Çevrimdışı okanakinci

  • Penguen
  • ***
  • İleti: 315
  • Dağıtım: Linux Mint 19
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia GT820M + Intel Haswell-ULT
  • İşlemci: Intel Core i5-4210U @ 1.70GHz x 2
Ynt: Eski bir Ubuntu sürümüne program yükleme
« Yanıtla #1 : 17 Kasım 2018, 14:00:11 »
Sözünü ettiğiniz eski sürümün desteği sona ermişse depoları kapatılmıştır. Bu yüzden kendi depolarını kullanamazsınız. İlgili yazılımın PPA deposu da ancak desteği kesmemişse ve ilgili paketin bağımlılığı yoksa ancak öyle kurabilirsiniz. Sorun yaşamanız çok muhtemeldir.Sorunuzun cevabı değil ama destek süresi sonra ermiş bir sürümü kullanmanızı tavsiye etmem.

Ubuntu'nun hangi sürümünü kullanıyorsunuz ve hangi yazılımı yüklemek istiyorsunuz? Böylece sürümün desteğinin sona erip ermediğini öğrenebiliriz.

Çevrimdışı marcos3

  • Yeni Penguen
  • *
  • İleti: 55
  • Dağıtım: Zorin OS 12.4 Lite
  • Masaüstü: Xfce
  • Grafik Kartı: Intel + Nvidia Optimus
  • İşlemci: i3 işlemci 2300 mhz 2.30 Ghz x2
Ynt: Eski bir Ubuntu sürümüne program yükleme
« Yanıtla #2 : 17 Kasım 2018, 15:16:09 »
Sözünü ettiğiniz eski sürümün desteği sona ermişse depoları kapatılmıştır. Bu yüzden kendi depolarını kullanamazsınız. İlgili yazılımın PPA deposu da ancak desteği kesmemişse ve ilgili paketin bağımlılığı yoksa ancak öyle kurabilirsiniz. Sorun yaşamanız çok muhtemeldir.Sorunuzun cevabı değil ama destek süresi sonra ermiş bir sürümü kullanmanızı tavsiye etmem.

Ubuntu'nun hangi sürümünü kullanıyorsunuz ve hangi yazılımı yüklemek istiyorsunuz? Böylece sürümün desteğinin sona erip ermediğini öğrenebiliriz.

Ubuntu nun eski sürümlerinde ram kullanımı daha azdı. Linux Mint in de 17. sürümü öncesinde.

Ubuntu da 14.04 lts sürümü öncesinde ram kullanımı çok azdı.

Bu yüzden eski sürümleri kurmak istedim. Eski sürümler indirilebilir durumda ama program kurulmuyor.

Dediğiniz gibi depolar kapalı.

Peki bu eski sürümlere yeni depolar eklenemez mi ?

Çevrimdışı okanakinci

  • Penguen
  • ***
  • İleti: 315
  • Dağıtım: Linux Mint 19
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia GT820M + Intel Haswell-ULT
  • İşlemci: Intel Core i5-4210U @ 1.70GHz x 2
Ynt: Eski bir Ubuntu sürümüne program yükleme
« Yanıtla #3 : 17 Kasım 2018, 16:13:50 »
Ubuntu'nun şu an desteği devam eden sürümleri 14.04, 16.04, 18.04 ve 18.10 sürümleridir. Sizin kullanmak istediğiniz sürüm bunların dışında anladığım kadarıyla.

Belki bir PPA eklersiniz bilemiyorum hiç denemedim ama o PPA'dan paket yüklerken bile sıkıntı yaşayacaksınız. Çünkü o PPA'lardaki paketlerin bile bağımlılıkları var ve Ubuntu depoları kapalı olduğu için kuramayacaksınız.

Yeni sürümlerin depolarını eski sürüme entegre etmekten bahsediyorsanız bu da mümkün değil, mümkün olsa bile kesinlikle tavsiye etmem. Çünkü hem uyumsuzluk sorunlarından dolayı sisteminiz kararsız hâle gelecek ve belki de tamamen kullanılmaz hâle gelecek hem de hiçbir sorun yaşanmasa bile güncel depolardaki paketler güncelleme yoluyla eskilerinin yerini aldığında sistem yeniden hantallaşacak.

Eğer eski sürüm kullanma isteğinizin nedeni sadece bilgisayarınızın kaldırabileceği hafif bir dağıtım kullanmaksa bunu daha güncel dağıtımlarda da yapabilirsiniz. Gnome, Unity, Cinnamon gibi masaüstü ortamlarının yerine çok daha hafif masaüstü ortamları var. Ayrıca Gnome ve KDE gibi dağıtımlar da son güncellemelerle daha da akıcı oldular. Ubuntu'dan daha hafif dağıtım tabanları da var. Başlı başına sadece eski bilgisayarlar için geliştirilmiş hafif dağıtımlar da var. Ayrıca kullandığınız bütün yazılımların hafif alternatifleri de var. Yani desteği kesilmiş bir Ubuntu sürümü yerine güncel ama hafif bir dağıtım bulabilirsiniz.

Çevrimdışı marcos3

  • Yeni Penguen
  • *
  • İleti: 55
  • Dağıtım: Zorin OS 12.4 Lite
  • Masaüstü: Xfce
  • Grafik Kartı: Intel + Nvidia Optimus
  • İşlemci: i3 işlemci 2300 mhz 2.30 Ghz x2
Ynt: Eski bir Ubuntu sürümüne program yükleme
« Yanıtla #4 : 17 Kasım 2018, 18:33:06 »
Ubuntu'nun şu an desteği devam eden sürümleri 14.04, 16.04, 18.04 ve 18.10 sürümleridir. Sizin kullanmak istediğiniz sürüm bunların dışında anladığım kadarıyla.

Belki bir PPA eklersiniz bilemiyorum hiç denemedim ama o PPA'dan paket yüklerken bile sıkıntı yaşayacaksınız. Çünkü o PPA'lardaki paketlerin bile bağımlılıkları var ve Ubuntu depoları kapalı olduğu için kuramayacaksınız.

Yeni sürümlerin depolarını eski sürüme entegre etmekten bahsediyorsanız bu da mümkün değil, mümkün olsa bile kesinlikle tavsiye etmem. Çünkü hem uyumsuzluk sorunlarından dolayı sisteminiz kararsız hâle gelecek ve belki de tamamen kullanılmaz hâle gelecek hem de hiçbir sorun yaşanmasa bile güncel depolardaki paketler güncelleme yoluyla eskilerinin yerini aldığında sistem yeniden hantallaşacak.

Eğer eski sürüm kullanma isteğinizin nedeni sadece bilgisayarınızın kaldırabileceği hafif bir dağıtım kullanmaksa bunu daha güncel dağıtımlarda da yapabilirsiniz. Gnome, Unity, Cinnamon gibi masaüstü ortamlarının yerine çok daha hafif masaüstü ortamları var. Ayrıca Gnome ve KDE gibi dağıtımlar da son güncellemelerle daha da akıcı oldular. Ubuntu'dan daha hafif dağıtım tabanları da var. Başlı başına sadece eski bilgisayarlar için geliştirilmiş hafif dağıtımlar da var. Ayrıca kullandığınız bütün yazılımların hafif alternatifleri de var. Yani desteği kesilmiş bir Ubuntu sürümü yerine güncel ama hafif bir dağıtım bulabilirsiniz.


O zaman Ubuntu tabanlı bir distro indirip üzerine lxde kurmak en mantıklısı görünüyor. Lxqt denedim alışamadım.

Lxde masaüstünü sonradan bir dağıtıma kurmak nasıl olur sizce ? Bu şekilde güncel ve hafif bir distro olur diye düşünüyorum.

Çevrimdışı sinanix

  • Yeni Penguen
  • *
  • İleti: 20
  • Dağıtım: Mint Arch
  • Masaüstü: Xfce Kde
  • Grafik Kartı: İntel+nvıdıa
  • İşlemci: İ5
Ynt: Eski bir Ubuntu sürümüne program yükleme
« Yanıtla #5 : 17 Kasım 2018, 20:46:13 »
Sizin bilgisayara en uygun dagıtım  Antix, tavsiye ederim.Degilse Openbox dağıtımını öneririm.Linux dagıtımlarının bir çoğu Openbox distro çıkarıyor Distrowact sitesinden inceleme yapabilirsiniz.

Çevrimdışı marcos3

  • Yeni Penguen
  • *
  • İleti: 55
  • Dağıtım: Zorin OS 12.4 Lite
  • Masaüstü: Xfce
  • Grafik Kartı: Intel + Nvidia Optimus
  • İşlemci: i3 işlemci 2300 mhz 2.30 Ghz x2
Ynt: Eski bir Ubuntu sürümüne program yükleme
« Yanıtla #6 : 17 Kasım 2018, 20:58:38 »
Sizin bilgisayara en uygun dagıtım  Antix, tavsiye ederim.Degilse Openbox dağıtımını öneririm.Linux dagıtımlarının bir çoğu Openbox distro çıkarıyor Distrowact sitesinden inceleme yapabilirsiniz.

Openbox ı da ilk açtığım da sudan çıkmış balığa dönüyorum  :D

Yani çabuk ayarlayamıyorum. Gerekli kodları bilmiyorum. Çok hafif bir masaüstü ama ayarlaması çok zor.

Openbox üzerinde cairodock benzeri bir uygulama kullanmak lazım. Çabuk ayarlayabilmek için.

Openbox + Cairodock kullanabilir miyim ?
« Son Düzenleme: 17 Kasım 2018, 21:02:19 Gönderen: marcos3 »

Çevrimdışı sinanix

  • Yeni Penguen
  • *
  • İleti: 20
  • Dağıtım: Mint Arch
  • Masaüstü: Xfce Kde
  • Grafik Kartı: İntel+nvıdıa
  • İşlemci: İ5
Ynt: Eski bir Ubuntu sürümüne program yükleme
« Yanıtla #7 : 17 Kasım 2018, 22:15:05 »
Openbox masaüstü'de diger dagıtımlar gibi özelleştirilebilir.Bahsettiğiniz dock kurulabilir fakat biraz fazla kaynak tüketen bir programdır.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16061
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Eski bir Ubuntu sürümüne program yükleme
« Yanıtla #8 : 17 Kasım 2018, 22:41:18 »
Desteği biten sürümlerin paketleri buradaki farklı bir alanda arşivleniyor. Eğer desteği biten br sürüm kullanmak istiyorsanız depo listesini buna göre burada anlatıldığı biçimde değiştirmelisiniz. Sadece bağlantıdaki kısmı uygulayacaksınız, konudaki diğer adımlar desteği biten sürümün yükseltilmesi ile ilgili.

Bir de buna benzer konuyu daha önce açmıştınız, böyle durumlarda yeni konu açmak yerine eski konunun kilidinin açılmasını talep etmeniz forum düzeni daha uygun olacaktır.

Ayrıca dağıtım, sürüm vb. ile ilgili tavsiye almak için bu konu yerine yeni bir konu açmanızı rica edelim.

Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı marcos3

  • Yeni Penguen
  • *
  • İleti: 55
  • Dağıtım: Zorin OS 12.4 Lite
  • Masaüstü: Xfce
  • Grafik Kartı: Intel + Nvidia Optimus
  • İşlemci: i3 işlemci 2300 mhz 2.30 Ghz x2
Ynt: Eski bir Ubuntu sürümüne program yükleme
« Yanıtla #9 : 17 Kasım 2018, 23:26:56 »
Desteği biten sürümlerin paketleri buradaki farklı bir alanda arşivleniyor. Eğer desteği biten br sürüm kullanmak istiyorsanız depo listesini buna göre burada anlatıldığı biçimde değiştirmelisiniz. Sadece bağlantıdaki kısmı uygulayacaksınız, konudaki diğer adımlar desteği biten sürümün yükseltilmesi ile ilgili.

Bir de buna benzer konuyu daha önce açmıştınız, böyle durumlarda yeni konu açmak yerine eski konunun kilidinin açılmasını talep etmeniz forum düzeni daha uygun olacaktır.

Ayrıca dağıtım, sürüm vb. ile ilgili tavsiye almak için bu konu yerine yeni bir konu açmanızı rica edelim.

Teşekkürler @Butterfly 

Şuan linux mint cinnamon üzerine lxde masaüstünü kurdum. Ama yazılım yöneticisi ve gdebi gtk da yetkiniz yoktur diyor. Program kuramıyorum.


Bu konuda ise Ubuntu nun desteği sona ermiş sürümlerinden birini kurmak istiyorum. 12.04 sürümünü kurarsam program kurmada sorun yaşar mıyım ?

Eski sürüm kurmak istiyorum çünkü 14.04 ten önceki sürümlerde ram kullanımı daha azdı. Mesela 12.04 ilk açıldığında 450 - 500 mb ram kullanıyordu.

Program kurma da sorun yaşamadan eski bir sürüm kurabilir miyim ?

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16061
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Eski bir Ubuntu sürümüne program yükleme
« Yanıtla #10 : 18 Kasım 2018, 00:00:10 »
Yukarıdaki bağlantıda anlatıldığı biçimde depo adreslerini değiştirirseniz, desteği biten sürümlere depodan paket ve uygulama kurabilirsiniz. Diğer sorunlara bu konudan çözüm aramanız forum tarzımıza uygun değil. Aynı konu içinde farklı soru ve sorunlar hakkında konuşmamayı tercih diyoruz. Her farklı soru ve sorun için yeni konu açmalısınız.

« Son Düzenleme: 18 Kasım 2018, 00:02:24 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı marcos3

  • Yeni Penguen
  • *
  • İleti: 55
  • Dağıtım: Zorin OS 12.4 Lite
  • Masaüstü: Xfce
  • Grafik Kartı: Intel + Nvidia Optimus
  • İşlemci: i3 işlemci 2300 mhz 2.30 Ghz x2
Ynt: Eski bir Ubuntu sürümüne program yükleme
« Yanıtla #11 : 18 Kasım 2018, 00:12:31 »
Yukarıdaki bağlantıda anlatıldığı biçimde depo adreslerini değiştirirseniz, desteği biten sürümlere depodan paket ve uygulama kurabilirsiniz. Diğer sorunlara bu konudan çözüm aramanız forum tarzımıza uygun değil. Aynı konu içinde farklı soru ve sorunlar hakkında konuşmamayı tercih diyoruz. Her farklı soru ve sorun için yeni konu açmalısınız.


Teşekkürler @Butterfly 

Etiketliyorum.