Gönderen Konu: [Çözüldü] Ekran kartı kurulumu sonrası siyah ekran ?  (Okunma sayısı 783 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16214
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #15 : 27 Ekim 2018, 02:17:43 »
Nouveau sürücüsünün etkin olmaması gerekirdi. Aşağıdaki komutların çıktısına bakalım.

Kod: [Seç]
lsmod | grep bbswitch
cat /proc/acpi/bbswitch
systemctl status nvidia-prime-boot.service
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı marcos3

  • Yeni Penguen
  • *
  • İleti: 55
  • Dağıtım: Zorin OS 12.4 Lite
  • Masaüstü: Xfce
  • Grafik Kartı: Intel + Nvidia Optimus
  • İşlemci: i3 işlemci 2300 mhz 2.30 Ghz x2
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #16 : 27 Ekim 2018, 02:21:26 »
Kod: [Seç]
:~$ lsmod | grep bbswitch

:~$ cat /proc/acpi/bbswitch

cat: /proc/acpi/bbswitch: Böyle bir dosya ya da dizin yok

l:~$ systemctl status nvidia-prime-boot.service

Unit nvidia-prime-boot.service could not be found[code]
« Son Düzenleme: 27 Ekim 2018, 02:24:17 Gönderen: marcos3 »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16214
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #17 : 27 Ekim 2018, 02:30:26 »
Bu sonuca göre bahsettiğim düzenlemeleri hala yapmamışsınız. Nvidia GPU'yu etkinleştirip sistemi yeniden başlattıktan sonra, yukarıya da alıntıladığım düzenlemeleri uygulamayı deneyiniz. Zaten adım adım ne yapacağınızı belirttim.

Ama öncelikle sisteminizi tam olarak güncelleyin, çıktılara göre hala eski çekirdeği ve mesa sürümünü kullanıyorsunuz. Lütfen yönlendirmeleri tam olarak uygulayın.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı marcos3

  • Yeni Penguen
  • *
  • İleti: 55
  • Dağıtım: Zorin OS 12.4 Lite
  • Masaüstü: Xfce
  • Grafik Kartı: Intel + Nvidia Optimus
  • İşlemci: i3 işlemci 2300 mhz 2.30 Ghz x2
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #18 : 27 Ekim 2018, 02:42:57 »
Bu sonuca göre bahsettiğim düzenlemeleri hala yapmamışsınız. Nvidia GPU'yu etkinleştirip sistemi yeniden başlattıktan sonra, yukarıya da alıntıladığım düzenlemeleri uygulamayı deneyiniz. Zaten adım adım ne yapacağınızı belirttim.

Ama öncelikle sisteminizi tam olarak güncelleyin, çıktılara göre hala eski çekirdeği ve mesa sürümünü kullanıyorsunuz. Lütfen yönlendirmeleri tam olarak uygulayın.



Mesajlar Birleştirildi.
Kod: [Seç]
:~$ lsmod | grep bbswitch

bbswitch               16384  0

:~$ cat /proc/acpi/bbswitch

0000:01:00.0 OFF

:~$ systemctl status nvidia-prime-boot.service

Unit nvidia-prime-boot.service could not be found[hr][color=red]Mesajlar Birleştirildi.[/color][hr]
Nvidia settings açılmıyor şuan.

Nouveau gpu etkin ve sıcaklık 70 C ye dayandı.  Intel gpu ya geçemiyorum.
« Son Düzenleme: 27 Ekim 2018, 03:19:18 Gönderen: marcos3 »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16214
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #19 : 27 Ekim 2018, 11:22:24 »
Alıntı
:~$ systemctl status nvidia-prime-boot.service

Unit nvidia-prime-boot.service could not be found

Sistemi yeniden başlattığınıza bu servis, güç tasarrufu etkinken Nvidia ve Nouveau ile ilgili sürücüleri pasifleştirecek bir dosyayı çalıştıryor. Sistemi yeniden başlatıp bu servisin etkin olup olmadığını aşağıdaki komutla bir daha kontrol edelim. Etkin değilse kurulumu tamamlamamışsınız demektir.

Kod: [Seç]
systemctl status nvidia-prime-boot.service

Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı marcos3

  • Yeni Penguen
  • *
  • İleti: 55
  • Dağıtım: Zorin OS 12.4 Lite
  • Masaüstü: Xfce
  • Grafik Kartı: Intel + Nvidia Optimus
  • İşlemci: i3 işlemci 2300 mhz 2.30 Ghz x2
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #20 : 27 Ekim 2018, 19:39:32 »
Sistemi yeniden başlattığınıza bu servis, güç tasarrufu etkinken Nvidia ve Nouveau ile ilgili sürücüleri pasifleştirecek bir dosyayı çalıştıryor. Sistemi yeniden başlatıp bu servisin etkin olup olmadığını aşağıdaki komutla bir daha kontrol edelim. Etkin değilse kurulumu tamamlamamışsınız demektir.

Kod: [Seç]
systemctl status nvidia-prime-boot.service

sıcaklık 70 c ye çıkınca kapattım. Şuan Elementary OS indiriyorum. Onda bumblebee yi deneyeceğim.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16214
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #21 : 27 Ekim 2018, 20:09:03 »
Size daha önce Bumblebee kurmanızı önermiştim zaten. Hatta Linux Mint 19 yerine, temiz biçimde  Linux Mint 18.3 kurun demiştim. Nvidia 520m ile Nvidia sürücüsü kursanız bile aman aman bir performans elde edemezsiniz, bu sebeple Bumblebee daha uygun bir çözüm. Forumdaki anlatım ile başarılı şekilde kurulum yapan pek çok üyemiz var.

Elementary OS sizin tercihiniz ama, bu aşamadan bile Bumblebee kurulumuna dönebilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı marcos3

  • Yeni Penguen
  • *
  • İleti: 55
  • Dağıtım: Zorin OS 12.4 Lite
  • Masaüstü: Xfce
  • Grafik Kartı: Intel + Nvidia Optimus
  • İşlemci: i3 işlemci 2300 mhz 2.30 Ghz x2
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #22 : 27 Ekim 2018, 20:38:19 »
Size daha önce Bumblebee kurmanızı önermiştim zaten. Hatta Linux Mint 19 yerine, temiz biçimde  Linux Mint 18.3 kurun demiştim. Nvidia 520m ile Nvidia sürücüsü kursanız bile aman aman bir performans elde edemezsiniz, bu sebeple Bumblebee daha uygun bir çözüm. Forumdaki anlatım ile başarılı şekilde kurulum yapan pek çok üyemiz var.

Elementary OS sizin tercihiniz ama, bu aşamadan bile Bumblebee kurulumuna dönebilirsiniz.

E OS iptal oldu inmedi. Lubuntu indirdim iso boyutu kucuk diye. Lubuntu uzerine farkli bir masaustu kurarim artik.

Bumblebee yi deneyelim.

Mesajlar Birleştirildi.
Bir ekran kartını ve programı kurmak daha kolay olmalı.

Linux ta program kurmak basit. Program sonrası dosya düzenlemeler bağımlılık sağlanamadı deyip programların kurulmaması bunlar kullanıcıları linux tan soğutuyor.

Windows 10 kurdum antivirüsler yavaşlattığı için kurmadım. Birçok gereksiz servisi devre dışı bıraktım. Time Freeze kullanıyorum. Windows ta kullandığım birkaç klasörü devre dışı bıraktım ve kalan bütün sistemi donduruyor.  Yeniden başlatınca sistem time freeze i açtığın ana geri dönüyor   :D

Linux hakkında yardım ettiğin için çok teşekkürler. Forumda ve yeni konularda sana kolaylıklar diliyorum. Kendine iyi bak  ;)
« Son Düzenleme: 28 Ekim 2018, 22:33:53 Gönderen: marcos3 »

Çevrimdışı marcos3

  • Yeni Penguen
  • *
  • İleti: 55
  • Dağıtım: Zorin OS 12.4 Lite
  • Masaüstü: Xfce
  • Grafik Kartı: Intel + Nvidia Optimus
  • İşlemci: i3 işlemci 2300 mhz 2.30 Ghz x2
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #23 : 30 Ekim 2018, 21:08:50 »
Windows 10 da patladı  :D

Hocam şuan Xubuntu indiriyorum 18.10

Sürücü kurulumunu nasıl yapalım ? Bumblebee kuralım.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16214
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #24 : 30 Ekim 2018, 21:34:19 »
Ubuntu 18.10 tabanında, Xubuntu gibi LightDM kullanan türevlerde Nvidia Prime eskisi gibi acpi çağrılarını kullanarak çalışıyormuş. Bu sebeple Ek Sürücülerden, sürücüyü kurmayı deneyebilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı marcos3

  • Yeni Penguen
  • *
  • İleti: 55
  • Dağıtım: Zorin OS 12.4 Lite
  • Masaüstü: Xfce
  • Grafik Kartı: Intel + Nvidia Optimus
  • İşlemci: i3 işlemci 2300 mhz 2.30 Ghz x2
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #25 : 30 Ekim 2018, 22:23:44 »
Bumblebee kurmayalım mı diyorsun ?

Direkt nvidia prime ı kuruyorum. İntel-microcode kuruluymuş zaten.

Ek sürücülerde nvidia 340 ve nvidia 390 var hocam hangisini kuralım ?
« Son Düzenleme: 30 Ekim 2018, 22:29:32 Gönderen: marcos3 »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16214
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #26 : 30 Ekim 2018, 22:31:07 »
Nvidia-390 .
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı marcos3

  • Yeni Penguen
  • *
  • İleti: 55
  • Dağıtım: Zorin OS 12.4 Lite
  • Masaüstü: Xfce
  • Grafik Kartı: Intel + Nvidia Optimus
  • İşlemci: i3 işlemci 2300 mhz 2.30 Ghz x2
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #27 : 30 Ekim 2018, 22:32:25 »
Tamam kurup yeniden başlatıyorum.

Mesajlar Birleştirildi.
Nvidia 390 prime kuruldu. Yeniden başlattım ve intel i seçtim. Oturumu kapatıp açtım.

Şuan 60 - 62 C sıcaklık

Mesajlar Birleştirildi.
Sıcaklık düşmüyor hocam yine aynı.

Sürekli arka planda bir işlem yapılıyormuş gibi fan hiç susmuyor.
« Son Düzenleme: 30 Ekim 2018, 22:50:41 Gönderen: marcos3 »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16214
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #28 : 30 Ekim 2018, 23:19:17 »
Intel GPU etkinken çıktılara bakalım.

Kod: [Seç]
inxi -Gxx
cat proc/cmdline
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı marcos3

  • Yeni Penguen
  • *
  • İleti: 55
  • Dağıtım: Zorin OS 12.4 Lite
  • Masaüstü: Xfce
  • Grafik Kartı: Intel + Nvidia Optimus
  • İşlemci: i3 işlemci 2300 mhz 2.30 Ghz x2
Ynt: Ekran kartı kurulumu sonrası siyah ekran ?
« Yanıtla #29 : 30 Ekim 2018, 23:22:08 »
Intel GPU etkinken çıktılara bakalım.

Kod: [Seç]
inxi -Gxx
cat proc/cmdline

Kod: [Seç]
:~$ inxi -Gxx
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0116
  Device-2: NVIDIA GF108M [GeForce GT 520M] driver: N/A bus ID: 01:00.0
  chip ID: 10de:0ded
  Display: x11 server: X.Org 1.20.1 driver: modesetting unloaded: fbdev,vesa
  resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 18.2.2
  compat-v: 3.0 direct render: Yes
:~$ cat proc/cmdline
cat: proc/cmdline: Böyle bir dosya ya da dizin yok
:~$ [code]