Gönderen Konu: Paket Yönetimi Bağımlılık ve Depo Sorunu  (Okunma sayısı 192 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı ternerov

  • Çok Yeni Penguen
  • *
  • İleti: 2
  • Dağıtım: linux mint
Paket Yönetimi Bağımlılık ve Depo Sorunu
« : 06 Eylül 2018, 20:21:28 »
selam ,
1. sudo dpkg --add-architecture i386
2. wget -nc https://dl.winehq.org/wine-builds/Release.key
3. sudo apt-key add Release.key
Kod: [Seç]
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
. If you want to get stable version: sudo apt-get install --install-recommends winehq-stablebu
sudo apt-get install --install-recommends winehq-stable

bunları yapıyorum aşağıdaki gibi bir hata veriyor.

Kod: [Seç]
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Bu sorunları düzeltmek için 'apt --fix-broken install' komutunu çalıştırmanız gerekebilir.
Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
 gconf2 : Bağımlılıklar: gconf-service (= 3.2.6-5)
 libgstreamer-gl1.0-0 : Bağımlılıklar: libgstreamer1.0-0 (>= 1.14.2) ama 1.14.1-1~ubuntu18.04.1 kurulacak
 libwebkit2gtk-4.0-37 : Bağımlılıklar: libjavascriptcoregtk-4.0-18 (= 2.20.5-1) ama 2.20.3-0ubuntu0.18.04.1 kurulacak
 vlc : Bağımlılıklar: vlc-bin (= 3.0.4-1) ama 3.0.3-1-1ubuntu1 kurulacak
       Bağımlılıklar: vlc-plugin-base (= 3.0.4-1) ama 3.0.3-1-1ubuntu1 kurulacak
       Tavsiye ettikleri: vlc-l10n (= 3.0.4-1) ama kurulmayacak
       Tavsiye ettikleri: vlc-plugin-notify (= 3.0.4-1) ama kurulmayacak
       Tavsiye ettikleri: vlc-plugin-samba (= 3.0.4-1) ama kurulmayacak
       Tavsiye ettikleri: vlc-plugin-skins2 (= 3.0.4-1) ama kurulmayacak
       Tavsiye ettikleri: vlc-plugin-video-splitter (= 3.0.4-1) ama kurulmayacak
       Tavsiye ettikleri: vlc-plugin-visualization (= 3.0.4-1) ama kurulmayacak
 vlc-plugin-qt : Bağımlılıklar: libvlccore9 (>= 3.0.4) ama 3.0.3-1-1ubuntu1 kurulacak
 vlc-plugin-video-output : Bağımlılıklar: libavcodec58 (>= 7:4.0) ama kurulmayacak ya da
                                              libavcodec-extra58 (>= 7:4.0) ama kurulmayacak
                           Bağımlılıklar: libavutil56 (>= 7:4.0) ama kurulmayacak
                           Bağımlılıklar: libplacebo5 (>= 0.4.0) ama kurulmayacak
                           Bağımlılıklar: libva2 (>= 2.2.0) ama 2.1.0-3 kurulacak
                           Bağımlılıklar: libvlccore9 (>= 3.0.4) ama 3.0.3-1-1ubuntu1 kurulacak
 winehq-stable : Bağımlılıklar: wine-stable (= 3.0.2~stretch)
W: Packages (main/binary-amd64/Packages) hedefi /etc/apt/sources.list.d/additional-repositories.list:1 ve /etc/apt/sources.list.d/additional-repositories.list:4 konumlarında birden fazla kez yapılandırılmış
W: Packages (main/binary-i386/Packages) hedefi /etc/apt/sources.list.d/additional-repositories.list:1 ve /etc/apt/sources.list.d/additional-repositories.list:4 konumlarında birden fazla kez yapılandırılmış
W: Packages (main/binary-all/Packages) hedefi /etc/apt/sources.list.d/additional-repositories.list:1 ve /etc/apt/sources.list.d/additional-repositories.list:4 konumlarında birden fazla kez yapılandırılmış
W: Translations (main/i18n/Translation-tr_TR) hedefi /etc/apt/sources.list.d/additional-repositories.list:1 ve /etc/apt/sources.list.d/additional-repositories.list:4 konumlarında birden fazla kez yapılandırılmış
W: Translations (main/i18n/Translation-tr) hedefi /etc/apt/sources.list.d/additional-repositories.list:1 ve /etc/apt/sources.list.d/additional-repositories.list:4 konumlarında birden fazla kez yapılandırılmış
W: Translations (main/i18n/Translation-en) hedefi /etc/apt/sources.list.d/additional-repositories.list:1 ve /etc/apt/sources.list.d/additional-repositories.list:4 konumlarında birden fazla kez yapılandırılmış
W: DEP-11 (main/dep11/Components-amd64.yml) hedefi /etc/apt/sources.list.d/additional-repositories.list:1 ve /etc/apt/sources.list.d/additional-repositories.list:4 konumlarında birden fazla kez yapılandırılmış
W: DEP-11 (main/dep11/Components-all.yml) hedefi /etc/apt/sources.list.d/additional-repositories.list:1 ve /etc/apt/sources.list.d/additional-repositories.list:4 konumlarında birden fazla kez yapılandırılmış
W: CNF (main/cnf/Commands-amd64) hedefi /etc/apt/sources.list.d/additional-repositories.list:1 ve /etc/apt/sources.list.d/additional-repositories.list:4 konumlarında birden fazla kez yapılandırılmış
W: CNF (main/cnf/Commands-all) hedefi /etc/apt/sources.list.d/additional-repositories.list:1 ve /etc/apt/sources.list.d/additional-repositories.list:4 konumlarında birden fazla kez yapılandırılmış
W: Packages (main/binary-amd64/Packages) hedefi /etc/apt/sources.list.d/yandex-disk.list:1 ve /etc/apt/sources.list.d/yandex.list:1 konumlarında birden fazla kez yapılandırılmış
W: Packages (main/binary-i386/Packages) hedefi /etc/apt/sources.list.d/yandex-disk.list:1 ve /etc/apt/sources.list.d/yandex.list:1 konumlarında birden fazla kez yapılandırılmış
W: Packages (main/binary-all/Packages) hedefi /etc/apt/sources.list.d/yandex-disk.list:1 ve /etc/apt/sources.list.d/yandex.list:1 konumlarında birden fazla kez yapılandırılmış
W: Translations (main/i18n/Translation-tr_TR) hedefi /etc/apt/sources.list.d/yandex-disk.list:1 ve /etc/apt/sources.list.d/yandex.list:1 konumlarında birden fazla kez yapılandırılmış
W: Translations (main/i18n/Translation-tr) hedefi /etc/apt/sources.list.d/yandex-disk.list:1 ve /etc/apt/sources.list.d/yandex.list:1 konumlarında birden fazla kez yapılandırılmış
W: Translations (main/i18n/Translation-en) hedefi /etc/apt/sources.list.d/yandex-disk.list:1 ve /etc/apt/sources.list.d/yandex.list:1 konumlarında birden fazla kez yapılandırılmış
W: DEP-11 (main/dep11/Components-amd64.yml) hedefi /etc/apt/sources.list.d/yandex-disk.list:1 ve /etc/apt/sources.list.d/yandex.list:1 konumlarında birden fazla kez yapılandırılmış
W: DEP-11 (main/dep11/Components-all.yml) hedefi /etc/apt/sources.list.d/yandex-disk.list:1 ve /etc/apt/sources.list.d/yandex.list:1 konumlarında birden fazla kez yapılandırılmış
W: CNF (main/cnf/Commands-amd64) hedefi /etc/apt/sources.list.d/yandex-disk.list:1 ve /etc/apt/sources.list.d/yandex.list:1 konumlarında birden fazla kez yapılandırılmış
W: CNF (main/cnf/Commands-all) hedefi /etc/apt/sources.list.d/yandex-disk.list:1 ve /etc/apt/sources.list.d/yandex.list:1 konumlarında birden fazla kez yapılandırılmış
E: Karşılanmamış bağımlılıklar. 'apt --fix-broken install' komutunu paket seçeneği vermeden deneyin (ya da bir çözüm belirtin).

şöyle bir hata veriyor.
« Son Düzenleme: 06 Eylül 2018, 23:18:05 Gönderen: Butterfly »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 15605
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 3
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Paket Yönetimi Bağımlılık ve Depo Sorunu
« Yanıtla #1 : 06 Eylül 2018, 23:19:18 »
Sorunun doğrudan Wine kurulumu ile alakası, başka bir şeyler yapmışsınız ve paket yönetiminde sorunlara neden olmuşsunuz.

Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ternerov

  • Çok Yeni Penguen
  • *
  • İleti: 2
  • Dağıtım: linux mint
Ynt: Paket Yönetimi Bağımlılık ve Depo Sorunu
« Yanıtla #2 : 07 Eylül 2018, 00:11:36 »
sudo apt-get install -f
Kod: [Seç]
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Bağımlılıklar düzeltiliyor... Tamamlandı
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  gcc-8-base:i386 libbsd0:i386 libc6:i386 libgcc1:i386 libgcrypt20:i386
  libgpg-error0:i386 liblz4-1:i386 libopenal-data libopenal1 libplacebo4
  libreoffice-pdfimport libstdc++6:i386 libwine libxau6:i386 wine64
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Aşağıdaki ek paketler kurulacak:
  gconf-service gconf2-common libavcodec58 libavformat58 libavutil56
  libbasicusageenvironment1 libcodec2-0.8.1 libgconf-2-4 libgroupsock8
  libgstreamer1.0-0 libjavascriptcoregtk-4.0-18 liblivemedia62 libmysofa0
  libplacebo5 libpostproc55 libspatialaudio0 libssh-gcrypt-4 libswresample3
  libswscale5 libusageenvironment3 libva-drm2 libva-wayland2 libva-x11-2
  libva2 libvlc-bin libvlc5 libvlccore9 libx265-160 vlc-bin vlc-data
  vlc-plugin-base
Önerilen paketler:
  libdvdcss2
Tavsiye edilen paketler:
  va-driver-all | va-driver libproxy-tools
Aşağıdaki paketler KALDIRILACAK:
  gconf-service-backend
Aşağıdaki YENİ paketler kurulacak:
  libavcodec58 libavformat58 libavutil56 libcodec2-0.8.1 libmysofa0
  libplacebo5 libpostproc55 libspatialaudio0 libswresample3 libswscale5
  libx265-160
Aşağıdaki paketler yükseltilecek:
  gconf-service gconf2-common libbasicusageenvironment1 libgconf-2-4
  libgroupsock8 libgstreamer1.0-0 libjavascriptcoregtk-4.0-18 liblivemedia62
  libssh-gcrypt-4 libusageenvironment3 libva-drm2 libva-wayland2 libva-x11-2
  libva2 libvlc-bin libvlc5 libvlccore9 vlc-bin vlc-data vlc-plugin-base
20 paket yükseltilecek, 11 yeni paket kurulacak, 1 paket kaldırılacak ve 1349 paket yükseltilmeyecek.
6 paket tam olarak kurulmayacak ya da kaldırılmayacak.
0 B/21,0 MB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 37,8 MB ek disk alanı kullanılacak.
Devam etmek istiyor musunuz? [E/h] e
Paketlerdeki ileti şablonları çıkarılıyor: 100%
(Veritabanı okunuyor ... 345484 dosya veya dizin kurulu durumda.)
Paket açılacak: .../gconf-service_3.2.6-5_amd64.deb ...
Paket açılıyor: gconf-service (3.2.6-4ubuntu1) üzerine (3.2.6-5) ...
dpkg: /var/cache/apt/archives/gconf-service_3.2.6-5_amd64.deb arşivi işlenirken sorun yaşandı (--unpack):
 gconf-service-backend 3.2.6-4ubuntu1 paketinde de bulunan '/usr/lib/x86_64-linux-gnu/gconf/2/libgconfbackend-evoldap.so' dosyasının üzerine yazılmaya çalışılıyor
dpkg-deb: hata: yapıştır subprocess was killed by signal (Veri alınamıyor)
İşleme sırasında hatalarla karşılaşıldı:
 /var/cache/apt/archives/gconf-service_3.2.6-5_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

böyle hata veriyor.


Düzenleme: Kod etiketi
« Son Düzenleme: 07 Eylül 2018, 00:26:51 Gönderen: Butterfly »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 15605
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 3
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Paket Yönetimi Bağımlılık ve Depo Sorunu
« Yanıtla #3 : 07 Eylül 2018, 00:28:37 »
Önceki mesajda istenen çıktıların tamamını paylaşınız, o bağlantıyı gerekli olduğu için ekledim.



Lütfen forum içi mesajlarda yazım kurallarına özen gösteriniz ve çıktıları kod etiketi içinde paylaşınız.
Elimizden geldiğince dilimizin döndüğünce...