Gönderen Konu: [Çözüldü] Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu  (Okunma sayısı 1401 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16229
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #15 : 17 Ağustos 2018, 19:49:04 »
Biz çekirdek sürümü kurmadık, mevcut çekirdeğe sürücü ekliyoruz sadece, şimdi sonraki komutlarla sürücü kurulumuna devam edelim.

Kod: [Seç]
git clone -b extended --single-branch https://github.com/lwfinger/rtlwifi_new.git
Kod: [Seç]
sudo dkms add ./rtlwifi_new
Kod: [Seç]
sudo dkms build rtlwifi-new/0.6
Kod: [Seç]
sudo dkms install rtlwifi-new/0.6
En sonra şağıdaki komutla linux-firmware paketini de ne olur olmaz diyerek güncelleyelim ve sistemi yeniden başlatalım.

Kod: [Seç]
sudo apt install linux-firmware
Kurulum sonrasında şağıdaki komutn çıktısını çalıştırdığınızda,

Kod: [Seç]
modinfo rtl8723de
aşağıdaki gibi çıktı alıyorsanız sürücü kurulumu tamam demektir.

Kod: [Seç]
modinfo rtl8723de
filename:       /lib/modules/4.15.0-32-generic/updates/rtl8723de.ko
firmware:       rtlwifi/rtl8723defw.bin
description:    Realtek 8723DE 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         PageHe <page_he@realsil.com.cn>
srcversion:     57B1D6F7DC3266BCB31ABDD
alias:          pci:v000010ECd0000D723sv*sd*bc*sc*i*
depends:        rtlwifi,rtl_pci,btcoexist,rtl8723-common,phydm_mod
retpoline:      Y
name:           rtl8723de
vermagic:       4.15.0-32-generic SMP mod_unload
parm:           dma64:bool
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
parm:           aspm:Set to 1 to enable ASPM (default 1)
 (int)
parm:           debug_level:Set debug level (0-5) (default 0) (int)
parm:           debug_mask:Set debug mask (default 0) (ullong)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0) (bool)
parm:           ant_sel:Set to 1 or 2 to force antenna number (default 0)  (int)
« Son Düzenleme: 17 Ağustos 2018, 19:50:08 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı noobuserLX

  • Yeni Penguen
  • *
  • İleti: 33
  • Dağıtım: Linux Mint
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #16 : 17 Ağustos 2018, 20:05:31 »
SAnırım bu da tamam. Aynısı sizin paylaştığınız çıktıy
Sorun maalesef çözülmedi hala ethernet network kısmı gri , wireless ağlarını gösteren bölüm yok. Üstüne klavyedeki @ tuşu ile prt sc tdiuşu da işlevi bozuldu. Ne yapmamı önerirsiniz, gerçekten 1 günümü yedi bu sorun.. Temiz kurulum mu yapayım yada önerdiğiniz sürüm varsa onu kurayım , hiç bir şekilde işlev görmez bilgisayar şu halde , telefon usb ile idare etmem imkansız..

Kod: [Seç]
yyy@yyy-HP-Laptop-15-ra0xx:~$ modinfo rtl8723de
filename:       /lib/modules/4.15.0-32-generic/updates/rtl8723de.ko
firmware:       rtlwifi/rtl8723defw.bin
description:    Realtek 8723DE 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         PageHe <page_he@realsil.com.cn>
srcversion:     57B1D6F7DC3266BCB31ABDD
alias:          pci:v000010ECd0000D723sv*sd*bc*sc*i*
depends:        rtlwifi,rtl_pci,btcoexist,rtl8723-common,phydm_mod
retpoline:      Y
name:           rtl8723de
vermagic:       4.15.0-32-generic SMP mod_unload
signat:         PKCS#7
signer:         
sig_key:       
sig_hashalgo:   md4
parm:           dma64:bool
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
parm:           aspm:Set to 1 to enable ASPM (default 1)
 (int)
parm:           debug_level:Set debug level (0-5) (default 0) (int)
parm:           debug_mask:Set debug mask (default 0) (ullong)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)
parm:           ant_sel:Set to 1 or 2 to force antenna number (default 0)
« Son Düzenleme: 17 Ağustos 2018, 20:15:11 Gönderen: noobuserLX »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16229
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #17 : 17 Ağustos 2018, 20:22:24 »
Sistemi yeniden başlattınız mı?
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı noobuserLX

  • Yeni Penguen
  • *
  • İleti: 33
  • Dağıtım: Linux Mint
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #18 : 17 Ağustos 2018, 20:23:00 »
Sistemi yeniden başlattınız mı?

Evet efendim.

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16229
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #19 : 17 Ağustos 2018, 20:31:40 »
Aşağıdaki komutun çıktısına bakalım.

Kod: [Seç]
inxi -Nnxxz
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı noobuserLX

  • Yeni Penguen
  • *
  • İleti: 33
  • Dağıtım: Linux Mint
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #20 : 17 Ağustos 2018, 20:33:10 »
Aşağıdaki komutun çıktısına bakalım.

Kod: [Seç]
inxi -Nnxxz

 
Kod: [Seç]
yyy@yyy-HP-Laptop-15-ra0xx:~$ inxi -Nnxxz
Network:   Card-1: Realtek Device d723
           port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:d723
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           port: 1000 bus-ID: 03:00.0 chip-ID: 10ec:8168
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16229
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #21 : 17 Ağustos 2018, 20:36:39 »
Aşağıdaki komutu uçbirimde çalıştrınca durum ne oluyor?

Kod: [Seç]
sudo modpobe rtl8723de
Ayrıca aşağıdaki komutun çıktısına da bakalım.

Kod: [Seç]
rfkill list
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı noobuserLX

  • Yeni Penguen
  • *
  • İleti: 33
  • Dağıtım: Linux Mint
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #22 : 17 Ağustos 2018, 20:38:41 »
Aşağıdaki komutu uçbirimde çalıştrınca durum ne oluyor?

Kod: [Seç]
sudo modpobe rtl8723de
Ayrıca aşağıdaki komutun çıktısına da bakalım.

Kod: [Seç]
rfkill list

Kod: [Seç]
yy@yyy-HP-Laptop-15-ra0xx:~$ sudo modpobe rtl8723de
sudo: modpobe: command not found

Kod: [Seç]
yyy@yyy-HP-Laptop-15-ra0xx:~$ rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16229
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #23 : 17 Ağustos 2018, 20:40:40 »
Pardon komutu yanlış yazmışım, aşağıdaki gibi olacaktı.

Kod: [Seç]
sudo modprobe rtl8723de
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı noobuserLX

  • Yeni Penguen
  • *
  • İleti: 33
  • Dağıtım: Linux Mint
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #24 : 17 Ağustos 2018, 20:41:48 »
Pardon komutu yanlış yazmışım, aşağıdaki gibi olacaktı.

Kod: [Seç]
sudo modprobe rtl8723de

Kod: [Seç]
yyy@yyy-HP-Laptop-15-ra0xx:~$ sudo modprobe rtl8723de
modprobe: ERROR: could not insert 'rtl8723de': Required key not available

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16229
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #25 : 17 Ağustos 2018, 20:42:40 »
BIOS'tan secure boot özelliğini kapatmanızı söylemiştim. Sistemi yeniden başlatıp secure boot özelliğini kapatın.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı noobuserLX

  • Yeni Penguen
  • *
  • İleti: 33
  • Dağıtım: Linux Mint
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #26 : 17 Ağustos 2018, 20:49:06 »
BIOS'tan secure boot özelliğini kapatmanızı söylemiştim. Sistemi yeniden başlatıp secure boot özelliğini kapatın.

Disabled efendim Secure Boot özelliği , tekrar kontrol ettim.
Kod: [Seç]
yyy@yyy-HP-Laptop-15-ra0xx:~$ sudo modprobe rtl8723de
[sudo] password for yyy:
modprobe: ERROR: could not insert 'rtl8723de': Required key not available


Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16229
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #27 : 17 Ağustos 2018, 21:09:24 »
Bu durumda aşağıdaki komutları sırasıyla uçbirimde çalıştırıp, sucure boot özelliğini pasifleştirmeyi deneyiniz. Yukarıdaki çıktı secure boot özelliğinin aktif olduğunu gösteriyor.

Kod: [Seç]
sudo apt install mokutil
sudo mokutil --disable-validation
« Son Düzenleme: 17 Ağustos 2018, 21:10:49 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı noobuserLX

  • Yeni Penguen
  • *
  • İleti: 33
  • Dağıtım: Linux Mint
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #28 : 17 Ağustos 2018, 21:28:39 »
Bu durumda aşağıdaki komutları sırasıyla uçbirimde çalıştırıp, sucure boot özelliğini pasifleştirmeyi deneyiniz. Yukarıdaki çıktı secure boot özelliğinin aktif olduğunu gösteriyor.

Kod: [Seç]
sudo apt install mokutil
sudo mokutil --disable-validation

Kod: [Seç]
yyy@yyy-HP-Laptop-15-ra0xx:~$ sudo apt install mokutil
[sudo] password for yyy:
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
mokutil zaten en yeni sürümde (0.3.0-0ubuntu5).
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
yyy@yyy-HP-Laptop-15-ra0xx:~$ sudo mukotil --disable-validation
sudo: mukotil: command not found
yyy@yyy-HP-Laptop-15-ra0xx:~$ sudo mokutil --disable-validation
password length: 8~16
input password:
input password again:

Mesajlar Birleştirildi.
Kod: [Seç]
yyy@yyy-HP-Laptop-15-ra0xx:~$ sudo apt install mokutil
[sudo] password for yyy:
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
mokutil zaten en yeni sürümde (0.3.0-0ubuntu5).
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
yyy@yyy-HP-Laptop-15-ra0xx:~$ sudo mukotil --disable-validation
sudo: mukotil: command not found
yyy@yyy-HP-Laptop-15-ra0xx:~$ sudo mokutil --disable-validation
password length: 8~16
input password:
input password again:

Şu an bir araştırma yaptımda WiFİ-Radar diye bir uygulama mı yüklemem lazım ağları görüntüleyebilmek için ? Yoksa sağ alttaki bağlantılar sekmesinden direk görebilir miyim kablosuz ağları ?
« Son Düzenleme: 17 Ağustos 2018, 21:47:04 Gönderen: noobuserLX »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16229
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Linux Mint 19 - RTL8723DE Kablosuz Ağ Bağlantı Sorunu
« Yanıtla #29 : 17 Ağustos 2018, 21:51:06 »
8-16 haneli bir şifre girmeni ve ikincisinde aynı şifreyi tekralamanı istemiş. Aklınızda kalacak herhangi bir şifre olabilir. İşlem sonrası sistemi yeniden başlatırsınız.
Elimizden geldiğince dilimizin döndüğünce...