Gönderen Konu: [Çözüldü] Güncelleme Sorunu (update-alternatives: unknown argument `--force')  (Okunma sayısı 73 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı Docea37

  • Çok Yeni Penguen
  • *
  • İleti: 19
Merhaba 18.3 mate kullanıyorum.
sistem güncellemesi yaparken wine1.6 uyumluluk hatası alıyordum. şimd wine1.6 ve wine ile başlayan hepsini kaldırdım. güncelleme yaparken yine hatalıyorum. hata ekranı
Kod: [Seç]
(Veritabanı okunuyor ... 370548 dosya veya dizin kurulu durumda.)
Paket açılacak: .../mintupdate_5.3.2.3_all.deb ...
Paket açılıyor: mintupdate (5.3.2.1) üzerine (5.3.2.3) ...
Tetikleyiciler işleniyor: desktop-file-utils (0.22+linuxmint1) ...
Tetikleyiciler işleniyor: mime-support (3.59ubuntu1) ...
Tetikleyiciler işleniyor: libglib2.0-0:amd64 (2.48.2-0ubuntu1) ...
Tetikleyiciler işleniyor: hicolor-icon-theme (0.15-0ubuntu1) ...
Ayarlanıyor: libgl1-mesa-glx:i386 (17.2.8-0ubuntu0~16.04.1) ...
update-alternatives: unknown argument `--force'

Usage: update-alternatives --install <link> <name> <path> <priority>
       update-alternatives --remove <name> <path>
       update-alternatives --help
<link> is the link pointing to the provided path (ie. /usr/bin/foo).
<name> is the name in /usr/lib/opkg/alternatives/alternatives (ie. foo)
<path> is the name referred to (ie. /usr/bin/foo-extra-spiffy)
<priority> is an integer; options with higher numbers are chosen.

dpkg: libgl1-mesa-glx:i386 paketi işlenirken sorun yaşandı (--configure):
 alt süreç post-installation betiği kuruldu 2 çıkış kodu ile sona erdi
dpkg: bağımlılık sorunları yüzünden libglu1-mesa:i386 paketi yapılandırılamıyor:
 libglu1-mesa:i386 şuna bağımlı: libgl1-mesa-glx | libgl1, ama:
  libgl1-mesa-glx:i386 paketi henüz yapılandırılmadı.
  libgl1 paketini sağlayan libgl1-mesa-glx:i386 henüz yapılandırılmadı.

dpkg: libglu1-mesa:i386 paketi işlenirken sorun yaşandı (--configure):
 bağımlılık sorunları - yapılandırılmadan bırakılıyor
Ayarlanıyor: mintupdate (5.3.2.3) ...
Apport raporu yazılmadı çünkü hata iletisi bu durumun bir önceki hatadan kaynaklanan bir hata olduğunu belirtiyor.
                                  Tetikleyiciler işleniyor: libc-bin (2.23-0ubuntu10) ...
İşleme sırasında hatalarla karşılaşıldı:
 libgl1-mesa-glx:i386
 libglu1-mesa:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)
Bir paket kurulamadı. Geri alınmaya çalışılıyor:
Ayarlanıyor: libgl1-mesa-glx:i386 (17.2.8-0ubuntu0~16.04.1) ...
update-alternatives: unknown argument `--force'

Usage: update-alternatives --install <link> <name> <path> <priority>
       update-alternatives --remove <name> <path>
       update-alternatives --help
<link> is the link pointing to the provided path (ie. /usr/bin/foo).
<name> is the name in /usr/lib/opkg/alternatives/alternatives (ie. foo)
<path> is the name referred to (ie. /usr/bin/foo-extra-spiffy)
<priority> is an integer; options with higher numbers are chosen.

dpkg: libgl1-mesa-glx:i386 paketi işlenirken sorun yaşandı (--configure):
 alt süreç post-installation betiği kuruldu 2 çıkış kodu ile sona erdi
dpkg: bağımlılık sorunları yüzünden libglu1-mesa:i386 paketi yapılandırılamıyor:
 libglu1-mesa:i386 şuna bağımlı: libgl1-mesa-glx | libgl1, ama:
  libgl1-mesa-glx:i386 paketi henüz yapılandırılmadı.
  libgl1 paketini sağlayan libgl1-mesa-glx:i386 henüz yapılandırılmadı.

dpkg: libglu1-mesa:i386 paketi işlenirken sorun yaşandı (--configure):
 bağımlılık sorunları - yapılandırılmadan bırakılıyor
Tetikleyiciler işleniyor: libc-bin (2.23-0ubuntu10) ...
İşleme sırasında hatalarla karşılaşıldı:
 libgl1-mesa-glx:i386
 libglu1-mesa:i386

buda paket kurulumundan

Kod: [Seç]
sudo apt-get install htop automake make cmake cmake-curses-gui subversion libusb-dev libusb-1.0-0-dev libssl-dev libssh-dev build-essential bzip2 g++ dialog gdb
[sudo] password for docea37:
1Üzgünüm, yeniden deneyin.
[sudo] password for docea37:
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
automake zaten en yeni sürümde (1:1.15-4ubuntu1).
build-essential zaten en yeni sürümde (12.1ubuntu2).
bzip2 zaten en yeni sürümde (1.0.6-8).
g++ zaten en yeni sürümde (4:5.3.1-1ubuntu1).
libssh-dev zaten en yeni sürümde (0.6.3-4.3).
libusb-1.0-0-dev zaten en yeni sürümde (2:1.0.20-1).
libusb-dev zaten en yeni sürümde (2:0.1.12-28).
make zaten en yeni sürümde (4.1-6).
dialog zaten en yeni sürümde (1.3-20160209-1).
cmake zaten en yeni sürümde (3.5.1-1ubuntu3).
gdb zaten en yeni sürümde (7.11.1-0ubuntu1~16.5).
libssl-dev zaten en yeni sürümde (1.0.2g-1ubuntu4.12).
subversion zaten en yeni sürümde (1.9.3-2ubuntu1.1).
cmake-curses-gui zaten en yeni sürümde (3.5.1-1ubuntu3).
htop zaten en yeni sürümde (2.0.1-1ubuntu1).
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  gcc-5-base:i386 libasn1-8-heimdal:i386 libasound2:i386 libbsd0:i386
  libdrm-amdgpu1:i386 libdrm-intel1:i386 libdrm-nouveau2:i386
  libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libelf1:i386 libexif12:i386
  libexpat1:i386 libffi6:i386 libfontconfig1:i386 libfreetype6:i386
  libgd3:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386
  libglu1-mesa:i386 libgmp10:i386 libgnutls30:i386 libgphoto2-6:i386
  libgphoto2-port12:i386 libgssapi3-heimdal:i386 libhcrypto4-heimdal:i386
  libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386 libhogweed4:i386
  libhx509-5-heimdal:i386 libicu55:i386 libidn11:i386 libjbig0:i386
  libjpeg-turbo8:i386 libjpeg8:i386 libkrb5-26-heimdal:i386 liblcms2-2:i386
  libldap-2.4-2:i386 libllvm5.0:i386 libltdl7:i386 libmpg123-0:i386
  libnettle6:i386 libopenal1:i386 libp11-kit0:i386 libpciaccess0:i386
  libpng12-0:i386 libroken18-heimdal:i386 libsasl2-2:i386
  libsasl2-modules-db:i386 libsensors4:i386 libsqlite3-0:i386 libstdc++6:i386
  libtasn1-6:i386 libtiff5:i386 libusb-1.0-0:i386 libvpx3:i386
  libwind0-heimdal:i386 libwine-development libx11-6:i386 libx11-xcb1:i386
  libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386
  libxcb-present0:i386 libxcb-sync1:i386 libxcb1:i386 libxdamage1:i386
  libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxml2:i386 libxpm4:i386
  libxshmfence1:i386 libxxf86vm1:i386 ocl-icd-libopencl1:i386
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 4 paket yükseltilmeyecek.
2 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 0 B ek disk alanı kullanılacak.
Devam etmek istiyor musunuz? [E/h] e
Ayarlanıyor: libgl1-mesa-glx:i386 (17.2.8-0ubuntu0~16.04.1) ...
update-alternatives: unknown argument `--force'

Usage: update-alternatives --install <link> <name> <path> <priority>
       update-alternatives --remove <name> <path>
       update-alternatives --help
<link> is the link pointing to the provided path (ie. /usr/bin/foo).
<name> is the name in /usr/lib/opkg/alternatives/alternatives (ie. foo)
<path> is the name referred to (ie. /usr/bin/foo-extra-spiffy)
<priority> is an integer; options with higher numbers are chosen.

dpkg: libgl1-mesa-glx:i386 paketi işlenirken sorun yaşandı (--configure):
 alt süreç post-installation betiği kuruldu 2 çıkış kodu ile sona erdi
dpkg: bağımlılık sorunları yüzünden libglu1-mesa:i386 paketi yapılandırılamıyor:
 libglu1-mesa:i386 şuna bağımlı: libgl1-mesa-glx | libgl1, ama:
  libgl1-mesa-glx:i386 paketi henüz yapılandırılmadı.
  libgl1 paketini sağlayan libgl1-mesa-glx:i386 henüz yapılandırılmadı.

dpkg: libglu1-mesa:i386 paketi işlenirken sorun yaşandı (--configure):
 bağımlılık sorunları - yapılandırılmadan bırakılıyor
Apport raporu yazılmadı çünkü hata iletisi bu durumun bir önceki hatadan kaynaklanan bir hata olduğunu belirtiyor.
                                  Tetikleyiciler işleniyor: libc-bin (2.23-0ubuntu10) ...
İşleme sırasında hatalarla karşılaşıldı:
 libgl1-mesa-glx:i386
 libglu1-mesa:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)

konuyu yanlış yere açtıysam özür dilerim.  bu konuda yardımcı olursanız sevinirim
« Son Düzenleme: 16 Haziran 2018, 14:59:48 Gönderen: Docea37 »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14562
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 2
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Aşağıdaki komutların çıktılarına bakalım.

Kod: [Seç]
locate update-alternatives
which update-alternatives
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Docea37

  • Çok Yeni Penguen
  • *
  • İleti: 19
Kod: [Seç]
docea37[member=1843]Docea37[/member]-K53SD ~ $ locate update-alternatives
/home/docea37/.local/share/Trash/files/opkg-utils-0.3.5/update-alternatives
/home/docea37/.local/share/Trash/files/opkg-utils-0.3.6/update-alternatives
/home/docea37/Masaüstü/opkg-utils-0.3.6/update-alternatives
/usr/bin/update-alternatives
/usr/local/bin/update-alternatives
/usr/sbin/update-alternatives
/usr/share/bash-completion/completions/update-alternatives
/usr/share/man/de/man1/update-alternatives.1.gz
/usr/share/man/es/man1/update-alternatives.1.gz
/usr/share/man/fr/man1/update-alternatives.1.gz
/usr/share/man/it/man1/update-alternatives.1.gz
/usr/share/man/ja/man1/update-alternatives.1.gz
/usr/share/man/man1/update-alternatives.1.gz
/usr/share/man/pl/man1/update-alternatives.1.gz
/usr/share/man/sv/man1/update-alternatives.1.gz
docea37[member=1843]Docea37[/member]-K53SD ~ $ which update-alternatives
/usr/local/bin/update-alternatives
docea37[member=1843]Docea37[/member]-K53SD ~ $

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14562
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 2
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Sorun OPKG'den kaynaklı, bunu sistemden kaldırsanız sorun çözülecektir. https://forum.linuxmint.net.tr/index.php?topic=8373.msg51585#msg51585
Elimizden geldiğince dilimizin döndüğünce...