Gönderen Konu: Kulaklığımın 7.1 Özelliği Çalışmıyor  (Okunma sayısı 232 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı Elephant Man

  • Çok Yeni Penguen
  • *
  • İleti: 15
  • I am not an animal, i am a human being!
    • ElephantMan1862
    • ElephantMan1862
  • Dağıtım: Linux Mint 18.3 Sylvia
  • Masaüstü: MATE x64
  • Grafik Kartı: Radeon HD 4850
  • İşlemci: AMD Athlon(tm) 7750 Dual-Core Processor x2
Kulaklığımın 7.1 Özelliği Çalışmıyor
« : 06 Nisan 2018, 15:28:23 »
Arkadaşlar kulaklık olarak Logitech G430 Dolby 7.1 Surround Sound Gaming adlı kulaklığı kullanıyorum fakat kulaklığın 7.1 özelliği çalışmıyor.  Logitech'in sitesine baktım ama Linux için driver desteği bulunmuyor. Bu sorunu çözmek için hangi yollara başvurabilirim? Teşekkürler.

Kod: [Seç]
System:    Host: JohnMerrick Kernel: 4.13.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: ASUSTeK model: M4A78L-M LE v: Rev X.0x
           Bios: American Megatrends v: 0510 date: 08/20/2010
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] RV770 HDMI Audio [Radeon HD 4850/4870]
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-3 Logitech G430 Surround Sound Gaming Headset
           driver: USB Audio usb-ID: 006-003
           Sound: Advanced Linux Sound Architecture v: k4.13.0-38-generic

Kod: [Seç]
Codec: VIA VT1708S
 
Kod: [Seç]
0 snd_hda_intel
 1 snd_hda_intel
 2 snd_usb_audio

Kod: [Seç]
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_seq                65536  2 snd_seq_midi_event,snd_seq_midi
snd_hda_codec_via      24576  1
snd_hda_codec_generic    73728  1 snd_hda_codec_via
snd_hda_codec_hdmi     49152  1
snd_usb_audio         196608  2
snd_usbmidi_lib        32768  1 snd_usb_audio
snd_hda_intel          40960  5
snd_hda_codec         126976  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_via
snd_hda_core           81920  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_via
snd_rawmidi            32768  2 snd_seq_midi,snd_usbmidi_lib
snd_hwdep              20480  2 snd_hda_codec,snd_usb_audio
snd_pcm                98304  5 snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_hda_core,snd_hda_codec_hdmi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_seq,snd_pcm
snd                    81920  27 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_usb_audio,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_usbmidi_lib,snd_seq_device,snd_pcm,snd_hda_codec_via
soundcore              16384  1 snd

Kod: [Seç]
**** PLAYBACK Donanım Aygıtlarının Listesi ****
kart 0: SB [HDA ATI SB], aygıt 0: VT1708S Analog [VT1708S Analog]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 0: SB [HDA ATI SB], aygıt 2: VT1708S Alt Analog [VT1708S Alt Analog]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 0: SB [HDA ATI SB], aygıt 3: VT1708S Digital [VT1708S Digital]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 1: HDMI [HDA ATI HDMI], aygıt 3: HDMI 0 [HDMI 0]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 2: Headset [Logitech G430 Gaming Headset], aygıt 0: USB Audio [USB Audio]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14449
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: Kulaklığımın 7.1 Özelliği Çalışmıyor
« Yanıtla #1 : 06 Nisan 2018, 15:56:13 »
Yazılım Yöneticisinden pavucontrol paketini aratıp kurunuz. Sonra menüden PulseAudio Ses Denetimi seçeneğini aratıp bu aracı açınız. Yapılandırma/Configuration sekmesine gelip, aygıtınızın karşısındaki Profil kısmından ses kanallarını değiştirmeyi deneyebilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Elephant Man

  • Çok Yeni Penguen
  • *
  • İleti: 15
  • I am not an animal, i am a human being!
    • ElephantMan1862
    • ElephantMan1862
  • Dağıtım: Linux Mint 18.3 Sylvia
  • Masaüstü: MATE x64
  • Grafik Kartı: Radeon HD 4850
  • İşlemci: AMD Athlon(tm) 7750 Dual-Core Processor x2
Ynt: Kulaklığımın 7.1 Özelliği Çalışmıyor
« Yanıtla #2 : 06 Nisan 2018, 16:16:25 »
Yazılım Yöneticisinden pavucontrol paketini aratıp kurunuz. Sonra menüden PulseAudio Ses Denetimi seçeneğini aratıp bu aracı açınız. Yapılandırma/Configuration sekmesine gelip, aygıtınızın karşısındaki Profil kısmından ses kanallarını değiştirmeyi deneyebilirsiniz.



Söylediklerinizi yaptım fakat 7.1 seçeneği RV770 HDMI Audio (Radeon HD 4850/4870] Radeon HD 4850 512MB GDDR3 PCI-E Dual Slot Fansink) adlı bölüme geliyor. Çıkış aygıtlarından orayı seçtiğimde ise bilgisayarımdan ses gelmiyor. G430 Surround Sound Gaming Headset Analog Mono adlı bölümde de 7.1  seçeneği yok. Sadece şu seçenekler var;

Analog Stereo Çıkışı + Analog Mono Girişi
Analog Stereo Çıkışı
Dijital İki Kanallı (IEC958) Çıkışı + Analog Mono Girişi
Dijital İki Kanallı (IEC958)
Kapalı
« Son Düzenleme: 06 Nisan 2018, 16:18:52 Gönderen: Elephant Man »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14449
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: Kulaklığımın 7.1 Özelliği Çalışmıyor
« Yanıtla #3 : 06 Nisan 2018, 16:25:49 »
Buradaki öneriyi deneyebilirsiniz. Linux Mint 18.x'de gedit yerine xed yazacaksınız. 7.1 ses için değişkeni 8 olarak belirlemelisiniz.

Kod: [Seç]
default-sample-channels = 8
Ses servislerini yeniden başlattıktan sonra, pavucontrol ile ses kanallarını ayarlamayı deneyebilirsiniz.
« Son Düzenleme: 06 Nisan 2018, 16:27:11 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Elephant Man

  • Çok Yeni Penguen
  • *
  • İleti: 15
  • I am not an animal, i am a human being!
    • ElephantMan1862
    • ElephantMan1862
  • Dağıtım: Linux Mint 18.3 Sylvia
  • Masaüstü: MATE x64
  • Grafik Kartı: Radeon HD 4850
  • İşlemci: AMD Athlon(tm) 7750 Dual-Core Processor x2
Ynt: Kulaklığımın 7.1 Özelliği Çalışmıyor
« Yanıtla #4 : 06 Nisan 2018, 16:38:04 »
Buradaki öneriyi deneyebilirsiniz. Linux Mint 18.x'de gedit yerine xed yazacaksınız. 7.1 ses için değişkeni 8 olarak belirlemelisiniz.

Kod: [Seç]
default-sample-channels = 8
Ses servislerini yeniden başlattıktan sonra, pavucontrol ile ses kanallarını ayarlamayı deneyebilirsiniz.

"speaker-test -c 8"  Komutunu  yazdığımda tüm kanallardan ses geliyor fakat;

 7 - Sağ Taraf
 3 - Arka Sağ
 2 - Arka Sol
 6 - Sol Taraf

kanallarından daha az ses geliyor, bu normal mi? Bir de "pavucontrol" komutunu yazıp tekrar ayarları kontrol ettim fakat G430 kısmında 7.1 seçeneği yine gözükmedi.
« Son Düzenleme: 06 Nisan 2018, 16:40:04 Gönderen: Elephant Man »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14449
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: Kulaklığımın 7.1 Özelliği Çalışmıyor
« Yanıtla #5 : 06 Nisan 2018, 16:53:51 »
Yazılım Yöneticisinden gnome-alsamixer paketini aratıp kurunuz. Sonra menüden Gnome Alsa Mixer seçeneğini aratıp bu aracı açınız. Bu araçla ses seviyesi az olan kanalların düzeyini yükseltmeyi deneyebilirsiniz.

Tüm kanallardan ses geliyorsa pavucontrol'de kanal sayısının ayarlanamamasını gözardı edebilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Elephant Man

  • Çok Yeni Penguen
  • *
  • İleti: 15
  • I am not an animal, i am a human being!
    • ElephantMan1862
    • ElephantMan1862
  • Dağıtım: Linux Mint 18.3 Sylvia
  • Masaüstü: MATE x64
  • Grafik Kartı: Radeon HD 4850
  • İşlemci: AMD Athlon(tm) 7750 Dual-Core Processor x2
Ynt: Kulaklığımın 7.1 Özelliği Çalışmıyor
« Yanıtla #6 : 06 Nisan 2018, 17:03:08 »
Yazılım Yöneticisinden gnome-alsamixer paketini aratıp kurunuz. Sonra menüden Gnome Alsa Mixer seçeneğini aratıp bu aracı açınız. Bu araçla ses seviyesi az olan kanalların düzeyini yükseltmeyi deneyebilirsiniz.

Tüm kanallardan ses geliyorsa pavucontrol'de kanal sayısının ayarlanamamasını gözardı edebilirsiniz.
Burada kulaklığımı tanıyan kısım "USB Mixer" sekmesi fakat burada sadece tek bir kanal seçeneği var, "alsamixer" diye bir komut ile de buna benzer bir şeye girmiştim fakat orada da aynı şekildeydi.

« Son Düzenleme: 06 Nisan 2018, 17:04:18 Gönderen: Elephant Man »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14449
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: Kulaklığımın 7.1 Özelliği Çalışmıyor
« Yanıtla #7 : 06 Nisan 2018, 17:07:46 »
Sistemi yeniden başlatmayı deneyin.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Elephant Man

  • Çok Yeni Penguen
  • *
  • İleti: 15
  • I am not an animal, i am a human being!
    • ElephantMan1862
    • ElephantMan1862
  • Dağıtım: Linux Mint 18.3 Sylvia
  • Masaüstü: MATE x64
  • Grafik Kartı: Radeon HD 4850
  • İşlemci: AMD Athlon(tm) 7750 Dual-Core Processor x2
Ynt: Kulaklığımın 7.1 Özelliği Çalışmıyor
« Yanıtla #8 : 06 Nisan 2018, 17:11:41 »
Sistemi yeniden başlatmayı deneyin.
Başlattım ama bir şey değişmedi, yine tek bir kanal var.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14449
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: Kulaklığımın 7.1 Özelliği Çalışmıyor
« Yanıtla #9 : 06 Nisan 2018, 17:13:36 »
Komutun çıktısına bakalım, lütfen çıktıları resim olarak değil kod etiketi içinde foruma yapıştırarak paylaşınız.

Kod: [Seç]
cat /etc/pulse/daemon.conf
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Elephant Man

  • Çok Yeni Penguen
  • *
  • İleti: 15
  • I am not an animal, i am a human being!
    • ElephantMan1862
    • ElephantMan1862
  • Dağıtım: Linux Mint 18.3 Sylvia
  • Masaüstü: MATE x64
  • Grafik Kartı: Radeon HD 4850
  • İşlemci: AMD Athlon(tm) 7750 Dual-Core Processor x2
Ynt: Kulaklığımın 7.1 Özelliği Çalışmıyor
« Yanıtla #10 : 06 Nisan 2018, 17:19:45 »
Komutun çıktısına bakalım, lütfen çıktıları resim olarak değil kod etiketi içinde foruma yapıştırarak paylaşınız.

Kod: [Seç]
cat /etc/pulse/daemon.conf
Peki Bundan sonra daha dikkatli olurum. :)

Kod: [Seç]
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no

; high-priority = yes
; nice-level = -11

; realtime-scheduling = yes
; realtime-priority = 5

; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file = /etc/pulse/default.pa

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

; resample-method = speex-float-1
; enable-remixing = yes
; enable-lfe-remixing = yes
; lfe-crossover-freq = 120

flat-volumes = no

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rttime = 200000

; default-sample-format = s16le
; default-sample-rate = 44100
; alternate-sample-rate = 48000
  default-sample-channels = 8
; default-channel-map = front-left,front-right,front-center,rear-left,rear-right,lfe

; default-fragments = 4
; default-fragment-size-msec = 25

; enable-deferred-volume = yes
deferred-volume-safety-margin-usec = 1
; deferred-volume-extra-delay-usec = 0
« Son Düzenleme: 06 Nisan 2018, 17:23:35 Gönderen: Elephant Man »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14449
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: Kulaklığımın 7.1 Özelliği Çalışmıyor
« Yanıtla #11 : 06 Nisan 2018, 17:47:42 »
Aşağıdaki komutla alsa karıştırıcısını açınız.

Kod: [Seç]
alsamixer
F6 ile ses aygıtını seçiniz ve sağ sol ok tuşları Kanal/Channel seçeneğine gelip, yukarı aşağı ok tuşları ile kanal sayısını ayarlamayı deneyiniz.

« Son Düzenleme: 06 Nisan 2018, 17:49:23 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Elephant Man

  • Çok Yeni Penguen
  • *
  • İleti: 15
  • I am not an animal, i am a human being!
    • ElephantMan1862
    • ElephantMan1862
  • Dağıtım: Linux Mint 18.3 Sylvia
  • Masaüstü: MATE x64
  • Grafik Kartı: Radeon HD 4850
  • İşlemci: AMD Athlon(tm) 7750 Dual-Core Processor x2
Ynt: Kulaklığımın 7.1 Özelliği Çalışmıyor
« Yanıtla #12 : 06 Nisan 2018, 17:57:30 »
Aşağıdaki komutla alsa karıştırıcısını açınız.

Kod: [Seç]
alsamixer
F6 ile ses aygıtını seçiniz ve sağ sol ok tuşları Kanal/Channel seçeneğine gelip, yukarı aşağı ok tuşları ile kanal sayısını ayarlamayı deneyiniz.



Olmuyor F6 ile kulakığı seçtiğim zaman sadece Headphone adında bir kanal ve yanında Mic yazılı bir seçenek çıkıyor.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14449
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: Kulaklığımın 7.1 Özelliği Çalışmıyor
« Yanıtla #13 : 06 Nisan 2018, 21:21:58 »
Mesajları alıntılamanıza gerek yok, forumda bu şekilde herhangi bir bildirim olmuyor. Bir de ekran görüntülerini tam ekran yerine pencere görüntüsü olarak alırsanız daha uygun olabilir.



Ses Ayarlarının sınama/test bölümünde kaç çıkış görünüyor peki?

Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Elephant Man

  • Çok Yeni Penguen
  • *
  • İleti: 15
  • I am not an animal, i am a human being!
    • ElephantMan1862
    • ElephantMan1862
  • Dağıtım: Linux Mint 18.3 Sylvia
  • Masaüstü: MATE x64
  • Grafik Kartı: Radeon HD 4850
  • İşlemci: AMD Athlon(tm) 7750 Dual-Core Processor x2
Ynt: Kulaklığımın 7.1 Özelliği Çalışmıyor
« Yanıtla #14 : 06 Nisan 2018, 21:25:42 »
Peki fakat o şekilde resim atmayı  bir türlü beceremedim . O yüzden biraz önceki mesajımda atmadım. Sınama bölümünde de Front Left ve Frint Right olmak üzere iki tane gözüküyor.

Mesajlar Birleştirildi.
Konu kapatılabilir arkadaşlar, Mint'i sildim ve Manjaro XFCE kurdum. Değerli zamanınızı boş yere almamak adına sizi haberdar etmek istedim, yardımlarınız için çok teşekkürler. :)
« Son Düzenleme: 08 Nisan 2018, 21:15:20 Gönderen: Elephant Man »