Gönderen Konu: [Çözüldü] Realtek ALC889 Entegre Ses Kartında 5.1 surround çıkış sorunu  (Okunma sayısı 7608 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı ogedayhun

  • Yeni Penguen
  • *
  • İleti: 27
  • Ars Gratia Homines
  • Dağıtım: Mint Mate (Petra) 16
Merhaba,
Masaüstü makineme bundan birkaç gün önce Linux Mint Petro 16 sürümünü kurdum. O gün bugündür ses kartımı stereo çıkış olarak tanıyor ve 6 (5+1) adet bağlı hoparlörümden yalnızca ikisinden (ön sağ ve sol hoparlörlerden) ses geliyor. 5.1 surround çıkış almak istiyorum. Sorunun çözümüne ilişkin olarak gezdiğim internet sayfalarında önüme gelen bir çözümü denedim. Bu çözüm http://www.webupd8.org/2009/06/enable-surround-sound-in-ubuntu-linux.html adresinde bulduğum uç birim komutlarıydı. Aynen uyguladım ancak herhangi bir değişiklik olmadı. Sistemim hala stereo çalışıyor. İlk kez Linux kullanmaya üç gün önce başladım. Öncesinde hep Windows kullandığım için ne yapacağım konusunda başka bir yöntem varsa, gösterirseniz sevinirim. Yardımlarınız için şimdiden teşekkür ederim.


Düzenleme : Çözüldü etiketi
« Son Düzenleme: 03 Haziran 2014, 21:05:34 Gönderen: Butterfly »

Çevrimdışı fortran

  • Kıdemli Penguen
  • ****
  • İleti: 784
  • Bir insanı sevmekle başlar her şey...
  • Dağıtım: Linux Mint
ogedayhun, açtığınız konunun altına aşağıdaki komutların çıktılarını  kod tagları içerisinde yazarsanız, donanımınız hakkında bir fikir vereceğiniz için çözüme daha yakın bir atmosfer sağlamış olacaksınız.

Şu kod, ses kartınızı görüntüler:
Kod: [Seç]
lspci | grep Audio
Şu kod, ses kartınızın kullandığı çözücüleri listeler:
Kod: [Seç]
cat /proc/asound/card0/codec#* | grep Codec
Şu kod, ses kartınızın kullandığı modülleri (sürücüleri) listeler:
Kod: [Seç]
lsmod | grep snd
Şu kod, ses kartlarını ve bunlara bağlı aygıtları listeler:
Kod: [Seç]
aplay -l

Çevrimdışı ogedayhun

  • Yeni Penguen
  • *
  • İleti: 27
  • Ars Gratia Homines
  • Dağıtım: Mint Mate (Petra) 16
Elbette. Komutlar ve çıktıları sırasıyla aşağıdaki gibidir.

Kod: [Seç]
$ lspci | grep Audio
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
01:05.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RS780 HDMI Audio [Radeon (HD) 3000 Series]
02:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Turks/Whistler HDMI Audio [Radeon HD 6000 Series]

Kod: [Seç]
$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC889A

Kod: [Seç]
$ lsmod | grep snd
snd_hda_codec_hdmi     41154  2
snd_seq_midi           13324  0
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            30095  1 snd_seq_midi
snd_hda_codec_realtek    56475  1
snd_seq                61560  2 snd_seq_midi_event,snd_seq_midi
snd_hda_intel          52267  6
snd_hda_codec         188738  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep              13602  1 snd_hda_codec
snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_pcm               102033  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc         18710  2 snd_pcm,snd_hda_intel
snd_timer              29433  2 snd_pcm,snd_seq
snd                    69141  23 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi
soundcore              12680  1 snd

Kod: [Seç]
$ aplay -l
**** PLAYBACK Donanım Aygıtlarının Listesi ****
kart 0: SB [HDA ATI SB], aygıt 0: ALC889A Analog [ALC889A Analog]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 0: SB [HDA ATI SB], aygıt 1: ALC889A Digital [ALC889A Digital]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 1: HDMI [HDA ATI HDMI], aygıt 3: HDMI 0 [HDMI 0]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 2: Generic [HD-Audio Generic], aygıt 3: HDMI 0 [HDMI 0]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0

Bu şekildedir. İlk kez kod giriyorum umarım doğru olmuştur.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16621
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Aşağıdaki komutu uçbirimde çalıştırıp Alsamixer uygulamasını açınız. Sol ok tuşunu kullanarak Kanal (Channel) üstüne geliniz. Yukarı ok tuşunu kulllanarak ses kanalı sayısını değiştirmeyi deneyebilirsiniz.

Kod: [Seç]
alsamixer

Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ogedayhun

  • Yeni Penguen
  • *
  • İleti: 27
  • Ars Gratia Homines
  • Dağıtım: Mint Mate (Petra) 16
Anladığım kadarıyla 6 kanal surround ayarını yapamamışım çünkü alsamixer çıktısında görünmüyor. Aldığım ekran çıktısı şöyle:



Bu konuda yardımcı olursanız sevinirim.

Çevrimdışı ogedayhun

  • Yeni Penguen
  • *
  • İleti: 27
  • Ars Gratia Homines
  • Dağıtım: Mint Mate (Petra) 16
Maalesef ekran çıktısı buraya nasıl yerleştirilir bilmiyorum henüz. Windows sisteminden çok farklı. Bir de kod olarak göndermeyi deneyeyim.

Kod: [Seç]
┌───────────────────────────────────────── AlsaMixer v1.0.27.1 ─────────────────────────────────────────┐
│    Kart: HDA ATI SB                                                               F1: Yardım          │
│     Çip: Realtek ALC889A                                                          F2: Sistem bilgisi  │
│ Görünüm: F3:[Oynatma] F4: Yakala  F5: Tümü                                        F6: Ses kartını seç │
│     Öğe: Rear Mic Boost [dB kazancı: 30,00, 30,00]                                Esc: Çıkış          │
│                                                                                                       │
│    ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐                                ┌──┐     ┌──┐     │
│    │▒▒│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │                                │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │                                │▒▒│     │▒▒│     │
←    │▒▒│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │                                │▒▒│     │▒▒│     │
←    │▒▒│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │                                │▒▒│     │▒▒│     │
←    │▒▒│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │                                │▒▒│     │▒▒│     │
←    │▒▒│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │                                │▒▒│     │▒▒│     │
←    │▒▒│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │                                │▒▒│     │▒▒│     │
←    │▒▒│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │                                │▒▒│     │▒▒│     │
←    │▒▒│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │                                │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │                                │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │                                │▒▒│     │▒▒│     │
│    ├──┤     ├──┤     ├──┤     ├──┤     ├──┤     └──┘     ┌──┐     ┌──┐   Enabled    ├──┤     └──┘     │
│    │AA│     │AA│     │AA│     │AA│     │SS│              │SS│     │AA│              │SS│              │
│    └──┘     └──┘     └──┘     └──┘     └──┘              └──┘     └──┘              └──┘              │
│  100<>100   100      100    100<>100   0<>0     0<>0                              100<>100 100<>100   │
│  Surround  Center    LFE      Side     Line   Line Boo  S/PDIF  S/PDIF D Auto-Mut Rear Mic<Rear Mic>  │
└───────────────────────────────────────────────────────────────────────────────────────────────────────┘
Görüleceği gibi, 6 kanallı surround ses tanımım bulunmuyor.

Çevrimdışı Danny

  • Proje Sorumlusu
  • *****
  • İleti: 1998
  • Nihilist
  • Dağıtım: Linux Mint
  • Masaüstü: Cinnamon
  • Grafik Kartı: Intel HD 620
  • İşlemci: Intel i7 - 7500U
  • RAM: 8 GB
Kod: [Seç]
sudo apt-get install alsa-utils
Kod: [Seç]
sudo apt-get install alsamixer
dedikten sonra, tekrar aynı işlemi yapalım bakalım değişen birşey olacak mı ?
Gelip sağ yanağımdan öptü. Dindar değildim ama sol yanağımı da çevirmek istedim o an...

Çevrimdışı ogedayhun

  • Yeni Penguen
  • *
  • İleti: 27
  • Ars Gratia Homines
  • Dağıtım: Mint Mate (Petra) 16
Değişen bir şey olmadı. Aynı yukarıda vermeye çalıştığım ekran çıktısını aldım yine.
« Son Düzenleme: 28 Mayıs 2014, 03:16:20 Gönderen: ogedayhun »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16621
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Aşağıdaki komutlar ile alsa sürücülerini güncellemeyi dener misiniz?

Kod: [Seç]
sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily
sudo apt-get update
sudo apt-get install oem-audio-hda-daily-dkms
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ogedayhun

  • Yeni Penguen
  • *
  • İleti: 27
  • Ars Gratia Homines
  • Dağıtım: Mint Mate (Petra) 16
Denedim. Güncellemeleri yükledi. Ardından alsamixer ile çıktı aldım. Ancak tablo değişmedi. Arada geçen zamanda http://ubuntuforums.org/showthread.php?t=795525 adresinde bulduğum makale içeriği talimatları bilgisayarıma birebir uyguladım. Anlatılan kolay yöntem işe yaramadığı için, zor yolu da denedim ancak yine bir şey olmadı. Önerdiğiniz güncellemeler sonucunda bir kez daha speaker-testi yaptım ve elimdeki stereo kanallardan birini daha kaybettiğimi ve yalnızca bir tek ön sol hoparlör kanalına kaldığımı gördüm.
Kod: [Seç]
peaker-test -ch 6

speaker-test 1.0.27.1

Oynatım aygıtı default
Akım değiştirgeleri 48000Hz, S16_LE, 1 kanal
16 oktavlık pembe gürültü kullanılıyor
Oynatma açma hatası: -16,Aygıt ya da özkaynak meşgul
Şu an tek kanal üzerinden mono ses alıyorum.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16621
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Aşağıdaki komutu uçbirimde çalıştırınız.

Kod: [Seç]
pluma ~/.asoundrc
Açılan metin düzenleyiciye aşağıdaki satırları ekleyip kaydediniz.

Kod: [Seç]
pcm.upmix51 {
    type upmix
    slave.pcm "surround51"
    delay 15
    channels 6
}

pcm.!default "plug:upmix51"

Akabinde aşağıdaki komut ile ses servislerini yeniden başlatmayı deneyebilirsiniz.

Kod: [Seç]
pulseaudio -k && sudo alsa force-reload
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ogedayhun

  • Yeni Penguen
  • *
  • İleti: 27
  • Ars Gratia Homines
  • Dağıtım: Mint Mate (Petra) 16
İlk komut dizisini ilgili dosya içeriğine kaydettikten sonra ikinci komutu uç birim satırından girdiğimde şu yanıtı aldım:
Kod: [Seç]
$ pulseaudio -k && sudo alsa force-reload
Unloading ALSA sound driver modules: snd-hda-codec-realtek snd-hda-codec-generic snd-hda-codec-hdmi snd-hda-intel snd-hda-controller snd-hda-codec snd-seq-midi snd-seq-midi-event snd-rawmidi snd-hwdep snd-seq snd-pcm snd-seq-device snd-page-alloc snd-timer (failed: modules still loaded: snd-hda-codec-realtek snd-hda-codec-generic snd-hda-codec-hdmi snd-hda-intel snd-hda-controller snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-timer).
Loading ALSA sound driver modules: snd-hda-codec-realtek snd-hda-codec-generic snd-hda-codec-hdmi snd-hda-intel snd-hda-controller snd-hda-codec snd-seq-midi snd-seq-midi-event snd-rawmidi snd-hwdep snd-seq snd-pcm snd-seq-device snd-page-alloc snd-timerFATAL: Module snd-hda-codec-generic not found.
FATAL: Module snd-hda-controller not found.
 (failed).

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16621
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Sistemi yeniden başlattığınızda bir değişiklik oldu mu peki?
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ogedayhun

  • Yeni Penguen
  • *
  • İleti: 27
  • Ars Gratia Homines
  • Dağıtım: Mint Mate (Petra) 16
Evet tekrar stereo ses düzenime kavuştum.

Çevrimdışı ogedayhun

  • Yeni Penguen
  • *
  • İleti: 27
  • Ars Gratia Homines
  • Dağıtım: Mint Mate (Petra) 16
Makineyi tekrar açıp kapattım. Sonra Realtek-Linux-HD audio-5.18 sürücüsünü internetten yükledim. Kurmaya çalıştım. Bu işlem sonucunda alsamixer komutunu çalıştıramaz oldum. Seslerin tamamı şu an suskun (mute) konumda. O yüzden test dahi yapamıyorum.