Gönderen Konu: [Çözüldü] mysql kuramıyorum.  (Okunma sayısı 841 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı ykulac

  • Çok Yeni Penguen
  • *
  • İleti: 7
  • Dağıtım: linux min 18 mate
[Çözüldü] mysql kuramıyorum.
« : 12 Ekim 2016, 12:32:53 »
merhaba.
windowsu tamamen terkerdip linux mint kurdum. çok memnun kaldım.
php ile ile çalışmak için sitede tarif edildiği gibi apache, mysql, php paketlerini kurmaya başladım. apache kurulu. mysql kurarken root şifresini boş geçmiştim. bundan dolayı kaldırıp tekrar kurayım dedim. kaldırdım lakin şimdi kurulum yapamıyorum. şu hatayı veriyor
kurmak için yazdığım komut : sudo apt-get install mysql-server
Kod: [Seç]
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Bunları düzeltmek için 'apt-get -f install' komutunu çalıştırmanız gerekebilir:
Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
 mysql-server-5.7 : ÖnBağımlılıklar: mysql-common (>= 5.5) ama kurulmayacak
                    Bağımlılıklar: mysql-client-5.7 (>= 5.7.15-0ubuntu0.16.04.1) ama kurulmayacak
                    Bağımlılıklar: mysql-common (>= 5.6.22-1~) ama kurulmayacak
E: Karşılanmamış bağımlılıklar. 'apt-get -f install' komutunu paket seçeneği vermeden deneyin (ya da bir çözüm belirtin).

yardımcı olursanın memnun olurum.
« Son Düzenleme: 12 Ekim 2016, 16:38:33 Gönderen: ykulac »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13398
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.2 & LMDE 2
  • Masaüstü: Cinnamon 3.4 & Mate 1.18
Ynt: mysql kuramıyorum.
« Yanıtla #1 : 12 Ekim 2016, 13:00:15 »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ykulac

  • Çok Yeni Penguen
  • *
  • İleti: 7
  • Dağıtım: linux min 18 mate
Ynt: mysql kuramıyorum.
« Yanıtla #2 : 12 Ekim 2016, 13:20:25 »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13398
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.2 & LMDE 2
  • Masaüstü: Cinnamon 3.4 & Mate 1.18
Ynt: mysql kuramıyorum.
« Yanıtla #3 : 12 Ekim 2016, 13:24:48 »

php ile ile çalışmak için sitede tarif edildiği gibi ...


demişsiniz.


Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ykulac

  • Çok Yeni Penguen
  • *
  • İleti: 7
  • Dağıtım: linux min 18 mate
Ynt: mysql kuramıyorum.
« Yanıtla #4 : 12 Ekim 2016, 13:51:08 »
linuxta yeniyim. bu sitede tarif edildiği gibi.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13398
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.2 & LMDE 2
  • Masaüstü: Cinnamon 3.4 & Mate 1.18
Ynt: mysql kuramıyorum.
« Yanıtla #5 : 12 Ekim 2016, 13:54:06 »
Linux Mint 18 için buradaki konuda anlatıldığı biçimde LAMP kurulumunu yapabilirsiniz. Bağlantıdaki konuda MariaDB kurulumu adımının sonunda Mysql'in nasıl kaldırılacağı anlatılıyor, ilgili öneri ile Mysql le ilgili paketleri tamamen kaldırmayı deneyiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ykulac

  • Çok Yeni Penguen
  • *
  • İleti: 7
  • Dağıtım: linux min 18 mate
Ynt: mysql kuramıyorum.
« Yanıtla #6 : 12 Ekim 2016, 14:20:21 »
sudo mysql_secure_installation komutunda şu hatayı veriyor

Kod: [Seç]
sudo: mysql_secure_installation: command not found

sudo service mysql status kodunda ise şu çıktıyı alıyorum

Kod: [Seç]
mysql.service
   Loaded: masked (/dev/null; bad)
   Active: inactive (dead) (Result: exit-code) since Çrş 2016-10-12 13:48:48 EES

Eki 12 13:48:48 ysfklc systemd[1]: mysql.service: Service hold-off time over, sc
Eki 12 13:48:48 ysfklc systemd[1]: Stopped MySQL Community Server.
Eki 12 13:48:48 ysfklc systemd[1]: mysql.service: Start request repeated too qui
Eki 12 13:48:48 ysfklc systemd[1]: Failed to start MySQL Community Server.
Eki 12 13:57:11 ysfklc systemd[1]: Stopped MySQL Community Server.
Eki 12 13:58:33 ysfklc systemd[1]: Stopped MySQL Community Server.
Eki 12 13:59:24 ysfklc systemd[1]: Stopped MySQL Community Server.
Eki 12 14:04:01 ysfklc systemd[1]: Stopped MySQL Community Server.
Eki 12 14:08:04 ysfklc systemd[1]: Stopped mysql.service.
Eki 12 14:18:14 ysfklc systemd[1]: Stopped mysql.service.
lines 1-14/14 (END)
bundan sonra terminalde işlem yapamıyorum
« Son Düzenleme: 12 Ekim 2016, 14:24:18 Gönderen: ykulac »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13398
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.2 & LMDE 2
  • Masaüstü: Cinnamon 3.4 & Mate 1.18
Ynt: mysql kuramıyorum.
« Yanıtla #7 : 12 Ekim 2016, 14:24:54 »
MariaDB veya Mysql kurulu değildir. Lütfen yaptığınz dönüşlerde gerçekleştirdiğiniz işlemleri paylaşınız.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ykulac

  • Çok Yeni Penguen
  • *
  • İleti: 7
  • Dağıtım: linux min 18 mate
Ynt: mysql kuramıyorum.
« Yanıtla #8 : 12 Ekim 2016, 14:38:11 »
sudo apt-get -f install ; sudo dpkg --configure -a

bu komutları girince install ve reinstall sorunları gitti.
şimdi kurulumları yaptım.

Kod: [Seç]

sudo ln -s /usr/share/phpmyadmin /var/www/html/phpmyadmin
bu komuttn sonra www/html klasörnün içine phpmyadmin kısayolu gelmiş.
localhost/phpmyadmin yazınca tarayıcı penceresi boş bir sayfa açıyor.
var/www/html klasörünün içinde phpmyadmin klasörü  olması gerekiyor mu?

Mesajlar Birleştirildi.
localhost/phpmyadmin yazınca tarayıcıda boş bir sayfa açılıyordu.

aşağıdaki işlemleri yapınca phpmyadmin çalışmaya başladı

Kod: [Seç]
sudo dpkg-reconfigure phpmyadmin
ile yeniden yapılandırdım.

Kod: [Seç]
apt install php-gettext
paketini kurdum ve sorun çözüldü.
« Son Düzenleme: 12 Ekim 2016, 16:40:28 Gönderen: ykulac »