Anket

Hangi Güncelleme İlkesini Tercih Ediyorsunuz?

Sistemim kırılmasın!
7 (19.4%)
Kararlılık ve güvenlik optimizasyonu
23 (63.9%)
Daima herşeyi güncelle
6 (16.7%)

Toplam Oy Verenler: 36

Gönderen Konu: Hangi Güncelleme İlkesini Tercih Ediyorsunuz?  (Okunma sayısı 891 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 12158
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18 & LMDE 2
  • Masaüstü: Cinnamon & Mate
Hangi Güncelleme İlkesini Tercih Ediyorsunuz?
« : 06 Ekim 2016, 17:55:08 »
Linux Mint 18 ile birlikte yeni olan Güncelleme İlkelerinden hangisini tercih ediyorsunuz?

Bu konu altından tercih nedenleri ve deneyimleriniz ile ilgili paylaşımda bulunabilirsiniz.



Sistemim kırılmasın!
Bu seçenek biraz daha az tecrübeli kullanıcılara yönelik olup, daha önceki sürümlerde gelen ilk 3 güncelleme seviyesini etkinleştirir. Sistemin kritik parçaları olan, çekirdek, X sunucusu vb. öğeleri güncelleme kapsamı dışında bırakır. Böylece yeni ve daha az tecrübeli kullanıcılar bu güncellemeler ile oluşabilecek sorunlardan korumuş olurlar.

Kararlılık ve güvenlik optimizasyonu
Bu seçenek genel kullanıcı seçimi olarak öneriliyor ve varsayılan olarak seçilmiş oluyor. Bu seçenek ilk 3 güncelleme seviyesi ile birlikte çekirdek, X sunucusu ve benzeri öğelerin güvenlik güncellemelerini görünür yapıyor. Yani eğer bir güvenlik güncellemesi varsa hangi seviyede olduğuna bakılmaksızın görünebilir oluyor. Böylece bu öğelerle ilgili güvenlik güncellemeleri geldiğinde elle seçip kurabiliyorsunuz.

Daima herşeyi güncelle
Bu seçenek bir miktar daha deneyimli kullanıcılar için öneriliyor ve tüm seviyelerdeki güncellemeleri etkinleştiriyor.


Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı okanakinci

  • Çaylak Penguen
  • **
  • İleti: 119
    • Iwinoa
  • Dağıtım: Linux Mint 18.1
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia GT820M
  • İşlemci: Intel Core i5-4210U @ 1.70GHz x 2
Ynt: Hangi Güncelleme İlkesini Tercih Ediyorsunuz?
« Yanıtla #1 : 06 Ekim 2016, 19:33:36 »
Bence ideal ayar, kararlılık ve güvenlik optimizasyonu. Fakat ben her şeyin güncel olmasını istediğim için her şeyi güncelle diyorum. Sorun çıkardığını görmedim ama çıkarırsa da bir şekilde düzeltebileceğime, düzeltemez isem de forumda bir araştırmayla çözümünü bulabileceğime inanıyorum.

Öte yandan bilgisayarlardan pek anlamayan ve bilgisayarına sürekli virüs bulaştıran küçük yaşta bir akrabamın bilgisayarına Linux Mint kurdum ve sistemim kırılmasın ayarını yaptım. Çünkü sorun çıkarsa her zaman yanında olamayabilirim.

Çevrimdışı abdyek

  • Penguen
  • ***
  • İleti: 348
  • Hi!! ^^
  • Dağıtım: Linux Mint 18 - 64bit
  • Masaüstü: Cinnamon
  • Grafik Kartı: Intel HD 3000 / Nvidia GeForce 610M - 2GB
  • İşlemci: Intel Core i5-2450M 2.50Ghz x 2
Ynt: Hangi Güncelleme İlkesini Tercih Ediyorsunuz?
« Yanıtla #2 : 06 Ekim 2016, 20:51:05 »
Sistemim kırılmasın ile Kararlılık ve güvenlik optimizasyonu arasında kalmıştım. Sanırım aralarındaki tek fark, ikincisinin 4. ve 5. seviye güncellemelerini göstermesi. Ben tercihimi "sistemim kırılmasın" dan yana kullandım ki bu yeni gelen özelliğin "yeni gelen özellik" diye tanımlanmasına sebep olan da bu seçenek. Son kullanıcı her zaman sisteminin sorunsuz çalışmasını isteyen tiptir. Çünkü o işini halletmek için bilgisayar başındadır, sorunlarla uğraşmak için değil.
Geleceğin Front-end Developer ı

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 12158
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18 & LMDE 2
  • Masaüstü: Cinnamon & Mate
Ynt: Hangi Güncelleme İlkesini Tercih Ediyorsunuz?
« Yanıtla #3 : 06 Ekim 2016, 21:06:53 »
Sistemim kırılmasın ile Kararlılık ve güvenlik optimizasyonu arasında kalmıştım. Sanırım aralarındaki tek fark, ikincisinin 4. ve 5. seviye güncellemelerini göstermesi. Ben tercihimi "sistemim kırılmasın" dan yana kullandım ki bu yeni gelen özelliğin "yeni gelen özellik" diye tanımlanmasına sebep olan da bu seçenek. Son kullanıcı her zaman sisteminin sorunsuz çalışmasını isteyen tiptir. Çünkü o işini halletmek için bilgisayar başındadır, sorunlarla uğraşmak için değil.

Aslında "Sistemim kırılmasın" seçeneği önceki sürümlerde varsayılan olarak gelen yapılandırma, yani sadece ilk 3 seviye güncellemeler görülüyor ve kurmak için seçili oluyor. Eskiden 4. ve 5. güncelleme seviyelerini etkinleştirmek veya güvenlik güncellemeleri ile ilgili olarak "Tercihler"den düzenlemeler yapmak gerekiyordu. Şimdi ise ilk kullanımda tanımlanmış profillerin  sunulması yenilik. "Kararlılık ve güvenlik optimizasyonu" seçildiğinde ilk 3 seviye güncellemeler hem gösteriliyor, hem de kurulması için işaretli oluyor, ayrıca hangi güncelleme seviyesinden olduğuna bakılmaksızın güvenlik deposundan gelen tüm güncellemeler görünür oluyor ama işaretli omuyor. "Kararlılık ve güvenlik optimizasyonu" ilkesini seçtiyseniz görünür olan güvenlik ile ilgili güncellemelerin kurulması için elle işaretlemeniz gerekiyor.
« Son Düzenleme: 06 Ekim 2016, 21:10:05 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı okanakinci

  • Çaylak Penguen
  • **
  • İleti: 119
    • Iwinoa
  • Dağıtım: Linux Mint 18.1
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia GT820M
  • İşlemci: Intel Core i5-4210U @ 1.70GHz x 2
Ynt: Hangi Güncelleme İlkesini Tercih Ediyorsunuz?
« Yanıtla #4 : 06 Ekim 2016, 22:05:40 »
@Butterfly benim takıldığım bir şey var. Güvenlik güncellemeleri adı üstünde güvenlik için önemli değil mi? Sistemim kırılmasın dediğimizde güvenlik güncellemelerini görmezden geliyorsa bu, güvenlik zafiyeti yaratmaz mı?

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 12158
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18 & LMDE 2
  • Masaüstü: Cinnamon & Mate
Ynt: Hangi Güncelleme İlkesini Tercih Ediyorsunuz?
« Yanıtla #5 : 06 Ekim 2016, 22:14:05 »
Evet riski oluşturur, bu sebeple varsayılan olarak "Kararlılık ve güvenlik optimizasyonu" öneriliyor. Sistemimi kırılmasın seçeneği daha çok Linux'la yeni tanışan kullanıcılara bir geçiş dönemi için önerilebilir. Bununla birlikte tüm güvenlik güncellemeleri 4. ve 5. seviyede değil.

Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı abdyek

  • Penguen
  • ***
  • İleti: 348
  • Hi!! ^^
  • Dağıtım: Linux Mint 18 - 64bit
  • Masaüstü: Cinnamon
  • Grafik Kartı: Intel HD 3000 / Nvidia GeForce 610M - 2GB
  • İşlemci: Intel Core i5-2450M 2.50Ghz x 2
Ynt: Hangi Güncelleme İlkesini Tercih Ediyorsunuz?
« Yanıtla #6 : 06 Ekim 2016, 22:24:22 »
Aslında "Sistemim kırılmasın" seçeneği önceki sürümlerde varsayılan olarak gelen yapılandırma, yani sadece ilk 3 seviye güncellemeler görülüyor ve kurmak için seçili oluyor. Eskiden 4. ve 5. güncelleme seviyelerini etkinleştirmek veya güvenlik güncellemeleri ile ilgili olarak "Tercihler"den düzenlemeler yapmak gerekiyordu. Şimdi ise ilk kullanımda tanımlanmış profillerin  sunulması yenilik. "Kararlılık ve güvenlik optimizasyonu" seçildiğinde ilk 3 seviye güncellemeler hem gösteriliyor, hem de kurulması için işaretli oluyor, ayrıca hangi güncelleme seviyesinden olduğuna bakılmaksızın güvenlik deposundan gelen tüm güncellemeler görünür oluyor ama işaretli omuyor. "Kararlılık ve güvenlik optimizasyonu" ilkesini seçtiyseniz görünür olan güvenlik ile ilgili güncellemelerin kurulması için elle işaretlemeniz gerekiyor.


Bunu bildiğim iyi oldu. Bilgilendirme için teşekkür ederim.
Geleceğin Front-end Developer ı

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 12158
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18 & LMDE 2
  • Masaüstü: Cinnamon & Mate
Ynt: Hangi Güncelleme İlkesini Tercih Ediyorsunuz?
« Yanıtla #7 : 06 Ekim 2016, 22:27:52 »
Güvenlik güncellemelerinin kurulum için daima seçili olmasını istiyorsanız, Güncelleme Yöneticisi => Tercihler => Seçenekler sekmesinden "Güvenlik güncellemelerini daima seç ve güven" seçeneğini işaretleyebilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı okanakinci

  • Çaylak Penguen
  • **
  • İleti: 119
    • Iwinoa
  • Dağıtım: Linux Mint 18.1
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia GT820M
  • İşlemci: Intel Core i5-4210U @ 1.70GHz x 2
Ynt: Hangi Güncelleme İlkesini Tercih Ediyorsunuz?
« Yanıtla #8 : 10 Ekim 2016, 12:31:29 »
Bugün linux-firmware adında bir beşinci seviye güncelleme geldi. Açıklamasında doğrudan donanım sürücüleriyle ilgili olduğu yazıyor. Donanım sürücüsünde sorun yaşamayan arkadaşlar için gerekli değil ama sorun yaşayanlar deneyebilir.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 12158
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18 & LMDE 2
  • Masaüstü: Cinnamon & Mate
Ynt: Hangi Güncelleme İlkesini Tercih Ediyorsunuz?
« Yanıtla #9 : 11 Ekim 2016, 10:11:37 »
Bugün linux-firmware adında bir beşinci seviye güncelleme geldi. Açıklamasında doğrudan donanım sürücüleriyle ilgili olduğu yazıyor. Donanım sürücüsünde sorun yaşamayan arkadaşlar için gerekli değil ama sorun yaşayanlar deneyebilir.

Gelen güncellemeler hakkında "Değişim Günlüğü" sekmesinden bilgi alınabilir, mesela bu güncelleme ath10k ile ilgili bir iyileştirme içeriyormuş.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 12158
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18 & LMDE 2
  • Masaüstü: Cinnamon & Mate
Ynt: Hangi Güncelleme İlkesini Tercih Ediyorsunuz?
« Yanıtla #10 : 11 Ekim 2016, 10:44:48 »
Benim güncelleme ile ilgili izlediğim yöntem aşağıdaki gibidir.

Öncelikle Güncelleme İlkesi olarak "Kararlılık ve güvenlik optimizasyonu" seçeneğini seçiyorum.
Ardından Düzenle menüsü => Tercihler seçeneğini açıyorum.
Seçenekler sekmesinden "Güvenlik güncellemelerini daima seç ve güven" seçeneğini işaretliyorum ki herhangi bir güvenlik güncellemesini kaçırmadan kurayım.
Sonra Seviyeler sekmesine gelip 4. ve 5. seviye güncellemeleri görünür kılıyorum. Bu seviyelerden herhangi bir güncelleme geldiğinde Değişim Günlüğü ile inceleyip kuruyorum.
Çekirdek güncellemelerini genellikle, Görünüm menüsü => Linux çekirdekleri aracı ile yapıyorum. Güncelleyeceğim çekirdeği seçip "Bug Report, Changelog ve CVE Tracker" bağlantıları yardımıyla olası hatalar, değişim günlüğü ve güvenlik ile ilgili bilgileri kontrol ediyorum.

Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı okanakinci

  • Çaylak Penguen
  • **
  • İleti: 119
    • Iwinoa
  • Dağıtım: Linux Mint 18.1
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia GT820M
  • İşlemci: Intel Core i5-4210U @ 1.70GHz x 2
Ynt: Hangi Güncelleme İlkesini Tercih Ediyorsunuz?
« Yanıtla #11 : 24 Ekim 2016, 18:08:36 »
Ubuntu'nun da güncelleme ilkesi gibi bir şey yapmamış olması üzücü.  Ubuntu önüne gelen donanım sürücüsü, yeni kernel vs. doğrudan kullanıcıya iletiyor.  Kararlılığı bozma pahasına. Tamam, çoğunluk pek bir sorun yaşamıyor. Fakat yaşayanlar da oluyor.

Dün bir bilgisayara Lubuntu 16.04.1 kurdum. Başta sorunsuzdu. Sonra güncellemeleri yaptım ve kablosuz sürücüsü gitti. Ben de bu kez Linux Mint 18 - Xfce kurdum. Üst seviye güncellemeleri reddettim ve şimdi o bilgisayar sorunsuz çalışıyor.

Çevrimdışı rafael

  • Yeni Penguen
  • *
  • İleti: 44
  • Dağıtım: linuxmint 17.2
  • Masaüstü: xfce
  • Grafik Kartı: hp bütünleşik
  • İşlemci: i7
Ynt: Hangi Güncelleme İlkesini Tercih Ediyorsunuz?
« Yanıtla #12 : 09 Aralık 2016, 02:11:40 »
Merhaba. Ben üçünü de denedim,  sonunda kararlılıkta karar kıldım!

Çevrimdışı Exor1st

  • Çok Yeni Penguen
  • *
  • İleti: 7
  • Coming soon...
  • Dağıtım: Linux Mint 18.1 Serena
  • Masaüstü: Cinnamon 3.2.6
  • Grafik Kartı: Nvidia GeForce GTX 480
  • İşlemci: Intel Core i7 960
Ynt: Hangi Güncelleme İlkesini Tercih Ediyorsunuz?
« Yanıtla #13 : 22 Aralık 2016, 01:40:23 »
Şu an için sistemim kırılmasın! seçeneğini tercih ediyorum.