Gönderen Konu: [Çözüldü] Wireless Adaptör install sorunu ?  (Okunma sayısı 6515 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı cmertkucuk

  • Penguen
  • ***
  • İleti: 493
  • Dağıtım: Mint
  • Masaüstü: KDE
Ynt: Wireless Adaptör install sorunu ?
« Yanıtla #30 : 22 Ocak 2016, 10:55:48 »


Komutun çıktısı
Kod: [Seç]
x[member=226]acer[/member]-AO725 ~ $ sudo apt-get install --reinstall mt7601-sta-dkms
[sudo] password for x:
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
0 paket yükseltilecek, 0 yeni paket kurulacak, 1 paket yeniden kurulacak, 0 paket kaldırılacak ve 22 paket yükseltilmeyecek.
0 B/928 kB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 0 B ek disk alanı kullanılacak.
(Veritabanı okunuyor... mevcut 163973 dosya veya klasör yüklü.)
Açılmaya hazırlanan .../mt7601-sta-dkms_3.0.0.4-0~201510061531~rev24~pkg4~ubuntu14.04.1_all.deb ...

------------------------------
Deleting module version: 3.0.0.4
completely from the DKMS tree.
------------------------------
Done.
mt7601-sta-dkms (3.0.0.4-0~201510061531~rev24~pkg4~ubuntu14.04.1) paketi (3.0.0.4-0~201510061531~rev24~pkg4~ubuntu14.04.1) üzerine açılıyor ...
mt7601-sta-dkms (3.0.0.4-0~201510061531~rev24~pkg4~ubuntu14.04.1) ayarlanıyor...
Loading new mt7601-3.0.0.4 DKMS files...
First Installation: checking all kernels...
Building only for 3.16.0-38-generic
Building for architecture i386
Building initial module for 3.16.0-38-generic
Error! Bad return status for module build on kernel: 3.16.0-38-generic (i386)
Consult /var/lib/dkms/mt7601/3.0.0.4/build/make.log for more information.
x[member=226]acer[/member]-AO725 ~ $


/var/lib/dkms/mt7601/3.0.0.4/build/make.log verileri aşağıdaki gibidir.
Kod: [Seç]
DKMS make.log for mt7601-3.0.0.4 for kernel 3.16.0-38-generic (i386)
Cum Oca 22 10:53:27 EET 2016
make -C tools
make[1]:`/var/lib/dkms/mt7601/3.0.0.4/build/tools' dizinine giriliyor
gcc -g bin2h.c -o bin2h
bin2h.c:28:19: fatal error: stdio.h: Böyle bir dosya ya da dizin yok
 #include <stdio.h>
                   ^
compilation terminated.
make[1]: *** [all] Hata 1
make[1]: `/var/lib/dkms/mt7601/3.0.0.4/build/tools' dizininden çıkılıyor
make: *** [build_tools] Hata 2
« Son Düzenleme: 22 Ocak 2016, 11:04:00 Gönderen: osmanturkq »
ϜϓſϞ EY TÜRK!
Üstte mavi gök çökmedikçe altta yağız yer delinmedikçe senin ilini ve töreni kim bozabilir TİTRE ve KENDiNE DÖN !
(Bilge Kağan)ϜϓſϞ

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16465
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Wireless Adaptör install sorunu ?
« Yanıtla #31 : 22 Ocak 2016, 11:26:50 »
Aşağıdaki komutlar ile yeniden dener misiniz?

Kod: [Seç]
sudo apt-get install --reinstall build-essential dkms linux-headers-$(uname -r)
sudo apt-get install --reinstall mt7601-sta-dkms
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı cmertkucuk

  • Penguen
  • ***
  • İleti: 493
  • Dağıtım: Mint
  • Masaüstü: KDE
Ynt: Wireless Adaptör install sorunu ?
« Yanıtla #32 : 22 Ocak 2016, 11:41:42 »
Aşağıdaki komutlar ile yeniden dener misiniz?

Kod: [Seç]
sudo apt-get install --reinstall build-essential dkms linux-headers-$(uname -r)
sudo apt-get install --reinstall mt7601-sta-dkms

Kod: [Seç]
x[member=226]acer[/member]-AO725 ~ $ sudo apt-get install --reinstall build-essential dkms linux-headers-$(uname -r)
[sudo] password for x:
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Aşağıdaki ek paketler de kurulacak:
  dpkg-dev g++ g++-4.8 libc-dev-bin libc6-dev libstdc++-4.8-dev
Önerilen paketler:
  debian-keyring g++-multilib g++-4.8-multilib gcc-4.8-doc libstdc++6-4.8-dbg
  glibc-doc libstdc++-4.8-doc
Tavsiye edilen paketler:
  libalgorithm-merge-perl
Aşağıdaki YENİ paketler kurulacak:
  build-essential dpkg-dev g++ g++-4.8 libc-dev-bin libc6-dev
  libstdc++-4.8-dev
0 paket yükseltilecek, 7 yeni paket kurulacak, 2 paket yeniden kurulacak, 0 paket kaldırılacak ve 22 paket yükseltilmeyecek.
18,9 MB/19,0 MB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 46,4 MB ek disk alanı kullanılacak.
Devam etmek istiyor musunuz? [E/h] e
Alınıyor: 1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libc-dev-bin i386 2.19-0ubuntu6.6 [63,4 kB]
Alınıyor: 2 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libc6-dev i386 2.19-0ubuntu6.6 [1.554 kB]
Alınıyor: 3 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libstdc++-4.8-dev i386 4.8.4-2ubuntu1~14.04 [1.058 kB]
Alınıyor: 4 http://archive.ubuntu.com/ubuntu/ trusty-updates/main g++-4.8 i386 4.8.4-2ubuntu1~14.04 [14,8 MB]
Alınıyor: 5 http://archive.ubuntu.com/ubuntu/ trusty/main g++ i386 4:4.8.2-1ubuntu6 [1.500 B]
Alınıyor: 6 http://archive.ubuntu.com/ubuntu/ trusty-updates/main dpkg-dev all 1.17.5ubuntu5.5 [726 kB]
Alınıyor: 7 http://archive.ubuntu.com/ubuntu/ trusty/main build-essential i386 11.6ubuntu6 [4.824 B]
Alınıyor: 8 http://archive.ubuntu.com/ubuntu/ trusty-updates/main linux-headers-3.16.0-38-generic i386 3.16.0-38.52~14.04.1 [706 kB]
2 dk. 51 sn.'de 18,9 MB alındı (110 kB/s)                                     
Önceden seçili olmayan libc-dev-bin paketi seçiliyor.
(Veritabanı okunuyor... mevcut 163973 dosya veya klasör yüklü.)
Açılmaya hazırlanan .../libc-dev-bin_2.19-0ubuntu6.6_i386.deb ...
libc-dev-bin (2.19-0ubuntu6.6) paketi açılıyor ...
Önceden seçili olmayan libc6-dev:i386 paketi seçiliyor.
Açılmaya hazırlanan .../libc6-dev_2.19-0ubuntu6.6_i386.deb ...
libc6-dev:i386 (2.19-0ubuntu6.6) paketi açılıyor ...
Önceden seçili olmayan libstdc++-4.8-dev:i386 paketi seçiliyor.
Açılmaya hazırlanan .../libstdc++-4.8-dev_4.8.4-2ubuntu1~14.04_i386.deb ...
libstdc++-4.8-dev:i386 (4.8.4-2ubuntu1~14.04) paketi açılıyor ...
Önceden seçili olmayan g++-4.8 paketi seçiliyor.
Açılmaya hazırlanan .../g++-4.8_4.8.4-2ubuntu1~14.04_i386.deb ...
g++-4.8 (4.8.4-2ubuntu1~14.04) paketi açılıyor ...
Önceden seçili olmayan g++ paketi seçiliyor.
Açılmaya hazırlanan .../g++_4%3a4.8.2-1ubuntu6_i386.deb ...
g++ (4:4.8.2-1ubuntu6) paketi açılıyor ...
Önceden seçili olmayan dpkg-dev paketi seçiliyor.
Açılmaya hazırlanan .../dpkg-dev_1.17.5ubuntu5.5_all.deb ...
dpkg-dev (1.17.5ubuntu5.5) paketi açılıyor ...
Önceden seçili olmayan build-essential paketi seçiliyor.
Açılmaya hazırlanan .../build-essential_11.6ubuntu6_i386.deb ...
build-essential (11.6ubuntu6) paketi açılıyor ...
Açılmaya hazırlanan .../dkms_2.2.0.3-1.1ubuntu5.14.04.5_all.deb ...
dkms (2.2.0.3-1.1ubuntu5.14.04.5) paketi (2.2.0.3-1.1ubuntu5.14.04.5) üzerine açılıyor ...
Açılmaya hazırlanan .../linux-headers-3.16.0-38-generic_3.16.0-38.52~14.04.1_i386.deb ...
linux-headers-3.16.0-38-generic (3.16.0-38.52~14.04.1) paketi (3.16.0-38.52~14.04.1) üzerine açılıyor ...
man-db (2.6.7.1-1ubuntu1) için tetikleyiciler işleniyor ...
libc-dev-bin (2.19-0ubuntu6.6) ayarlanıyor...
libc6-dev:i386 (2.19-0ubuntu6.6) ayarlanıyor...
libstdc++-4.8-dev:i386 (4.8.4-2ubuntu1~14.04) ayarlanıyor...
g++-4.8 (4.8.4-2ubuntu1~14.04) ayarlanıyor...
g++ (4:4.8.2-1ubuntu6) ayarlanıyor...
update-alternatives: /usr/bin/g++ kullanılarak /usr/bin/c++ (c++) sağlamak için otomatik kip durumunda
dpkg-dev (1.17.5ubuntu5.5) ayarlanıyor...
build-essential (11.6ubuntu6) ayarlanıyor...
dkms (2.2.0.3-1.1ubuntu5.14.04.5) ayarlanıyor...
linux-headers-3.16.0-38-generic (3.16.0-38.52~14.04.1) ayarlanıyor...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.16.0-38-generic /boot/vmlinuz-3.16.0-38-generic

Good news! Module version 1.59 for ndiswrapper.ko
exactly matches what is already found in kernel 3.16.0-38-generic.
DKMS will not replace this module.
You may override by specifying --force.
x[member=226]acer[/member]-AO725 ~ $ sudo apt-get install --reinstall mt7601-sta-dkms
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
0 paket yükseltilecek, 0 yeni paket kurulacak, 1 paket yeniden kurulacak, 0 paket kaldırılacak ve 22 paket yükseltilmeyecek.
0 B/928 kB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 0 B ek disk alanı kullanılacak.
(Veritabanı okunuyor... mevcut 165506 dosya veya klasör yüklü.)
Açılmaya hazırlanan .../mt7601-sta-dkms_3.0.0.4-0~201510061531~rev24~pkg4~ubuntu14.04.1_all.deb ...

-------- Uninstall Beginning --------
Module:  mt7601
Version: 3.0.0.4
Kernel:  3.16.0-38-generic (i686)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

mt7601Usta.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.16.0-38-generic/kernel/drivers/net/wireless/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.

------------------------------
Deleting module version: 3.0.0.4
completely from the DKMS tree.
------------------------------
Done.
mt7601-sta-dkms (3.0.0.4-0~201510061531~rev24~pkg4~ubuntu14.04.1) paketi (3.0.0.4-0~201510061531~rev24~pkg4~ubuntu14.04.1) üzerine açılıyor ...
mt7601-sta-dkms (3.0.0.4-0~201510061531~rev24~pkg4~ubuntu14.04.1) ayarlanıyor...
Loading new mt7601-3.0.0.4 DKMS files...
First Installation: checking all kernels...
Building only for 3.16.0-38-generic
Building for architecture i386
Building initial module for 3.16.0-38-generic
Done.

mt7601Usta:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.16.0-38-generic/kernel/drivers/net/wireless/

depmod....

DKMS: install completed.
x[member=226]acer[/member]-AO725 ~ $
ϜϓſϞ EY TÜRK!
Üstte mavi gök çökmedikçe altta yağız yer delinmedikçe senin ilini ve töreni kim bozabilir TİTRE ve KENDiNE DÖN !
(Bilge Kağan)ϜϓſϞ

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16465
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Wireless Adaptör install sorunu ?
« Yanıtla #33 : 22 Ocak 2016, 12:01:34 »
Alıntı
DKMS: install completed

Sistemi yeniden başlatın ya da aşağıdaki komut ile sürücüyü etkinleştirmeyi deneyiniz.

Kod: [Seç]
sudo modprobe mt7601Usta
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı cmertkucuk

  • Penguen
  • ***
  • İleti: 493
  • Dağıtım: Mint
  • Masaüstü: KDE
Ynt: Wireless Adaptör install sorunu ?
« Yanıtla #34 : 22 Ocak 2016, 12:55:39 »
Sistemi yeniden başlatın ya da aşağıdaki komut ile sürücüyü etkinleştirmeyi deneyiniz.

Kod: [Seç]
sudo modprobe mt7601Usta

Şuanda çalışıyor, Çok teşekkür ederim.
Konuyu kilitlemeden son birşey daha sormak istiyorum.
Yaptığımız çekirdek değişikliği sistemde farklılaşmaya yol açar mı ? Yavaşlama vs gibi?
Sistem biraz yavaşladı gibi geldi bana.
« Son Düzenleme: 22 Ocak 2016, 13:03:25 Gönderen: osmanturkq »
ϜϓſϞ EY TÜRK!
Üstte mavi gök çökmedikçe altta yağız yer delinmedikçe senin ilini ve töreni kim bozabilir TİTRE ve KENDiNE DÖN !
(Bilge Kağan)ϜϓſϞ

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16465
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Wireless Adaptör install sorunu ?
« Yanıtla #35 : 22 Ocak 2016, 13:12:55 »
Çekirdek değişikliği yapmadık, kurulan çekirdekleri konudaki mesajlardaki yönlendirmelerle kaldırdık. Şu an bu konuyu açtığınız zaman ki çekirdeği kullanıyorsunuz.

Alıntı
Installing to /lib/modules/3.16.0-38-generic/kernel/drivers/net/wireless/
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı cmertkucuk

  • Penguen
  • ***
  • İleti: 493
  • Dağıtım: Mint
  • Masaüstü: KDE
Ynt: Wireless Adaptör install sorunu ?
« Yanıtla #36 : 22 Ocak 2016, 13:26:44 »
Çekirdek değişikliği yapmadık, kurulan çekirdekleri konudaki mesajlardaki yönlendirmelerle kaldırdık. Şu an bu konuyu açtığınız zaman ki çekirdeği kullanıyorsunuz.

Tamam o zaman sorun yok.
Tekrardan Çok teşekkür ederim, konuyu kilitliyorum.
ϜϓſϞ EY TÜRK!
Üstte mavi gök çökmedikçe altta yağız yer delinmedikçe senin ilini ve töreni kim bozabilir TİTRE ve KENDiNE DÖN !
(Bilge Kağan)ϜϓſϞ