Gönderen Konu: LibreOffice Paketini PPA Deposundan Güncelleme  (Okunma sayısı 11868 defa)

0 Üye ve 2 Ziyaretçi konuyu incelemekte.

Çevrimdışı fortran

  • Kıdemli Penguen
  • ****
  • İleti: 827
  • Bir insanı sevmekle başlar her şey...
  • Dağıtım: Linux Mint
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #15 : 05 Ocak 2015, 01:18:49 »
Alıntı
Linux Mint 13 ve Linux Mint 17 için aşağıdaki komutları sırasıyla uçbirimde çalıştırarak Libre Office 4.3.1 sürümü PPA deposundan kurabilirsiniz.
Kod: [Seç]
sudo add-apt-repository ppa:libreoffice/ppa
sudo apt-get update
sudo apt-get install libreoffice libreoffice-gnome libreoffice-l10n-tr

Sürüm: 4.3.5.2. Günceli bu. Güncellemesi lazım.

Çevrimdışı yildiz2005

  • Çok Yeni Penguen
  • *
  • İleti: 4
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #16 : 05 Ocak 2015, 01:31:06 »
O zaman üzülerek belirtmek gerekiyor ki

libreoffice üzerinden baktığımda  yardım/hakkında "Sürüm: 4.1.3.2
İnşa NO: 410m0(Build:2)" şeklinde çıkıyor
ancak terminalden yükleme yaptığımda ise
Kod: [Seç]
root[member=898]Kadir[/member]:/home/kadir# sudo apt-get install libreoffice libreoffice-gnome libreoffice-l10n-tr
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
libreoffice is already the newest version.
libreoffice-gnome is already the newest version.
libreoffice-l10n-tr is already the newest version.
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
şeklinde uyarı veriyor.

Düzenleme: Kod Etiketi
« Son Düzenleme: 10 Ağustos 2015, 13:48:01 Gönderen: Reddet »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13629
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #17 : 05 Ocak 2015, 01:38:11 »
Aşağıdaki komutların çıktılarını paylaşınız.

Kod: [Seç]
inxi -r
dpkg -l | grep libreoffice
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı yildiz2005

  • Çok Yeni Penguen
  • *
  • İleti: 4
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #18 : 05 Ocak 2015, 01:46:28 »
hemen ekliyorum.

Kod: [Seç]
root[member=898]Kadir[/member]:/home/kadir# inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/libreoffice-ppa-testing.list
           deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu testing main
           deb-src http://ppa.launchpad.net/libreoffice/ppa/ubuntu testing main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com debian main upstream import
           deb http://debian.linuxmint.com/latest/ testing main contrib non-free
           deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
           deb http://debian.linuxmint.com/latest/multimedia testing main non-free
           deb http://extra.linuxmint.com debian main
Kod: [Seç]
root[member=898]Kadir[/member]:/home/kadir# dpkg -l | grep libreoffic
ii  libreoffice                                  1:4.1.3-1                       amd64        office productivity suite (metapackage)
ii  libreoffice-base                             1:4.1.3-1                       amd64        office productivity suite -- database
ii  libreoffice-base-core                        1:4.1.3-1                       amd64        office productivity suite -- shared library
ii  libreoffice-calc                             1:4.1.3-1                       amd64        office productivity suite -- spreadsheet
ii  libreoffice-common                           1:4.1.3-1                       all          office productivity suite -- arch-independent files
ii  libreoffice-core                             1:4.1.3-1                       amd64        office productivity suite -- arch-dependent files
ii  libreoffice-draw                             1:4.1.3-1                       amd64        office productivity suite -- drawing
ii  libreoffice-emailmerge                       1:4.1.3-1                       all          transitional package for LibreOffices email mail merge
ii  libreoffice-gnome                            1:4.1.3-1                       amd64        office productivity suite -- GNOME integration
ii  libreoffice-gtk                              1:4.1.3-1                       amd64        office productivity suite -- GTK+ integration
ii  libreoffice-help-en-us                       1:4.1.3-1                       all          office productivity suite -- English_american help
ii  libreoffice-impress                          1:4.1.3-1                       amd64        office productivity suite -- presentation
ii  libreoffice-java-common                      1:4.1.3-1                       all          office productivity suite -- arch-independent Java support files
ii  libreoffice-l10n-tr                          1:4.1.3-1                       all          office productivity suite -- Turkish language package
ii  libreoffice-math                             1:4.1.3-1                       amd64        office productivity suite -- equation editor
ii  libreoffice-report-builder-bin               1:4.1.3-1                       amd64        LibreOffice component for building database reports -- libraries
ii  libreoffice-writer                           1:4.1.3-1                       amd64        office productivity suite -- word processor
root[member=898]Kadir[/member]:/home/kadir#

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13629
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #19 : 05 Ocak 2015, 02:37:52 »
@yildiz2005, bu konu PPA deposundan LibreOffice güncellemesi ile ilgili, kurulum yapmaya çalıştığınız depoda bir PPA deposu. PPA depoları Linux Mint 17.x gibi Ubuntu tabanlı sürümlerde kullanılır. Sizin paylaştığınız verilerden ise Debian tabanlı olan LMDE'yi kurduğunuz anlaşılıyor. Bu sebeple öncelikle aşağıdaki komutlar ile eklediğiniz PPA deposunu siliniz.

Kod: [Seç]
sudo rm -rf /etc/apt/sources.list.d/libreoffice-ppa-testing.list
sudo apt-get update

LMDE için buradan indirip Libre Office paketlerini elle kurmalısınız. Bu LMDE için en sağlıklısı olacaktır. İstenirse Debian Jessie deposu geçici olarak eklenip sürüm yükseltilebiliyor. Ama bu işlem sırasında başka paketleri içinde güncelleme yapmak zorunda kalıyorsunuz. Bu durum paketlerin birbiri ile etkileşimini bozup sistem kararlılığını etkileyebilir.  Elle kurulum öncesi depodaki sürümlerin kaldırılması gerekir. Elle kurulum ile ilgili ayrı bir konuyu önümüzdeki gün hazırlayabilirim.

Bununla birlikte eğer Linux hakkında fazla tecrübeniz yoksa LMDE yerine Linux Mint 17.1 sürümü kurmanız en uygunu olacaktır.

« Son Düzenleme: 05 Ocak 2015, 02:40:51 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13629
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #20 : 25 Şubat 2015, 10:55:35 »
Linux Mint 17.x ve Linux Mint 13 için Libre Office 4.4.1 sürüme PPA deposundan güncelleme yapılabilir.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13629
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #21 : 24 Haziran 2015, 18:08:57 »
LibreOffice'in PPA deposundaki sürümü 4.4.4'e güncellendi.

PPA deposundan güncelleme yapıp LibreOffice'i açtığınızda aşağıdaki sorunla karşılaşırsanız,

Kod: [Seç]
LibreOffice 4.4 Fatal Error

Uygulama başlatılamadı.
Kullanıcı kurulumu tamamlanamadı.

sorunu aşağıdaki komutu uçbirimde çalıştırarak çözebilirsiniz.

Kod: [Seç]
mv ~/.config/libreoffice/4/user/  ~/.config/libreoffice/4/user_ydk/
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı yyz

  • Çaylak Penguen
  • **
  • İleti: 113
  • Dağıtım: Linux Mint 18 64bit
  • Masaüstü: Cinnamon&Mate
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #22 : 10 Ağustos 2015, 12:11:58 »
Merhaba; şöyle ilginç bir sorun yaşıyorum. Libreoffice sürümüm rutin bir şekilde güncellemesini aldı ve 5 sürümüne güncellendi ancak ben üzerinde çalıştığım doktora tez belgemde (docx.) sorunlar - donma, kilitlenme gibi - yaşadığım için, lbreoffice'i kaldırıp tekrar yüklemek istedim. purge komutu ile kaldırdım, depoyu da kaldırdım. Sonra da bu başlıkta anlatıldığı gibi depoyu ekleyip tekrar kurdum, ancak 5 sürümü yerine 4.4 sürümü kuruldu. Tekrar tekrar kurmaya çalışsam da "güncel sürüm zaten yüklü" uyarısı alıyorum. Yani 5 sürümünü kuramıyorum...  Bu şekilde bir sıkıntı yok, dosyam üzerinde çalışabiliyorum ama neden böyle bir sorun oluyor merak ettim?

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13629
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #23 : 10 Ağustos 2015, 12:26:17 »
Aşağıdaki komutun çıktısını paylaşınız.

Kod: [Seç]
inxi -r
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı yyz

  • Çaylak Penguen
  • **
  • İleti: 113
  • Dağıtım: Linux Mint 18 64bit
  • Masaüstü: Cinnamon&Mate
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #24 : 10 Ağustos 2015, 18:00:01 »
Hocam kusura bakma biraz geç oldu...
Kod: [Seç]
inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/additional-repositories.list
           deb http://repository.spotify.com stable non-free
           Active apt sources in file: /etc/apt/sources.list.d/danielrichter2007-grub-customizer-trusty.list
           deb http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu trusty main
           deb-src http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/libreoffice-ppa-trusty.list
           deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu trusty main
           deb-src http://ppa.launchpad.net/libreoffice/ppa/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/mc3man-trusty-media-trusty.list
           deb http://ppa.launchpad.net/mc3man/trusty-media/ubuntu trusty main
           deb-src http://ppa.launchpad.net/mc3man/trusty-media/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/nilarimogard-webupd8-trusty.list
           deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu trusty main
           deb-src http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/noobslab-icons-trusty.list
           deb http://ppa.launchpad.net/noobslab/icons/ubuntu trusty main
           deb-src http://ppa.launchpad.net/noobslab/icons/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/noobslab-icons2-trusty.list
           deb http://ppa.launchpad.net/noobslab/icons2/ubuntu trusty main
           deb-src http://ppa.launchpad.net/noobslab/icons2/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/noobslab-nitrux-os-trusty.list
           deb http://ppa.launchpad.net/noobslab/nitrux-os/ubuntu trusty main
           deb-src http://ppa.launchpad.net/noobslab/nitrux-os/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://linux-mint.froonix.org rafaela main upstream import
           deb http://extra.linuxmint.com rafaela main
           deb http://ftp.tu-chemnitz.de/pub/linux/ubuntu trusty main restricted universe multiverse
           deb http://ftp.tu-chemnitz.de/pub/linux/ubuntu trusty-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ trusty partner


Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13629
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #25 : 10 Ağustos 2015, 18:11:00 »
Depoyu ekledikten sonra aşağıdaki komutla paket bilgisi önbelleğini güncellemeiş olabilir misiniz?

Kod: [Seç]
sudo apt-get update
Bunun yerine Güncelleme Yöneticisini açıp Yenile düğmesine tıklamayı deneyebilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı yyz

  • Çaylak Penguen
  • **
  • İleti: 113
  • Dağıtım: Linux Mint 18 64bit
  • Masaüstü: Cinnamon&Mate
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #26 : 10 Ağustos 2015, 19:01:54 »
Yok hocam yaptım o dediklerinizi defalarca...  Kaldırıp tekrar da yükledim bikaç kez ama aynı sonuç.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13629
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #27 : 10 Ağustos 2015, 19:18:58 »
Aşağıdaki komutun çıktısını da rica edelim.

Kod: [Seç]
sudo apt-cache policy libreoffice
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı yyz

  • Çaylak Penguen
  • **
  • İleti: 113
  • Dağıtım: Linux Mint 18 64bit
  • Masaüstü: Cinnamon&Mate
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #28 : 10 Ağustos 2015, 19:23:54 »
Buyur hocam
Kod: [Seç]
libreoffice:
  Kurulu: 1:4.4.3~rc2-0ubuntu1~trusty1
  Aday:   1:4.4.3~rc2-0ubuntu1~trusty1
  Sürüm çizelgesi:
     1:5.0.0~rc5-0ubuntu1~trusty1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ trusty/main amd64 Packages
 *** 1:4.4.3~rc2-0ubuntu1~trusty1 0
        700 http://linux-mint.froonix.org/ rafaela/import amd64 Packages
        100 /var/lib/dpkg/status
     1:4.2.8-0ubuntu2 0
        500 http://ftp.tu-chemnitz.de/pub/linux/ubuntu/ trusty-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/universe amd64 Packages
     1:4.2.3~rc3-0ubuntu2 0
        500 http://ftp.tu-chemnitz.de/pub/linux/ubuntu/ trusty/universe amd64 Packages

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13629
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Ynt: LibreOffice Paketini PPA Deposundan Güncelleme
« Yanıtla #29 : 10 Ağustos 2015, 19:37:06 »
Alıntı
     1:5.0.0~rc5-0ubuntu1~trusty1 0
       500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ trusty/main amd64 Packages
 *** 1:4.4.3~rc2-0ubuntu1~trusty1 0
        700 http://linux-mint.froonix.org/ rafaela/import amd64 Packages

Libreoffice'in 4.4.3 sürümü Linux Mint 17.2 deposunda mevcut olduğu (Linux Mint 17 ve Linux Mint 17.1 deposunda mevcut değil) ve Linux Mint deposu pin değeri 700 olarak atandığı için, PPA deposundaki sürüm daha yeni olsa da, diğer depoların pin değeri 500 olarak atandığından, Linux Mint deposundaki paketler PPA deposundaki paketleri eziyor.

Bunun etrafından dolaşmak için aşağıdaki komutu uçbirimde çalıştırınız.
(Not : Mate masaüstü için gedit yerine pluma,
KDE masaüstü için kate ya da kwrite,
XFCE masaüstü için mousepad yada gedit,
LXDE masaüstü için leafpad yazmayı deneyiniz.
Gnome, Cinnamon, Unity masaüstleri için gedit kullanılacak.)

Kod: [Seç]
sudo gedit /etc/apt/preferences.d/libreoffice.pref
Açılan dosyaya aşağıdaki satırları ekleyip kaydediniz.

Kod: [Seç]
Package: *
Pin: release o=LP-PPA-libreoffice
Pin-Priority: 700

Şimdi paket bilgilerini güncellerseniz bu sorun çözülecektir. Bu düzenlemeyi konunun ilk mesajını da ekleyeyim.
« Son Düzenleme: 10 Ağustos 2015, 19:53:24 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...