Gönderen Konu: Linux Mint + Windows Çift İşletim Sisteminde NTFS Harddiske Erişememe Sorunu  (Okunma sayısı 16838 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16609
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Linux Mint ile birlikte sisteminize Windows 8/10 yüklüyse ve bu işletim sisteminin bulunduğu disk bölümüne erişemiyorsanız ve aşağıdakine benzer hata alıyorsanız;

Alıntı
non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda6': Operation not permitted

The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

bu sorunu windows altında hazırda beklet (Hibernation) ve hızlı başlatma özelliklerini iptal ederek çözebilirsiniz. Bu seçenek etkin olduğunda disk tamamen kapatılmıyor ve Linux altında erişimi bu sebeple sıkıntı oluşturuyor.

Hazırda bekleti kapatmak için aşağıdaki komutu, yönetici haklarıyla açtığınız komut satırında çalıştırınız.

Kod: [Seç]
powercfg.exe /hibernate off
Hızlı başlatmayı kapatmak için, Denetim Masası => Güç Seçenekleri => "Güç düğmesinin yapacaklarını seçin" kısayolu => Kapatma ayarları altından "Hızlı başlatmayı aç"  seçeneği önündeki işareti kaldırın.



Eğer sisteminizde kurulu bir Windows işletim sistemi yoksa, ulaşamadığınız diski aşağıdaki şablon komutla Linux altında düzeltmeyi deneyebilirsiniz.

Kod: [Seç]
sudo ntfsfix /dev/sdxy
Yukarıdaki komutdaki sdxy yerine, sorun yaşadığınız disk bölümünün adresini yazacaksınız. Sorun yaşanan diskin adresi /dev/sda1 ise komutu aşağıdaki şekilde düzenlemelisiniz

Kod: [Seç]
sudo ntfsfix /dev/sda1
« Son Düzenleme: 06 Nisan 2018, 11:51:31 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı mhm60

  • Yeni Penguen
  • *
  • İleti: 29
  • Dağıtım: Linux Mint 16 Cinnamon/Windows 8 DualBoot
Ben de Windows 8 dualboot kullanıyorum bu sorunun nedeni butterfly arkadaşımızın dediği gibi. Bu özelliği kapatmak istemediğim için windowsu yeniden başlatıyorum grub2 ekranı gelince güç düğmesinden kapatılacak ya da linuxa geçince harddiskinize erişim sağlayabilirsiniz
ASUS Eee PC 1000H Linux Mint 16 Cinnamon/Windows 8 DualBoot

Çevrimdışı dustengercege

  • Çaylak Penguen
  • **
  • İleti: 138
  • Dağıtım: Linux Mint Cinnamon
Forumda bi kaç konuda paylaşılanları denedim fakat sonuç alamadım. Bende gözüken hatayı paylaşmak istedim. Güncellemeden önce bi sıkıntı yoktu aslında. Gün içeriisnde güncellemeden sonra sorun ortaya çıktı(Windows8). Sırf uzun süren bu problemimden dolayı PCBSD'den vazgeçmek mecburiyetinde kaldım. Acaba orada da mı Windowstan kaynaklıydı :(

Neyse artık oyunları, programları indirdim, tam keyfine sürcek idim :) Windowsu kapatırken, kapat diyerek kapatıyorum. Güç pilanı seçeneklerinden uyku kısmını iptal ediyorum. Belkide Windows kısmında beceremedim kapatmayı bilemiyorum, biraz daha kurcalamk lazım. Keyfini sürebilmem için yardım edecek olanlara teşekkür ederim :(

Kod: [Seç]
Error mounting /dev/sda2 at /media/linuxusers/62F43CCFF43CA767: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda2" "/media/linuxusers/62F43CCFF43CA767"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda2': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Kod: [Seç]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda3 during installation
UUID=027a8ee3-4fe9-41c2-a5e1-c9fcc7d71c4e /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda4 during installation
UUID=684e2b31-32e6-4afb-89d5-6ba79b2cf2ac none            swap    sw              0       0

Bir de benim için Windows kısmının önemi, orayı hem windows programları için, hem de yedek gibi kullanmam. Fazla açmadığım için. Eğer varsa bir yolu bağlamanın... Teşekkürler şimdiden.
« Son Düzenleme: 16 Aralık 2014, 13:44:37 Gönderen: dustengercege »
Şükran duygusu asaletin göstergesi, nankörlük sevginin mezarıdır.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16609
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
@dustengercege, hata mesajlarındaki dialog metinleri de kopyalanabiliyor. Lütfen resim olarak çıktı paylaşmayınız.
Sorun Windows kaynaklı, hızlı başlat seçeneğini pasifleştirmeniz gerekiyor.

Ya da aşağıdaki komut ile hızlı başlatma seçeneğinin oluşturduğu dosyayı silmeyi deneyebilirsiniz.

Kod: [Seç]
sudo mkdir /media/win
sudo mount -t ntfs-3g -o remove_hiberfile /dev/sda2 /media/win

Alternatif olarak disk bölümünü salt okunur olarak bağlamayı deneyebilirsiniz.

Kod: [Seç]
sudo mkdir /media/win
sudo mount -t ntfs-3g -o ro /dev/sda2 /media/win
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı dustengercege

  • Çaylak Penguen
  • **
  • İleti: 138
  • Dağıtım: Linux Mint Cinnamon
Düzelttim.  :)  Sorun da düzeldi, teşekkür ederim @Butterfly
« Son Düzenleme: 16 Aralık 2014, 15:30:56 Gönderen: dustengercege »
Şükran duygusu asaletin göstergesi, nankörlük sevginin mezarıdır.

Çevrimdışı alembizim

  • Çok Yeni Penguen
  • *
  • İleti: 6
  • Dağıtım: mint
Linux Mint sürümünü, Windows 8'i sistemden kaldırarak bugün kurdum. Yerel disk C'ye kurdum. Yerel disk D'yi biçimlendirmedim. Şimdi yerel disk D'ye giremiyorum. (Kurulumu yaparken Extt4 günlük dosya sistemini seçtim). Aç dediğimde veya bağla dediğimde bu hata geliyor:

Kod: [Seç]
Error mounting /dev/sda5 at /media/can/BC28B38228B33A6A: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda5" "/media/can/BC28B38228B33A6A"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda5': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option

Yardım ederseniz sevinirim, İnşallah yerel disk D'deki veriler silinmemiştir.




Düzenleme: İmla ve konu başlığı.
Cümleler büyük harfle başlar, noktalama işaretleri.

Forum Kuralları
« Son Düzenleme: 09 Ocak 2015, 21:49:06 Gönderen: Butterfly »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16609
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Aşağıdaki komut ile diskinizi salt okunur olarak bağlamayı deneyin. Salt okunur olarak bağladıktan sonra içindeki verileri yedekleyebilirsiniz.

Kod: [Seç]
sudo mkdir /media/NTFS1
sudo mount -t ntfs-3g -o ro /dev/sda5 /media/NTFS1

Verileri yedekledikten sonra ilgili disk bölümünü biçimlendirip sorunsuzca kullanabilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ernuynk

  • Yeni Penguen
  • *
  • İleti: 42
  • Dağıtım: Ubuntu, Linux Mint
Arkadaşlar grub ekranında güç düğmesi ile kapatıyorum fakat yeniden linux açtığımda aynı hatayı alıyorum. Bunun kalıcı bir çözümü yok mu acaba?


Windows 8.1 + Linux Mint MATE 17.1 sürümlerini kullanıyorum.


Teşekkürler.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16609
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Windows tarafında hibernation ve hızlı başlatma ile ilgili ayarları kapatmanız gerekiyor.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ernuynk

  • Yeni Penguen
  • *
  • İleti: 42
  • Dağıtım: Ubuntu, Linux Mint
Windows tarafında hibernation ve hızlı başlatma ile ilgili ayarları kapatmanız gerekiyor.


Hibernation'ı kapatmıştım olmadı. Şimdi ise Hızlı Başlatma'yı da kapattım. İlk denemelerimde bir sıkıntı çıkmadı.


Teşekkürler.

Çevrimdışı bilonemsi

  • Çok Yeni Penguen
  • *
  • İleti: 9
merhabalar.


Mint 17.3 Cinnamon kurdum bilgisayarım da bulunan diğer NTFS diskleri açmaya çalıştığımda aşağıdaki gibi bir hata alıyorum sizce nedendir? KDE li olan versiyonu kurduğumda herhangi bir sorun yoktu.


Forumda arama yaptım ama bi sonuç bulamadım daha önce sorundu ise özür dilerim.


İyi çalışmalar


Kod: [Seç]
Error mounting /dev/sdc1 at /media/elfbeh/yedd: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177"
 "/dev/sdc1" "/media/elfbeh/yedd"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sdc1': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.




Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16609
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı bes5uc3

  • Çok Yeni Penguen
  • *
  • İleti: 1
Bir başka çözüm şekli de şöyle:

   
 WindowsDosyalarını Linux Mintte Görünür Yapmak

1 Denetim masasını aç

2 Ağ ve interneti aç.  Oradan da “Ağ durumunu ve görevlerini görüntüleyi” tıkla

3 Sol yandaki “Gelişmiş paylaşım ayarlarını değiştirini” tıkla.

4 En altta “tümağlar” sekmesi var.  Oradaki,  ilk önerme olan “ortak klasör
paylaşımı” altındaki ilk seçenek olan “ağ erişimi olan herkesin ortak klasörlerdeki dosyaları okuyabilmesi ve yazabilmesi
için paylaşımı aç” seçeneğini tıkıla.

En altta “değişiklikleri kaydet” deyin. Bu kadar

Bundan sonra mint,ubuntu vs. de Windows 10  görünür olacaktır.  Eğer PC’nizi başka
vakitlerde açıp kapattığınızda mintte, win 10 u görmüyorsanız, bu windowsu hatalı
kapatmadığınız içindir.

Her hatalı kapatışınızda ancak bu sorunu yaşarsınız. Win 10 u tekrar hatasız kapatırsanız, böyle
bir sorun oluşmayacaktır.
« Son Düzenleme: 31 Temmuz 2016, 18:48:44 Gönderen: bes5uc3 »

Çevrimdışı calmo

  • Yeni Penguen
  • *
  • İleti: 30
  • Dağıtım: Linux Mint 18
  • Masaüstü: Mate
@Butterfly , dediğiniz ayarları yaptım, hatta en son mesajda bahsedilen ağ ayarlarını da yaptım ama sonuç değişmedi. Hala aynı hatayı alıyorum.

Minti win8'in üstüne kurduğum için format da atamıyorum.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16609
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
@calmo, aldığınız hata çıktısını kod etiketi içinde foruma yapıştırınız.
Elimizden geldiğince dilimizin döndüğünce...