Gönderen Konu: [Çözüldü] 5.1 Ses Seçeneğini Etkinleştiremiyorum  (Okunma sayısı 5843 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı donurh

  • Yeni Penguen
  • *
  • İleti: 26
Linux Mint Cinnamon kurdum ve ilk kez Linux kullanıyorum. Kurulumdan sonra bir kaç temel şeyi halletsem gerisini yavaş yavaş öğreniceğim. İlk olarak güncellemeleri ve Nvidia sürücüsünü kurdum, başka bir sürücü kurmadım. Şimdi ses ayarlarımda 5+1 seçeneğini bulamıyorum ve web sayfalarındaki bazı ses efektleri çok kötü geliyor. Bir de film izlemek için VLC ve Totem var. VLC'de altyazılar incecik okunaksız çıkıyor, Totem'de ise bazı Türkçe karakterler bozuk. Ama Totem'de araçlarda altyazıyı otomatik bulma özelliği gördüm, işlevliyse bu çok iyi. Ne öneririsiniz?



Düzenleme : İmla ve Türkçe karşılıklar.
Cümleler ve özel isimler büyük harfle başlar.
driver => sürücü
« Son Düzenleme: 24 Ocak 2015, 04:27:46 Gönderen: donurh »

Çevrimdışı Linüks

  • Çok Yeni Penguen
  • *
  • İleti: 4
  • Dağıtım: ubuntu + mint + arch
Ynt: 5.1 Ses Seçeneğini Etkinleştiremiyorum
« Yanıtla #1 : 21 Ocak 2015, 08:39:37 »
Bilgisayarınız  5+1 ses kartına sahip değilse,  bu şekilde bir seçenek de olmaz. Ses kartınız 5+1 çıkışı desteklediğine eminseniz, yazılımsal sorun aranabilir. Vlc için, araçlar / ayarlar / altyazı menüsünü kullanarak, altyazının yazı tipi, kalınlık, konum, renk ayarlarını isteğinize göre yapılandırabilirsiniz. Ayrıca depolar da varsa, Umplayer ve medya center uygulaması olarak Xbmc 'yi deneyebilirsiniz. Doğru şekilde ön ayarlarını yaparsanız, izlediğiniz videoya ait dil, fps oranı gibi gerekli bilgileri otomatik olarak algılayıp, internet üzerinden videoya en uygun altyazıyı kendisi bulur ve oynatır. 

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16214
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: 5.1 Ses Seçeneğini Etkinleştiremiyorum
« Yanıtla #2 : 21 Ocak 2015, 09:05:38 »
@donurh, aynı başlık altında sadece bir soru/sorun hakkında konuşuyoruz. Bu konuya 5.1 ses sorunu çerçevesinde devam edelim, diğer soru ve sorunlar için ayrı başlıklar açabilirsiniz.

Aşağıdaki komutu uçbirimde çalıştırarak alsa-mixer'i açınız.

Kod: [Seç]
alsa-mixer
Sağ sol klavye tuşları ile Channel seçeneğine gelip yukarı ve aşağı tuşlar ile ses kanalı sayısını değiştirmeyi deneyebilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı donurh

  • Yeni Penguen
  • *
  • İleti: 26
Ynt: 5.1 Ses Seçeneğini Etkinleştiremiyorum
« Yanıtla #3 : 21 Ocak 2015, 13:31:43 »
"komut bulunamadı" diyor

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16214
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: 5.1 Ses Seçeneğini Etkinleştiremiyorum
« Yanıtla #4 : 21 Ocak 2015, 14:07:10 »
Aşağıdaki komutu deneyiniz.

Kod: [Seç]
alsamixer
Alternatif olarak aşağıdaki komutlar ile gnome-alsamixer veya pavucontrol karıştırıcılarını yükleyip, bu uygulamalar yardımıyla ayarlarınızı yapmayı deneyebilirsiniz.

Kod: [Seç]
sudo apt-get install gnome-alsamixer
Kod: [Seç]
sudo apt-get install pavucontrol
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı donurh

  • Yeni Penguen
  • *
  • İleti: 26
Ynt: 5.1 Ses Seçeneğini Etkinleştiremiyorum
« Yanıtla #5 : 21 Ocak 2015, 14:52:14 »
bunları yaptım, alsamixer yüklendi ama sağ alttaki ses simgesinden ses ayarlarında 5+1 seçeneğini hala göremmiyorum. "sına" sekmesinde de sadece sağ ve sol hoparlörler var.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16214
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: 5.1 Ses Seçeneğini Etkinleştiremiyorum
« Yanıtla #6 : 21 Ocak 2015, 21:45:09 »
Alsamixer değişiklikleri yapıp Pulse Adudio servisini aşağıdaki komut ile yeniden başlatınız.

Kod: [Seç]
pulseaudio -k
Yukarıdaki komut sonrası sistem çekmesindeki ses sismgesi kısa süreliğine kaybolacak, sonra geri gelecektir.
Şimdi ses ayarlarını açınız ve Kip kısmından ses kanalları ile ilgili ayarları değiştirmeyi deneyiniz.

Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı donurh

  • Yeni Penguen
  • *
  • İleti: 26
Ynt: 5.1 Ses Seçeneğini Etkinleştiremiyorum
« Yanıtla #7 : 22 Ocak 2015, 01:14:53 »
evet 5+1 seçeneği şimdi ortaya çıktı ve aynen bu resimdeki gibi oldu. ama sınadığımda yine sadece 2 hoparlörden ses geliyor malesef

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16214
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: 5.1 Ses Seçeneğini Etkinleştiremiyorum
« Yanıtla #8 : 22 Ocak 2015, 01:29:35 »
CTRL+ALT+T tuşlarına birlikte basarak uçbirimi açınız (Menü => Donatılardan da uçbirime ulaşabilirsiniz).
Aşağıdaki komutları sırasıyla kopyalayıp sağ tık ile uçbirime yapıştırınız ve giriş (enter) tuşu ile komutu çalıştırınız.
Bu komutlar bazı çıktılar üretecek, bu çıktıları kopyalayıp foruma yapıştırarak bizimle paylaşınız. (Lütfen çıktıları resim olarak paylaşmayınız.)

Kod: [Seç]
uname -r
lspci | grep Audio
cat /proc/asound/card0/codec#* | grep Codec
lsmod | grep snd
aplay -l
inxi -Ax
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı donurh

  • Yeni Penguen
  • *
  • İleti: 26
Ynt: 5.1 Ses Seçeneğini Etkinleştiremiyorum
« Yanıtla #9 : 22 Ocak 2015, 05:44:15 »
Kod: [Seç]
onurhan@onurhan-System-Product-Name ~ $ uname -r
3.13.0-37-generic
Kod: [Seç]
onurhan@onurhan-System-Product-Name ~ $ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
onurhan@onurhan-System-Product-Name ~ $ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC662 rev1
Kod: [Seç]
onurhan@onurhan-System-Product-Name ~ $ lsmod | grep snd
snd_hda_codec_realtek    65580  1
snd_hda_intel          56451  3
snd_hda_codec         192906  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13602  1 snd_hda_codec
snd_pcm               102099  2 snd_hda_codec,snd_hda_intel
snd_page_alloc         18710  2 snd_pcm,snd_hda_intel
snd_seq_midi           13324  0
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            30144  1 snd_seq_midi
snd_seq                61560  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              29482  2 snd_pcm,snd_seq
snd                    69322  16 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi
soundcore              12680  1 snd
onurhan@onurhan-System-Product-Name ~ $ aplay -l
**** PLAYBACK Donanım Aygıtlarının Listesi ****
kart 0: Intel [HDA Intel], aygıt 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 0: Intel [HDA Intel], aygıt 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
Kod: [Seç]
onurhan@onurhan-System-Product-Name ~ $ inxi -Ax
Audio:     Card: Intel 82801JI (ICH10 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-37-generic
onurhan@onurhan-System-Product-Name ~ $ ^C
onurhan@onurhan-System-Product-Name ~ $


Düzenleme : Kod etiketi
« Son Düzenleme: 22 Ocak 2015, 16:22:58 Gönderen: Butterfly »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16214
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: 5.1 Ses Seçeneğini Etkinleştiremiyorum
« Yanıtla #10 : 22 Ocak 2015, 16:28:23 »
Aşağıdaki komut ile alsa-base.conf ayar dosyasını açınız.

Kod: [Seç]
sudo gedit /etc/modprobe.d/alsa-base.conf
Açılan dosyanın en altına aşağıdaki satırı ekleyip dosyayı kaydediniz.

Kod: [Seç]
options snd-hda-intel model=3stack-6ch
Sonrasında sistemi yeniden başlatınız ya da aşağıdaki komutlarla ses servislerini yeniden başlatınız.

Kod: [Seç]
sudo alsa force-reload
pulseaudio -k
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı donurh

  • Yeni Penguen
  • *
  • İleti: 26
Ynt: 5.1 Ses Seçeneğini Etkinleştiremiyorum
« Yanıtla #11 : 22 Ocak 2015, 20:14:49 »
dediklerinizi yaptım hem ses aygıtını, olmayınca hem de sistemi yeniden başlattım ama hala sınamada sesleri vermiyor. bağlantılarımda mı bir sorun var acaba? verdiğim çıktılardan bu anlaşılıyor mu?

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16214
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: 5.1 Ses Seçeneğini Etkinleştiremiyorum
« Yanıtla #12 : 22 Ocak 2015, 20:17:14 »
Aşağıdaki komutun çıktısına bir bakalım. Belki marka ve modele göre bir çözüm bulabiliriz.

Kod: [Seç]
inxi -Fx
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı donurh

  • Yeni Penguen
  • *
  • İleti: 26
Ynt: 5.1 Ses Seçeneğini Etkinleştiremiyorum
« Yanıtla #13 : 22 Ocak 2015, 20:41:07 »
onurhan@onurhan-System-Product-Name ~ $ inxi -Fx
System:    Host: onurhan-System-Product-Name Kernel: 3.13.0-37-generic x86_64 (64 bit, gcc: 4.8.2)
           Desktop: Gnome Distro: Linux Mint 17.1 Rebecca
Machine:   Mobo: ASUSTeK model: P5QL-ASUS-SE version: Rev X.0x Bios: American Megatrends version: 0620 date: 06/17/2010
CPU:       Dual core Intel Core2 CPU 4400 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 ssse3) bmips: 8066.08
           Clock Speeds: 1: 1203.00 MHz 2: 1203.00 MHz
Graphics:  Card: NVIDIA G84 [GeForce 8600 GT] bus-ID: 01:00.0
           X.Org: 1.15.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1440x900@59.9hz
           GLX Renderer: GeForce 8600 GT/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 331.113 Direct Rendering: Yes
Audio:     Card: Intel 82801JI (ICH10 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-37-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 ver: 2.3LK-NAPI port: d800 bus-ID: 02:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:24:8c:6f:f5:c9
Drives:    HDD Total Size: 1378.3GB (0.4% used) 1: id: /dev/sda model: Corsair_Force_LS size: 120.0GB
           2: id: /dev/sdb model: ST3250410AS size: 250.1GB 3: USB id: /dev/sdc model: TransMemory size: 8.0GB
           4: id: /dev/sdd model: SAMSUNG_HD103SJ size: 1000.2GB
Partition: ID: / size: 51G used: 5.8G (13%) fs: ext4 ID: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap
           ID: swap-2 size: 0.52GB used: 0.00GB (0%) fs: swap ID: swap-3 size: 0.52GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 73.0C mobo: 29.0C gpu: 0.0:63C
           Fan Speeds (in rpm): cpu: 1687 sys-1: 0
Info:      Processes: 169 Uptime: 31 min Memory: 1248.4/2001.2MB Runlevel: 2 Gcc

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16214
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: 5.1 Ses Seçeneğini Etkinleştiremiyorum
« Yanıtla #14 : 22 Ocak 2015, 21:21:35 »
Hoparlörler nasıl bağlı, örneğin aşağıda kullandığımız değişken 3 çıkışa bağlı analog sistem için.

Kod: [Seç]
model=3stack-6ch
3 çıkışa bağlı dijital ses için aşağıdaki değişken denenebilir.

Kod: [Seç]
3stack-6ch-dig
Bunun için alsa.conf dosyasını yazıp eklenen satırı aşağıdaki şekilde değiştirmek denenebilir.

Kod: [Seç]
model=3stack-6ch-dig
ALC662/663 serisi için değişkenleri tüm listesi aşağıya alıntıladım.

ALC662/663
stack-dig    3-stack (2-channel) with SPDIF
3stack-6ch     3-stack (6-channel)
3stack-6ch-dig 3-stack (6-channel) with SPDIF
6stack-dig     6-stack with SPDIF
lenovo-101e    Lenovo laptop
 eeepc-p701    ASUS Eeepc P701
eeepc-ep20    ASUS Eeepc EP20
ecs           ECS/Foxconn mobo
m51va         ASUS M51VA
g71v          ASUS G71V
h13           ASUS H13
g50v          ASUS G50V
asus-mode1    ASUS
asus-mode2    ASUS
asus-mode3    ASUS
asus-mode4    ASUS
asus-mode5    ASUS
asus-mode6    ASUS
auto          auto-config reading BIOS (default)

Not: Alsamixer ile ses kanalı sayısını da kontrol ediniz.

Elimizden geldiğince dilimizin döndüğünce...