Gönderen Konu: [ÇÖZÜLDÜ]Nvidia performans modu sorunu  (Okunma sayısı 4843 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı redlabel

  • Yeni Penguen
  • *
  • İleti: 35
[ÇÖZÜLDÜ]Nvidia performans modu sorunu
« : 30 Ağustos 2014, 00:14:43 »
Arkadaşlar battery saving modundan Nvidia performans modu geçiş yapmaya çalıştığımda ne olduğu belli olmayan bir hata veriyor nasıl çözebilirim bu sorunu
teşekkürler.
« Son Düzenleme: 06 Eylül 2014, 17:02:52 Gönderen: redlabel »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16484
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Nvidia performans modu sorunu
« Yanıtla #1 : 30 Ağustos 2014, 08:53:56 »
CTRL+ALT+T tuşlarına birlikte basarak uçbirimi açınız (Menü => Donatılardan da uçbirime ulaşabilirsiniz).
Aşağıdaki komutları sırasıyla kopyalayıp sağ tık ile uçbirime yapıştırınız ve giriş (enter) tuşu ile komutu çalıştırınız.
Bu komutlar bazı çıktılar üretecek, bu çıktıları kopyalayıp foruma yapıştırarak bizimle paylaşınız.

Kod: [Seç]
lspci | egrep 'VGA|3D|Display'
dpkg -l | egrep 'nvidia|prime'
glxinfo | grep render
inxi -Gx
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı redlabel

  • Yeni Penguen
  • *
  • İleti: 35
Ynt: Nvidia performans modu sorunu
« Yanıtla #2 : 31 Ağustos 2014, 22:36:40 »
Kod: [Seç]
lspci | egrep 'VGA|3D|Display'
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 630M] (rev ff)
Kod: [Seç]
dpkg -l | egrep 'nvidia|prime'
ii  bumblebee-nvidia                            3.2.1-90~trustyppa1                                  amd64        NVIDIA Optimus support using the proprietary NVIDIA driver
ii  nvidia-331                                  331.89-0ubuntu1~xedgers14.04.2                       amd64        NVIDIA binary driver - version 331.89
ii  nvidia-prime                                0.6.2linuxmint1                                      amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                             343.13-0ubuntu1~xedgers14.04.1                       amd64        Tool for configuring the NVIDIA graphics driver
ii  prime-indicator                             0.1-1+git20140109~webupd8~0                          all          PRIME Indicator
Kod: [Seç]
glxinfo | grep render:
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
    GL_ARB_conditional_render_inverted, GL_ARB_copy_buffer, GL_ARB_copy_image,
    GL_MESA_texture_signed_rgba, GL_NV_conditional_render, GL_NV_depth_clamp,
    GL_ARB_conditional_render_inverted, GL_ARB_copy_buffer, GL_ARB_copy_image,
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_light_max_exponent,
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,
Kod: [Seç]
inxi -Gx:
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GF108M [GeForce GT 630M] bus-ID: 01:00.0
           X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 10.4.0-devel Direct Rendering: Yes

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16484
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Nvidia performans modu sorunu
« Yanıtla #3 : 31 Ağustos 2014, 22:40:44 »
Aşağıdaki komutlar ile nvidia-prime paketini tekrar kurup yapılandırmayı deneyiniz.

Kod: [Seç]
sudo apt-get install --reinstall nvidia-prime
sudo dpkg dpkg-reconfigure nvidia-prime

Sonrasında aşağıdaki komutun çıktısını paylaşınız.

Kod: [Seç]
cat /etc/X11/xorg.conf
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı redlabel

  • Yeni Penguen
  • *
  • İleti: 35
Ynt: Nvidia performans modu sorunu
« Yanıtla #4 : 31 Ağustos 2014, 22:42:27 »
sudo dpkg dpkg-reconfigure nvidia-prime bu komutta şöyle bi hata veriyor

Kod: [Seç]
sudo dpkg dpkg-reconfigure nvidia-prime
dpkg: error: need an action option

Type dpkg --help for help about installing and deinstalling packages [*];
Use 'apt' or 'aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through 'less' or 'more' !

Kod: [Seç]
cat /etc/X11/xorg.conf
cat: /etc/X11/xorg.conf: No such file or directory

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16484
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Nvidia performans modu sorunu
« Yanıtla #5 : 31 Ağustos 2014, 22:44:52 »
Aşağıdaki komutu dener misiniz?

Kod: [Seç]
sudo dpkg-reconfigure nvidia-prime
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı redlabel

  • Yeni Penguen
  • *
  • İleti: 35
Ynt: Nvidia performans modu sorunu
« Yanıtla #6 : 31 Ağustos 2014, 22:46:23 »
Kod: [Seç]
sudo dpkg-reconfigure nvidia-prime
nvidia-prime start/running, process 4977

Kod: [Seç]
cat /etc/X11/xorg.conf
cat: /etc/X11/xorg.conf: No such file or directory
« Son Düzenleme: 31 Ağustos 2014, 22:49:34 Gönderen: redlabel »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16484
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Nvidia performans modu sorunu
« Yanıtla #7 : 31 Ağustos 2014, 23:26:54 »
Siz Bumblebee'yi de mi kurdunuz? Aşağıdaki komutun çıktısını da paylaşınız.

Kod: [Seç]
dpkg -l | grep bumblebee
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı redlabel

  • Yeni Penguen
  • *
  • İleti: 35
Ynt: Nvidia performans modu sorunu
« Yanıtla #8 : 31 Ağustos 2014, 23:34:19 »
aynen bumblebee yide kurdum
Kod: [Seç]
dpkg -l | grep bumblebee
ii  bumblebee                                   3.2.1-90~trustyppa1                                  amd64        NVIDIA Optimus support
ii  bumblebee-nvidia                            3.2.1-90~trustyppa1                                  amd64        NVIDIA Optimus support using the proprietary NVIDIA driver

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16484
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Nvidia performans modu sorunu
« Yanıtla #9 : 31 Ağustos 2014, 23:49:06 »
Bumblebee ve Nvidia-prime birbirinin alternatifi teknolojiler. Bir arada kurulmamaları gerekiyor. Bu sebeple bunlardan birini kaldırmak gerekir. Daha olgunlaşmış bir proje olan Bumblebee ile yolunuza devam etmeniz en uygunu olacaktır. Bu sebeple aşağıdaki komut ile nvidia-prime ile ilgili paketleri kaldırmanızı öneririm.

Kod: [Seç]
sudo apt-get purge nvidia-prime prime-indicator
Aşağıdaki komutun çıktısı ile Bumblebee'nin sorunsuz çalışıp çalışmadığını kontrol edelim.

Kod: [Seç]
optirun -vvv glxgears
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı redlabel

  • Yeni Penguen
  • *
  • İleti: 35
Ynt: Nvidia performans modu sorunu
« Yanıtla #10 : 31 Ağustos 2014, 23:55:12 »
Kod: [Seç]
optirun -vvv glxgears
[ 5627.556650] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 5627.556897] [INFO]Configured driver: nvidia
[ 5627.557008] [DEBUG]optirun version 3.2.1 starting...
[ 5627.557019] [DEBUG]Active configuration:
[ 5627.557024] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 5627.557029] [DEBUG] X display: :8
[ 5627.557033] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-331:/usr/lib32/nvidia-331
[ 5627.557037] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 5627.557041] [DEBUG] Accel/display bridge: auto
[ 5627.557046] [DEBUG] VGL Compression: proxy
[ 5627.557050] [DEBUG] VGLrun extra options:
[ 5627.557054] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[ 5627.574420] [DEBUG]Using auto-detected bridge primus
[ 5632.051937] [INFO]Response: Yes. X is active.

[ 5632.051961] [INFO]Running application using primus.
[ 5632.052259] [DEBUG]Process glxgears started, PID 8149.
295 frames in 5.0 seconds = 58.819 FPS
301 frames in 5.0 seconds = 60.159 FPS
301 frames in 5.0 seconds = 60.163 FPS

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16484
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Nvidia performans modu sorunu
« Yanıtla #11 : 01 Eylül 2014, 00:26:01 »
Bumblebee sorunsuz çalşıyor görünüyor. Bu sebeple nvidia-prime ile ilgili paketleri kaldırınız.

Bumblebee kurulduğunda entegre GPU etkin olur. Siz optirun komutu ile bir uygulamayı başlatmadıkça ya da bumblebee-ui uygulaması ile Nvidia kartla ilişkilendirilmiş bir uygulama başlatılmadıkça Nvidia kart devreye girmez ve bu şekilde güç tasarrufu sağlarsınız. Bu da pil ile kullanım süresinin daha uzun olmasına yarar sağlar.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı redlabel

  • Yeni Penguen
  • *
  • İleti: 35
Ynt: Nvidia performans modu sorunu
« Yanıtla #12 : 01 Eylül 2014, 01:06:54 »
Anladım teşekkür ederim.

Çevrimdışı okan6067

  • Çok Yeni Penguen
  • *
  • İleti: 10
  • Dağıtım: linux mint 17 Kde
Ynt: Nvidia performans modu sorunu
« Yanıtla #13 : 06 Eylül 2014, 14:52:43 »
merhaba bende böyle bi sorun alıyorum "err:winediag:xrandr12_init_modes Broken NVIDIA RandR detected, falling back to RandR 1.0. Please consider using the Nouveau driver instead." daha önce league of legends oynayabiliyodum. fakat sistemi yeniledim. ozamanda çok uğraşmıştım ve işin  kötüsü nasıl yaptığımı hatırlamıyorum :(

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16484
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Nvidia performans modu sorunu
« Yanıtla #14 : 06 Eylül 2014, 14:56:09 »
@okan6067, lütfen aşağıdaki komutların çıktılarını içeren yeni bir konu açınız.

Kod: [Seç]
lspci | egrep 'VGA|3D|Display'
dpkg -l | egrep 'nvidia|prime|bumblebee'
glxinfo | grep render
inxi -Gx
cat /etc/X11/xorg.conf



@redlabel, sorun görece çözüldü ise konuyu kilitleyelim mi?
Elimizden geldiğince dilimizin döndüğünce...