Gönderen Konu: [Çözüldü] Çözünürlük Değiştirme Dosyasına "chmod" ile Çalıştırma İzni Verme Sorunu  (Okunma sayısı 264 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı karaca911

  • Yeni Penguen
  • *
  • İleti: 84
  • Dağıtım: mint18
  • Masaüstü: Cinnamon
  • Grafik Kartı: geforce 630
  • İşlemci: i3
Çözünürlük dosyasını yıllardır "cvt 1280 800" komutuyla oluşturup, bunu dosyanın izin kısmındaki "bu dosyayı bir program gibi çalıştırmaya izin ver" kutusunu işaretleyip, başlangıç programlarına kaydedip  vs... yapıyordum. Bu dosyadaki çalıştırma izni, bazı sürümlerde yok, mesela xfce'de eskiden vardı, şimdi yok. Diğer sürümleri kullanmam için bu izni chmod ile vermek gerekiyor, ama bu nasıl yapılır bilmiyorum. Çözünürlük dosyasını oluşturdum, uçbirim'e "chmod +x/home/krc" yazdık ama bir şey değişmedi. 
« Son Düzenleme: 27 Nisan 2019, 11:37:57 Gönderen: karaca911 »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16907
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: çözünürlük dosyasını "chmod" ile çalıştırmak
« Yanıtla #1 : 26 Nisan 2019, 14:32:54 »
Alıntı
Kurulum Öncesi ve Sonrası Kurulum aşamasında ve sonrasında yaşadığınız sorunlara ait yardım alabileceğiniz forum alanı. Lütfen bu bölüme kurulum ile ilgisi olmayan hususlarda konu açmayınız.

Lütfen konuları uygun bölüme açmaya özen gösterelim, bu bölüm kurulum sonrasında yaşadığınız bu tür sorunlar ile ilgili değil. Bölüm açıklamalarına dikkat ederseniz, konular için daha uygun bölümler bulabilirsiniz. Bu sebeple konuyu genel bölümüne taşıdık.




Paylaştığınız gibi yazdıysanız olmaz. +x değişkeninden sonra boşluk bırakmamışsınız. Aşağıdaki şekilde denerseniz sorun yaşamazsınız. ~/ değişkeni doğrudan kullanıcı ev dizinini gösterir, ardından dosya adını girersiniz.

Kod: [Seç]
chmod +x ~/dosyaadı
Ya da aşağıdaki gibi olacak, boşluklara dikkat etmelisiniz.

Kod: [Seç]
chmod +x /home/kullanıcıadı/dosyaadı
Bunların yerine dosyayı açıp, başına aşağıdaki satırı eklerseniz, Xfce dosya yönetici Thunar ile bu tür dosyalara sağ tıklayıp çalıştırma izni verebilirsiniz.

Kod: [Seç]
#!/bin/bash
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı karaca911

  • Yeni Penguen
  • *
  • İleti: 84
  • Dağıtım: mint18
  • Masaüstü: Cinnamon
  • Grafik Kartı: geforce 630
  • İşlemci: i3
Her iki şekilde de dosya çalışmadı, kullanıcı adı "krc", dosya adı da "krc". Dosya ev dizininde duruyor.
Kod: [Seç]
krc@krc-P61-USB3-B3:~$ chmod +x ~/krc
krc@krc-P61-USB3-B3:~$ chmod +x /home/krc/krc
krc@krc-P61-USB3-B3:~$
« Son Düzenleme: 26 Nisan 2019, 15:21:27 Gönderen: karaca911 »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16907
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Dosyanın adı nedir? Ayrıca dosya içeriğini paylaşaınız, belki hazırladığınız dosyada hata vardır. Dosyanın başına "#!/bin/bash" satırı ekleyip deneyebilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı karaca911

  • Yeni Penguen
  • *
  • İleti: 84
  • Dağıtım: mint18
  • Masaüstü: Cinnamon
  • Grafik Kartı: geforce 630
  • İşlemci: i3
Dosyanın adı "krc" dosyada hata yok, diğer türlü dosyanın üzerine çift tıkladığımda "çalıştırmak istermisiniz" diye soruyor, çalıştır'a basıyorum hemen çözünürlük istediğim gibi değişiyor, sonra bunu başlangıç proglamlarına ekliyorum. Uçbirimden sizin kodları verdiğimde aynı şekilde çözünürlüğün değişmesi gerekmiyor mu, yani o şekilde mi oluyor, ya da bilgisayarı kapatıp açmak mı gerekiyor? bilmediğim için soruyorum. Dosya içeriği bu. Şu anda zaten dosya çalışır durumda değil, yani çalışan dosyaya sizin komutlarla tekrar üst üste komut vermiş değilim. Çözünürlük değişmeden duruyor yani. Masaüstü Cinnamon ayrıca.

xrandr --newmode "CUSTOM" 83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync
xrandr --addmode VGA-1 "CUSTOM"
xrandr --output VGA-1 --mode "CUSTOM"
« Son Düzenleme: 26 Nisan 2019, 16:18:12 Gönderen: karaca911 »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16907
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Dosyayı aşağıdaki şekilde düzenleyin. Böyle yapınca özelliklerden çalıştırma izni verebileceğinizi belirtmiştim.

Kod: [Seç]
#!/bin/bash
xrandr --newmode "CUSTOM" 83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync
xrandr --addmode VGA-1 "CUSTOM"
xrandr --output VGA-1 --mode "CUSTOM"
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı karaca911

  • Yeni Penguen
  • *
  • İleti: 84
  • Dağıtım: mint18
  • Masaüstü: Cinnamon
  • Grafik Kartı: geforce 630
  • İşlemci: i3
chmod komutları işe yaramadı, ama gene de teşekkür ederim.
« Son Düzenleme: 26 Nisan 2019, 18:55:26 Gönderen: karaca911 »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16907
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Chmod komutunun işe yaramaması gibi bir durum olacağını sanmam. ls -l komutunun çıkısında sonucu görürsünüz. Çalıştırma izni verdiğiniz dosyaya çift tıklayınca çalıştıramamanız, Thunar dosya yöneticisi ile ilgili bir durum. Dosyanın başına "#!/bin/bash" satırını ekleyerek, Thunar'daki işlevin etrafından dolaşabilirsiniz.

Kod: [Seç]
ls -l dosya-adı
Thunar dosya yöneticinde, bu tür izin verilmiş dosyaların çift tıklanarak çalıştırılması pasifleştirilmiştir. Aşağıdaki komutla bu etkinleştirilebilir, ardından oturumu kapatıp açmanız gerekebilir. Ya da dosyanın başına "#!/bin/bash" satırını eklersiniz.

Kod: [Seç]
xfconf-query --channel thunar --property /misc-exec-shell-scripts-by-default --create --type bool --set true
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı karaca911

  • Yeni Penguen
  • *
  • İleti: 84
  • Dağıtım: mint18
  • Masaüstü: Cinnamon
  • Grafik Kartı: geforce 630
  • İşlemci: i3
"#!/bin/bash" komutu ile çözünürlük dosyası çalışıyor. xfce'de dosya izin seçeneklerinde "bu dosyayı bir program gibi çalıştırmaya izin ver" seçeneği yok, bu komutu verdikten sonra bu seçenek geri geliyor, bu da tamam, benim öğrenmek istediğim şey chmod ile dosyayı çalıştırmaktı, verdiğiniz komutlar ile çalışmadı. Lütfen yanlış anlamayın apartmanda çok da iyi tanımadığım ama bu işlerle ilgili olduğunu bildiğim bir arkadaşa danıştım, "chmod +x /home/krc/krc", yada "chmod +x ~/krc" komutundan sonra alt satıra "./krc" komutunu vermemi söyledi, ve çalıştı, siz yıllardır derdimizi dinliyorsunuz, bu arkadaş sizin bir alternatifiniz değil. Yanlış anlamayın. Dosya bu şekilde çalıştı.
Kod: [Seç]
krc@krc-P61-USB3-B3:~$ chmod +x /home/kullanıcıadı/dosyaadı
krc@krc-P61-USB3-B3:~$ ./dosyaadı
« Son Düzenleme: 27 Nisan 2019, 11:57:37 Gönderen: karaca911 »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16907
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Chmod komutunun bir betik çalıştırma yeteneği yok, bu komut sadece dosya izinlerini ayarlar. Dosya çalıştırma izni verir, dosyayı çalıştırmaz. Dosyaya çalıştırma izni verdiğiniz halde, çift tıklayınca dosya çalışmıyorsa, bu dosya yöneticisi ile ilgili bir durumdur. Bunun chmod komutuyla ilgisi yoktur. Ya dosyanın başına "#!/bin/bash" ekleyeceksiniz ya da dosya adının sonuna .sh ekleyeceksiniz. Bunları yaparsanız, bu durumda dosya  özelliklerden, dosyaya çalıştırma izni verme özelliğini kullanabilir ve dosyaya çift tıklayarak çalıştırabilirsiniz. Bu Thunar dosya yöneticisi ile ilgili bir kısıt.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı karaca911

  • Yeni Penguen
  • *
  • İleti: 84
  • Dağıtım: mint18
  • Masaüstü: Cinnamon
  • Grafik Kartı: geforce 630
  • İşlemci: i3
Anladım, son bir soru... aşağıdaki de çözünürlük için kullanılan bir alternatif, bu yanlız xfce için mi geçerli, yoksa tüm masaüstü ortamlarında kullanılabilir mi?, hiç kullanmadığım için soruyorum. 
Kod: [Seç]
[Desktop Entry]
Type=Application
Exec=BURAYA-BAHSETTİĞİNİZ-DOSYANIN-YOLUNU-YAZIN
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name=ekran
StartupNotify=true

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16907
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Alıntı
X-GNOME-Autostart-enabled=true

Şu satıra (Gnome haricinde) gerek yok. Bu sadece bir betiği çalıştırmak için başlatıcı olabilir. İlgili betiği başlangıç uygulamalarına (oturum ve başlangıç) eklediğinizde böyle bir dosya zaten otomatik olarak oluşturulur.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı karaca911

  • Yeni Penguen
  • *
  • İleti: 84
  • Dağıtım: mint18
  • Masaüstü: Cinnamon
  • Grafik Kartı: geforce 630
  • İşlemci: i3
Teşekkür ederim, sağolasın.