Gönderen Konu: [Çözüldü] Nvidia Prime panel uygulamacığı hatası  (Okunma sayısı 191 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı format sart

  • Yeni Penguen
  • *
  • İleti: 20
  • Dağıtım: Linux Mint 19.1
  • Masaüstü: Mate + Cİnnamon
  • Grafik Kartı: Nvidia 930M
  • İşlemci: i7 5500U
  • RAM: 8 GB
Arkadaşlar merhaba. Mint 19.1 Cİnnamon kullanıyorum. Panele nvidia prime gpu gösterimi uygulamacığını ekledim. Fakat çalışmıyor, hata yazıyor ve şöyle diyor "Nvidia Prime doğru biçimde yapılandırılmamış - nvidia sürücüsü ve nvidia-prime kurulu mu?" kurulu da oysa. İnternette araştırma yaptım fakat benzer bir şey bulamadım. Bu da görüntüsü:
« Son Düzenleme: 17 Şubat 2019, 07:36:17 Gönderen: format sart »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16579
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Nvidia Prime panel uygulamacığı hatası
« Yanıtla #1 : 16 Şubat 2019, 20:45:20 »
Üyelerimize sürekli hatırlatmak zorunda kalıyoruz, oysa ki bu başlıkları bu tür mesajlar göndermeye gerek kalmasın diye hazırlamıştık.

« Son Düzenleme: 16 Şubat 2019, 21:54:34 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı format sart

  • Yeni Penguen
  • *
  • İleti: 20
  • Dağıtım: Linux Mint 19.1
  • Masaüstü: Mate + Cİnnamon
  • Grafik Kartı: Nvidia 930M
  • İşlemci: i7 5500U
  • RAM: 8 GB
Ynt: Nvidia Prime panel uygulamacığı hatası
« Yanıtla #2 : 16 Şubat 2019, 20:51:26 »
Üyelerimize sürekli hatırlatmak zorunda kalıyoruz, oysa ki bu başlıkları bu tür mesajlar göndermeye gerek kalmasın diye hazırlamıştık.


Affola hocam, araştırdım böyle bir konu var mı diye bulamadım. Eğer sorun burdaysa mevcut konunun linkini gönderebilirseniz mutlu olurum.

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16579
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Nvidia Prime panel uygulamacığı hatası
« Yanıtla #3 : 16 Şubat 2019, 21:53:42 »
Önceki mesajımdaki, uyarı kutusunda bulunan bağlantıdan ulaşabilirsiniz. Konuda ekran kartı ile ilgili sorunlarda, paylaşılması gerekenler ile ilgili bir bağlantı mevcut.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı lalabaki

  • Yeni Penguen
  • *
  • İleti: 38
  • Dağıtım: Manjaro
  • Masaüstü: XFCE
  • Grafik Kartı: ATI Medison Readon|Intel Hybrid
  • İşlemci: Intel Core i5
Ynt: Nvidia Prime panel uygulamacığı hatası
« Yanıtla #4 : 16 Şubat 2019, 21:54:09 »
Hata alıyorsunuz ama hatayı tespit edebilmek için sistem hakkında hiçbir bilgi yok.
https://forum.linuxmint.net.tr/index.php?topic=2738.0

Çevrimdışı format sart

  • Yeni Penguen
  • *
  • İleti: 20
  • Dağıtım: Linux Mint 19.1
  • Masaüstü: Mate + Cİnnamon
  • Grafik Kartı: Nvidia 930M
  • İşlemci: i7 5500U
  • RAM: 8 GB
Ynt: Nvidia Prime panel uygulamacığı hatası
« Yanıtla #5 : 16 Şubat 2019, 22:38:15 »
inxi -SMGxx

Kod: [Seç]
System:
  Host: ali-SATELLITE-L50-C Kernel: 4.15.0-20-generic x86_64 bits: 64
  compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.9 wm: muffin dm: LightDM
  Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic
Machine:
  Type: Laptop System: TOSHIBA product: SATELLITE L50-C v: PSKWSE-01400PTE
  serial: <root required>
  Mobo: FF50 model: 06F2 v: Type2 - Board Version serial: <root required>
  UEFI: INSYDE v: 5.30 date: 03/25/2016
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Toshiba America Info Systems
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:1616
  Device-2: NVIDIA GM108M [GeForce 930M]
  vendor: Toshiba America Info Systems driver: nvidia v: 390.77
  bus ID: 09:00.0 chip ID: 10de:1346
  Display: x11 server: X.Org 1.19.6 driver: modesetting,nvidia
  unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: GeForce 930M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.77
  direct render: Yes
glxinfo | grep render
Kod: [Seç]
direct rendering: Yes
OpenGL renderer string: GeForce 930M/PCIe/SSE2
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
    GL_KTX_buffer_region, GL_NVX_conditional_render, GL_NVX_gpu_memory_info,
    GL_NV_compute_program5, GL_NV_conditional_render,
    GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite,
    GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted,
    GL_KTX_buffer_region, GL_NVX_conditional_render, GL_NVX_gpu_memory_info,
    GL_NV_compute_program5, GL_NV_conditional_render,
    GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite,
    GL_EXT_multisample_compatibility, GL_EXT_multisampled_render_to_texture,
    GL_EXT_multisampled_render_to_texture2, GL_EXT_occlusion_query_boolean,
    GL_EXT_render_snorm, GL_EXT_robustness, GL_EXT_sRGB,
    GL_NV_blend_minmax_factor, GL_NV_conditional_render, GL_NV_copy_buffer,
    GL_NV_path_rendering, GL_NV_pixel_buffer_object, GL_NV_polygon_mode,
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

lspci | egrep 'VGA|3D|Display'
Kod: [Seç]
0:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
09:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 930M] (rev a2)
xrandr
Kod: [Seç]
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
   1920x1080     60.02*+  60.01    59.97    59.96    59.93 
   1680x1050     59.95    59.88 
   1600x1024     60.17 
   1400x1050     59.98 
   1600x900      59.99    59.94    59.95    59.82 
   1280x1024     60.02 
   1440x900      59.89 
   1400x900      59.96    59.88 
   1280x960      60.00 
   1440x810      60.00    59.97 
   1368x768      59.88    59.85 
   1360x768      59.80    59.96 
   1280x800      59.99    59.97    59.81    59.91 
   1152x864      60.00 
   1280x720      60.00    59.99    59.86    59.74 
   1024x768      60.04    60.00 
   960x720       60.00 
   928x696       60.05 
   896x672       60.01 
   1024x576      59.95    59.96    59.90    59.82 
   960x600       59.93    60.00 
   960x540       59.96    59.99    59.63    59.82 
   800x600       60.00    60.32    56.25 
   840x525       60.01    59.88 
   864x486       59.92    59.57 
   800x512       60.17 
   700x525       59.98 
   800x450       59.95    59.82 
   640x512       60.02 
   720x450       59.89 
   700x450       59.96    59.88 
   640x480       60.00    59.94 
   720x405       59.51    58.99 
   684x384       59.88    59.85 
   680x384       59.80    59.96 
   640x400       59.88    59.98 
   576x432       60.06 
   640x360       59.86    59.83    59.84    59.32 
   512x384       60.00 
   512x288       60.00    59.92 
   480x270       59.63    59.82 
   400x300       60.32    56.34 
   432x243       59.92    59.57 
   320x240       60.05 
   360x202       59.51    59.13 
   320x180       59.84    59.32 
HDMI-1-1 disconnected (normal left inverted right x axis y axis)

cat /etc/X11/xorg.conf

Kod: [Seç]
cat: /etc/X11/xorg.conf: Böyle bir dosya ya da dizin yok
dpkg -l | egrep 'nvidia|bumblebee|primus|prime|virtualgl|fglrx'


dpkg -l | egrep 'nvidia|bumblebee|primus|prime|virtualgl|fglrx'

Kod: [Seç]
ii  libnvidia-cfg1-390:amd64                   390.77-0ubuntu0.18.04.2                     amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-390                       390.77-0ubuntu0.18.04.2                     all          Shared files used by the NVIDIA libraries
ii  libnvidia-compute-390:amd64                390.77-0ubuntu0.18.04.2                     amd64        NVIDIA libcompute package
ii  libnvidia-compute-390:i386                 390.77-0ubuntu0.18.04.2                     i386         NVIDIA libcompute package
ii  libnvidia-decode-390:amd64                 390.77-0ubuntu0.18.04.2                     amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-390:i386                  390.77-0ubuntu0.18.04.2                     i386         NVIDIA Video Decoding runtime libraries
ii  libnvidia-encode-390:amd64                 390.77-0ubuntu0.18.04.2                     amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-390:i386                  390.77-0ubuntu0.18.04.2                     i386         NVENC Video Encoding runtime library
ii  libnvidia-fbc1-390:amd64                   390.77-0ubuntu0.18.04.2                     amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-390:i386                    390.77-0ubuntu0.18.04.2                     i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-390:amd64                     390.77-0ubuntu0.18.04.2                     amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-390:i386                      390.77-0ubuntu0.18.04.2                     i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-ifr1-390:amd64                   390.77-0ubuntu0.18.04.2                     amd64        NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  libnvidia-ifr1-390:i386                    390.77-0ubuntu0.18.04.2                     i386         NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  nvidia-compute-utils-390                   390.77-0ubuntu0.18.04.2                     amd64        NVIDIA compute utilities
ii  nvidia-dkms-390                            390.77-0ubuntu0.18.04.2                     amd64        NVIDIA DKMS package
ii  nvidia-driver-390                          390.77-0ubuntu0.18.04.2                     amd64        NVIDIA driver metapackage
ii  nvidia-kernel-common-390                   390.77-0ubuntu0.18.04.2                     amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-390                   390.77-0ubuntu0.18.04.2                     amd64        NVIDIA kernel source package
ii  nvidia-prime                               0.8.8.2                                     all          Tools to enable NVIDIA's Prime
ii  nvidia-settings                            390.77-0ubuntu0.18.04.1                     amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-390                           390.77-0ubuntu0.18.04.2                     amd64        NVIDIA driver support binaries
ii  prime-indicator-plus                       1.0.3+git20170919-1~webupd8~0               all          PRIME Indicator Plus
ii  xserver-xorg-video-nvidia-390              390.77-0ubuntu0.18.04.2                     amd64        NVIDIA binary Xorg driver
« Son Düzenleme: 16 Şubat 2019, 22:40:40 Gönderen: format sart »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16579
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Nvidia Prime panel uygulamacığı hatası
« Yanıtla #6 : 16 Şubat 2019, 22:55:05 »
Öncelikle sisteminizi güncellemeyi dener misiniz?

« Son Düzenleme: 16 Şubat 2019, 22:59:15 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı format sart

  • Yeni Penguen
  • *
  • İleti: 20
  • Dağıtım: Linux Mint 19.1
  • Masaüstü: Mate + Cİnnamon
  • Grafik Kartı: Nvidia 930M
  • İşlemci: i7 5500U
  • RAM: 8 GB
Ynt: Nvidia Prime panel uygulamacığı hatası
« Yanıtla #7 : 16 Şubat 2019, 22:55:58 »
Sistem zaten güncel. Güncelleme yöneticisinden güncelledim. O güncellemeyi diyorsanız yani.

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16579
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Nvidia Prime panel uygulamacığı hatası
« Yanıtla #8 : 16 Şubat 2019, 23:00:28 »
Çekirdek sürümü eski göründüğü için, bundan kaynaklı bir sorun ihtimali olabileceğini düşündüm.

Alıntı
ii  prime-indicator-plus                       1.0.3+git20170919-1~webupd8~0               all          PRIME Indicator Plus

Ama sorunun kaynağı bu değil sanırım.  Yukarıda alıntıladığım paket Linux Mint'in aracı değil, bunu kaldırıp Linux Mint'in uygulamacığının bulunduğu nvidia-prime-applet paketini kurmayı deneyiniz. Ardından bu uygulamacığı panele eklersiniz. Nvidia Prime kurulum konusunda anlatılıyor.

Kod: [Seç]
sudo apt install nvidia-prime-applet
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı format sart

  • Yeni Penguen
  • *
  • İleti: 20
  • Dağıtım: Linux Mint 19.1
  • Masaüstü: Mate + Cİnnamon
  • Grafik Kartı: Nvidia 930M
  • İşlemci: i7 5500U
  • RAM: 8 GB
Ynt: Nvidia Prime panel uygulamacığı hatası
« Yanıtla #9 : 16 Şubat 2019, 23:18:10 »
Çekirdek sürümü eski göründüğü için, bundan kaynaklı bir sorun ihtimali olabileceğini düşündüm.

Ama sorunun kaynağı bu değil sanırım.  Yukarıda alıntıladığım paket Linux Mint'in aracı değil, bunu kaldırıp Linux Mint'in uygulamacığının bulunduğu nvidia-prime-applet paketini kurmayı deneyiniz. Ardından bu uygulamacığı panele eklersiniz. Nvidia Prime kurulum konusunda anlatılıyor.

Kod: [Seç]
sudo apt install nvidia-prime-applet

Dediğinizi yaptım, fakat benim sonradan kurduğum uygulama silinmedi tam olarak sanırım. sudo apt-get purge prime indicator-plus dedim. Komut başarılı da oldu ama hala gözüküyor panelde sanırım. Nvidia'nın kendi uygulamacığı da hala hata veriyor.


Paket yöneticisinde şöyle gözüküyor:

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16579
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Nvidia Prime panel uygulamacığı hatası
« Yanıtla #10 : 16 Şubat 2019, 23:20:05 »
Aşağıdaki komutla kaldırmayı deneyin.

Kod: [Seç]
sudo apt purge prime-indicator-plus
Oturumu kapatıp açtıktan ya da sistemi yeniden başlattıktan sonra panelde görünmeyecektir.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı format sart

  • Yeni Penguen
  • *
  • İleti: 20
  • Dağıtım: Linux Mint 19.1
  • Masaüstü: Mate + Cİnnamon
  • Grafik Kartı: Nvidia 930M
  • İşlemci: i7 5500U
  • RAM: 8 GB
Ynt: Nvidia Prime panel uygulamacığı hatası
« Yanıtla #11 : 16 Şubat 2019, 23:23:16 »
Aşağıdaki komutla kaldırmayı deneyin.

Kod: [Seç]
sudo apt purge prime-indicator-plus
Oturumu kapatıp açtıktan ya da sistemi yeniden başlattıktan sonra panelde görünmeyecektir.

Zaten kurulu değildi dedi hocam.

Kod: [Seç]
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
'prime-indicator-plus' kurulu değildi, dolayısıyla kaldırılmadı
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  bbswitch-dkms gir1.2-nmgtk-1.0 icoutils libnm-gtk0 libwxbase3.0-0v5
  libwxgtk3.0-gtk3-0v5 python-wxgtk3.0 python-wxversion
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16579
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Nvidia Prime panel uygulamacığı hatası
« Yanıtla #12 : 16 Şubat 2019, 23:25:05 »
Önceden kaldırmışsındır o zaman! Oturumu kapatıp yeniden açmayı dene bakalım.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı format sart

  • Yeni Penguen
  • *
  • İleti: 20
  • Dağıtım: Linux Mint 19.1
  • Masaüstü: Mate + Cİnnamon
  • Grafik Kartı: Nvidia 930M
  • İşlemci: i7 5500U
  • RAM: 8 GB
Ynt: Nvidia Prime panel uygulamacığı hatası
« Yanıtla #13 : 16 Şubat 2019, 23:26:36 »
Önceden kaldırmışsındır o zaman! Oturumu kapatıp yeniden açmayı dene bakalım.

Kaldırdıktan sonra zaten yeniden açtım sistemi ama hala durum bu şekilde. Şu panelde gözüken nvidia logosu prime-indicator uygulaması olsa gerek, o zaman hala silinmedi demek oluyor.

Mesajlar Birleştirildi.

Bu arada bir işe yarar mı bilmem ama mate yanına kurulu cinnamon.

Edit: Nvidia Prime ve nVidia Prime GPU Gösterimi farklı uygulamacıklarmış. Önceki attığım ekran görüntüsündeki nvidia prime'ın logosuymuş çünkü nvidia prime uygulamasını kurduğum zaman o logo gitti farklı şekilde geldi.  nVidia Prime GPU adlı uygulamacık hala hata veriyor ama önemi de yok artık çünkü çalışan bir prime göstergecim var artık. Önceden kurduğum program da vardı ama resmi değildi o, bu daha güzel. Teşekkür ederim hocam yardımların için.[/size][/font]
« Son Düzenleme: 16 Şubat 2019, 23:40:35 Gönderen: format sart »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16579
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Nvidia Prime panel uygulamacığı hatası
« Yanıtla #14 : 17 Şubat 2019, 00:44:47 »
Bu durumda hata veren uygulamacığı panelden kaldırırsanız, sorun çözülecek demektir.

Çözüme ulaşan başlığı etiketlerseniz, konuyu kilitleyebiliriz.




Not: nVidia Prime GPU Gösterimi uygulamacığı bbswitch üzerinden çalışacak şekilde yapılandırılmış. Ama Linux Mint 19.x sürüm ile gelen Nvidia-prime yöntemi bbswitch kullanmıyor. Bu sebeple uygulamacık bbswitch üzerinden kontrol yapamadığı için, yapılandırma ve paket hakkında uyarı veriyor.

Alıntı
      // This catches error if bbswitch is not loaded                     
   } catch (e) {
//          global.logError(e);  // Commented out to avoid filling error log
        this.bbst = "ERROR";
   }


Alıntı
         if(this.bbst == "ERROR" || this.nvidiaPrimeMissing) {
             this.set_applet_label(_("Err" ));
              this.set_applet_tooltip(_("Nvidia Prime is not set up correctly - are the nvidia drivers and nvidia-prime  installed?"));

Bu uygulamacık şu an için Linux Mint 18.x serisinde çalışabilir, Linux Mint 19.x serisinde hata verecektir. Bu sebeple Linux Mint'in kendi aracını kullanmak daha uygun olacaktır. Linux Mint'in aracı GPU sorgulamasını prime-select komutu üzerinden yaptığı için sorun yaşanmıyor.

Alıntı
                if (this._doCommand(["prime-supported"]) == "yes") {
                    let active_gpu = this._doCommand(["prime-select", "query"]);
                    if (active_gpu == "nvidia") {
                        this.set_applet_icon_symbolic_name("prime-applet-nvidia");
                        this.set_applet_tooltip(_("Active graphics card: NVIDIA"));
                    }
                    else if (active_gpu == "intel") {
                        this.set_applet_icon_symbolic_name("prime-applet-intel");
                        this.set_applet_tooltip(_("Active graphics card: Intel"));
                    }

Bununla ilgili bir hata kaydı oluşturdum.
« Son Düzenleme: 17 Şubat 2019, 01:21:37 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...