Gönderen Konu: [Çözüldü] Mint 19.1 açılışta tty1 login ekranı  (Okunma sayısı 376 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı mesut24

  • Yeni Penguen
  • *
  • İleti: 59
  • Dağıtım: Linux Mint 19
  • Masaüstü: Cinnamon
  • Grafik Kartı: NVDİA
  • İşlemci: İNTEL
Merhaba. Sistem açılırken tty1 login ekranı geliyor ve 4-5 sn sonra kendiliğinden geçiyor. Bu ekranın gelmemesi için ne yapmalıyım. Teşekkürler...
« Son Düzenleme: 09 Ocak 2019, 14:20:26 Gönderen: mesut24 »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16926
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.2 & LMDE 3
  • Masaüstü: Cinnamon 4.2 & Mate 1.22
Ynt: Mint 19.1 açılışta tty1 login ekranı
« Yanıtla #1 : 08 Ocak 2019, 16:18:52 »
Size de merhaba.

Buradaki öneriyi uygulamayı deneyiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı mesut24

  • Yeni Penguen
  • *
  • İleti: 59
  • Dağıtım: Linux Mint 19
  • Masaüstü: Cinnamon
  • Grafik Kartı: NVDİA
  • İşlemci: İNTEL
Ynt: Mint 19.1 açılışta tty1 login ekranı
« Yanıtla #2 : 08 Ocak 2019, 17:38:30 »
Aynısını yaptım sorun devam ediyor.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16926
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.2 & LMDE 3
  • Masaüstü: Cinnamon 4.2 & Mate 1.22
Ynt: Mint 19.1 açılışta tty1 login ekranı
« Yanıtla #3 : 08 Ocak 2019, 19:41:42 »
Komutun çıktısına bakalım.

Kod: [Seç]
cat /proc/cmdline
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı mesut24

  • Yeni Penguen
  • *
  • İleti: 59
  • Dağıtım: Linux Mint 19
  • Masaüstü: Cinnamon
  • Grafik Kartı: NVDİA
  • İşlemci: İNTEL
Ynt: Mint 19.1 açılışta tty1 login ekranı
« Yanıtla #4 : 09 Ocak 2019, 00:12:32 »
Kod: [Seç]
erden@erdenler:~$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.15.0-43-generic root=UUID=c8014e40-b525-4399-8444-d982a26ea629 ro vt.handoff=7 quiet splash vt.handoff=1


Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16926
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.2 & LMDE 3
  • Masaüstü: Cinnamon 4.2 & Mate 1.22
Ynt: Mint 19.1 açılışta tty1 login ekranı
« Yanıtla #5 : 09 Ocak 2019, 01:41:49 »
BOOT_IMAGE=/boot/vmlinuz-4.15.0-43-generic root=UUID=c8014e40-b525-4399-8444-d982a26ea629 ro vt.handoff=7 quiet splash vt.handoff=1


Aşağıdaki komutla 10_linux dosyasını açınız.

Kod: [Seç]
sudo xed /etc/grub.d/10_linux
Açılan dosyada aşağıdaki satırı bulup,

Kod: [Seç]
vt_handoff="1"
aşağıdaki şekilde değiştirip kaydediniz.

Kod: [Seç]
vt_handoff="0"
Bu satırın değeri 1 olduğunda, 10_linux dosyası açılışa $vt_handoff değişkenini ekliyor, bu da otomatik olarak vt.handoff=1 değişkeni ile başlatılmasını sağlıyor. Bu düzenleme sonrasında, açılışta sadece grub varsayılan dosyasına eklediğimiz vt.handoff=7 değişkeni kalacak. Düzenlemeden sonra aşağıdaki komutu da çalıştırınız.

Kod: [Seç]
sudo update-grub
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı mesut24

  • Yeni Penguen
  • *
  • İleti: 59
  • Dağıtım: Linux Mint 19
  • Masaüstü: Cinnamon
  • Grafik Kartı: NVDİA
  • İşlemci: İNTEL
Ynt: Mint 19.1 açılışta tty1 login ekranı
« Yanıtla #6 : 09 Ocak 2019, 14:17:37 »
Çok teşekkür edrim sorun çözüldü.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16926
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.2 & LMDE 3
  • Masaüstü: Cinnamon 4.2 & Mate 1.22
Ynt: [Çözüldü] Mint 19.1 açılışta tty1 login ekranı
« Yanıtla #7 : 09 Ocak 2019, 15:38:57 »
Rica ederiz.

Sorun çözüldüğü için konu kilitlenmiştir.



Bir öneri daha ekleyelim. Tüm bu işlemlere rağmen giriş ekranından önce hâlâ TTY1 ekranı görünüyorsa, aşağıdaki komutla getty@tty1 servisini pasifleştirmek denenebilir.

Kod: [Seç]
sudo systemctl disable getty@tty1.service
Bu işlem sonrasında CTRL+ALT+F1 kısayolu ile TTY1'e ulaşamayabilirsiniz, bunun yerine ihtiyaç olduğunda CTRL+ALT+F2 kısayolu ile TTY2'yi kullanabilirsiniz. Aşağıdaki komutla getty@tty1 servisi yeniden etkinleştirilebilir.

Kod: [Seç]
sudo systemctl enable getty@tty1.service
Elimizden geldiğince dilimizin döndüğünce...