Gönderen Konu: [Çözüldü] Realtek ALC889 Entegre Ses Kartında 5.1 surround çıkış sorunu  (Okunma sayısı 7659 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı ogedayhun

  • Yeni Penguen
  • *
  • İleti: 27
  • Ars Gratia Homines
  • Dağıtım: Mint Mate (Petra) 16
Yaptığım araştırmalar neticesinde Realtek Azalia kodu ile Gigabyte, Asus, MSI gibi üreticilerin anakartlarına yerleştirilen ALCxxx kodlu Intel yonga grubu tümleşik ses donanımlarının hiçbirisinde 5.1, 7.1 ya da benzeri bir surround sesin zorlu bir uğraş vermeden alınamadığını öğrendim. Çünkü Linux Mintin de içinde bulunduğu geniş bir yelpazede çoğu Linux dağıtımı Pulseaudio ile geliyor ve tamamen 2.0 yani Stereo çalışmaya ayarlı. ALSA uygulamasını ise bir alt birim olarak kullanıyor bu yapı. Dolayısıyla her ikisinin yapılandırma (.conf uzantılı) ve sistem (.pa) dosyalarında da kapsamlı bir düzeltmenin yanı sıra, paman gibi uç birimde çalışan bir programdan deneme yanılma yolu ile surround kanalı yakalayıp üzerinde ayar yapmak gerekiyor. Intel uyumluluk listelerinden donanım mod ve kod bilgilerini söküp çıkarıp hepsini yapılandırma dosyalarında deneyip yanılmakla geçecek günler de cabası. Açıkçası Ubuntu ve Linux Mint forumlarına da konuyu daha önce yazmış pek çok kullanıcı mevcut. Bu durum çözülebilen ancak sancılı bir sorun gibi görünüyor. Üretici ve geliştiricilerin dikkate almadığı bu soruna ilişkin kapsamlı ve açıklayıcı bir çözüm sunulabilirse, hem benim hem de benden sonra foruma üye olacakların sorunları çözülmüş olur. Ben üzerinde çalışmaya başladım ancak linux konusunda bilgim neredeyse şu son bir iki hafta aralıksız okuyup araştırdıklarımdan ibaret ki, sanırım giriş seviyesinde bile nitelendirilemez. En son Realtek HD Ses Sürücüleri 15.8 kodu ile yayında. Bunları indirip derleyecek ve kuracak olursanız sorun daha da içinden çıkılmaz bir hal alıyor. Açıkçası Open Sound System denilen ve hem Pulseaudio'nun hem de ALSA nın atası olan bir programın ihtiyacım olan tüm sürücülere sahip olduğu ve zamanında bunları sorunsuz çalıştırdığı, ancak şimdi bu iki selefi ile birlikte çalışmadığı ya da çalışamadığını, çünkü artık bu programın geliştirilmesine son verilmiş olduğunu da ayrıca esefle öğrenmiş bulunuyorum. Eskilerin deyişi geliyor aklıma ister istemez : "Gelen Gideni Aratır".
Yardımlarınız için teşekkürler. Bu konunun ayrıntılı bir şekilde ele alınması gerektiği açık. Ancak bunu Avrupalılardan beklemeyin. Zira hiçbiri Tayvan ya da Çin malı kullanmadığı için buralardan gelen markalı bilgisayar parça ve donanımları üzerinde pek ehil değiller. Eğer kişisel özveri ile kapsamlı bir çalışma yapılıp sonuçları bu forumda duyurulacak olursa, bilgi ve bulguları zevkle bildiğim yabancı dillere çevirerek uluslararası forumlara atacağım postalarla yaymaktan, duyulmalarını ve bilinmelerini sağlamaktan memnuniyet duyarım. Aksi takdirde gidip 30 - 50 liralık bir Creative Ses Kartı alarak sorunu çözmeyi planlıyorum. Yardımlarınız için tekrar teşekkür ederim.
« Son Düzenleme: 03 Haziran 2014, 10:07:00 Gönderen: ogedayhun »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16737
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Burasını incelemiş miydiniz?

Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ogedayhun

  • Yeni Penguen
  • *
  • İleti: 27
  • Ars Gratia Homines
  • Dağıtım: Mint Mate (Petra) 16
Evet. Hatta söylenen tüm tar.bz2, tar.gz dosyalarını da indirdim. Ancak hiçbirisini derleyemediğim için kuramadım. Yazılım ya da modül bağımlılıklarını çözmek inanılmaz güç bir iş.
Kod: [Seç]
./configure parça bağımlılıklarını veriyor vermesine ama bu parçaların hepsini çoğu zaman bulamıyorum sanırım listemdeki kaynaklar yetersiz. İnternetten indirdiğim bu gibi dosyaların haddi hesabı yok ancak hiçbirini kurmakta şu ana kadar başarılı olamadım.

Çevrimdışı ogedayhun

  • Yeni Penguen
  • *
  • İleti: 27
  • Ars Gratia Homines
  • Dağıtım: Mint Mate (Petra) 16
Son indirdiğim paketi kazasız belasız kurabildim. Dolayısıyla verdiğiniz kaynaktaki sürücü kuruldu. Ancak yine değişen bir şey yok sistemim hala stereo :D. Yine de teşekkürler.

Çevrimdışı ogedayhun

  • Yeni Penguen
  • *
  • İleti: 27
  • Ars Gratia Homines
  • Dağıtım: Mint Mate (Petra) 16
Çözdüm!!!
Forumlarda anlatılan ve sizin önerdiğiniz çözümlerin tamamını uyguladıktan ve arada mate sistemini mahvettiğimden bir de üstüne sıfırdan cinnamon kurmak zorunda kaldıktan sonra, sıfırdan kurulum ile baştan alıp tek tek yinelediğim çözümlerin ardından, son derece komik bir yerde takıldığımı fark ettim: "Ses Çıkışlarını Hoparlörlere Bağlayan Kablolar" Windows 7 ile aynı giriş ve çıkışları kullanmıyormuş ses kartı. Sorun oradan kaynaklanıyormuş. İki mikrofon çıkışı ve üç hoparlör girişi olmak üzere toplamda 5 delik bulunan kart üzerinde sadece kabloların yerlerini tek tek ses gelip gelmediğini kontrol etmek için AC3 ses kaydına sahip olduğum bir video filmi oynatarak kulağıma gelen seslerle olayı çözdüm. Teknikten anlamadığım için bunun nedenini de açıklayamayacağım ancak sorunum çözüldü. İlgi ve bilgileriniz için tekrar teşekkürler.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16737
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Bize de güle güle kullanın demek düşer o zaman.



Sorun çözüldüğü için konu kilitlendi.
Elimizden geldiğince dilimizin döndüğünce...