Gönderen Konu: [Çözüldü] Linux Mint`te Creative Ses Kartı Sorunu  (Okunma sayısı 3509 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı LinuxMİnt

  • Çaylak Penguen
  • **
  • İleti: 102
    • mehmet akın
  • Dağıtım: Linux Mint
  • Masaüstü: gnome
  • Grafik Kartı: intel
  • İşlemci: intel
[Çözüldü] Linux Mint`te Creative Ses Kartı Sorunu
« : 18 Ağustos 2016, 23:03:18 »
Arkadaşlar merhaba bilgisayarımda Creative ses kartı var, ve bu ses kartımdan ses alamıyorum, ilginç olan Linux Mint`in Ses Tercihleri bölümü test kısmında soldan ses geliyor sağdan ses gelmiyor. Youtube`dan hiç ses alamadım (ses kartında seçimde Creative`i seçmeme rağmen ses aktarımı diğer ses kartından yapılmaya devam ediyor)
« Son Düzenleme: 21 Ağustos 2016, 00:34:38 Gönderen: LinuxMİnt »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16947
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.2 & LMDE 3
  • Masaüstü: Cinnamon 4.2 & Mate 1.22
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı LinuxMİnt

  • Çaylak Penguen
  • **
  • İleti: 102
    • mehmet akın
  • Dağıtım: Linux Mint
  • Masaüstü: gnome
  • Grafik Kartı: intel
  • İşlemci: intel
Ynt: Linux Mint`te Creative Ses Kartı Sorunu
« Yanıtla #2 : 18 Ağustos 2016, 23:30:40 »
Kod: [Seç]
umut[member=2199]Umut[/member]-G41M-Combo ~ $ inxi -SMAx
System:    Host: umut-G41M-Combo Kernel: 3.13.0-37-generic x86_64 (64 bit gcc: 4.8.2)
           Desktop: MATE 1.12.0 (Gtk 3.10.8~8+qiana)
           Distro: Linux Mint 17.3 Rosa
Machine:   Mobo: Gigabyte model: G41M-Combo v: x.x
           Bios: Award v: FA date: 02/29/2012
Audio:     Card-1 Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Creative Labs CA0106 Soundblaster
           driver: snd_ca0106 port: df00 bus-ID: 03:00.0
           Sound: Advanced Linux Sound Architecture v: k3.13.0-37-generic
umut[member=2199]Umut[/member]-G41M-Combo ~ $ cat /proc/asound/card0/codec#* | grep Codec
cat: /proc/asound/card0/codec#*: Böyle bir dosya ya da dizin yok
umut[member=2199]Umut[/member]-G41M-Combo ~ $ cat /proc/asound/modules
 0 snd_ca0106
 1 snd_hda_intel
umut[member=2199]Umut[/member]-G41M-Combo ~ $ lsmod | grep snd
snd_hda_codec_realtek    65580  1
snd_hda_intel          56451  3
snd_ca0106             44698  2
snd_hda_codec         192906  2 snd_hda_codec_realtek,snd_hda_intel
snd_ac97_codec        130285  1 snd_ca0106
snd_hwdep              13602  1 snd_hda_codec
ac97_bus               12730  1 snd_ac97_codec
snd_seq_midi           13324  0
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            30144  2 snd_ca0106,snd_seq_midi
snd_pcm               102099  4 snd_ac97_codec,snd_hda_codec,snd_hda_intel,snd_ca0106
snd_seq                61560  2 snd_seq_midi_event,snd_seq_midi
snd_page_alloc         18710  3 snd_pcm,snd_hda_intel,snd_ca0106
snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              29482  2 snd_pcm,snd_seq
snd                    69322  22 snd_hda_codec_realtek,snd_ac97_codec,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_ca0106,snd_seq_midi
soundcore              12680  1 snd
umut[member=2199]Umut[/member]-G41M-Combo ~ $ aplay -l
**** PLAYBACK Donanım Aygıtlarının Listesi ****
kart 0: CA0106 [CA0106], aygıt 0: ca0106 [CA0106]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 0: CA0106 [CA0106], aygıt 1: ca0106 [CA0106]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 0: CA0106 [CA0106], aygıt 2: ca0106 [CA0106]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 0: CA0106 [CA0106], aygıt 3: ca0106 [CA0106]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 1: Intel [HDA Intel], aygıt 0: ALC887-VD Analog [ALC887-VD Analog]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
umut[member=2199]Umut[/member]-G41M-Combo ~ $

Mesajlar Birleştirildi.
Böyle daha düzgün:

Kod: [Seç]
lsb_release -a
No LSB modules are available.
Distributor ID: LinuxMint
Description: Linux Mint 17.3 Rosa
Release: 17.3
Codename: rosa

Kod: [Seç]
lspci | grep Audio
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)

Kod: [Seç]
grep "Codec:" /proc/asound/card*/codec*
Codec: Realtek ALC887-VD

Kod: [Seç]
lsmod | grep snd
snd_hda_codec_realtek    65580  1
snd_hda_intel          56451  4
snd_ca0106             44698  1
snd_hda_codec         192906  2 snd_hda_codec_realtek,snd_hda_intel
snd_ac97_codec        130285  1 snd_ca0106
snd_hwdep              13602  1 snd_hda_codec
ac97_bus               12730  1 snd_ac97_codec
snd_seq_midi           13324  0
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            30144  2 snd_ca0106,snd_seq_midi
snd_pcm               102099  5 snd_ac97_codec,snd_hda_codec,snd_hda_intel,snd_ca0106
snd_seq                61560  2 snd_seq_midi_event,snd_seq_midi
snd_page_alloc         18710  3 snd_pcm,snd_hda_intel,snd_ca0106
snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              29482  2 snd_pcm,snd_seq
snd                    69322  21 snd_hda_codec_realtek,snd_ac97_codec,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_ca0106,snd_seq_midi
soundcore              12680  1 snd

Kod: [Seç]
aplay -l
**** PLAYBACK Donanım Aygıtlarının Listesi ****
kart 0: CA0106 [CA0106], aygıt 0: ca0106 [CA0106]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 0: CA0106 [CA0106], aygıt 1: ca0106 [CA0106]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 0: CA0106 [CA0106], aygıt 2: ca0106 [CA0106]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 0: CA0106 [CA0106], aygıt 3: ca0106 [CA0106]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
kart 1: Intel [HDA Intel], aygıt 0: ALC887-VD Analog [ALC887-VD Analog]
  Altaygıtlar: 1/1
  Altaygıt #0: subdevice #0
« Son Düzenleme: 19 Ağustos 2016, 00:09:49 Gönderen: LinuxMİnt »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16947
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.2 & LMDE 3
  • Masaüstü: Cinnamon 4.2 & Mate 1.22
Ynt: Linux Mint`te Creative Ses Kartı Sorunu
« Yanıtla #3 : 19 Ağustos 2016, 00:09:12 »
Aşağıdaki komutla alsa-base.conf dosyasını açıp,

Kod: [Seç]
sudo pluma /etc/modprobe.d/alsa-base.conf
aşağıdaki satırları dosyanın en altına ekleyiniz ve dosyayı kaydettikten sonra sistemi yeniden başlatmayı deneyiniz.

Kod: [Seç]
options snd_ca0106 index=0
options snd_hda_intel index=1
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı LinuxMİnt

  • Çaylak Penguen
  • **
  • İleti: 102
    • mehmet akın
  • Dağıtım: Linux Mint
  • Masaüstü: gnome
  • Grafik Kartı: intel
  • İşlemci: intel
Ynt: Linux Mint`te Creative Ses Kartı Sorunu
« Yanıtla #4 : 19 Ağustos 2016, 00:18:32 »
Aşağıdaki komutla alsa-base.conf dosyasını açıp,

Kod: [Seç]
sudo pluma /etc/modprobe.d/alsa-base.conf
aşağıdaki satırları dosyanın en altına ekleyiniz ve dosyayı kaydettikten sonra sistemi yeniden başlatmayı deneyiniz.

Kod: [Seç]
options snd_ca0106 index=0
options snd_hda_intel index=1

Dediğinizi yaptım ve tekrar başlattım, sorun aynen devam ediyor.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16947
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.2 & LMDE 3
  • Masaüstü: Cinnamon 4.2 & Mate 1.22
Ynt: Linux Mint`te Creative Ses Kartı Sorunu
« Yanıtla #5 : 19 Ağustos 2016, 01:16:27 »
Aşağıdaki komutla Alsa karıştırıyı açıp,

Kod: [Seç]
alsamixer
F6 tuşuna basarak ses aygıtını değiştirmeyi deneyebilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı LinuxMİnt

  • Çaylak Penguen
  • **
  • İleti: 102
    • mehmet akın
  • Dağıtım: Linux Mint
  • Masaüstü: gnome
  • Grafik Kartı: intel
  • İşlemci: intel
Ynt: Linux Mint`te Creative Ses Kartı Sorunu
« Yanıtla #6 : 19 Ağustos 2016, 01:42:35 »
Aşağıdaki komutla Alsa karıştırıyı açıp,

Kod: [Seç]
alsamixer
F6 tuşuna basarak ses aygıtını değiştirmeyi deneyebilirsiniz.

Dediğinizi yaptım  ilk başta bir değişiklik olmadı ama Youtube`da bir videoya tıklayınca ses gelmeye başladı ancak ses sadece soldan geliyordu.

Sanırım en son ses olduğundan ses cızırtılı geliyordu

sonra Ses Tercihlerindeki; "seçilen aygıt için ayarlar" kısmendan seçim yapmayı denedim; ilk ikisinde bir değiklik olmadı, üçüncüde ses gitti, eski seçimi tıklasamda ses geri gelmediği gibi ses yeniden diğer ses kartından gelmeye başladı.


ses kartı böyle gözüküyor:

« Son Düzenleme: 19 Ağustos 2016, 01:52:03 Gönderen: LinuxMİnt »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16947
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.2 & LMDE 3
  • Masaüstü: Cinnamon 4.2 & Mate 1.22
Ynt: Linux Mint`te Creative Ses Kartı Sorunu
« Yanıtla #7 : 20 Ağustos 2016, 01:07:14 »
Aşağıdaki komutla Pulse ses denetimini ve Gnome Alsa karıştırıcıyı kurmayı deneyin.

Kod: [Seç]
sudo apt-get install pavucontrol gnome-alsamixer
Pulse ses denetimi ile Çıkış Aygıtları kısmından ses kartını değiştirmeyi, Gnome Alsa karıştırıcı ile ses seviyelerini (sağ ve sol hoparlörler için) ayarlamayı deneyebilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı LinuxMİnt

  • Çaylak Penguen
  • **
  • İleti: 102
    • mehmet akın
  • Dağıtım: Linux Mint
  • Masaüstü: gnome
  • Grafik Kartı: intel
  • İşlemci: intel
Ynt: Linux Mint`te Creative Ses Kartı Sorunu
« Yanıtla #8 : 21 Ağustos 2016, 00:32:44 »
Aşağıdaki komutla Pulse ses denetimini ve Gnome Alsa karıştırıcıyı kurmayı deneyin.

Kod: [Seç]
sudo apt-get install pavucontrol gnome-alsamixer
Pulse ses denetimi ile Çıkış Aygıtları kısmından ses kartını değiştirmeyi, Gnome Alsa karıştırıcı ile ses seviyelerini (sağ ve sol hoparlörler için) ayarlamayı deneyebilirsiniz.

Düzeldi çok teşekkür ederim.