Gönderen Konu: [Nasıl] Linux Mint 18.x LAMP (Linux + Apache + MariaDB + Php) Sunucu Kurulumu  (Okunma sayısı 13241 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16907
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20


LAMP, Linux, Apache, MariaDB (Mysql) + PHP uygulamalarının baş harflerinden oluşturulmuştur, özetle Linux üzerinde PHP desteği ile Apache ve MariaDB (MySQL) kullanılmasını sağlamaktadır.

Aşağıdaki adımlarla Linux Mint 18.x sürümlere LAMP kurabilirsiniz.

1 - Apache 2.4 Kurulumu

Aşağıdaki komutla Apache kurulumunu yapabilirsiniz.

Kod: [Seç]
sudo apt-get install apache2
Kurulum sonrasında tarayıcınıza http://localhost adresini girip açtığınızda  üst kısmında kırmızı ile “It works!” yazılı bir sayfayla karşılaşıyorsanız kurulum tamamlanmış demektir. Eğer bir sorunla karşılaştınızsa aşağıdaki komutla apache2 servisini yeniden başlatmayı deneyebilirsiniz.

Kod: [Seç]
sudo systemctl restart apache2

2 - MariaDB (MySQL'in Uyumlu Çatallaması) Kurulumu

Bu anlatımda MySQL yerine, yine bir MySQL geliştirici olan Monty Widenius tarafından yeni özellikler ve hız iyileştirmeleri eklenerek çatallanan MariaDB uygulamasını kuracağız. MariaDB uygulaması MySQL ile uyumludur. (Not: Eğer sisteminizde MySQL kuruluysa, önce konuda anlatıldığı biçimde MySQL ile ilgili paketleri burada anlatıldığı biçimde kaldırmanız gerekiyor)

Aşağıdaki komutla MariaDB kurulumunu gerçekleştirebilirsiniz.

Kod: [Seç]
sudo apt-get install mariadb-server mariadb-client
Kurulum sonrası aşağıdaki komutla root şifresini ayarlıyoruz.

Kod: [Seç]
sudo mysql_secure_installation
Aşağıdaki örneğe göre MariaDB root şifrenizi ayarlayabilirsiniz.

Alıntı
Enter current password for root (enter for none): (Burada giriş (enter) tuşuna basacaksınız)
Set root password? [Y/n] (Burada y tuşuna basarak devam edeceksiniz)
New password: (Burada root şifrenizi gireceksiniz)
Re-enter new password: (Burada root şifrenizi yeniden gireceksiniz)
Remove anonymous users? [Y/n] (Burada y tuşuna basarak devam edeceksiniz)
Disallow root login remotely? [Y/n] (Burada y tuşuna basarak devam edeceksiniz)
Reload privilege tables now? [Y/n] (Burada y tuşuna basarak devam edeceksiniz)

Aşağıdaki komutla MariaDB'ye root girişi yapmayı test edebilirsiniz.

Kod: [Seç]
sudo mysql -u root -p
Aşağıdakine benzer bir ekranla karşılaşmanız gerekecek.
Alıntı
Enter password:
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 68
Server version: 10.0.25-MariaDB-0ubuntu0.16.04.1 Ubuntu 16.04

Copyright (c) 2000, 2016, Oracle, MariaDB Corporation Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]>

MariaDB kabuğundan çıkmak için "quit" yazıp giriş tuşuna basınız.

Alıntı
MariaDB [(none)]> quit
Bye

MariaDB'nin çalışıp çalışmadığını aşağıdaki komutla kontrol edebilirsiniz.

Kod: [Seç]
sudo service mysql status


Eğer MariaDB öncesinde MySQL kurdu iseniz, önce aşağıdaki komutları sırasıyla uçbirimde çalıştırarak MySQL ile ilgili paketleri kaldırmanız gerektiğini ekleyelim.

Kod: [Seç]
sudo systemctl stop mysql
sudo apt-get --purge --auto-remove mysql-server mysql-client mysql-common
sudo apt-get autoclean
sudo rm -rf /var/lib/mysql/
sudo rm -rf /etc/mysql/




3 - PHP 7.0 Kurulumu

Aşağıdaki komutla PHP 7.0 kurulumunu gerçekleştirebilirsiniz.

Kod: [Seç]
sudo apt-get install php7.0 libapache2-mod-php7.0
Kurulum sonrasında aşağıdaki komutla apache2 servisini yeniden başlatmanız gerekecektir.

Kod: [Seç]
sudo systemctl restart apache2
Aşağıdaki komutla PHP sürümünü kontrol edebilirsiniz.

Kod: [Seç]
php -v
Aşağıdaki şekilde bir test PHP sayfası oluşturabilirsiniz. Bunun için önce aşağıdaki komutu uçbirimde çalıştırınız.

Kod: [Seç]
sudo xed /var/www/html/testphp.php
Açılan metin düzenleyiciye aşağıdaki satırları kopyalayıp yapıştırınız ve dosyayı kaydediniz.

Kod: [Seç]
<?php
phpinfo
();
?>

http://localhost/testphp.php adresini açtığınızda PHP ile ilgili bilgilerin paylaşıldığı bir sayfanın açılması gerekir.


4 - PHP için MariaDB (MySQL) Destek Paketlerinin Kurulumu

PHP7'ye için MariaDB (MySQL) desteği kazandırmak için gerekli paketleri aşağıdaki komutla kurabilirsiniz.

Kod: [Seç]
sudo apt-get install php7.0-mysql php7.0-curl php7.0-gd php7.0-intl php-pear php-imagick php7.0-imap php7.0-mcrypt php-memcache  php7.0-pspell php7.0-recode php7.0-sqlite3 php7.0-tidy php7.0-xmlrpc php7.0-xsl php7.0-mbstring php-gettext
Sonrasında apache2 servisini yeniden başlatmak gerekecektir.

Kod: [Seç]
sudo systemctl restart apache2
Sonrasında önceden oluşturduğumuz testphp.php test sayfası ile kontrol edebilirsiniz (açılan sayfada mysqli ve mysqlnd kısımlarında "enabled" yazacak).

http://localhost/testphp.php


5 - PhpMyAdmin Kurulumu (Tercihli)

Aşağıdaki komutla MariDB (MySQL) veritabanınızı yönetmenizi kolaylaştırabilecek bir web arayüzü olan phpMyAdmin uygulamasını kurabilirsiniz.

Kod: [Seç]
sudo apt-get install phpmyadmin
Kurulum sırasında sizden tercih yapmanız isteyecek bir alan gelecek. Bu ekranda yukarı ve aşağı tuşları ile apache2'yi seçmeli ve boşluk tuşuna basarak işaretlmesiniz. Sonrasında sekme (tab) tuşuna basarak "Tamam" seçeneğini seçip giriş (enter) tuşu ile kuruluma devam edeceksiniz.

Alıntı
phpmyadmin paketinin veritabanı dbconfig-common ile yapılandırılsın mı?

Kuurlum sırasında yukarıda tercih alanında "Evet" seçeneği ile devam edeceksiniz.

Alıntı
phpmyadmin paketi için MySQL uygulama parolası:

Sonraki alanda PhpMyAdmin için bir parola belirleyip kurulumu bitirebilirsiniz.

Ardından aşağıdaki komutla apache2.conf yapılandırma dosyasını açınız,

Kod: [Seç]
sudo xed /etc/apache2/apache2.conf
açılan dosyanın en altına aşağıdaki satırı ekleyip dosyayı kaydediniz,

Kod: [Seç]
Include /etc/phpmyadmin/apache.conf
aşağıdaki komutla apache2 servisini yeniden başlatınız.

Kod: [Seç]
sudo systemctl restart apache2
Artık http://localhost/phpmyadmin ile PhpMyAdmin web arayüzüne ulaşabilirsiniz. Açılan sayfada kullanıcı adı olarak root, parola olarak MariaDB kurulumunda belirlenen root parolasını gireceksiniz.

Eğer belirlediğiniz root parolası ile giriş yapamadıysanız aşağıdaki komutu uçbirimde çalıştırınız.

Kod: [Seç]
sudo mysql -u root
Sonra MariaDB kabuğunda sırasıyla aşağıdaki komutları çalıştırınız.

Kod: [Seç]
use mysql;
Kod: [Seç]
update user set plugin='' where User='root';
Kod: [Seç]
flush privileges;
Kod: [Seç]
\q
Ardından http://localhost/phpmyadmin web arayüzünü tazeleyip yeniden oturum açmayı deneyebilirsiniz.

Bu adımla birlikte Linux Mint 18.x serisi için LAMP kurulumunu tamamlamış olduk.



Bu konunun hazırlanmasında faydalanılan kaynaklar.

www.howtoforge.com
www.linode.com
www.unixmen.com

« Son Düzenleme: 03 Ağustos 2016, 16:12:14 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Abizer

  • Yeni Penguen
  • *
  • İleti: 48
  • Dağıtım: Fedora
  • Masaüstü: Cinnamon
teşekkürler peki php5 içinde çalışma yapabilirmisiniz php7 de herşey çalışmıyor bazı komutlar hata veriyor

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16907
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
PHP5 Linux Mint 18/Ubuntu 16.04 deposunda mevcut değil. Bir PPA deposu yardımıyla kurulabiliyor ama ne kadar sağlılık olur bilemem. Aşağıdaki komutlarla kurulumu denenebilir.

Linux Mint 18'e PHP 5.6 Kurulumu

Kod: [Seç]
sudo add-apt-repository ppa:ondrej/php
Kod: [Seç]
sudo apt-get update
Kod: [Seç]
sudo apt-get install php5.6 libapache2-mod-php5.6 php5.6-curl php5.6-gd php5.6-mbstring php5.6-mcrypt php5.6-mysql php5.6-xml php5.6-xmlrpc


PHP Sürümleri Arasında Geçiş

Aşağıdaki komutla PHP sürümleri arasında istemci bazında geçiş yapabilirsiniz.

Kod: [Seç]
sudo update-alternatives --config php
Komutu çalıştırdığınızda aşağıdakine benzer çıktı alacasınız, bu ekrandan varsayılan PHP sürümünün başındaki rakamı girerek seçim yapabilirsiniz..

Kod: [Seç]
php alternatifi için 2 seçenek var (/usr/bin/php sağlanıyor).

  Seçim       Yol              Öncelik   Durum
------------------------------------------------------------
* 0            /usr/bin/php7.0   70        otomatik kip
  1            /usr/bin/php5.6   56        elle ayarlanmış kip
  2            /usr/bin/php7.0   70        elle ayarlanmış kip

Mevcut seçimi[*] korumak için <enter>'a basın ya da seçiminizin numarasını girin:


Aşağıdaki şekilde Apache'nin kullanacağı PHP sürümleri arasında  geçiş yapabilirsiniz.

PHP 7.0'dan PHP 5.6'ya geçiş için aşağıdaki komutu çalıştırınız.

Kod: [Seç]
sudo a2dismod php5.6 & sudo a2enmod php7.0 & sudo service apache2 restart
PHP 5.6'dan PHP 7.0'aa geçiş için aşağıdaki komutu çalıştırınız.

Kod: [Seç]
sudo a2dismod php7.0 & sudo a2enmod php5.6 & sudo service apache2 restart
Sonrasında aşağıdaki komutla Apache servisini yeniden başlatmayı unutmayınız.

Kod: [Seç]
sudo systemctl restart apache2


Kurulum sonrasında aşağıdaki komutla sürüm kontrolü yapılabilir.

Kod: [Seç]
php -v
Kaynak
« Son Düzenleme: 06 Ağustos 2016, 23:30:46 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Abizer

  • Yeni Penguen
  • *
  • İleti: 48
  • Dağıtım: Fedora
  • Masaüstü: Cinnamon
Teşekkürler ikisi kurarak çözüm buldum daha sonra hangisi istiyorsam onu kullanıyorum.

Kod: [Seç]
    From php5.6 to php7.0 :
        Apache:
        sudo a2dismod php5.6 ; sudo a2enmod php7.0 ; sudo service apache2 restart
        CLI:
        sudo ln -sfn /usr/bin/php7.0 /etc/alternatives/php

    from php7.0 to php5.6:
        Apache:
        sudo a2dismod php7.0 ; sudo a2enmod php5.6 ; sudo service apache2 restart
        CLI:
        sudo ln -sfn /usr/bin/php5.6 /etc/alternatives/php

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16907
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
@Abizer, geri dönüş ve bilgi paylaşımı için teşekkürler. Bildiriminize istinaden PHP 5.6 kurulumu ile ilgili kısma PHP sürümleri arasında geçiş ile ilgili bilgileri de ekledim.
« Son Düzenleme: 13 Temmuz 2016, 18:42:20 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Abizer

  • Yeni Penguen
  • *
  • İleti: 48
  • Dağıtım: Fedora
  • Masaüstü: Cinnamon
klasör izinleri için bu kodları uygulayabilirsiniz.

Kod: [Seç]
sudo adduser $USER www-data
sudo chown $USER:www-data -R /var/www
sudo chmod u=rwX,g=srX,o=rX -R /var/www

Çevrimdışı HocaXD

  • Yeni Penguen
  • *
  • İleti: 46
  • Dağıtım: Linux Mint 18.1
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia Geforce 920M
  • İşlemci: İntel Core i3
Hocam ellerinize sağlık gerçekten çok yararlı, en azından benim için çok yararlı oldu ellerinize sağlık :)
Banned.

Çevrimdışı aliasikar

  • Çok Yeni Penguen
  • *
  • İleti: 13
  • TürkMvc
    • turkmvc
    • TürkMvc
  • Dağıtım: Linux/Mint 18.1 Serena
  • Masaüstü: MATE
  • Grafik Kartı: NVIDIA
  • İşlemci: İ3
edit: ben hata yapmışım kuruldu ve çalışıyor sorunsuz tşkrler
« Son Düzenleme: 27 Ocak 2017, 18:39:25 Gönderen: aliasikar »
TürkMvc

Çevrimdışı daligo5

  • Yeni Penguen
  • *
  • İleti: 47
    • http://piyonsatranc.blogspot.com
  • Dağıtım: elementary os

merhabalar ben php yi çalıştıramıyorum test sayfasını yada  phpmyadmin sayfasını açtığımda sadece php kodları çıkıyor sayfamda ne yapmalıyım

Mesajlar Birleştirildi.

 şöyle bir hata alıyorum çözemedim durumu



sudo service mysql status

Kod: [Seç]
Mar 22 07:54:40 ismail-M85M-US2H mysqld[1605]: 170322  7:54:40 [Warning] 'user' entry 'root@localhost' has both a password and an authentication plugin specified. The password
Mar 22 07:54:44 ismail-M85M-US2H mysqld[1605]: 170322  7:54:44 [Warning] 'user' entry 'root@localhost' has both a password and an authentication plugin specified. The password
« Son Düzenleme: 22 Mart 2017, 08:05:30 Gönderen: daligo5 »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16907
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Phpmyadmin kurulumunun ilerleyen bölümlerinde root parolasının yeniden ayarlanması ile ilgili bir kısım var, ilgili öneriyi uygulamayı dener misiniz?
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı daligo5

  • Yeni Penguen
  • *
  • İleti: 47
    • http://piyonsatranc.blogspot.com
  • Dağıtım: elementary os

denedim ama sonuc aynı acaba başka öneriniz var mıdır?



Kod: [Seç]
mysql.service - LSB: Start and stop the mysql database server daemon
   Loaded: loaded (/etc/init.d/mysql; bad; vendor preset: enabled)
   Active: active (running) since Çrş 2017-03-22 18:38:54 +03; 38min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1343 ExecStart=/etc/init.d/mysql start (code=exited, status=0/SUCCESS
   CGroup: /system.slice/mysql.service
           ├─1455 /bin/bash /usr/bin/mysqld_safe
           ├─1659 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plu
           └─1660 logger -t mysqld -p daemon error


Mar 22 18:38:54 ismail-M85M-US2H mysqld[1660]: 170322 18:38:54 [Note] /usr/sbin/
Mar 22 18:38:54 ismail-M85M-US2H mysqld[1660]: Version: '10.0.29-MariaDB-0ubuntu
Mar 22 18:38:54 ismail-M85M-US2H mysql[1343]:    ...done.
Mar 22 18:38:54 ismail-M85M-US2H systemd[1]: Started LSB: Start and stop the mys
Mar 22 18:38:54 ismail-M85M-US2H /etc/mysql/debian-start[1903]: /usr/bin/mysql_u
Mar 22 18:38:54 ismail-M85M-US2H /etc/mysql/debian-start[1903]: Looking for 'mys
Mar 22 18:38:54 ismail-M85M-US2H /etc/mysql/debian-start[1903]: Looking for 'mys
Mar 22 18:38:54 ismail-M85M-US2H /etc/mysql/debian-start[1903]: This installatio
Mar 22 19:16:28 ismail-M85M-US2H mysqld[1660]: 170322 19:16:28 [Warning] 'user'
Mar 22 19:16:34 ismail-M85M-US2H mysqld[1660]: 170322 19:16:34 [Warning] 'user'
lines 1-20/20 (END)...skipping...
● mysql.service - LSB: Start and stop the mysql database server daemon
   Loaded: loaded (/etc/init.d/mysql; bad; vendor preset: enabled)
   Active: active (running) since Çrş 2017-03-22 18:38:54 +03; 38min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1343 ExecStart=/etc/init.d/mysql start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/mysql.service
           ├─1455 /bin/bash /usr/bin/mysqld_safe
           ├─1659 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib/mysql/plugin --user=mysql --skip-log-error --pid-file=/var/run/mysqld/mysqld.pi
           └─1660 logger -t mysqld -p daemon error


Mar 22 18:38:54 ismail-M85M-US2H mysqld[1660]: 170322 18:38:54 [Note] /usr/sbin/mysqld: ready for connections.
Mar 22 18:38:54 ismail-M85M-US2H mysqld[1660]: Version: '10.0.29-MariaDB-0ubuntu0.16.04.1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  Ubuntu 16.04
Mar 22 18:38:54 ismail-M85M-US2H mysql[1343]:    ...done.
Mar 22 18:38:54 ismail-M85M-US2H systemd[1]: Started LSB: Start and stop the mysql database server daemon.
Mar 22 18:38:54 ismail-M85M-US2H /etc/mysql/debian-start[1903]: /usr/bin/mysql_upgrade: the '--basedir' option is always ignored
Mar 22 18:38:54 ismail-M85M-US2H /etc/mysql/debian-start[1903]: Looking for 'mysql' as: /usr/bin/mysql
Mar 22 18:38:54 ismail-M85M-US2H /etc/mysql/debian-start[1903]: Looking for 'mysqlcheck' as: /usr/bin/mysqlcheck
Mar 22 18:38:54 ismail-M85M-US2H /etc/mysql/debian-start[1903]: This installation of MySQL is already upgraded to 10.0.29-MariaDB, use --force if you still need to run mysql_up
Mar 22 19:16:28 ismail-M85M-US2H mysqld[1660]: 170322 19:16:28 [Warning] 'user' entry 'root@localhost' has both a password and an authentication plugin specified. The password
Mar 22 19:16:34 ismail-M85M-US2H mysqld[1660]: 170322 19:16:34 [Warning] 'user' entry 'root@localhost' has both a password and an authentication plugin specified. The password
~
~
~
~
~
~
~

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16907
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Aşağıdaki komutun çıtısını bakalım.

Kod: [Seç]
dpkg -l | egrep "libapache2-mod|php-gettext"
« Son Düzenleme: 24 Mart 2017, 16:28:53 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ByEfexor

  • Yeni Penguen
  • *
  • İleti: 69
  • apt-get install huzur
    • ezel.php
    • EZELinux
  • Dağıtım: Linux Mint
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia
  • İşlemci: İntel
  • RAM: 8
Hocam Merhabalar, Herşeyi sorunsuz kurdum, Fakat Phpmyadmin'kurulumunda hata ile karşılaştım, phpmyadmin paketi için MySQL uygulama parolası, belirledim ardından, yapılacak adımları sırası ile takip ettim tam sonunageldiğimde hata aldım phpmyadmin'i yeniden kur hataları yok say gibisinden bir ekran ile karşılaştım yeniden kur dedim, bu sefer parola belirlemedim  localhost/phpmyadmin'e girdim ardından root şifresiz giriş denedim
Alıntı
Yapılandırma tarafından parolasız oturum açma yasaktır (AllowNoPassword'a bakın)
hatasını aldım ardından girmiş olduğum parolayı denedim ve
Alıntı
#2002 - No such file or directory<br />Sunucu yanıt vermiyor (ya da yerel MySQL sunucusunun soketi doğru olarak yapılandırılmadı).
Şu şekilde hata aldım Phpmyadmin için yeniden Parola belirteyim dedim Terminal'e şu komutları girdim
Alıntı
sudo mysql -u root
ve Terminalde şu hatayı aldım
Alıntı
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2 "No such file or directory")
sonra Pc yeniden başlattım Phpmyadmin'i defalarca kaldırıp tekrardan kurmayu denedim fakat yine olmadı Phpmyadmin'i kaldırıp yeniden kurmaya çalıştığımda parola belirtme ekranı gelmedi, Yardımlarınızı bekliyorum

Hocam Lamp'ı tamamen kaldırdım Pc res attım bu sefer Apache vs hiç birşeyi kuramıyorum
şu şekilde bir hata alıyorum.
Alıntı
ezel ezel # apt-get install apache2
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Önerilen paketler:
  apache2-doc apache2-suexec-pristine | apache2-suexec-custom
Aşağıdaki YENİ paketler kurulacak:
  apache2
0 paket yükseltilecek, 1 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
0 B/86,7 kB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 500 kB ek disk alanı kullanılacak.
Daha önce seçili olmayan apache2 paketi seçiliyor.
(Veritabanı okunuyor ... 275745 dosya veya dizin kurulu durumda.)
Paket açılacak: .../apache2_2.4.18-2ubuntu3.1_amd64.deb ...
Paket açılıyor: apache2 (2.4.18-2ubuntu3.1) ...
Tetikleyiciler işleniyor: systemd (229-4ubuntu16) ...
Tetikleyiciler işleniyor: ureadahead (0.100.0-19) ...
Tetikleyiciler işleniyor: ufw (0.35-0ubuntu2) ...
Tetikleyiciler işleniyor: man-db (2.7.5-1) ...
Ayarlanıyor: apache2 (2.4.18-2ubuntu3.1) ...
Job for apache2.service failed because the control process exited with error code. See "systemctl status apache2.service" and "journalctl -xe" for details.
invoke-rc.d: initscript apache2, action "start" failed.
● apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2; bad; vendor preset: enabled)
  Drop-In: /lib/systemd/system/apache2.service.d
           └─apache2-systemd.conf
   Active: failed (Result: exit-code) since Prş 2017-04-06 13:42:53 +03; 4ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 19096 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

Nis 06 13:42:53 ezel apache2[19096]:  *
Nis 06 13:42:53 ezel apache2[19096]:  * The apache2 configtest failed.
Nis 06 13:42:53 ezel apache2[19096]: Output of config test was:
Nis 06 13:42:53 ezel apache2[19096]: apache2: Syntax error on line 140 of /etc/apache2/apache2.conf:...ctory
Nis 06 13:42:53 ezel apache2[19096]: Action 'configtest' failed.
Nis 06 13:42:53 ezel apache2[19096]: The Apache error log may have more information.
Nis 06 13:42:53 ezel systemd[1]: apache2.service: Control process exited, code=exited status=1
Nis 06 13:42:53 ezel systemd[1]: Failed to start LSB: Apache2 web server.
Nis 06 13:42:53 ezel systemd[1]: apache2.service: Unit entered failed state.
Nis 06 13:42:53 ezel systemd[1]: apache2.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
« Son Düzenleme: 06 Nisan 2017, 13:47:47 Gönderen: ByEfexor »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16907
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Önce aşağaıdaki komutlarla kurduğunuz tüm paketleri yapılandırma dosyaları ile kaldırmayı deneyiniz. Aşağıdaki komutda konudaki tüm paketleri kurduğunuz öngörülmüştür.

Kod: [Seç]
sudo apt-get remove --purge --autoremove apache2 mariadb-server mariadb-client php7.0 libapache2-mod-php7.0 php7.0-mysql php7.0-curl php7.0-gd php7.0-intl php-pear php-imagick php7.0-imap php7.0-mcrypt php-memcache  php7.0-pspell php7.0-recode php7.0-sqlite3 php7.0-tidy php7.0-xmlrpc php7.0-xsl php7.0-mbstring php-gettext phpmyadmin
Kod: [Seç]
sudo rm -rf /var/lib/mysql/
Kod: [Seç]
sudo rm -rf /etc/mysql/
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ByEfexor

  • Yeni Penguen
  • *
  • İleti: 69
  • apt-get install huzur
    • ezel.php
    • EZELinux
  • Dağıtım: Linux Mint
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia
  • İşlemci: İntel
  • RAM: 8
Hocam İlgilendiğiniz için teşekkür ederim, adımları uyguladım şimdi tekrardan kurulum yapayımmı, yoksa uygulamamı istediğiniz birşey varmı ?