Gönderen Konu: [Çözüldü] Tarayıcı sorunu  (Okunma sayısı 2822 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı serdar

  • Penguen
  • ***
  • İleti: 440
  • Dağıtım: linuxmint cinnamon 17.3 64 bit
  • Masaüstü: cinnamon
  • Grafik Kartı: Nvidia geforce 210
  • İşlemci: İntel i3
[Çözüldü] Tarayıcı sorunu
« : 05 Ocak 2016, 16:42:00 »
iyi akşamlar olsun,
Bu sabah Hp Cm1312 çok fonksiyonlu yazıcımı başarılı biçimde Linuxmint Cinnamon'a tanıttım ve çıktı aldım. Fakat yazıcımın tarayıcı kısmını maalesef tanıtmayı başaramadım.
İlk önce basit taramayı açtım yazıcı açıkken ardından tara'yı seçtim. Fakat "tarama başarısız oldu tarayıcıya bağlanamadı" uyarısını aldım.
Sonra xsane uygulamasını açtım. Fakat onda da "aygıt açmada hata - aygıt I/O hatası"nı aldım.
Bu durumda çok fonksiyonlu yazıcımın tarayıcısını nasıl tanıtabilirim?
« Son Düzenleme: 06 Ocak 2016, 02:24:33 Gönderen: serdar »

Çevrimdışı Danny

  • Proje Sorumlusu
  • *****
  • İleti: 2016
  • Nihilist
  • Dağıtım: Linux Mint
  • Masaüstü: Cinnamon
  • Grafik Kartı: Intel HD 620
  • İşlemci: Intel i7 - 7500U
  • RAM: 8 GB
Ynt: Tarayıcı sorunu
« Yanıtla #1 : 05 Ocak 2016, 19:59:40 »
Kod: [Seç]
sudo apt-get install hp-plugin
yukarıdaki eklenti paketini kurulmayı deneyebilirsiniz.
Gelip sağ yanağımdan öptü. Dindar değildim ama sol yanağımı da çevirmek istedim o an...

Çevrimdışı serdar

  • Penguen
  • ***
  • İleti: 440
  • Dağıtım: linuxmint cinnamon 17.3 64 bit
  • Masaüstü: cinnamon
  • Grafik Kartı: Nvidia geforce 210
  • İşlemci: İntel i3
Ynt: Tarayıcı sorunu
« Yanıtla #2 : 05 Ocak 2016, 20:49:17 »
İyi akşamlar olsun,
Danny, verdiğiniz komutu çalıştırdım. Fakat "hp-plugin paketi bulunamadı" uyarısını aldım. Bu durumda ne yapmam lazım?

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16806
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Tarayıcı sorunu
« Yanıtla #3 : 05 Ocak 2016, 20:52:59 »
Aşağıdaki komut yardımıyla eklentileri yüklemeyi deneyebilirsiniz.

Kod: [Seç]
hp-plugin
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı serdar

  • Penguen
  • ***
  • İleti: 440
  • Dağıtım: linuxmint cinnamon 17.3 64 bit
  • Masaüstü: cinnamon
  • Grafik Kartı: Nvidia geforce 210
  • İşlemci: İntel i3
Ynt: Tarayıcı sorunu
« Yanıtla #4 : 05 Ocak 2016, 20:56:02 »
İyi akşamlar olsun,
Butterfly, verdiğiniz komutu çalıştırdım ve şöyle bir çıktı elde ettim,
Kod: [Seç]
mehmet[member=1581]Mehmet[/member]-All-Series ~ $ hp-plugin

HP Linux Imaging and Printing System (ver. 3.15.2)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-15 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: HPLIP is not installed properly or is installed without graphical support. Please reinstall HPLIP
warning: Qt/PyQt 4 initialization failed.
error: hp-plugin requires GUI support (try running with --qt3). Try using interactive (-i) mode.
mehmet[member=1581]Mehmet[/member]-All-Series ~ $

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16806
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Tarayıcı sorunu
« Yanıtla #5 : 05 Ocak 2016, 21:00:22 »
Önce şağıdaki komut ile hplip-gui paketini yükleyiniz.

Kod: [Seç]
apt-get install hplip-gui
Ardından aşağıdaki komutu çalıştırmayı yeniden deneyebilirsiniz.

Kod: [Seç]
hp-plugin
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı serdar

  • Penguen
  • ***
  • İleti: 440
  • Dağıtım: linuxmint cinnamon 17.3 64 bit
  • Masaüstü: cinnamon
  • Grafik Kartı: Nvidia geforce 210
  • İşlemci: İntel i3
Ynt: Tarayıcı sorunu
« Yanıtla #6 : 05 Ocak 2016, 21:06:34 »
İyi akşamlar olsun,
Butterfly, şimdi de şöyle bir komutla karşılaştım:
Kod: [Seç]
mehmet[member=1581]Mehmet[/member]-All-Series ~ $ apt-get install hplip-gui
E: Kilit dosyası /var/lib/dpkg/lock açılamadı - open (13: Erişim engellendi)
E: Yönetim dizini (/var/lib/dpkg/) kilitlenemiyor, root kullanıcısı mısınız?
mehmet[member=1581]Mehmet[/member]-All-Series ~ $ sudo apt*get install hplip-gui
[sudo] password for mehmet:
sudo: apt*get: command not found
mehmet[member=1581]Mehmet[/member]-All-Series ~ $ sudo apt-get install hplip-qui
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
E: hplip-qui paketi bulunamadı
mehmet[member=1581]Mehmet[/member]-All-Series ~ $ hp-plugin

HP Linux Imaging and Printing System (ver. 3.15.2)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-15 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: HPLIP is not installed properly or is installed without graphical support. Please reinstall HPLIP
warning: Qt/PyQt 4 initialization failed.
error: hp-plugin requires GUI support (try running with --qt3). Try using interactive (-i) mode.
mehmet[member=1581]Mehmet[/member]-All-Series ~ $

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16806
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Tarayıcı sorunu
« Yanıtla #7 : 05 Ocak 2016, 21:22:35 »
Aşağıdaki komutu kopyalayıp yapıştırmayı dener misiniz?

Kod: [Seç]
sudo apt-get install hplip-gui
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı serdar

  • Penguen
  • ***
  • İleti: 440
  • Dağıtım: linuxmint cinnamon 17.3 64 bit
  • Masaüstü: cinnamon
  • Grafik Kartı: Nvidia geforce 210
  • İşlemci: İntel i3
Ynt: Tarayıcı sorunu
« Yanıtla #8 : 05 Ocak 2016, 21:31:15 »
iyi akşamlar olsun,
Butterfly, paketi kurdum fakat şöyle bir uyarı aldım:
Kod: [Seç]
mehmet[member=1581]Mehmet[/member]-All-Series ~ $ sudo apt-get install hplip-gui
[sudo] password for mehmet:
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Aşağıdaki ek paketler de kurulacak:
  python3-dbus.mainloop.qt python3-pyqt4 python3-sip
Önerilen paketler:
  python3-pyqt4-dbg
Tavsiye edilen paketler:
  python3-notify2
Aşağıdaki YENİ paketler kurulacak:
  hplip-gui python3-dbus.mainloop.qt python3-pyqt4 python3-sip
0 paket yükseltilecek, 4 yeni paket kurulacak, 0 paket kaldırılacak ve 5 paket yükseltilmeyecek.
3.300 kB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 14,7 MB ek disk alanı kullanılacak.
Devam etmek istiyor musunuz? [E/h] e
Alınıyor: 1 http://archive.ubuntu.com/ubuntu/ trusty/main python3-sip amd64 4.15.5-1build1 [69,3 kB]
Alınıyor: 2 http://packages.linuxmint.com/ rosa/import hplip-gui all 3.15.2-0trusty4.1 [92,9 kB]
Alınıyor: 3 http://archive.ubuntu.com/ubuntu/ trusty/main python3-pyqt4 amd64 4.10.4+dfsg-1ubuntu1 [3.121 kB]
Alınıyor: 4 http://archive.ubuntu.com/ubuntu/ trusty/main python3-dbus.mainloop.qt amd64 4.10.4+dfsg-1ubuntu1 [16,5 kB]
28 sn.'de 3.300 kB alındı (115 kB/s)                                           
Önceden seçili olmayan python3-sip paketi seçiliyor.
(Veritabanı okunuyor... mevcut 169757 dosya veya klasör yüklü.)
Açılmaya hazırlanan .../python3-sip_4.15.5-1build1_amd64.deb ...
python3-sip (4.15.5-1build1) paketi açılıyor ...
Önceden seçili olmayan python3-pyqt4 paketi seçiliyor.
Açılmaya hazırlanan .../python3-pyqt4_4.10.4+dfsg-1ubuntu1_amd64.deb ...
python3-pyqt4 (4.10.4+dfsg-1ubuntu1) paketi açılıyor ...
Önceden seçili olmayan python3-dbus.mainloop.qt paketi seçiliyor.
Açılmaya hazırlanan .../python3-dbus.mainloop.qt_4.10.4+dfsg-1ubuntu1_amd64.deb ...
python3-dbus.mainloop.qt (4.10.4+dfsg-1ubuntu1) paketi açılıyor ...
Önceden seçili olmayan hplip-gui paketi seçiliyor.
Açılmaya hazırlanan .../hplip-gui_3.15.2-0trusty4.1_all.deb ...
hplip-gui (3.15.2-0trusty4.1) paketi açılıyor ...
man-db (2.6.7.1-1ubuntu1) için tetikleyiciler işleniyor ...
gnome-menus (3.10.1-0ubuntu2) için tetikleyiciler işleniyor ...
desktop-file-utils (0.22-1ubuntu1) için tetikleyiciler işleniyor ...
mime-support (3.54ubuntu1.1) için tetikleyiciler işleniyor ...
python3-sip (4.15.5-1build1) ayarlanıyor...
python3-pyqt4 (4.10.4+dfsg-1ubuntu1) ayarlanıyor...
python3-dbus.mainloop.qt (4.10.4+dfsg-1ubuntu1) ayarlanıyor...
hplip-gui (3.15.2-0trusty4.1) ayarlanıyor...
mehmet[member=1581]Mehmet[/member]-All-Series ~ $ hp-plugin

HP Linux Imaging and Printing System (ver. 3.15.2)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-15 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


(python3:3389): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python3:3389): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
Checking for network connection...
Downloading plug-in from:
error: /home/mehmet/.hplip/hplip-3.15.2-plugin.run file does not match its checksum. File may have been corrupted or altered

Done.
mehmet[member=1581]Mehmet[/member]-All-Series ~ $

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16806
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Tarayıcı sorunu
« Yanıtla #9 : 05 Ocak 2016, 21:34:37 »
Aşağıdaki komutu uçbirimde çalıştırıp yeniden deneyiniz.

Kod: [Seç]
rm -rf ~/.hplip
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı serdar

  • Penguen
  • ***
  • İleti: 440
  • Dağıtım: linuxmint cinnamon 17.3 64 bit
  • Masaüstü: cinnamon
  • Grafik Kartı: Nvidia geforce 210
  • İşlemci: İntel i3
Ynt: Tarayıcı sorunu
« Yanıtla #10 : 05 Ocak 2016, 21:41:58 »
iyi akşamlar olsun,
Butterfly, aldığım uyarı şöyle:
Kod: [Seç]
mehmet[member=1581]Mehmet[/member]-All-Series ~ $ rm -rf ~/.hplip
mehmet[member=1581]Mehmet[/member]-All-Series ~ $

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16806
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Tarayıcı sorunu
« Yanıtla #11 : 05 Ocak 2016, 21:59:13 »
Herhangi bir hata almamışsınız. Aşağıdaki komutu çalıştırmayı yeniden deneyebilirsiniz.

Kod: [Seç]
hp-plugin
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı serdar

  • Penguen
  • ***
  • İleti: 440
  • Dağıtım: linuxmint cinnamon 17.3 64 bit
  • Masaüstü: cinnamon
  • Grafik Kartı: Nvidia geforce 210
  • İşlemci: İntel i3
Ynt: Tarayıcı sorunu
« Yanıtla #12 : 05 Ocak 2016, 22:18:33 »
İyi akşamlar olsun,
Butterfly, aldığım uyarı şöyle:
Kod: [Seç]
mehmet[member=1581]Mehmet[/member]-All-Series ~ $ hp-plugin

HP Linux Imaging and Printing System (ver. 3.15.2)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-15 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


(python3:4976): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(python3:4976): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
Checking for network connection...
Downloading plug-in from:
error: /home/mehmet/.hplip/hplip-3.15.2-plugin.run file does not match its checksum. File may have been corrupted or altered

Done.
mehmet[member=1581]Mehmet[/member]-All-Series ~ $

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16806
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Tarayıcı sorunu
« Yanıtla #13 : 05 Ocak 2016, 22:26:55 »
Aşağıdaki komutlar ile deneyiniz.

Kod: [Seç]
wget -c --no-check-certificate https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.15.2-plugin.run
Kod: [Seç]
chmod +x hplip-3.15.2-plugin.run
Kod: [Seç]
./hplip-3.15.2-plugin.run
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı serdar

  • Penguen
  • ***
  • İleti: 440
  • Dağıtım: linuxmint cinnamon 17.3 64 bit
  • Masaüstü: cinnamon
  • Grafik Kartı: Nvidia geforce 210
  • İşlemci: İntel i3
Ynt: Tarayıcı sorunu
« Yanıtla #14 : 06 Ocak 2016, 02:24:20 »
İyi geceler olsun,
Butterfly, verdiğiniz komutlarla noksan olan paketleri kurdum. sonrasında deneme belgesini taradım. Desteğiniz için teşekkür ederim.