Gönderen Konu: [Çözüldü]Mintinstall paket kurarken kapattım.  (Okunma sayısı 3344 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı dev@mehmet

  • Çaylak Penguen
  • **
  • İleti: 189
  • Dağıtım: Linux Mint 19
  • Masaüstü: Cinnamon
[Çözüldü]Mintinstall paket kurarken kapattım.
« : 21 Haziran 2014, 15:45:45 »
Mintinstall'da k3b yüklerken yanlışıkla kapatım tekrar açıp yüklemeye çalışırken "İnternet bağlantısı yok. " şeklinde bir hata verdi. Uçbirimden kurmaya çalıştığımdaysa şöyle bir hata veriyor:
Kod: [Seç]
mehmet@mehmet-G41M-Combo ~ $ sudo apt-get install k3b
[sudo] password for mehmet:
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Aşağıdaki ek paketler de kurulacak:
  cdparanoia cdrdao docbook-xsl k3b-data kate-data katepart kde-runtime
  kde-runtime-data kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools
  language-selector-common libao-common libao4 libattica0.4 libdlrestrictions1
  libflac++6 libk3b6 libkactivities6 libkatepartinterfaces4 libkcddb4
  libkcmutils4 libkcompactdisc4 libkde3support4 libkdeclarative5 libkdecore5
  libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4
  libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff3-4
  libknotifyconfig4 libkntlm4 libkparts4 libkpty4 libkrosscore4
  libktexteditor4 libkubuntu0 libkxmlrpcclient4 libmusicbrainz5-0 libnepomuk4
  libnepomukquery4a libnepomukutils4 libntrack-qt4-1 libntrack0 libphonon4
  libplasma3 libpolkit-qt-1-1 libqapt2 libqapt2-runtime libqca2
  libqt4-qt3support libsolid4 libsoprano4 libssh-4 libstreamanalyzer0
  libstreams0 libthreadweaver4 libutempter0 libxml2-utils
  ntrack-module-libnl-0 oxygen-icon-theme phonon phonon-backend-gstreamer
  phonon-backend-gstreamer-common phonon-backend-gstreamer1.0
  plasma-scriptengine-javascript shared-desktop-ontologies soprano-daemon
Önerilen paketler:
  dbtoepub docbook-xsl-doc-html docbook-xsl-doc-pdf docbook-xsl-doc-text
  docbook-xsl-doc docbook-xsl-saxon fop libsaxon-java libxalan2-java
  libxslthl-java xalan k3b-extrathemes k3b-i18n normalize-audio movixmaker-2
  kde-config-cddb libk3b6-extracodecs djvulibre-bin finger libesd0
  libesd-alsa0 hspell libqca2-plugin-cyrus-sasl libqca2-plugin-gnupg
  libqca2-plugin-ossl phonon-backend-vlc phonon4qt5-backend-gstreamer
Tavsiye edilen paketler:
  vcdimager virtuoso-minimal kubuntu-debug-installer nepomuk-core-runtime
  libkactivities-bin
Aşağıdaki YENİ paketler kurulacak:
  cdparanoia cdrdao docbook-xsl k3b k3b-data kate-data katepart kde-runtime
  kde-runtime-data kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools
  language-selector-common libao-common libao4 libattica0.4 libdlrestrictions1
  libflac++6 libk3b6 libkactivities6 libkatepartinterfaces4 libkcddb4
  libkcmutils4 libkcompactdisc4 libkde3support4 libkdeclarative5 libkdecore5
  libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4
  libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff3-4
  libknotifyconfig4 libkntlm4 libkparts4 libkpty4 libkrosscore4
  libktexteditor4 libkubuntu0 libkxmlrpcclient4 libmusicbrainz5-0 libnepomuk4
  libnepomukquery4a libnepomukutils4 libntrack-qt4-1 libntrack0 libphonon4
  libplasma3 libpolkit-qt-1-1 libqapt2 libqapt2-runtime libqca2
  libqt4-qt3support libsolid4 libsoprano4 libssh-4 libstreamanalyzer0
  libstreams0 libthreadweaver4 libutempter0 libxml2-utils
  ntrack-module-libnl-0 oxygen-icon-theme phonon phonon-backend-gstreamer
  phonon-backend-gstreamer-common phonon-backend-gstreamer1.0
  plasma-scriptengine-javascript shared-desktop-ontologies soprano-daemon
0 paket yükseltilecek, 78 yeni paket kurulacak, 0 paket kaldırılacak ve 21 paket yükseltilmeyecek.
E: /var/cache/apt/archives/lock kilidi alınamadı - open (11: Özkaynak geçici olarak kullanılamaz durumda)
E: /var/cache/apt/archives/ dizini kilitlenemiyor

Ve bir pencere açılıp "İnternet bağlantısı yok" Hatası da veriyor.
« Son Düzenleme: 21 Haziran 2014, 15:59:20 Gönderen: metrekup »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16602
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: Mintinstall paket kurarken kapattım.
« Yanıtla #1 : 21 Haziran 2014, 15:53:16 »
Aşağıdaki komutları sırasıyla uçbirimde çalıştırmayı dener misiniz?

Kod: [Seç]
sudo rm -rf /var/lib/apt/lists/lock
sudo rm -rf /var/lib/dpkg/lock
sudo rm -rf /var/cache/apt/archives/lock
sudo apt-get install -f
sudo dpkg --configure -a

Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı dev@mehmet

  • Çaylak Penguen
  • **
  • İleti: 189
  • Dağıtım: Linux Mint 19
  • Masaüstü: Cinnamon
Ynt: Mintinstall paket kurarken kapattım.
« Yanıtla #2 : 21 Haziran 2014, 15:59:07 »
Teşekkürler Butterfly,
Sorunum çözüldü k3b'yi yükledim.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 16602
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19.1 & LMDE 3
  • Masaüstü: Cinnamon 4.0 & Mate 1.20
Ynt: [Çözüldü]Mintinstall paket kurarken kapattım.
« Yanıtla #3 : 21 Haziran 2014, 16:02:38 »
Rica ederiz. Siz Yazılım Yöneticisini elle kapattığınızda, DPKG paket yöneticisinin başka bir uygulama tarafından kullanılmasını engelleyen lock dosyaları silinmezler. Bu sebeple yine aynı paket yöneticisini kullanan apt'yi kullananamaış oldunuz. İlgili dosyaları silince ve devamındaki komutlar ile paket bağımlılıklarını düzeltince sorun çözülmüş oldu.


Sorun çözüldüğü için konu kilitlendi.
Elimizden geldiğince dilimizin döndüğünce...