Gönderen Konu: [Nasıl] Linux Mint 18.x LAMP (Linux + Apache + MariaDB + Php) Sunucu Kurulumu  (Okunma sayısı 3897 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13069
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.2 & LMDE 2
  • Masaüstü: Cinnamon 3.4 & Mate 1.18
Şimdi konuda anlatıldığı biçimde yeniden kurulum deneyebilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı ByEfexor

  • Çok Yeni Penguen
  • *
  • İleti: 11
  • Dağıtım: Linux Mint
  • Masaüstü: Linux Mint
  • Grafik Kartı: Nvidia
  • İşlemci: İntel
Hocam çok teşekkür ediyorum, sorunum çözüldü :)

Çevrimdışı thork

  • Yeni Penguen
  • *
  • İleti: 21
  • Dağıtım: Linux Mint 18.1
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia
  • İşlemci: İntel
Çok teşekkür ederim. Ellerinize sağlık yazınız çok yardımcı oldu.

Her şey çok güzel yükledim ve çalışır durumda.  Wordpress'i denemek için kurmak istedim ama burada tam da klasör izinlerinde sorunum var anladığım kadarı ile. 
Kod: [Seç]
sudo adduser $USER www-data
sudo chown $USER:www-data -R /var/www
sudo chmod u=rwX,g=srX,o=rX -R /var/www

Yukarıda verdiğiniz kodu kullandım ama yine wordpressden "Üzgünüm fakat wp-config.php dosyasına yazamıyorum." hatası alıyorum.
hala web üzerinden gerekli izinler yok.

Kod: [Seç]
cd /var/www/html
ls -l

kodunun çıktısı su şekilde

Kod: [Seç]
-rw-r-Sr--  1 thorque www-data   418 Eyl 25  2013 index.php
-rw-r-Sr--  1 thorque www-data 19935 Mar  6 22:35 license.txt
-rw-r-Sr--  1 thorque www-data 10273 Mar  6 22:36 readme.html
-rw-r-Sr--  1 thorque www-data  5447 Eyl 28  2016 wp-activate.php
drwxr-sr-x  9 thorque www-data  4096 Nis 13 19:46 wp-admin
-rw-r-Sr--  1 thorque www-data   364 Ara 19  2015 wp-blog-header.php
-rw-r-Sr--  1 thorque www-data  1627 Ağu 29  2016 wp-comments-post.php
-rw-r-Sr--  1 thorque www-data  3133 Mar  6 22:36 wp-config-sample.php
drwxr-sr-x  5 thorque www-data  4096 Nis 13 19:46 wp-content
-rw-r-Sr--  1 thorque www-data  3286 May 24  2015 wp-cron.php
drwxr-sr-x 18 thorque www-data 12288 Nis 13 19:46 wp-includes
-rw-r-Sr--  1 thorque www-data  2422 Kas 21 05:46 wp-links-opml.php
-rw-r-Sr--  1 thorque www-data  3301 Eki 25 06:15 wp-load.php
-rw-r-Sr--  1 thorque www-data 33939 Kas 21 05:46 wp-login.php
-rw-r-Sr--  1 thorque www-data  8048 Oca 11 08:15 wp-mail.php
-rw-r-Sr--  1 thorque www-data 16250 Kas 29 08:39 wp-settings.php
-rw-r-Sr--  1 thorque www-data 29896 Eki 19 07:47 wp-signup.php
-rw-r-Sr--  1 thorque www-data  4513 Eki 14 22:39 wp-trackback.php
-rw-r-Sr--  1 thorque www-data  3065 Ağu 31  2016 xmlrpc.php

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13069
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.2 & LMDE 2
  • Masaüstü: Cinnamon 3.4 & Mate 1.18
Kullanıcıyı www-data grubuna ekledikten sonra sistemi yeniden başlattınız mı?
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı thork

  • Yeni Penguen
  • *
  • İleti: 21
  • Dağıtım: Linux Mint 18.1
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia
  • İşlemci: İntel
Bilgisayarı yeniden başlattım. Yine durum aynı

A0001 cihazımdan Tapatalk kullanılarak gönderildi

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13069
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.2 & LMDE 2
  • Masaüstü: Cinnamon 3.4 & Mate 1.18
Dosyayı elle oluşturmayı deneyebilirsiniz.

Kod: [Seç]
sudo xed /var/www/html/wp-config.php
Açılan dosya içine gerekli satırları yapıştırın ve kaydetmeyi deneyin.

Ya da aşağıdaki komutla wp-config-sample.php dosyasını wp-config.php olarak kopyalamayı deneyin.

Kod: [Seç]
sudo cp /var/www/html/wp-config-sample.php /var/www/html/wp-config.php
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı thork

  • Yeni Penguen
  • *
  • İleti: 21
  • Dağıtım: Linux Mint 18.1
  • Masaüstü: Cinnamon
  • Grafik Kartı: Nvidia
  • İşlemci: İntel
Onu zaten yaptım ama bu gerçek bir çözüm olmuyor. Wordpress eklentileri wordpress üzerinden yüklemek istediğimde dosya yazma sorunundan dolayı ftp bilgisi istiyor.

Söylemek istediğim wordpress, dosyaya yazmak istediğinde izinler doğru ayarlı olmadığı için problem yaşıyorum.

A0001 cihazımdan Tapatalk kullanılarak gönderildi


Mesajlar Birleştirildi.
https://askubuntu.com/a/635542
Sorumun çözümünü yukarıdaki linkde buldum. "/var/www/" Klasörünün sahibi de  grubu da "www-data"  kullanıcısı olması gerekiyormuş.
Aşağıdaki kodu terminalde çalıştırınca sorunum çözüldü.
Kod: [Seç]
sudo chown -R www-data:www-data /var/www
« Son Düzenleme: 14 Nisan 2017, 00:19:46 Gönderen: thork »

Çevrimdışı Baturhan

  • Çok Yeni Penguen
  • *
  • İleti: 4
  • Dağıtım: linux mint v18 Sarah
  • Masaüstü: Cinnamon
  • Grafik Kartı: mvidia gtx950m
  • İşlemci: i5
merhaba bu sorunum için yardımcı olabilir misiniz ? Yeni kullanmaya başladım mint'ı ve php üzerinde geliştirme yapmak istiyorum php kurulumunda bu adımda hata aldım.
https://i.hizliresim.com/okWmro.png

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13069
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.2 & LMDE 2
  • Masaüstü: Cinnamon 3.4 & Mate 1.18
Lütfen ilgili hatayı kopyalayıp foruma aktarır mısınız? Uçbirimdeki tüm kısmı seçip, kod etiketi içinde foruma kopyalayacaksınız.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Baturhan

  • Çok Yeni Penguen
  • *
  • İleti: 4
  • Dağıtım: linux mint v18 Sarah
  • Masaüstü: Cinnamon
  • Grafik Kartı: mvidia gtx950m
  • İşlemci: i5
tekrar kurmaya çalıştığımda veya sudo dpkg --configure -a yazdığımda bu hata geliyor
Kod: [Seç]
Paket yapılandırması                                                           
                                                                               
 ┌──────────────────────┤ phpmyadmin yapılandırılıyor ├──────────────────────┐ 
 │                                                                           │ 
 │ error in future versions ERROR 2002 (HY000): Can't connect to local         
 │ MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)               
 │                                                                             
 │ Seçenekleriniz:                                                             
 │  * vazgeç - İşlemin başarısız olmasına neden olacak; bu paketin sürümünü     
 │    düşürmeniz, yeniden kurmanız veya yapılandırmanız ya da kullanmayı       
 │    sürdürmeden önce elle müdahele etmeniz gerekecektir. Bu genellikle,       
 │    kurulum hatalarını çözmedikçe, sizin başka paketleri kurmanızı da         
 │    engelleyecektir.                                                         
 │  * yeniden dene - Tüm yapılandırma seçeneklerini (debconf öncelik           
 │    seçeneğinize bağlı olarak kaçırmış olduğunuz seçenekler ile birlikte)     
 │    tekrar sorar ve işlemi tamamlamak için bir girişimde daha bulunur.       
 │  * yeniden dene (soruları atla) - Soruları sormadan işlemi yeniden           
 │ dener.                                                                       
 │                                                                             
 │                                  <Tamam>                                     
 │                                                                           │ 
 └───────────────────────────────────────────────────────────────────────────┘ 
                                                                               
                                                                               
« Son Düzenleme: 09 Ağustos 2017, 17:18:05 Gönderen: Baturhan »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13069
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.2 & LMDE 2
  • Masaüstü: Cinnamon 3.4 & Mate 1.18
Buradaki komutlarla, konuda anlatıldığı biçimde kurduğunuz tüm paketleri kaldırıp, ardından konuda anlatıldığı biçimde yeniden kurulum yapmayı dener misiniz?



Eğer sorun çözülmezse buradaki öneriyi deneyebiliriz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Baturhan

  • Çok Yeni Penguen
  • *
  • İleti: 4
  • Dağıtım: linux mint v18 Sarah
  • Masaüstü: Cinnamon
  • Grafik Kartı: mvidia gtx950m
  • İşlemci: i5
Merhaba , dediklerinizi yaptım. şu an çalışır halde teşekkür ederim. fakat roota şifresiz girişi disabled yapmışım sanırım roota erişemiyoum, şifre de atamamıştım. şu an onla uğraşıyorum

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13069
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.2 & LMDE 2
  • Masaüstü: Cinnamon 3.4 & Mate 1.18
Phpmyadmin kurulumunun devamında, root parolası ile sorun yaşandığındayapılması gerkenler anlatılıyor. Bu öneriyi uygulamayı dneeyebilirsiniz.

https://forum.linuxmint.net.tr/index.php?topic=6282.0#post_phpmyadmin
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı Muhammed Ali

  • Çaylak Penguen
  • **
  • İleti: 160
  • Dağıtım: Linux mint 17.3
  • Masaüstü: Cinnamon
İyi günler, kurulumu sorunsuzca tamamladım. Sadece phpmyadmin sayfasında girişi yapamadım. Aşağıdaki anlatımı da uyguladım ama hala giriş yapamıyorum. Ne yapmalıyım?



Eğer belirlediğiniz root parolası ile giriş yapamadıysanız aşağıdaki komutu uçbirimde çalıştırınız.

Kod: [Seç]
sudo mysql -u root

Sonra MariaDB kabuğunda sırasıyla aşağıdaki komutları çalıştırınız.

Kod: [Seç]
use mysql;
Kod: [Seç]
update user set plugin='' where User='root';
Kod: [Seç]
flush privileges;
Kod: [Seç]
\q

Ardından http://localhost/phpmyadmin web arayüzünü tazeleyip yeniden oturum açmayı deneyebilirsiniz.



Kırmızı bir kutucuk içinde " #1045 - Access denied for user 'root'@'localhost' (using password: YES) " şeklinde bir hata beliriyor.
« Son Düzenleme: Bugün, 17:02:25 Gönderen: Muhammed Ali »

Çevrimdışı Genizcil_N

  • Forum Yöneticisi
  • *****
  • İleti: 1939
  • Dağıtım: Linux Mint 18.2
  • Masaüstü: Mate
@Muhammed Ali
Aşağıdaki komutla MySQL'i yeniden yapılandırmayı deneyebilirsiniz:
Kod: [Seç]
sudo dpkg-reconfigure mysql-server-5.7