Gönderen Konu: Türkçe karakterler bozuk  (Okunma sayısı 736 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı karaca911

  • Yeni Penguen
  • *
  • İleti: 71
  • Dağıtım: mint18
  • Masaüstü: Cinnamon
  • Grafik Kartı: geforce 630
  • İşlemci: i3
Türkçe karakterler bozuk
« : 29 Aralık 2017, 14:00:45 »
İndirdiğim "srt" uzantılı altyazı dosyasını metin düzenleyici ile açtım ama Türkçe karakterlerin bazıları bozuk, forumlarda önerilen  "hunspell-tr_1.0_all.deb" paketini kurdum ama bir şey değişmedi. Belgenin, araçlar, dili ayarla bölümünde Türkçe seçeneği var ama bu da işe yaramıyor, teşekkürler.
« Son Düzenleme: 29 Aralık 2017, 14:50:22 Gönderen: karaca911 »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 15757
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 3
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Türkçe karakterler bozuk
« Yanıtla #1 : 29 Aralık 2017, 15:27:03 »
Aşağıdaki komutla dconf-editor paketini yükleyin.

Kod: [Seç]
sudo apt-get install dconf-editor
Menüden aratıp aracı açın.

Sırasıyla aşağıdaki anahtarları açarak "auto_detected" değişkenine ulaşınız.

org => x => editor => preferences => encodings => auto_detected

auto_detected değişkeni üzerine çift tıklayınız, açılan alanı aşağıdaki şekilde değiştirmeyi deneyiniz.

Kod: [Seç]
['UTF-8', 'CURRENT', 'ISO-8859-15', 'UTF-16', 'windows-1254']
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı karaca911

  • Yeni Penguen
  • *
  • İleti: 71
  • Dağıtım: mint18
  • Masaüstü: Cinnamon
  • Grafik Kartı: geforce 630
  • İşlemci: i3
Ynt: Türkçe karakterler bozuk
« Yanıtla #2 : 29 Aralık 2017, 15:51:31 »
Yaptım, ama bir şey değişmedi.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 15757
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 3
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Türkçe karakterler bozuk
« Yanıtla #3 : 29 Aralık 2017, 15:53:13 »
Oturmu kapatıp açmayı dener misiniz?
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı karaca911

  • Yeni Penguen
  • *
  • İleti: 71
  • Dağıtım: mint18
  • Masaüstü: Cinnamon
  • Grafik Kartı: geforce 630
  • İşlemci: i3
Ynt: Türkçe karakterler bozuk
« Yanıtla #4 : 29 Aralık 2017, 16:10:31 »
Olmadı,  yanlız editör seçeneği sonrası "preferences" yok, "auto-detected-enconding" seçeneği var, onu değiştirdim. Yanlış mı yaptım acaba?
« Son Düzenleme: 29 Aralık 2017, 16:12:39 Gönderen: karaca911 »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 15757
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 3
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Türkçe karakterler bozuk
« Yanıtla #5 : 29 Aralık 2017, 16:20:10 »
Hayır, auto-detected seçeneğini düzenlemelisiniz, aşağıdaki resimdeki gibi...

Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı karaca911

  • Yeni Penguen
  • *
  • İleti: 71
  • Dağıtım: mint18
  • Masaüstü: Cinnamon
  • Grafik Kartı: geforce 630
  • İşlemci: i3
Ynt: Türkçe karakterler bozuk
« Yanıtla #6 : 29 Aralık 2017, 16:51:38 »
Bu seçeneği ben bulamadım, 60 yaşında linux kullanmak bu kadar oluyor, ben vazgeçtim kardeş sabrın için teşekkürler.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 15757
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 3
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Türkçe karakterler bozuk
« Yanıtla #7 : 29 Aralık 2017, 17:23:32 »
Aşağıdaki komutla dconf-cli paketini yükleyip,

Kod: [Seç]
sudo apt-get install dconf-cli
ardından aşağıdaki komutu uçbirimde çalıştırarak aynı ayarı yapabilirsiniz.

Kod: [Seç]
gsettings set org.x.editor.preferences.encodings auto-detected "['UTF-8', 'CURRENT', 'ISO-8859-15', 'UTF-16', 'windows-1254']"
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı karaca911

  • Yeni Penguen
  • *
  • İleti: 71
  • Dağıtım: mint18
  • Masaüstü: Cinnamon
  • Grafik Kartı: geforce 630
  • İşlemci: i3
Ynt: Türkçe karakterler bozuk
« Yanıtla #8 : 30 Aralık 2017, 10:53:51 »
 "dconf-cli zaten en yeni sürümde" diyor, sonrasında "gsettings set org.x.editor.preferences.encodings auto-detected "['UTF-8', 'CURRENT', 'ISO-8859-15', 'UTF-16', 'windows-1254']''  'org.x.editor.preferences.encodings' gibi bir şema yok" diyor.


Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 15757
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 3
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Türkçe karakterler bozuk
« Yanıtla #9 : 30 Aralık 2017, 13:52:02 »
@karaca911 , aşağıdaki komutları çıktısını paylaşır mısınız?

Kod: [Seç]
inxi -S
cat /etc/gnome/defaults.list | grep text/plain
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı karaca911

  • Yeni Penguen
  • *
  • İleti: 71
  • Dağıtım: mint18
  • Masaüstü: Cinnamon
  • Grafik Kartı: geforce 630
  • İşlemci: i3
Ynt: Türkçe karakterler bozuk
« Yanıtla #10 : 30 Aralık 2017, 13:56:29 »
Kod: [Seç]
mzy@mzy-P61-USB3-B3 ~ $ inxi -S
System:    Host: mzy-P61-USB3-B3 Kernel: 4.4.0-21-generic x86_64 (64 bit)
           Desktop: Cinnamon 3.0.7  Distro: Linux Mint 18 Sarah
mzy@mzy-P61-USB3-B3 ~ $ cat /etc/gnome/defaults.list | grep text/plain
text/plain=xed.desktop;gedit.desktop;pluma.desktop
mzy@mzy-P61-USB3-B3 ~ $
« Son Düzenleme: 30 Aralık 2017, 14:22:26 Gönderen: karaca911 »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 15757
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 3
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Türkçe karakterler bozuk
« Yanıtla #11 : 30 Aralık 2017, 22:42:05 »
İlgili ayar Linux Mint 18'de farklı olabilir, dilerseniz Linux Mint 18.3'e yükseltme yaparak yukarıdaki öneriyi uygulamayı deneyebilirsiniz. Dilerseniz Linux Mint 18'i bir ara kurup ilgili ayarı bulup uyarlayabilirim.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı karaca911

  • Yeni Penguen
  • *
  • İleti: 71
  • Dağıtım: mint18
  • Masaüstü: Cinnamon
  • Grafik Kartı: geforce 630
  • İşlemci: i3
Ynt: Türkçe karakterler bozuk
« Yanıtla #12 : 31 Aralık 2017, 13:06:05 »
Anladım, zahmet verdik, teşekkürler.
« Son Düzenleme: 31 Aralık 2017, 13:22:41 Gönderen: karaca911 »