Gönderen Konu: [Nasıl] Linux Mint 18 - Intel + Nvidia Hibrit GPU İçin Bumblebee Kurulumu  (Okunma sayısı 18340 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13509
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18

Bu konudaki anlatım Linux Mint 18 sürüm içindir.

Linux Mint 17 ve öncesi için aşağıdaki bağlantıdaki anlatımı uygulayınız.

https://forum.linuxmint.net.tr/index.php?topic=78.0

Yeni nesil taşınabilir sistemlerde Nvidia ekran kartıyla birlikte entegre Intel ekran kartı da bulunabiliyor. Nvidia'nın Optimus ismini verdiği teknoloji ile yüksek GPU gücüne ihtiyaç duymayan uygulamalarda Nvidia ekran kartı devreye girmeyerek Intel GPU kullanılıyor. Böylece daha az güç harcayan GPU sayesinde daha uzun süre pil kullanamı ve daha az ısınma olması hedeflenmiş.

Linux tarafında henüz bu teknoloji için Nvidia tarafından resmi destek gelmedi. Ama Bumblebee isimli açık kaynak projesi olan uygulama Intel ve Nvidia kartlar arasında geçiş yapılması sağlanabiliyor ve açık bir nebze de olsa giderilmiş durumda.

Sizin sisteminizin Optimus teknolojisine sahip olup olmadığını aşağıdaki komutu uçbirimde çalıştırarak sorgulayabilirsiniz.

Kod: [Seç]
lspci | egrep 'VGA|3D|Display'
Yukarıdaki komutu uçbirimde çalıştırdığınızda aşağıdakine benzer bir çıktı alıyorsanız, sizin de sisteminizde Intel + Nvidia Optimus ekran kartı mevcut demektir. Sisteminizdeki ısınma ve fan sorunlarının temel nedenlerinden biri de budur.

Kod: [Seç]
00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation GK106M [GeForce GTX 765M] (rev a1)

Linux dağıtımlarında Bumblebee isimli açık kaynak projesi olan uygulama ile sistemin geneli Intel GPU kullandığı halde, istenen uygulamanın Nvidia GPU ile işlem yapması sağlanabiliyor.

Aşağıdaki şekilde komutları sırasıyla uçbirimde çalıştırarak Bumblebee uygulamasını kurabilirsiniz.


1 - Kurulum

Linux Mint 18.x LTS İçin

Linux Mint 18 sürüme kurulum için aşağıdaki komutları sırasıyla uçbirimde çalıştırınız.

Kod: [Seç]
sudo add-apt-repository ppa:bumblebee/testing -y
sudo add-apt-repository ppa:graphics-drivers/ppa -y
sudo apt-get update
sudo apt-get install bumblebee nvidia-381 nvidia-settings bumblebee-nvidia primus virtualgl linux-headers-$(uname -r) -y

64 bit sistemler için aşağıdaki komut ile Primus için 32 bit uyumluluk paketini kurmanızı da öneririz.

Kod: [Seç]
sudo apt-get install primus-libs-ia32

2 - Kurulum Sonrası Yapılandırma

Şimdi bir kaç ufak düzenleme yapılması gerekecek. Kurulum sonrası aşağıdaki komut ile bumblebee.conf dosyasını açınız.

Kod: [Seç]
sudo xed /etc/bumblebee/bumblebee.conf
Açılan dosyada aşağıdaki satırları bulunuz,

Kod: [Seç]
# (See also the driver-specific sections below)
Driver=


# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-current


# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-current:/usr/lib32/nvidia-current


# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules

ve aşağıdaki şekilde değiştirip dosyayı kaydediniz.

Kod: [Seç]
# (See also the driver-specific sections below)
Driver=nvidia


# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-381


# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-381:/usr/lib32/nvidia-381


# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-381/xorg,/usr/lib/xorg/modules


Bumblebee.conf dosyasında düzenleme yaptıktan sonra varsayılan GL sağlayıcısı için değişiklik yapılması gerekiyor. Bunun için aşağıdaki komutları sırasıyla uçbirimde çalıştırınız.

Kod: [Seç]
sudo update-alternatives --set i386-linux-gnu_gl_conf /usr/lib/i386-linux-gnu/mesa/ld.so.conf
Kod: [Seç]
sudo update-alternatives --set x86_64-linux-gnu_egl_conf /usr/lib/x86_64-linux-gnu/mesa-egl/ld.so.conf
Kod: [Seç]
sudo update-alternatives --set x86_64-linux-gnu_gl_conf /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf
Nvidia-381 sürücüsünün başlangıçta etkinleşmemesi için, aşağıdaki komutu uçbirimde çalıştırarak sürücüyü karalisteye alınız.

Kod: [Seç]
echo -e '# 381\nblacklist nvidia-381\nblacklist nvidia-381-updates\nblacklist nvidia-experimental-381' | sudo tee -a /etc/modprobe.d/bumblebee.conf

3 - Grub Dosyasında Düzenleme

Linux Mint 18 ile gelen gpumanager yazılımı Nvidia sürücüsü kurulduğunda otomatik olarak xorg.conf dosyası oluşturmaya çalışıyor, bu durum Bumblebee kuruduğunuzdada gerçekleşiyor. Bu sebeple aşağıdaki şekilde grub ayar dosyasında güncelleme yaparak bunu enegellememiz gerekecek.

Bunun için aşağıdaki komutla grub varsayılan dosyasını açınız.

Kod: [Seç]
sudo xed /etc/default/grub
Açılan dosyada aşağıdaki satırı bulup,

Kod: [Seç]
GRUB_CMDLINE_LINUX=""
aşağıdaki şekilde değiştiriniz ve dosyayı kaydediniz.

Kod: [Seç]
GRUB_CMDLINE_LINUX="nogpumanager"
Ardından aşağıdaki komutla grub ayar dosyasını güncelleyiniz ve sistemi yeniden başlatmayı deneyiniz.

Kod: [Seç]
sudo update-grub
Bu düzenlemeler sonrasında sisteminizi yeniden başlatınız.

Cinnamon masaüstünü kullananlar için not: Bu aşamada sisteminizi yeniden başlattığınızda 3D hızlandırma etkin olmayacağı için Cinnamon masaüstü ile ilgili çökme bildirimi alabilirsiniz. Bu durumda masaüstüne sağ tıklayıp "Burada uçbirimi aç" seçeneği ile uçbirime ulaşıp aşağıdaki adımlarla kurulum adımlarına devam ediniz, aşağıdaki adımları uygulayıp sistemi yeniden başlattıktan sonra sorun kalmayacaktır.


4 - Yeniden İnşa

Sisteminizi yeniden başlattıktan sonra bbswitch-dkms ve nvidia-381 paketlerinin yeniden yapılandırılmasını sağlamasınız.

Aşağıdaki komutla bbswitch-dkms paketini yeniden yapılandırınız.

Kod: [Seç]
sudo dpkg-reconfigure bbswitch-dkms
Aşağıdaki komutla nvidia-381 sürücüsünü yeniden yapılandırınız.

Kod: [Seç]
sudo dpkg-reconfigure nvidia-381
Bu işlemler sonrasında sisteminizi yeniden başatınız. Sisteminizi yeniden başlattıktan sonra aşağıdaki komutla Bumblebee'nin doğru çalışmasını kontrol edebilirsiniz.

Normal kullanım için aşağıdaki komutu çalıştırınız.

Kod: [Seç]
glxgears
Nvidia GPU ile kullanım için aşağıdaki komutu çalıştırınız.

Kod: [Seç]
optirun glxgears
Komutun çıktısında dönen çarklar görüyorsanız Bumblebee başarıyla çalışıyor demektir.


Kaynak


5 - Bumblebee Kullanımı

Bir uygulamayı Nvidia ekran kartı ile çalıştırmak için aşağıdaki şekilde uçbirimi kullanabilirsiniz.

Kod: [Seç]
optirun uygulama_adı
Örneğin Firefox'u Nvidia ekran kartı ile çalıştıracaksanız komutu aşağıdaki şekilde düzenlemelisiniz.

Kod: [Seç]
optirun firefox
Ya da uçbirimle hiç uğraşmazsınız, aşağıdaki komutları sırasıyla uçbirimde çalıştırarak bumblebee-ui uygulamasını yükleyip, elle optirun komutu girmekten kurtulabilirsiniz. İstediğiniz uygulamaları GUI (Grafik Arayüz) kullanarak Nvidia ekran kartı ile çalışmasını sağlayabilirsiniz.

Kod: [Seç]
sudo apt-get install python-appindicator
wget -c --no-check-certificate https://www.dropbox.com/s/c7mxeekoz66w4on/bumblebee-ui.tar.gz
tar -xzvf bumblebee-ui.tar.gz
cd bumblebee-ui
chmod +x ./INSTALL
sudo ./INSTALL

Kurulumdan uygulamayı menüden aratarak bulup çalıştırabilirsiniz.
Ya da kontrol amaçlı bir uygulamacığın başlangıçda devreye girmesini sağlayabilirsiniz.
Bunun için menüden Başlangıç Uygulamalarını bulup açınız.
Açılan Başlangıç Uygulamalarında Ekle düğmesine basınız ve aşağıdaki düzenlemeyi yapıp kaydediniz.


İsim : Bumblebee-ui
Komut : /usr/local/bin/bumblebee-indicator

Böylece başlangıç sırasında bumblebee-ui isimli uygulamayı kontol edebileceğiniz küçük bir uygulamacık sistem çekmesinde açılarak kontrolünüzü kolaylaştıracaktır.





Bumblebee kurulumu sonrası her şeyin yolunda gittiğini aşağıdaki komut ile anlamak mümkün. Hatalı olan bir ayar varsa komutun çıktısı uyarı mesajı verecektir.

Kod: [Seç]
optirun glxgears
Başarılı bir kurulumun çıktıları aşağıdaki gibi olacaktır.

Kod: [Seç]
optirun glxgears
4686 frames in 5.


6 - Sorunlar Hakkında

Hatalı bir şeylerin olduğunu düşünüyorsanız lütfen aşağıdaki komutları sırasıyla uçbirimde çalıştırıp çıktılarını paylaşınız.

Kod: [Seç]
optirun -vvv glxgears
cat /etc/bumblebee/bumblebee.conf
cat /etc/bumblebee/xorg.conf.nvidia
cat /etc/modprobe.d/bumblebee.conf
cat /etc/X11/xorg.conf
dpkg -l | egrep 'nvidia|bumblebee|primus|prime|virtualgl'
lspci | egrep 'VGA|3D|Display'
cat /proc/cmdline



7 - Bumblebee Kaldırma

Bumblebee ile ilgili paketleri sistemden kaldırmak için aşağıdaki komutları sırasıyla uçbirimde çalıştırınız.

Kod: [Seç]
sudo apt-get purge bumblebee* nvidia* bbswitch* primus* virtualgl*
Aşağıdaki komutlarla Bumblebee kurulumu için eklediğiniz depoları kaldırınız. (Not: Bumblebee'yi yeniden kuracaksanız bu depoları kaldırmanıza gerek yok.)

Kod: [Seç]
sudo rm -f /etc/apt/sources.list.d/bumblebee*
sudo rm -f /etc/apt/sources.list.d/graphics-drivers*
sudo apt-get update

Bumblebee ve Nvidia sürücüsü ile ilgili paketleri kaldırdıktan sonra buradaki Grub önyükleyici ile ilgili düzenlemeyi geri almanız gerekmektedir. Grub önyükleyici ile ilgili düzenlemeyi geri aldıktan sonra aşağıdaki komutla grub ayar dosyasını güncellemelisiniz. (Not : Bumblebee'yi yeniden kuracaksanız Grub dosyası ile ilgili düzenlemeyi geri almanıza gerek yok.)

Kod: [Seç]
sudo update-grub
« Son Düzenleme: 07 Ekim 2017, 16:35:28 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı natre

  • Çok Yeni Penguen
  • *
  • İleti: 4
    • ettunc92
    • ettunc
  • Dağıtım: Linux Mint 18 Sarah
  • Masaüstü: Cinnamon
  • Grafik Kartı: GeForce GT525M
  • İşlemci: i5 2430M
Daha önceden yüklediğim Nvidia kapalı kaynak sürücülerini belirttiğiniz komutlarla kaldırmama rağmen,

Kod: [Seç]
sudo add-apt-repository ppa:bumblebee/stable
komutu sonrası,

Kod: [Seç]
"Bu PPA'nin xenial destegi yok"
PPA eklenemiyor: '"Bu PPA'nin xenial destegi yok"'.

şeklinde çıktı veriyor. Bu sorun sonraki aşamalara da sirayet ediyor ki sanırım, örneğin bumblebee.conf dosyası bende boş geliyor. Bu sorunu nasıl çözebiliriz?

Ayrıca kapalı kaynak sürücüleri kullanmamızın ne gibi bir zararı var? Ben Linux Mint'in kendi sürücü yöneticisi ile kurduğum kapalı kaynaklı sürücüden memnundum. Sağ alta gelen uygulama sayesinde rahatlıkla ekran kartları arasında geçiş yapabiliyorduk.

Çevrimdışı tux5

  • Yeni Penguen
  • *
  • İleti: 41
  • Dağıtım: Linux Mint 18 Cinnamon 64 Bit
Bu sefer bunları uyguladığımda sorun çözüldü.Çok sağolun.Artık glxgears komutunu verdiğimde o hata gelmiyor.Yalnız bu sefer galiba 64 bit sistemler için primus paketinin 32 bit uyumluluk paketini yüklemedik.Yüklemeye gerek var mı acaba?
Birde
Kod: [Seç]
sudo add-apt-repository ppa:bumblebee/stable komutu verince ppa nin xenial desteği yok diyor.Tekrar kurulum yapmak istediğimizde bu komutu çalıştırmaya gerek var mı?

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13509
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Daha önceden yüklediğim Nvidia kapalı kaynak sürücülerini belirttiğiniz komutlarla kaldırmama rağmen,

Kod: [Seç]
sudo add-apt-repository ppa:bumblebee/stable
komutu sonrası,

Kod: [Seç]
"Bu PPA'nin xenial destegi yok"
PPA eklenemiyor: '"Bu PPA'nin xenial destegi yok"'.

şeklinde çıktı veriyor. Bu sorun sonraki aşamalara da sirayet ediyor ki sanırım, örneğin bumblebee.conf dosyası bende boş geliyor. Bu sorunu nasıl çözebiliriz?

Kurulum ile ilgili kısım düzeltildi. Yeniden kurulum denediğinizde bumblebee.conf dosyası boş gelmeyecektir.



Sürücü Yöneticisi ile Nvidia sürücüsünü kurduğunuzda, Intel + Nvidia hibrit GPU için Nvidia Prime seçeneğini kullanırsınız. Bumblebee ve Nvidia Prime bu sistemler için üretilmiş birbirinden farklı çözümlerdir. Forumda birbirinden farklılıklarını anlatan konumuz mevcut, inceleyebilirsiniz.
« Son Düzenleme: 05 Temmuz 2016, 15:12:17 Gönderen: Butterfly »
Elimizden geldiğince dilimizin döndüğünce...


Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13509
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Bu sefer bunları uyguladığımda sorun çözüldü.Çok sağolun.Artık glxgears komutunu verdiğimde o hata gelmiyor.Yalnız bu sefer galiba 64 bit sistemler için primus paketinin 32 bit uyumluluk paketini yüklemedik.Yüklemeye gerek var mı acaba?


Primus'un 32 bit uyumluluk paketi PPA deposunda mevcut aslında, aşağıdaki komutların çıktısına bakalım.

Kod: [Seç]
apt-cache policy primus-libs-ia32
sudo apt-get install primus-libs-ia32 -s

Alıntı
Birde
Kod: [Seç]
sudo add-apt-repository ppa:bumblebee/stable komutu verince ppa nin xenial desteği yok diyor.Tekrar kurulum yapmak istediğimizde bu komutu çalıştırmaya gerek var mı?

Bu komutu anlatımda düzelttim, doğrusu Nvidia sürücüsü ile ilgili PPA deposu olacaktı. Eğer PPA depolarını daha önce sisteme ekledi iseniz, yeniden kurulumlarda PPA deposu ekleme ile ilgili komutları geçebilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı tux5

  • Yeni Penguen
  • *
  • İleti: 41
  • Dağıtım: Linux Mint 18 Cinnamon 64 Bit
Kod: [Seç]
$ apt-cache policy primus-libs-ia32
primus-libs-ia32:i386:
  Installed: 0~20150328-1
  Candidate: 20150328-1~xenialppa1
  Version table:
     20150328-1~xenialppa1 500
        500 http://ppa.launchpad.net/bumblebee/testing/ubuntu xenial/main i386 Packages
 *** 0~20150328-1 500
        500 http://archive.ubuntu.com/ubuntu xenial/universe i386 Packages
        100 /var/lib/dpkg/status
Kod: [Seç]
$ sudo apt-get install primus-libs-ia32 -s
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be upgraded:
  primus-libs-ia32:i386
1 upgraded, 0 newly installed, 0 to remove and 251 not upgraded.
Inst primus-libs-ia32:i386 [0~20150328-1] (20150328-1~xenialppa1 Bumblebee Developer releases:16.04/xenial [i386])
Conf primus-libs-ia32:i386 (20150328-1~xenialppa1 Bumblebee Developer releases:16.04/xenial [i386])
Galiba yüklenmiş.Yeni kurulumda tekrar
Kod: [Seç]
sudo apt-get install primus-libs-ia32 komutunu çalıştırmaya gerek yok gibi.

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13509
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Alıntı
primus-libs-ia32:i386:
  Installed: 0~20150328-1

Paket zaten Ubuntu deposundan kurulu gözüküyor, güncelleyerek PPA deposundaki sürümü kurabilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı tux5

  • Yeni Penguen
  • *
  • İleti: 41
  • Dağıtım: Linux Mint 18 Cinnamon 64 Bit
Yardımlarınız için çok çok teşekkürler.Herhangi bir karşılık beklemeden insanlara böyle yardım etmeniz gerçekten herkesin yapabileceği birşey değil.Başarılarınızın devamını dilerim.

Çevrimdışı natre

  • Çok Yeni Penguen
  • *
  • İleti: 4
    • ettunc92
    • ettunc
  • Dağıtım: Linux Mint 18 Sarah
  • Masaüstü: Cinnamon
  • Grafik Kartı: GeForce GT525M
  • İşlemci: i5 2430M
Kurulum ile ilgili kısım düzeltildi. Yeniden kurulum denediğinizde bumblebee.conf dosyası boş gelmeyecektir.



Sürücü Yöneticisi ile Nvidia sürücüsünü kurduğunuzda, Intel + Nvidia hibrit GPU için Nvidia Prime seçeneğini kullanırsınız. Bumblebee ve Nvidia Prime bu sistemler için üretilmiş birbirinden farklı çözümlerdir. Forumda birbirinden farklılıklarını anlatan konumuz mevcut, inceleyebilirsiniz.

Tamamdır, sorunum çözüldü. Bumblebee düzgün olarak çalışmakta. Teşekkür ederim  :)

Çevrimdışı Trust

  • Forum Sorumlusu
  • *****
  • İleti: 352
    • Abdullah Barış
    • Abdullah Barış
  • Dağıtım: Lİnux Mint 18.2
  • Masaüstü: Mate
  • Grafik Kartı: Intel HD Graphics 3000 -NVIDIA Ge Force GT 520 MX
  • İşlemci: intel core i5-2450M
Anlatım ve bilgilendirme için teşekkürler üstad.Bir uyarı vermek isterim.     
     3. maddeden sonra bende sistemi yeniden başalattığımda Cinnamon fallback modunda açıldı. Masaüstü gnome-2 ye dönmüştü. Uçbirimi bulamadım bende synaptic paket yöneticisinden terminator adlı uçbirimi yükleyerek 4. maddeyi uyguladım ve şimdi sorunsuz bir şekilde çalışıyor.Bilgilendirmek istedim. :)
الهى انت مقصودى، ورضاك مطلوبى

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13509
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Cinnamon fallback (kurtarma) kipinde açıldığında masaüstüne sağ tıklayıp "Burada Uçbirimi Aç" seçeneğini kullanarak uçbirime ulaşabilirsiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı eersoy93

  • Çok Yeni Penguen
  • *
  • İleti: 5
Bende de işe yaradı, çok teşekkür ederim, Allah râzı olsun. glxgears ile yaklaşık 20 kat fps farkı elde ettim.

Yalnız daha yeni NVIDIA sürücüleri için ne yapacağız? Güncelleme Yöneticisi'nde 367 sürümü var, yükselteyim mi?

EKLEME: Linux Mint'in asıl forum sitesine de bu konuyla ilgili buraya bağlantı verdim: https://forum.linuxmint.net.tr/index.php?topic=6258.0

2. EKLEME: Sayın Butterfly, bu bilgileri nereden ve nasıl elde ediyorsunuz? Yanıt sayınıza baktığımda çok iyi bir Linux uzmanı olmalısınız.
« Son Düzenleme: 10 Temmuz 2016, 17:04:49 Gönderen: eersoy93 »

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13509
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Nvidia-367 ile bir miktar sorun yaşadığım için, başarılı kurulum yaptığım Nvidia-364 sürücüsü ile konuyu hazırladım. Gerçi PPA deposunda dahi Nvidia-361 sürücüsü öneriliyor ama şu an Nvidia-364 sürücü ile sorun yaşamadım.

Nvidia-364 sürücüsünü kurdu iseniz, Güncelleme Yöneticisinde Nvidia-367 sürücüsü görünmemesi gerekir, bununla ilgili aşağıdaki komutların çıktılarına bakalım.

Kod: [Seç]
sudo dpkg -l | grep nvidia
apt-cache policy nvidia-364 nvidia-367 nvidia-settings



Bende sizin gibi bir son kullanıcıyım, konuyu kaynağını paylaştığım bir başka konuyu referans alıp Linux Mint'e uyarlayarak hazırladım.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı eersoy93

  • Çok Yeni Penguen
  • *
  • İleti: 5
İkisi için de konsol çıktısını vereyim:

Kod: [Seç]
eersoy93@Lenovo ~ $ sudo dpkg -l | grep nvidia
[sudo] password for eersoy93:
ii  bumblebee-nvidia                             3.2.1-96~xenialppa1                        amd64        NVIDIA Optimus support using the proprietary NVIDIA driver
ii  nvidia-364                                   364.19-0ubuntu0~gpu16.04.6                 amd64        NVIDIA binary driver - version 364.19
ii  nvidia-settings                              367.18-0ubuntu0~gpu16.04.1                 amd64        Tool for configuring the NVIDIA graphics driver
eersoy93@Lenovo ~ $ apt-cache policy nvidia-364 nvidia-367 nvidia-settings
nvidia-364:
  Kurulu: 364.19-0ubuntu0~gpu16.04.6
  Aday:   364.19-0ubuntu0~gpu16.04.6
  Sürüm çizelgesi:
 *** 364.19-0ubuntu0~gpu16.04.6 500
        500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
nvidia-367:
  Kurulu: (hiçbiri)
  Aday:   367.27-0ubuntu0~gpu16.04.1
  Sürüm çizelgesi:
     367.27-0ubuntu0~gpu16.04.1 500
        500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial/main amd64 Packages
nvidia-settings:
  Kurulu: 367.18-0ubuntu0~gpu16.04.1
  Aday:   367.18-0ubuntu0~gpu16.04.1
  Sürüm çizelgesi:
 *** 367.18-0ubuntu0~gpu16.04.1 500
        500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
     361.42-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages
eersoy93@Lenovo ~ $

Çevrimiçi Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 13509
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 18.3 & LMDE 2
  • Masaüstü: Cinnamon 3.6 & Mate 1.18
Şu an Nvidia-367sürücüsü kurulu gözükmüyor, bu sebeple Güncelleme Yöneticisinde böyle bir öğe görünmemesi gerekir. Acaba Güncelleme Yöneticisi yerine böyle bir öğeyi Sürücü Yöneticisinde görüyor olabilir misiniz?
Elimizden geldiğince dilimizin döndüğünce...