Gönderen Konu: [Çözüldü] Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu  (Okunma sayısı 462 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı yukarihisar

  • Yeni Penguen
  • *
  • İleti: 74
Merhabalar, normalde Lenovo Z500 için Manjaro da ekran parlaklığı tuşlarının çalışabilmesi için aşağıdaki ayarı yapıyordum.

/etc/default/grub dosyasında GRUB_CMDLINE_LINUX_DEFAULT kısmına acpi_backlight=video bunu ekliyordum. Ardından sudo update-grub diyip yenşden başlattığımda sorunsuz çalışıyordu. Fakat sistemi yeni kurduktan sonra bunun çalışmadığını fark ettim. En son LTS olan 4.14.34-1kerneli aktifti. Kerneli 4.9.94-1 LTS sürümüne düşürdüğümde sorunsuz çalışıyor. Fakat bunun üst sürümü olarak LTS olan 4.14.34-1 kerneli kullandığımda ekran parlaklığını kontrol edemiyorum. Daha üst LTS olmayan kernellerde de çalışmıyor. Bu sorunu nasıl çözebilirim. Veyahut 4.9 kernelini kullanmaya devam edersem bir sorunla karşılaşır mıyım? En üst LTS sürümü kullanmamanın dezavantajı ne olur?

« Son Düzenleme: 19 Nisan 2018, 13:24:59 Gönderen: yukarihisar »

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14708
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 2
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu
« Yanıtla #1 : 16 Nisan 2018, 11:36:01 »
Sistemi 4.14.x çekirdek ile açıp, aşağıdaki komutu çalıştırdığınızda bahsettiğiniz değişken görünüyor mu?

Kod: [Seç]
cat /proc/cmdline
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı yukarihisar

  • Yeni Penguen
  • *
  • İleti: 74
Ynt: Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu
« Yanıtla #2 : 16 Nisan 2018, 11:47:12 »
Evet görünüyor.
Kod: [Seç]
BOOT_IMAGE=/boot/vmlinuz-4.14-x86_64 root=UUID=3ee rw quiet acpi_backlight=video resume=UUID=7b

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14708
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 2
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu
« Yanıtla #3 : 16 Nisan 2018, 11:56:53 »
acpi_backlight=video yerine acpi_backlight=vendor ya da acpi_backlight=native değişkenini dener misiniz?
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı yukarihisar

  • Yeni Penguen
  • *
  • İleti: 74
Ynt: Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu
« Yanıtla #4 : 16 Nisan 2018, 12:06:51 »
Denedim fakat bir değişilik olmadı. Fakat şöyle bir durum oldu. acpi_backlight=video kullandığımda herhangi bir parlaklık tuşuna basınca o anki parlaklığı tamamen düşüyorüyor bir anda ve daha yükseltilmiyor. acpi_backlight=vendor kullandığımda ise parlaklık tamamen düşük bir şekilde açıldı bilgisayar herhangi bir değişiklik yapıştırılamıyor yine tuşlarla. acpi_backlight=native kullandığımda ise normal bir seviyede parlaklık açıldı ama yine bir değişiklik yapılamıyor tuşlarla.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14708
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 2
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu
« Yanıtla #5 : 16 Nisan 2018, 12:27:34 »
4.14.x çekirdeğin üstü bir üsürüm dener misiniz? 4.15 serisi olabilir mesela, belki 4.14 sürümde bir regresyon sebebiyle sorun yaşanıyordur.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı yukarihisar

  • Yeni Penguen
  • *
  • İleti: 74
Ynt: Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu
« Yanıtla #6 : 16 Nisan 2018, 16:01:27 »
4.15.17-1 kernelinde hiç bir değişiklik olmuyor parlaklık tuşları ile. 4.16.2-1 de ise aynı 4.14.34-1 deki gibi herhangi bir parlaklık tuşuna bastığımda bir anda tamamen düşüyor parlaklık.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14708
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 2
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu
« Yanıtla #7 : 16 Nisan 2018, 22:12:27 »
Aşağıdaki komutların çıktılarına bir bakalım. İlk komutun çıktısını hem 4.9.x hem de 4.14.x çekirdek ile alıp paylaşınız.
Kod: [Seç]
ls /sys/class/backlight/
inxi -Fxxz

Ayrıca aşağıdaki komutu uçbirimde çalıştırınız, bu komut kullanıcı ev dizininde dmesg isimli bir dosya oluşturacak. Bu dosyanın içeriği çok uzun olacağı için, içeriğini foruma yapıştırmak yerine buraya aktarıp bağlantısını paylaşınız. dmesg komutunun çıktısını 4.14.x sürüm çekirdek ile alınız.

Kod: [Seç]
dmesg > dmesg
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı yukarihisar

  • Yeni Penguen
  • *
  • İleti: 74
Ynt: Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu
« Yanıtla #8 : 17 Nisan 2018, 18:46:44 »
4.9.x e göre olan çıktılar
Kod: [Seç]
$ ls /sys/class/backlight/
acpi_video0  intel_backlight
$ inxi -Fxxz
System:
  Host: lenovo Kernel: 4.9.94-1-MANJARO x86_64 bits: 64 compiler: gcc
  v: 7.3.1 Desktop: N/A dm: lightdm Distro: Manjaro Linux 17.1.8 Hakoila
Machine:
  Type: Laptop System: LENOVO product: 20202 v: Lenovo IdeaPad Z500
  serial: N/A Chassis: type: 10 v: Lenovo IdeaPad Z500 serial: N/A
  Mobo: LENOVO model: INVALID v: 00000000INVALID serial: N/A UEFI: LENOVO
  v: 71CN51WW(V1.21) date: 07/12/2013
Battery:
  ID-1: BAT1 charge: 37.3 Wh condition: 37.3/N/A Wh volts now/min: 16.2/14.4
  model: LENOVO PABAS0241231 serial: <filter> status: Full
CPU:
  Topology: Dual Core model: Intel Core i5-3230M type: MT MCP
  arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20761
  Speed: 1278 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 1288 2: 1260
  3: 1225 4: 1349
Graphics:
  Card-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  bus ID: 00:02.0 chip ID: 8086:0166
  Card-2: NVIDIA GK208M [GeForce GT 740M] driver: N/A bus ID: 01:00.0
  chip ID: 10de:1292
  Display Server: N/A driver: intel resolution: <xdpyinfo missing>
  OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.0.0
  compat-v: 3.0 direct render: Yes
Audio:
  Card-1: Intel 7 Series/C216 Family High Definition Audio
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20
  Sound Server: ALSA v: k4.9.94-1-MANJARO
Network:
  Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet
  driver: r8169 v: 2.3LK-NAPI port: 2000 bus ID: 02:00.0 chip ID: 10ec:8136
  IF: enp2s0 state: down mac: <filter>
  Card-2: Intel Centrino Wireless-N 2230 driver: iwlwifi v: kernel
  bus ID: 03:00.0 chip ID: 8086:0888
  IF: wlp3s0 state: up mac: <filter>
  IF-ID-1: vboxnet0 state: up speed: 10 Mbps duplex: full mac: <filter>
Drives:
  HDD Total Size: 232.89 GiB used: 29.67 GiB (12.7%)
  ID-1: /dev/sda model: Samsung_SSD_850 size: 232.89 GiB serial: <filter>
Partition:
  ID-1: / size: 219.28 GiB used: 29.67 GiB (13.5%) fs: ext4 dev: /dev/sda2
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3
Sensors:
  System Temperatures: cpu: 38.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 270 Uptime: 3h 26m Memory: 7.66 GiB used: 2.27 GiB (29.7%)
  Init: systemd v: 238 Compilers: gcc: 7.3.1 Shell: bash v: 4.4.19
  running in: xfce4-terminal inxi: 3.0.00

4.14.x e göre olan çıktılar
Kod: [Seç]
$ ls /sys/class/backlight/
intel_backlight
$ inxi -Fxxz
System:
  Host: lenovo Kernel: 4.14.34-1-MANJARO x86_64 bits: 64 compiler: gcc
  v: 7.3.1 Desktop: N/A dm: lightdm Distro: Manjaro Linux 17.1.8 Hakoila
Machine:
  Type: Laptop System: LENOVO product: 20202 v: Lenovo IdeaPad Z500
  serial: N/A Chassis: type: 10 v: Lenovo IdeaPad Z500 serial: N/A
  Mobo: LENOVO model: INVALID v: 00000000INVALID serial: N/A UEFI: LENOVO
  v: 71CN51WW(V1.21) date: 07/12/2013
Battery:
  ID-1: BAT1 charge: 37.3 Wh condition: 37.3/N/A Wh volts now/min: 16.2/14.4
  model: LENOVO PABAS0241231 serial: <filter> status: Full
CPU:
  Topology: Dual Core model: Intel Core i5-3230M type: MT MCP
  arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20761
  Speed: 1197 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 1197 2: 1197
  3: 1198 4: 1285
Graphics:
  Card-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  bus ID: 00:02.0 chip ID: 8086:0166
  Card-2: NVIDIA GK208M [GeForce GT 740M] driver: N/A bus ID: 01:00.0
  chip ID: 10de:1292
  Display Server: N/A driver: intel resolution: <xdpyinfo missing>
  OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.0.0
  compat-v: 3.0 direct render: Yes
Audio:
  Card-1: Intel 7 Series/C216 Family High Definition Audio
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20
  Sound Server: ALSA v: k4.14.34-1-MANJARO
Network:
  Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet
  driver: r8169 v: 2.3LK-NAPI port: 2000 bus ID: 02:00.0 chip ID: 10ec:8136
  IF: enp2s0 state: down mac: <filter>
  Card-2: Intel Centrino Wireless-N 2230 driver: iwlwifi v: kernel
  bus ID: 03:00.0 chip ID: 8086:0888
  IF: wlp3s0 state: up mac: <filter>
Drives:
  HDD Total Size: 232.89 GiB used: 29.66 GiB (12.7%)
  ID-1: /dev/sda model: Samsung_SSD_850 size: 232.89 GiB serial: <filter>
Partition:
  ID-1: / size: 219.28 GiB used: 29.66 GiB (13.5%) fs: ext4 dev: /dev/sda2
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 193 Uptime: N/A Memory: 7.65 GiB used: 1.10 GiB (14.4%)
  Init: systemd v: 238 Compilers: gcc: 7.3.1 Shell: bash v: 4.4.19
  running in: xfce4-terminal inxi: 3.0.00

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14708
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 2
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu
« Yanıtla #9 : 17 Nisan 2018, 21:12:15 »
Eklediğiniz acpi_backlight=video veya diğer türev değişkenlerini grub varsayılan dosyasından silip, grub yapılandırma dosyasını güncelleyiniz.

Ardından aşağıdaki komutu uçbirimde çalıştırınız (metin-düzenleyici yerine sistemdeki metin düzenleyiciyi yazacaksınız).

Kod: [Seç]
sudo mkdir -p /usr/share/X11/xorg.conf.d/
sudo metin-düzenleyici /usr/share/X11/xorg.conf.d/20-intel.conf

Açılan metin düzenleyiciye aşağıdaki satırları yapıştırıp dosyayı kaydetmeyi deneyiniz ve ardından sistemi yeniden başlatınız.

Kod: [Seç]
Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı yukarihisar

  • Yeni Penguen
  • *
  • İleti: 74
Ynt: Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu
« Yanıtla #10 : 17 Nisan 2018, 22:08:04 »
Aynen dediğiniz şekilde yaptım. Fakat 4.9.x de dahil hiç birisinde çalışmadı. 4.9.x de parlaklık aynı seviyede kalıyor tuşlara basınca herhangi bir değişiklik olmuyor. 4.14.x de ise parlaklık tuşlarına basınca bir anda düşüyor parlaklık.

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14708
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 2
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu
« Yanıtla #11 : 18 Nisan 2018, 15:34:27 »
20-intel.conf dosyasını silip, acpi_backlight=none acpi_osi= açılış değişkenini eklemeyi dener misiniz?

https://bugs.archlinux.org/task/54234#comment158571
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı yukarihisar

  • Yeni Penguen
  • *
  • İleti: 74
Ynt: Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu
« Yanıtla #12 : 18 Nisan 2018, 15:36:55 »
20-intel.conf dosyasını silip, acpi_backlight=none acpi_osi= açılış değişkenini eklemeyi dener misiniz?

https://bugs.archlinux.org/task/54234#comment158571

Tam olarak nasıl ? Aşağıdaki gibi mi?

Kod: [Seç]
GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_backlight=none acpi_osi= resume=UUID=7b"

Çevrimdışı Butterfly

  • Proje Sorumlusu
  • *****
  • İleti: 14708
  • Linux Mint Türkiye
  • Dağıtım: Linux Mint 19 & LMDE 2
  • Masaüstü: Cinnamon 3.8 & Mate 1.20
Ynt: Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu
« Yanıtla #13 : 18 Nisan 2018, 15:42:46 »
Evet öyle olacak. Ama ilgili satırdaki resume kısmı hatalı sanırım, ama bu başka bir başlık konusu.

Düzenleme sonrası yapılandırma dosyasını da güncelleyiniz.
Elimizden geldiğince dilimizin döndüğünce...


Çevrimdışı yukarihisar

  • Yeni Penguen
  • *
  • İleti: 74
Ynt: Manjaro - Lenovo Z500 Ekran Parlaklığı Sorunu
« Yanıtla #14 : 18 Nisan 2018, 16:21:56 »
Aynen dediğiniz gibi yaptım ama olmadı. Yine sorun devam ediyor. Şu mesajınızdaki intel_backlight olan kısmı acpi_video0 olarak değiştirsem olur mu acaba?

Eklediğiniz acpi_backlight=video veya diğer türev değişkenlerini grub varsayılan dosyasından silip, grub yapılandırma dosyasını güncelleyiniz.

Ardından aşağıdaki komutu uçbirimde çalıştırınız (metin-düzenleyici yerine sistemdeki metin düzenleyiciyi yazacaksınız).

Kod: [Seç]
sudo mkdir -p /usr/share/X11/xorg.conf.d/
sudo metin-düzenleyici /usr/share/X11/xorg.conf.d/20-intel.conf

Açılan metin düzenleyiciye aşağıdaki satırları yapıştırıp dosyayı kaydetmeyi deneyiniz ve ardından sistemi yeniden başlatınız.

Kod: [Seç]
Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection